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Overview 
This document describes how to install an XBOUND system, which may include: 

 XBOUND (required) 

 ReadSoft Capture Framework (RCF) 

 RCC Administration 

 RCC Document Capture 

 OmniPage 

 ABBYY 

 Various databases 

XBOUND  
A minimum operational XBOUND system consists of: 

 An administration workstation, where the XBOUND Management Center is installed and 
from which documents can be processed interactively. 

 The XBOUND database server containing an XBOUND database and the required 
XBOUND licenses. 

 An “application server” on which the XBOUND Platform service runs. 

 A “worker server” on which the remaining XBOUND services run. 

Recommended: Install all XBOUND components on all computers, and specify by 
configuration which ones are actually used. This makes the system very flexible in 
production. 

How to design processes is explained in “Processes: Overview” in XBOUND Help. 
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ReadSoft Capture Framework (RCF) 
ReadSoft Capture Framework (RCF) provides full OCR results to XBOUND, including the 
positions where text was found. 

RCC Administration  
The ReadSoft Capture Components (RCC) Administration module is used to set up the 
solution which is then imported into XBOUND. This module is a variant of the 
Administration module of ReadSoft’s DOCUMENTS product, and for those who are familiar 
with that, its setup is similar.  

You must install RCC Administration on all computers where RCC Document Capture will 
run, since the RCC Document Capture components require some DLLs that are included with 
RCC Administration.  

RCC Document Capture  
ReadSoft Capture Components (RCC) Document Capture includes: 

 Activities – Contains all of the assemblies for the Import Solution, Classification, 
Inspection, Interpretation, and Knowledge Processing activities.  

 Knowledge Processing – Includes the “ReadSoft Knowledge Processing Service” and the 
scripts for configuring the Knowledge Processing database. Using Knowledge Processing 
results in better interpretation of machine-printed character fields, date fields, and amount 
fields. It is recommended in solutions that include semi-structured documents.  

 Knowledge Processing Explorer – For viewing and changing the learned data for 
Knowledge Processing. 

 Inspection – Contains the Inspection client, used for examining documents, rearranging or 
separating documents and sheets, and classifying or canceling documents. 

 Database Configuration – For creating and configuring the two databases used by RCC 
Document Capture. Note: This tool currently cannot be used to create the Knowledge 
Processing database. 
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OmniPage 
OmniPage consists of the OmniPage Ultimate interpretation engine. 

RCC Document Capture requires OmniPage. 

The necessary licenses are included in the RCC installation. 

ABBYY 
ABBYY Runtime consists of the FlexiCapture and FineReader interpretation engines. This 
option is required for the following XBOUND and RCF activities and requires a separate 
license from ABBYY: 

 Create Searchable PDF 

 Extract XML 

 ABBYY FlexiCapture Extraction 

 ABBYY FullPage Extraction 
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Prerequisites 

Supported operating systems 
 XBOUND RCF RCC KP service 

host1 

Microsoft Windows 7 SP1 32-bit     X 

Microsoft Windows 7 SP1 64-bit 2
 X3   

Microsoft Windows 8.1 32-bit   X X 

Microsoft Windows 8.1 64-bit 2 X3   

Microsoft Windows Server 2008 R2 64-bit 2 X3   

Microsoft Windows Server 2012 64-bit 2 X3   

The operating system should be updated to the latest service pack. 

Microsoft .NET Framework 
Microsoft .NET Framework version 4.5 is required by XBOUND and all related components. 

1 The ReadSoft Knowledge Processing service is a 64-bit service and must run on a 64-bit operating system. See 
“Knowledge Processing Service hosts” on page 12 for important information. 
2 Be sure to read “64-bit installation” page 9 for details. 
3 The RCF components cannot run as native 64-bit components. On a 64-bit operating system they must be 
installed and used as 32-bit versions. To do this, start the XBOUND 32-bit setup explicitly and select the desired 
components. Exception: Two of the activities present in the RCF installation are not supported on Windows 8.1: 
RecoStar Professional Extraction and RecoStar FullPage Extraction. 
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64-bit installation 
Installing a 64-bit XBOUND system does not differ in principle from installing a 32-bit 
system. However, there are some issues to consider: 

 Important: 64-bit XBOUND installations are not supported by any RCC components. 
RCC can only be used with a 32-bit XBOUND installation. 

 You can install and operate the 32-bit XBOUND product on a 64-bit operating system. 

 You can install and operate 32-bit and 64-bit versions on one computer in parallel. 

 The 64-bit version supports only the XBOUND components specified below. All other 
components (including all RCF components) can be installed and used as 32-bit versions 
on a 64-bit operating system. To do this, start the XBOUND 32-bit setup explicitly and 
choose the desired components. 

 If dongle drivers are necessary, install the 64-bit versions. These are normally available on 
the manufacturer’s website. 

 The ReadSoft Knowledge Processing service is a 64-bit service and must run on a 64-bit 
operating system. 

XBOUND native 64-bit components 

The following XBOUND components can run as native 64-bit components:

 XBOUND plug-ins (Process Designer, 
Process Monitor, Common 
Configuration Manager, etc.) 

 XBOUND Platform Service 

 XBOUND License Service 

 XBOUND Activities Service 

 XBOUND Collect Service 

 XBOUND Agent Service 

 Build Document Structure activity 

 Split Documents activity 

 Merge Documents activity 

 Adapter for File System activity 

 Adapter for File System (Structured) 
activity 

 Classify by Barcodes activity 

 Delete Documents activity 

 Collector for File System 

 Collector for XBOUND Scan Client 

 Agent for Session Removal 

 Agent for Document Resubmit 

 Agent for Service Logging Removal 
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Supported database servers 
 XBOUND RCF RCC Knowledge 

Processing 

Microsoft SQL Server 2014   X X 

Microsoft SQL Server 2008, 2008 R2, and 2012   4  

Oracle 12.1 and later Oracle 12 versions   X X 

Oracle 11.2.0 and later Oracle 11 versions   X X 

Oracle 10.1.0.2 and later Oracle 10 versions   X X 

Oracle 9.2.0.1 and later Oracle 9 versions   X X 

IBM DB2 10.1 and 10.5   X  

SSRS 
Microsoft SQL Server Reporting Services (SSRS) is needed if you want to view the SSRS-
based reports in XBOUND (using the Reports plug-in). For further information, see “Setting 
up the report server for viewing SSRS-based reports in XBOUND” on page 50. 

4 Important: Install and set up SQL Server before installing RCC Administration. Please refer to Installing and 
Configuring Microsoft SQL Server For Use With ReadSoft Capture Components for instructions. 
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PC requirements 
Application servers 

Below are the minimum recommended requirements for an application server. These are 
normally used for the XBOUND platform and for automatic activities such as Interpretation 
and Classification. 

CPU Quad core or better. Intel and AMD processors, as well as hyper 
threading, are supported. 

RAM Min. 1 GB per core (min. 4 GB per application server). 

Disk space 80 GB. 

Scanning workstations 

Below are the minimum recommended requirements for a scanning workstation.  

CPU 2 GHz quad core or better. 

RAM 4 GB (8 GB is recommended). 

Disk space 2 x 100 GB 

Network 1 Gbit 

Graphics board 256 MB 

Display 1280 x 1024 resolution or better (1920 x 1200 is recommended). 

OS  Windows 7 or higher 

Scanner drivers ISIS or ISIS-compatible driver. The drivers that are included with scanner 
manufacturers’ standard installation are supported. 
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Other workstations 

Below are the minimum recommended requirements for workstations where manual activities 
such as Verification and Inspection are performed. 

CPU Dual core or better. Intel and AMD processors, as well as hyper threading, 
are supported. 

Display 19” display with 1600 x 1200 resolution or better. 

RAM 4 GB  

Disk space 80 GB 

Knowledge Processing Service hosts 

 Remember: The ReadSoft Knowledge Processing service is a 64-bit service and must run 
on a 64-bit operating system. 

 Recommended: Use one dedicated Knowledge Processing Service host computer per 
solution:  

• Multiple XBOUND processes running different solutions with Knowledge Processing 
should each have their own service host. 

• If within a single process there are process steps that use different solutions, there 
should be one service host per solution. 

Minimum RAM requirements  

Depends on how many document classes are to be used for the solution: 
≤ 50 classes: 4 GB 
≤ 200 classes: 8 GB 
≤1000 classes: 16 GB 
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Creating an XBOUND system 
Use the procedures described in the following sections.  

 Note: If you are using a 64-bit operating system, see page 9. 

Setting up an administration workstation 
You must first install XBOUND on a workstation where the initial XBOUND activities are to 
be executed. This also provides the SQL scripts for creating the XBOUND database. 

To install the administration workstation: 

1. Highly recommended: Create an XBOUND user account as described below. 

2. Run the XBOUND software setup as described on page 14. Select all XBOUND plug-ins 
and all of their subcomponents for installation. 

3. XBOUND saves all information on processes and documents in a relational database. 
Create the XBOUND databases as described on page 18. 

4. Install an application server as described on page 36, and assign it as described on page 
37. 

5. Initialize the XBOUND platform and database as described on pages 40–40. 

Creating an XBOUND user account 
XBOUND accesses its data via an application server on a relational database. For accessing 
the data, create a dedicated user account (called XBOUND user from now on) to which all 
access rights to the XBOUND database can be assigned.  

 Note: This XBOUND user is exclusively intended for data access of the application server 
and is not related to the end users who work with XBOUND. The end users can work with 
XBOUND using their regular user accounts. 

 Important: Make this a user that is centrally administered in the domain controller or 
Active Directory. Using local user accounts can cause problems that are difficult to 
resolve. Recommended: Prevent interactive login. This makes it more difficult for 
unauthorized users to access XBOUND data directly via the database. 
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Installing XBOUND and related 
components 
This section explains how to install XBOUND software components on a computer. 
Depending on what is selected for installation, some of the steps described below may not be 
needed. 

 Note: Microsoft .NET Framework 4.0 is required. Before installing XBOUND, ensure 
that .NET Framework 4.0 is installed. If RCC Administration is to be installed, update to 
.NET Framework 4.5.  

1. Exit all Windows programs. (Always close all other programs before installing any part of 
XBOUND.) 

2. Log in as a user with administrator rights. 

3. Insert the XBOUND DVD. 

4. To start a 64-bit installation, right-click x64\Setup.exe and select Run As Administrator. 

Alternatively, to start a 32-bit installation, right-click x86\Setup.exe and select Run As 
Administrator. 

 Important: You must indeed use Run As Administrator, even though you are 
logged in as a user with administrator rights.  

 Important: The 64-bit version does not support all XBOUND components (for 
details, see “64-bit installation” on page 9.) 

5. Select English and click OK. (Note: The language applies only to the installation 
program.) 

 XBOUND Installation Guide | © ReadSoft | page 14 of 79 



 

 

6. If you also want to install RCF or RCC components, select them in the dialog that is 
displayed:  

 

 Note: If you want to deselect the components, you must first deselect RCC 
Document Capture. Otherwise the other items cannot be deselected. 

 Important notes:  

• RCC Document Capture requires RCC Administration, and the latter must be 
installed first. Circumventing this requirement leads to problems. For more 
information see page 73.  

• RCC Document Capture and RCC Administration both require OmniPage. 

7. Click Next twice. 

8. Accept the terms of the license agreement and click Next. 

9. Enter your name and company and click Next. 

10. In most cases you will need to manually select the components to install. Select Custom 
and click Next. 

11. Select the software components to install and click Next. 

12. Optional: Change the installation path. Click Next. 
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13. Optional: Change the settings for the shortcuts. Click Next. 

14. If you chose to install services, enter the user name, the password (twice) and the domain 
of the XBOUND user account that you created in the previous section. Click Next. 

15. If you chose to install ABBYY FineReader, enter the installation path and click Next.  

16. Now that all required information has been collected, click Next to launch the installation 
actions. 

17. When the installation procedure has completed, click Finish.  

Setting up a small XBOUND system using 
the Configuration Wizard 
After installation, the Configuration Wizard becomes available. This wizard is intended for 
the smallest XBOUND installations, including those to be used for testing or demonstration 
purposes. The wizard is not recommended for larger installations. In such cases please 
continue with “Creating the databases” on page 18. 

1. Using Windows Explorer, navigate to the XBOUND installation folder. Right-click the 
xboundConfigurationWizard.exe file and select Run As Administrator.  

2. Click Next. 

3. The wizard first checks whether XBOUND is installed.  

Then it checks whether XBOUND is already configured. In that case you can select 
whether to continue and replace the existing configuration. If you confirm, XBOUND 
services will be stopped and all existing XBOUND settings and data will be overwritten.  

 Warning: In some cases—for example if XBOUND privileges are already set up and 
the user lacks a privilege such as “Log On to XBOUND”—the wizard cannot 
recognize a configured XBOUND system. If you run the wizard on such a system, it 
will overwrite the local XBOUND settings. It is your responsibility to ensure that no 
existing XBOUND system is overwritten. 

4. In the XBOUND Settings part of the wizard, the XBOUND license file is selected. You 
can also deactivate Windows-based logging in XBOUND. 
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5. In Databases you set the database settings. Ensure that Create databases is selected, if 
they do not yet exist and are to be created automatically.  

 Note: If you deselect this option, then the schemas, tables, etc. are created in the 
existing databases. 

If you activate Extended Settings, you can configure a separate database server for each 
XBOUND database. 

6. The Overview lists the actions to be executed. Click Execute to start the configuration 
process:  

o The user rights for the XBOUND service user are set.  

o If selected, the databases are created and configured. (Microsoft SQL Server 2012 
Shared Management Objects are used for this.) 

o The local XBOUND configuration files are adjusted.  

o The XBOUND Platform Service is configured.  

o The XBOUND-related Windows services are started. 

o RCF is configured (if installed). 

o The XBOUND system is initialized.  

o The RCC activities are added to the XBOUND Process Designer (if RCC is 
installed). 

o All of the XBOUND activities are assigned to one instance of the XBOUND 
Activities Service. 

o The collection of statistical and audit trail data is activated.  

The result of each step is represented in the overview by  (failed) or  (succeeded).  

7. After running the wizard, you can click Next to proceed to the next part of the wizard, 
which helps you with subsequent setup steps.  

 Tip: The wizard can be manually configured in advance by manipulating the 
xboundConfigurationAssistent.xml file, which is located in the XBOUND 
installation folder.  
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Creating the databases 
XBOUND databases 

Depending on how the system is set up, XBOUND stores data in three to five databases:5 

Required databases 

XBOUND database This is the main database. 

License database Contains information about your XBOUND license. 

Logging database Contains the XBOUND log. Also contains audit trail data, if 
that is activated. 

Note: Logging to the logging database is not required but is 
recommended due to its advantages:  

 The logging database can be used by different servers. 

 The log messages can be accessed individually. 

 The logging database is native to XBOUND. XBOUND 
accesses this database to provide information to users (for 
example using the Log Explorer and Process Monitor). 

 There is an agent for maintaining this database (Agent for 
Service Logging Removal). 

Other options are logging to file and logging to Windows 
event log. (Please refer to XBOUND Help for more 
information.) However, the logging database is still required.  

5 Or in one to three databases, if you use the script that combines the objects of the three required databases into 
a single database – see below. 
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Optional databases 

Statistics database (optional) XBOUND can collect statistical data and save it in this 
separate database during the processing of documents. These 
statistics provide the basis of several reports (for example the 
Processing Report). You can also interpret these statistics 
using common analysis tools. 

Recommended: Run the statistics database on an separate 
database server so that the performance of the XBOUND 
database is not adversely affected. 

After creating the statistics database, activate statistics 
collection in XBOUND (see “Synchronizing” on page 25).  

Audit trail database (optional) If XBOUND is set up to collect audit trail data, it is saved in 
the logging database by default. However, you can also 
(optionally) select to save that data to this separate audit trail 
database for archiving.  

After creating the audit trail database, activate the functionality 
in XBOUND (see “Synchronizing the audit trail database” on 
page 26). 

 Important: Data is not automatically deleted from the statistics database or the audit trail 
database. From time to time, old data must be deleted manually from these databases 
using an appropriate database maintenance program.  

 The sections below describe how to install the XBOUND databases on the supported 
database servers (see page 10). The procedure is the same for all of the databases; only 
the SQL scripts to use are different. 

To create this database: Default location of the SQL script to use: 

XBOUND database (main database) C:\Program Files\ReadSoft\xbound\Sql 

License database C:\Program Files\ReadSoft\xbound\Sql\License 

Logging database C:\Program Files\ReadSoft\xbound\Sql\Logging 

Objects of all three above dbs in one db C:\Program Files\ReadSoft\xbound\Sql\Combined 

Statistics database (optional) C:\Program Files\ReadSoft\xbound\Sql\Statistics 

Audit trail database (optional) C:\Program Files\ReadSoft\xbound\Sql\Audit 

Basic knowledge of database administration is required. 
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Creating XBOUND databases on SQL Server 2008 or 2012 

1. Install SQL Server on the XBOUND database server. 

2. Start SQL Server Management Studio and connect to the XBOUND database server. 

3. Right-click Security and select New > Login. Enter the XBOUND user details. 

 Important: Using Windows Authentication is strongly recommended in order to 
avoid the transmitting or saving of passwords in the connection string. 

4. Right-click Databases and select New Database. The XBOUND application server will 
save its data in this database. Assign suitable parameters under Database files. You will 
find details on database tuning in your SQL Server documentation. 

Click OK when you have set all parameters. 

 Optional: To manage very high data traffic, you can distribute the database file 
groups on two or even three different physical devices. This allows the database server 
to parallelize the I/O requests. If you want to do this, create dedicated file groups for 
data, indices, and/or image data. 

5. Click the icon of the new XBOUND database. Right-click Security and select New > 
User. 

6. Enter the name of the XBOUND user under User name. 

7. Select the XBOUND user under Login name. 

8. Under Database role membership, select db_datareader and db_datawriter. 

9. Click OK. 

10. Right-click the XBOUND database icon and select Properties. 

11. Click Permissions and select the XBOUND user. 

12. Select Grant in the lower table of the Execute line. 

13. Click OK. 

14. Open the xbound_create_3.8.2.0.sql file in SQL Server Management Studio. It is 
found in C:\Program Files\ReadSoft\xbound\Sql on the administration workstation. 

15. If you created database file groups on different physical devices in step 4, change the 
TABLESPACE_DATA, TABLESPACE_IND, and/or TABLESPACE_BLOB variables 
on lines 5–7 from PRIMARY to your new file group names. 

16. Click Connect. 
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17. Select the new database. 

 Warning: This step is important, because otherwise the XBOUND database objects 
are created in the master database! 

18. Make sure you are in the correct database for the script, and click Execute. 

19. Check your messages. You should see a “Query executed successfully” message. 

Creating XBOUND databases on Oracle 9.2.0.1 

 Note: When using Oracle version 11.2.0 or earlier, Microsoft .NET Framework 3.5 and 
2.0 must be present. (With Oracle 12 or later this is not needed.) 

Not all Windows installations include .NET Framework 3.5 and 2.0. However, you can 
install .NET Framework 3.5 and 2.0 after installing Windows. 

Only when these .NET Framework versions are installed does the Oracle installation 
include all of the necessary components. 

Use this procedure 

1. Install Oracle 9.2.0.1 on the XBOUND database server. 

2. Optional: To manage very high data traffic, you can distribute the tablespaces on two or 
even three different physical devices. This allows the database server to parallelize the I/O 
requests. If you want to do this, create dedicated tablespaces data, indices, and/or image 
data. 

3. Create a user for XBOUND and give that user all access rights to the tablespaces in which 
data and indices are to be saved (in the simplest case UNLIMITED TABLESPACE). 

 Important: Using Windows authentication is strongly recommended in order to avoid 
the transmitting or saving passwords in the connection string. You will find more 
details of setting up Windows authentication regarding your database in the Oracle 
documentation or suitable third-party products. 

4. Start SQL*Plus Worksheet and log in as the XBOUND user. 

5. Open the xbound_create_oracle_3.8.2.0.sql. file. By default this is found in 
C:\Program Files\ReadSoft\xbound\Sql on the administration workstation. 

6. If you created tablespaces on different physical devices in step 2, change the 
TABLESPACE_DATA, TABLESPACE_IND, and/or TABLESPACE_BLOB variables 
on lines 2–4 from USERS to your new tablespace names. 

7. Execute the SQL script. 
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Creating XBOUND databases on Oracle 10.2.0.1, 11.2.0, or 12.1.0.1.0 

 Important: When using Oracle version 11.2.0 or earlier, see Note on page 21.  

1. Install Oracle on the XBOUND database server. 

2. Optional: To manage very high data traffic, you can distribute the tablespaces on two or 
even three different physical devices. This allows the database server to parallelize the I/O 
requests. If you want to do this, create dedicated tablespaces data, indices, and/or image 
data. 

3. Create a user for XBOUND and give that user all rights to create, change, and delete 
tables as well as to create procedures, indices, and sequences. In the simplest case, use at 
least these rights: 

• ALTER ANY TABLE 

• CREATE ANY INDEX 

• CREATE ANY PROCEDURE 

• CREATE ANY SEQUENCE 

• CREATE ANY TABLE 

• CREATE ANY VIEW 

• CREATE SESSION 

• DROP ANY TABLE 

• UNLIMITED TABLESPACE 

 Important: Using Windows authentication is strongly recommended in order to avoid 
transmitting or saving passwords in the connection string. You will find more details 
of setting up the Windows authentication regarding your database in the Oracle 
documentation or suitable third-party products. 

4. Start a program like SQL Developer which you can use to execute SQL scripts on your 
Oracle database. 

5. Log in as the XBOUND user to Oracle and load xbound_create_oracle_3.8.2.0.sql. 
By default this file is found in C:\Program Files\ReadSoft\xbound\Sql on the 
administration workstation. 

6. If you created tablespaces on different physical devices in step 2, change the 
TABLESPACE_DATA, TABLESPACE_IND, and/or TABLESPACE_BLOB variables 
on lines 2–4 from USERS to your new tablespace names. 

7. Execute the SQL script. 
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Creating XBOUND databases on IBM DB2 Express 10.x  

1. Install IBM DB2 Express on the XBOUND database server.  

2. Start IBM Data Studio. 

3. Expand All Databases > localhost. 

4. Right-click DB2 and select New Database. Create a database for XBOUND.  

 Optional: To manage very high data traffic, you can distribute the database tables on 
two or even three different physical devices. This allows the database server to 
parallelize the I/O requests. If you want to do this, create dedicated database tables 
data, indices, and/or image data.  

 Important: Change the Page size of the default buffer pool and table space setting 
to 8 KB.  

5. Select the DB Users folder of this database. 

6. Add the XBOUND user and select every access option. 

7. Under DB2, select the new database and click the SQL button ( ). 

8. In the configuration screen, select the connection to use for executing the script. 
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9. Click the Select script button ( ) and select the XBOUND_create_db2_3.8.2.0.sql 
file. By default this file is found in C:\Program Files\ReadSoft\xbound\Sql on the 
administration workstation.  

 Note: The script creates the database object in the XBOUND schema. To create the 
objects in another schema, you must first change the script by replacing all 
occurrences of XBOUND by your desired schema. 

 If you created tables on different physical devices in step 3, search for IN USERSPACE1 
in the entire file and replace it with the name of the new table, for example IN 
TABLENAME. 

10. As Statement termination character, enter a hash symbol (#). 

11. Execute the script ( ). 

12. A dialog displays the log result. Check the results.  

Creating XBOUND databases on IBM DB2 Express-C 9.5 to 9.8 

1. Install IBM DB2 Express-C on the XBOUND database server. 

2. Start DB2 Control Center. 

3. Create a database for XBOUND. 

 Optional: To manage very high data traffic, you can distribute the database tables on 
two or even three different physical devices. This allows the database server to 
parallelize the I/O requests. If you want to do this, create dedicated database tables 
data, indices, and/or image data. 

4. Select the DB Users folder of this database. 

5. Add the XBOUND user and select every access option. 

6. On the database, select Selected > Queries. 

7. Select Selected > Open and open xbound_create_db2_3.8.2.0.sql. By default this file 
is found in C:\Program Files\ReadSoft\xbound\Sql on the administration 
workstation. 

 Note: The script creates the database object in the XBOUND schema. To create the 
objects in another schema, you must first change the script by replacing all 
occurrences of XBOUND by your desired schema. 

 If you created tables on different physical devices in step 3, search for IN USERSPACE1 
in the entire file and replace it with the name of the new table, for example IN 
TABLENAME. 
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8. As Statement termination character, enter a hash symbol (#). 

9. Click Execute. 

Synchronizing XBOUND databases 

If you created a statistics database, you must synchronize it with the main database. Likewise, 
if you created an audit trail database, you must synchronize it with the logging database. 

These databases may need to be synchronized at other times, as well, for example if they were 
offline. 

Synchronizing the statistics database 

1. Create an XBOUND Data Manager console:  

a) When logged in as the same user as the database owner, start the XBOUND 
Management Center by selecting Start menu > All Programs > ReadSoft > 
ReadSoft XBOUND Management Center.  

b) When the Management Center is displayed, click the link for adding a new console. 

c) Double-click Base Data. 

2. In the Statistics area, click the link that says Click here for reading or changing the 
settings. 

3. Specify the connection data for the statistics database, and click Check connection to test 
the connection. (As mentioned in step a) above, you must be the database owner.) 

4. If it is not selected already, select Activate statistics. 

5. Click Synchronize now and confirm by clicking Yes. The statistical data from the 
production database starts synchronizing to the statistics database. Wait until the action 
finishes.  

 This can take several minutes or even hours, depending on the amount of production 
data and the database server's performance. 

6. Click OK. 

7. Check the status line in the Process Designer to see whether synchronization was 
successful. If there was an error, double-click the error message to see a more detailed 
description and resolve the problem. 
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Now any changes to the statistics data are automatically kept synchronized in the statistics 
database. 

 The linking of the production database to the statistics database is specified in the 
StatisticsDB keyword of the C_DBInfo table in the main database. That keyword stores 
the connection string for the statistics database.  

Synchronizing the audit trail database 

1. In an XBOUND Data Manager console (see step 1 on page 25), in the Audit area, click 
the link that says Click here for reading or changing the settings. 

2. Specify the connection data for the audit trail database, and click Check connection to 
test the connection. (As mentioned in step a) above, you must be the database owner.) 

3. If it is not selected already, select Activate Audit Synchronization. 

4. Click Synchronize now and confirm with Yes. The audit messages from the logging 
database are start synchronizing to the audit trail database. Wait until the action has 
finished.  

 This can take several minutes or even hours, depending on the number of audit 
messages and the database server's performance. 

5. Click OK. 

Now any audit messages are automatically kept synchronized in the audit trail database. 
Exception: If the audit trail database goes offline, you should synchronize the audit messages 
again when the database is running again. 

Databases for RCC Document Capture 

Supported database servers 

 Microsoft SQL Server 2008, 2008 R2, and 2012  

 IBM DB2 version 10.1 or 10.5 (Knowledge Processing database only) 

Setting up the configuration and production databases 

Use the below procedure to create and initialize the two databases that are required by RCC 
Document Capture:  

 The configuration database will contain the configuration data from RCC Administration, 
as well as the solutions that you create. 

 The production database will contain the solutions that you deploy to it using RCC 
Administration.  
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(A third database is optional – see “Setting up the Knowledge Processing database” on page 
31.) 

 Note: To create a database that uses Windows authentication, you must log in as a 
Windows user with administrator rights. 

Even if the database will not use Windows authentication, you must still at least be an 
administrator on the computer. If not, it is sometimes (depending on the User Account 
Control settings) possible to enter administrator details and proceed. 

 Tip: You can also set up the databases manually – see “Setting up the configuration and 
production databases manually, using SQL scripts” on page 29. 

This procedure requires Database Configuration, part of the RCC Document Capture 
installation. 

1. Select Start menu > All Programs > ReadSoft > Capture Components > 
Configuration.  

2. In the navigation panel, select Capture Components > Database Configuration.  

3. Specify the server installation (Server setting) where the databases are to be created.  

4. In the Database name box, specify the name of the database to create. (When you click 
Create, two databases are created, one with the name you specify and one with the 
extension _PRODUCTION.) 

5. Now you must select how to connect to the database: 

• To use Windows authentication—both when creating the database and when accessing 
the database from Capture Components Administration: 

a) Select Use Windows authentication. 

b) At the bottom of the dialog, fill in the domain and user name (or Active Directory 
user group) that will need access to the database.  

Continue to the next step.  

• Alternatively, specify the following details: 

a) In the Server login and Server password boxes, specify an administrator login 
name and password for the server installation that you specified in step 3. This 
user is used only to: 

 Create the user that RCC Document Capture will always use (no matter which 
user is using the program) to connect to the databases (see step b). 
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 Create the databases (step 7). 

 

b) In the DatabaseLogin and DatabasePassword boxes, specify a login name and 
password that RCC Document Capture will always use (no matter which user is 
using the program) to connect to the databases.  

 Note: The password will not be encrypted in the Windows Registry. If you 
need more security, use Windows authentication (see above). 

6. Click Test to test the connection. 

7. Click Create. (Save is used after creating the databases manually – see page 29 – or for 
switching databases – see page 71.) Two databases are created, and the Windows Registry 
is updated. 

 XBOUND Installation Guide | © ReadSoft | page 28 of 79 



 

 

Using a dedicated database server 

After setting up the databases, follow this procedure to dedicate the server to the database:  

1. Select Start menu > Settings > Control Panel > System. 

2. Click the Advanced tab. 

3. Under Performance, click Settings. 

4. On the Advanced tab, in the Processor scheduling box, select Background services.  

 

Setting up the configuration and production databases manually, using SQL 
scripts 

You can manually create the databases, and then configure them using the SQL script files 
provided. This is an alternative to the procedure described under “Setting up the configuration 
and production databases” on page 26. 

 Note: This procedure should only be performed by a database administrator or a ReadSoft 
consultant. 

Before you begin 

 Copy the three script files (CreateTables.sql, GrantUser.sql, and CreateData.sql) 
from the Configuration Tools folder (by default this is C:\Program 
Files\ReadSoft\Configuration Tools\Bin) to another location.  

Do not delete or move the original files. They are used by the configuration tool and you 
may need them later. 

 Ensure that you have database permission to create databases and logins and to execute 
database scripts in SQL Server Management Studio.  
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Script What it does 

CreateTables.sql Creates the database structure for RCC Document Capture.  

Execute this script for each of the databases. 

GrantUser.sql Adds the roles db_datawriter, db_datareader, and db_ddladmin 
to the user; grants Execute rights for all stored procedures to the 
user.  

Execute this script for each of the databases. 

CreateData.sql Updates the runtimesystems table with server name, database 
name, user name, and password.  

Execute this script on the configuration database.  

Use this procedure 

1. Start SQL Server Management Studio. 

2. Create the first database named (for example) RSCaptureComponents.  

This “configuration database” will contain the Capture Components Administration 
configuration data, and the solutions that you create.  

3. Create a second database named (for example) RSCaptureComponents_PRODUCTION.  

4. Create or add a SQL Server login. This login will also be used as the database user for 
both databases. If you want to use a Windows user name or Windows group name, then 
the user or group must exist in the Active Directory. 

5. For each database, execute the SQL script CreateTables.sql. 

6. In the GrantUser.sql script, change these parameters:  

• $(databasename) – the name of the configuration database that you created in step 2 
(for example RSCaptureComponents). 

• $(user) – the user name (same as the SQL Server login that you created in step 4). 

7. Execute GrantUser.sql for the configuration database. 

8. In the GrantUser.sql script, change the $(databasename) parameter to the name of the 
production database that you created in step 3 (for example 
RSCaptureComponents_PRODUCTION). 

9. Execute GrantUser.sql for the production database. 
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10. In the CreateData.sql script, change these parameters: 

• $(server) – the name of the SQL Server. 

• $(databasename) – the name of the production database that you created in step 3. 

• $(user) – the user name (same as the SQL Server login, see step 4). Leave this empty 
if you are using Windows authentication. 

• $(encpwd) – the user password. Leave this empty if you are using Windows 
authentication. 

11. Execute the SQL script CreateData.sql for the configuration database that you created 
in step 2. 

12. Select Start menu > All Programs > ReadSoft > Capture Components > 
Configuration and use the configuration tool to specify the server, database name, and  
database login. (Detailed instructions are provided in the previous section, starting on 
page 27.) Then click Save instead of Create. 

Setting up the Knowledge Processing database 

Use the one of the below procedures to create and initialize the Knowledge Processing 
database that will contain the RCC Knowledge Processing data: 

 Manual setup (using a script) on Microsoft SQL Server 

 Manual setup (using a script) on IBM DB2 

These procedures require that you installed Knowledge Processing.  

 Note: The database configuration tool currently cannot be used to create the Knowledge 
Processing database. 

 Important: Knowledge Processing does not automatically clean up after itself during 
production. Therefore, we recommend creating a job that removes inactive LDPs. (For 
SQL Server there are instructions available in the ReadSoft Capture Components Help 
topic “Removing inactive LDPs”.)  
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Manual setup (using a script) on Microsoft SQL Server  

You can manually create the Knowledge Processing database, and then create the table using 
the script file provided. 

 Note: This procedure should only be performed by a database administrator or a ReadSoft 
consultant. 

You will need:  

 The script file Create Script SQL.sql. Default location: C:\Program Files 
(x86)\ReadSoft\Capture Components\SqlScripts\KnowledgeStore 

Use this procedure 

1. Start SQL Server Management Studio. 

2. Create the database named (for example) CapComponents_KP. The “Simple” recovery 
model is recommended. 

3. Create or add a SQL Server login. This login also be used as the database user, so grant it 
read and write permissions.  

4. Execute the SQL script Create Script SQL.sql.  

Follow the below additional steps to update the Knowledge Processing configuration file to 
allow connection to a SQL database server. This uses the standard connection string syntax 
for .NET Data Provider. Other connection strings can be used – see SQL Server 
documentation or for example https://www.connectionstrings.com/sql-server/. 

5. Using Notepad or another text or XML editor, open the Knowledge Processing 
configuration file, ReadSoft.Du.KnowledgeStore.Service.exe.config. This is 
located in the installation folder, typically C:\Program Files 
(x86)\ReadSoft\Capture Components. Ensure that you have administrator rights to 
edit the file. 

6. Find the ServerType setting and ensure that it is set to SqlServer:  

<setting name="ServerType" serializeAs="String"> 
   <value>SqlServer</value> 
</setting> 
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7. Find the SqlServer connection string and edit it as follows, depending on whether you are 
using integrated security or standard SQL Server security: 

• Integrated security: 

<add name="SqlServer" connectionString="data source=server;initial 
catalog=database;integrated 
security=True;MultipleActiveResultSets=True;App=EntityFramework" 
providerName="System.Data.SqlClient" /> 

Change the highlighted values: 

o data source: The name of the database server.  

o catalog: The name of the Knowledge Processing database that you 
created in step 2. 

• Standard SQL Server security (the user name and password must be defined in the 
connection string): 

<add name="SqlServer" connectionString="Server=server; 
Database=database;User Id=user;Password=password;” 
providerName="System.Data.SqlClient" /> 

Change the highlighted values: 

o Server: The name of the database server.  

o Database: The name of the Knowledge Processing database that you 
created in step 2. 

o User Id: The name of the database user.  

o Password: The password of the database user. 

8. Save your changes.  

9. Start the ReadSoft Knowledge Processing Service. 

10. Check the Event Log to ensure that the connection to the database succeeded. 
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Manual setup (using a script) on IBM DB2 

You can manually create the Knowledge Processing database on an IBM DB2 version 10.1 or 
10.5 database server, and then create the table using the SQL script file provided. 

 Note: This procedure should only be performed by a database administrator or a ReadSoft 
consultant. 

You will need:  

 The script file Create script DB2.sql. Default location: C:\Program Files 
(x86)\ReadSoft\Capture Components\SqlScripts\KnowledgeStore 

 If the Knowledge Processing service is not run on the same server as the database, you 
will need the 64-bit DB2 client database drivers. These drivers are not included in the 
installation package from ReadSoft. You must obtain them from IBM. Ensure that they 
match your database version and that relevant fix packs are also installed.  

 Important: As stated under “Prerequisites” on page 12, the ReadSoft Knowledge 
Processing service must run on a 64-bit operating system. Only the 64-bit DB2 client 
database drivers are to be used.  

Use this procedure 

1. Manually create a separate Knowledge Processing database on the DB2 server.  

Select a buffer pool and table space page size of 32 KB.  

The database user must be granted read and write access to the database. 

2. Create a database table named LDPDATA by executing Create script DB2.sql.  

You can change the database schema of the table by adding the schema name before the 
table name. However, you must always define the schema in the connection string as 
described below. 

3. If the Knowledge Processing service is not run on the same server as the database, install 
the 64-bit DB2 client database drivers on the Knowledge Processing service server.  

Follow the below additional steps to update the Knowledge Processing configuration file to 
allow connection to a DB2 database server. This uses the standard connection string syntax 
for .NET Data Provider. Other connection strings can be used, as long as the table schema is 
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defined in the CurrentSchema attribute. See DB2 documentation or for example 
https://www.connectionstrings.com/ibm-db2/. 

4. Using Notepad or another text or XML editor, open the Knowledge Processing 
configuration file, ReadSoft.Du.KnowledgeStore.Service.exe.config. This is 
located in the installation folder, typically C:\Program Files 
(x86)\Readsoft\Capture Components. Ensure that you have administrator rights to 
edit the file. 

5. Find the ServerType setting and change its value to Db2. Result:  

<setting name="ServerType" serializeAs="String"> 
   <value>Db2</value> 
</setting> 

6. Find the DB2 connection string, which looks like this: 

<add name="Db2" connectionString="Database=database;User 
ID=user;Password=password;Server=server";CurrentSchema=schema" 
providerName="IBM.Data.DB2" /> 

Change the highlighted values: 

• Database: The name of the Knowledge Processing database that you created in step 1. 

• User ID (UID): The name of the database user that has the necessary access rights to 
the Knowledge Processing database. 

• Password (PWD): The password of the database user. 

• Server: The name of the DB2 server. 

• CurrentSchema: The schema name of the LDPDATA table. 

 Note: UID and PWD can be used as abbreviations. 

7. Find and uncomment the DB2 database provider element for Entity Framework in the 
<providers> section. After uncommenting, it looks like this:  

<provider invariantName="IBM.Data.DB2" 
type="IBM.Data.DB2.EntityFramework.DB2ProviderServices, 
IBM.Data.DB2.EntityFramework, Version=10.5.5.6, Culture=neutral, 
PublicKeyToken=7c307b91aa13d208" /> 

8. Save your changes.  
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9. Start the ReadSoft Knowledge Processing Service. 

10. Check the Event Log to ensure that the connection to the database succeeded. 

Installing the application server 
The XBOUND Platform Service supports all communication possibilities (bindings) offered 
by XBOUND and can be configured easily: 

1. Follow the XBOUND installation procedure described on pages 14–16. In step 11, select 
XBOUND Platform Service for installation. 

2. Create an XBOUND Common Configuration Manager console:  

a) Start the XBOUND Management Center by selecting Start menu > All Programs > 
ReadSoft > ReadSoft XBOUND Management Center.  

b) When the Management Center is displayed, click the link for adding a new console. 

c) Double-click Configuration. 

3. Click XBOUND Platform Service and select the XBOUND Connection tab. 

4. Select in Database Provider whether to use Microsoft SQL Server, Oracle, or DB2. 

5. Select in Database Server Name the database server (for SQL Server and DB2) or the 
service (Oracle). 

6. Select in Authentication Type whether the integrated security of Windows is to be used 
for logging in (recommended). If not, enter the user name and password. 

7. If SQL Server or DB2 is used, enter the name of the database in Database Name. 

8. Click Check connection to see if a connection to the database can be established. 

 Note: If you work with Windows authentication (recommended), please be aware that 
this connection test is done from your Windows session. It must also be ensured that 
the user who runs the XBOUND Platform Service has all required rights to access the 
database. 

9. If applicable, select Use WebService so that the XBOUND Platform Service enables the 
WebService and makes it accessible. 

10. Click the XBOUND Service Logging Connection tab and configure the connection to 
the XBOUND logging database in the same way. 

11. Click Save. 
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12. Start the Windows service “XBOUND Platform”. (There are instructions on page 74.) 

If it is not possible to start the service because of an incorrect login, open this service in 
the Windows Service Manager and reenter the data of the XBOUND user account. Restart 
the “XBOUND Platform” service. 

If the service immediately closes again, include the XBOUND user in the group of the 
application server's local administrators, start the service once and stop it. Now you can 
take the XBOUND user out of the local administrator group and start the service 
successfully. 

Assigning an XBOUND application server 
Before you can initialize the XBOUND database using the XBOUND Process Designer, you 
must assign an application server to XBOUND applications. Use this procedure: 

1. Log in to the workstation with the XBOUND applications. 

2. Start XBOUND Management Center by selecting Start > All Programs > ReadSoft > 
XBOUND > XBOUND Management Center.  

3. Load the Common Configuration Manager plug-in. 

4. Select Enterprise Common Properties and click the Binding tab. 

5. If you are using the XBOUND Platform Service, select Native and enter the base URL 
tcp://host:4444 as server name, replacing host with the application server’s host 
name. 

If you are using the WebService application server, select WebService and enter the base 
URL https://host as server name, replacing host with the application server’s host 
name. 

6. Click the Service Logging tab and repeat the configuration described above. Select 
Native and specify port 4445. Activate service logging and select your log level. 

7. Select File > Save All and close the configuration program. 

8. Restart the XBOUND Platform Service. (There are instructions on page 74.)  
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Configuring HTTP 
If you selected Native binding (see step 5 in the previous section), you can skip this section 
and continue with “Initializing the XBOUND platform” on page 40.  

If you are using the WebService application server, these additional steps (described in detail 
below) are required: 

 Enabling the HTTP path of the Platform Service user 

 Registering the thumbprint of the SSL certificate 
 

Enabling the HTTP path of the Platform Service user 

The HTTP path of the user under which the Platform Service is running must be enabled in 
the operating system. Use this procedure: 

1. Log on as Administrator. 

2. Open a command prompt and execute the following command: 

netsh http add urlacl https://+:443/ user=<User> 

Example: 

netsh http add urlacl https://+:443/ user=ReadSoft\XboundTest1 

Registering the thumbprint of the SSL certificate 

Because only HTTPS is supported, the thumbprint of the SSL certificate must be registered 
with the operating system. Use this procedure: 

1. Click the Windows Start button. 

2. Type mmc.exe and press Return. Microsoft Management Console (MMC) is displayed. 

3. In the MMC console, select File > Add/Remove Snap-in. The Add or Remove Snap-ins 
dialog is displayed. 

4. In the left side of the dialog, select Certificates and click Add. The Certificates snap-in 
dialog is displayed. 

5. Select Computer account and click Next. The Select Computer dialog is displayed. 

6. Accept the default setting (Local computer) by clicking Finish.  

7. Click OK to close the Add or Remove Snap-ins dialog. 
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8. Under Console Root, expand Certificates (Local Computer). 

9. Expand Personal and select Certificates.  

10. Under Issued To, double-click the certificate. The Certificate dialog is displayed. 

11. On the Details tab, scroll down and click Thumbprint. The thumbprint code is displayed 
in a box, where you can select and copy it. 

12. Return to the command line and execute the following command, replacing 
<thumbprint> with the thumbprint you copied: 

netsh http add sslcert ipport=0.0.0.0:443 certhash=<thumbprint> 
appid={00000000-0000-0000-0000-000000000000} 

Example: 

netsh http add sslcert ipport=0.0.0.0:443 
certhash=817ee3a4c95ab5536c720cfa5d24d360c9d4e796 appid={00000000-
0000-0000-0000-000000000000}  

 Tip: Use the menu to paste in the thumbprint: 
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Initializing the XBOUND platform 
The below procedure does three things: 

 It adds activities to the Activities area (the right pane) in the Process Designer. (Activities 
can of course be added manually, as well, using the procedure described on page 60.) 

 It makes XBOUND collectors available in the Tools > Collectors menu in the Process 
Designer. (Collectors can of course be added manually, as well – see XBOUND Help topic 
“Adding a collector”.) 

 It starts the Security Wizard, where you can (optionally) set up role-based privileges.  

Follow these steps: 

1. Start XBOUND Management Center by selecting Start > All Programs > ReadSoft > 
XBOUND > XBOUND Management Center.  

2. Load the Process Designer plug-in. 

3. Select Tools > Initialize Platform. 

4. Click the XML file folder icon next to the edit box.  

5. Select xboundInitialize.xml and click Open. 

6. Click OK. A confirmation message is displayed. 

7. Click OK again.  

8. The Security Wizard starts automatically. Here you can (optionally) set up role-based 
privileges. If needed, press F1 for help. 

9. Close the XBOUND Management Center. 
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Initializing RCF data 
If you installed ReadSoft Capture Framework, use this procedure to “migrate” the database 
for ReadSoft Capture Framework. Among other things, this procedures adds the RCF 
activities to the Activities area (the right pane) in the Process Designer.  

1. Open the XBOUND installation folder. 

2. In the xboundOcfMigration.cmd file, adjust the connection parameter. 

3. Ensure that all processes are checked in, and exit XBOUND Management Center. 

4. Execute the xboundOcfMigration.cmd file. After it runs, you should see a message like 
“Migration successfully completed.” 

If execution is not successful, adjust the connection parameter and try again. 

5. After successful execution, restart XBOUND Management Center and add the Business 
Logic Designer plug-in:  

a) Click the Add/remove Plug-ins button ( ). The Add or Remove Plug-Ins dialog is 
displayed.  

b) Click the New Plug-In button ( ) below the left pane. 

c) Select the DLL file for the Business Logic Designer 
(XBOUNDPlugInOcfBusinessLogic.dll) and click Open. 

d) Click the arrow ( ) to move the plug-in to the right pane. The XBOUND Connection 
Assistant dialog is displayed. 

e) To use the default connection settings, click Next. 

f) Click Finish.  
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Setting up licensing 
Licenses are necessary for using XBOUND in production. They are managed by the 
XBOUND license server using a separate database.  

There are different types of licenses: 

 A volume license counts pages. (Front page + back page counts = two pages.) These two 
types of volume licenses are sometimes combined: 

• Annual volume license: A specific annual volume is purchased. Each year the volume 
is automatically reset on the purchase date to the initial value, regardless of how many 
pages were processed.  

• One-time volume license: A specific volume is purchased without an expiration date. 
When the volume is used up, a new license must be purchased. 

 Non-volume license: This type of license is purchased once and is always valid 
(regardless of the volume and time). 

 Important: License files cannot be reused. DO NOT remove a license that has already 
been loaded! 

Use the below procedures to install the license server and apply your licenses.  

Installing the license server 

1. Follow the XBOUND installation procedure described on pages 14–16. In step 11, select 
only XBOUND License Service for installation. 

2. Start the XBOUND License Service. (There are instructions on page 74.) 
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Applying a preliminary license file 

 Warning: Do not apply the license before the platform and database are initialized as 
described on pages 40–40. 

A preliminary license file is included with the delivery of XBOUND. It is valid for 30 days 
from the date of issue. This enables you to immediately start production and gather the 
information that ReadSoft needs to create the permanent license file (see “Requesting a 
permanent license file” on page 44).  

Use this procedure to import the preliminary license file: 

1. Start XBOUND Management Center by selecting Start > All Programs > ReadSoft > 
XBOUND > XBOUND Management Center. 

2. Load the License Information plug-in. 

3. Click Add License ( ). 

4. In the License Server Address box, enter the base URL to the license server in this 
format, replacing host with the license server’s host name: tcp://host:3333 

You can enter base URLs to more than one license servers separated by the pipe symbol  
( | ) in order to provide a backup. Example: tcp://host1:3333 | tcp://host2:3333  
In this case, the license server on host1 is tried first. If it fails, the license server on host2 
is used. 

5. In XBOUND License File, select the preliminary license file that you received from 
ReadSoft and click OK. 

6. A dialog is displayed where you enter details for connecting to the license database. Enter 
all necessary data. Then click Check connection to ensure that connection succeeds. If so, 
click OK. Otherwise, check the details that you specified and try again.  

 Note: If you are using Windows authentication (recommended), be aware that this 
connection test is done from your Windows session. Make sure that the user who runs 
the XBOUND License Service is authorized to access the database. 

7. Click OK. A message is displayed, saying that the license file was loaded successfully.  
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Requesting a permanent license file 

The preliminary license file is valid for 30 days after its date of issue. Check the expiration 
date by selecting Help > License information in the XBOUND Process Designer.  

 The permanent license file must be loaded by the expiry date to avoid interrupting 
production. Therefore, request a permanent license file from ReadSoft without delay. 

Request your license file as follows: 

1. Start XBOUND Management Center by selecting Start > All Programs > ReadSoft > 
XBOUND > XBOUND Management Center. 

2. Load the License Information plug-in. 

3. Click Save license information: 

 

4. In the dialog that is displayed, click Save to save xboundLicenseInformation.xml. 

5. Email the xboundLicenseInformation.xml file to ReadSoft. 

Loading the permanent license file 

 Warning: Do not apply the license before the platform and database are initialized as 
described on pages 40–40. 

Load the permanent license file as soon as you receive it. Use this procedure:  

1. Start XBOUND Management Center by selecting Start > All Programs > ReadSoft > 
XBOUND > XBOUND Management Center.  

2. Load the License Information plug-in. 

3. Click Add License ( ). 

4. In XBOUND License File, select the permanent license file that you received and click 
OK. 

5. Check the license by selecting Help > License information in the XBOUND Process 
Designer. 
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Installing XBOUND clients 
The server-side XBOUND components are now installed and ready to process requests from 
XBOUND clients, which are services and applications that process documents in the XBOUND 
system. The following sections describe how to install these services and applications. 

Installing XBOUND services 

The XBOUND services manage all non-interactive processes within XBOUND. Use this 
procedure to install them: 

1. Follow the XBOUND installation procedure described on pages 14–16. In step 11, select 
for installation all XBOUND services and all subcomponents except Platform Service and 
License Service.  

2. Assign an application server. The procedure is the same as on the administration 
workstation (see page 37). 

3. Start the following services. (There are instructions on page 74.)  

• XBOUND Collect Service 

• XBOUND Activities  

• XBOUND System Agent Service 

If any of these services does not start because of an incorrect login, open the service in the 
service manager and reenter the XBOUND user account data. Then restart the services. 

If one of the services stops immediately 

1. Move the XBOUND user to the group of the application server’s local administrators. (In the 
case of the Collect Service, it is enough to move the XBOUND user to the group of main users.)  

2. Restart the service. 

Installing an XBOUND workstation 

The interactive processes with documents are done at XBOUND workstations. Install each 
XBOUND workstation as follows: 

1. Run the XBOUND software setup as described in “Installing XBOUND” on page 14. 
Select XBOUND Clients and all subcomponents except XBOUND Process Designer and 
XBOUND Process Monitor Client. 

2. Assign an application server. The procedure is the same as on the administration 
workstation (see page 37). 
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Post-installation tasks 

Setting up XBOUND for mobile apps 
The following procedures are needed if Mobile Rescan or Monitoring is to be used with 
XBOUND. The instructions assume a Microsoft Windows 7 operating system. The actual 
steps vary according to the operating system. 

Activate and configure IIS  

1. Select Control Panel > All Programs > Windows Features > Turn Windows Features 
on or off. 

2. Expand Internet Information Services > Web Management Tools and select IIS 
Management Console.  

 

3. Expand World Wide Web Services > Application Development Features and select 
ASP.NET.  
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4. Click OK to close the Windows Features dialog. 

5. Select Control Panel > System and Security > Administrative Tools > Internet 
Information Services (IIS) Manager. 

6. In the Internet Information Services (IIS) Manager dialog, ensure that there is an 
ASP.NET section: 

 

7. In the right panel (under Actions), click Change .NET Framework Version. 

8. In the dialog that is displayed, select v4.0.30319.  

9. Click OK to close the Change .NET Framework Version dialog. (Keep the IIS Manager 
open for upcoming steps.) 

10. Open a command prompt and execute the following commands to register .NET 
Framework for IIS:  

cd C:\Windows\Microsoft.NET\Framework\v4.0.30319  

aspnet_regiis.exe -i 

11. After completion of the ASP.NET installation, close the command prompt. 

Set up xboundWebService as an application in IIS 

1. If you are performing these steps on a 64-bit computer:  

a) In the Internet Information Services Manager (IIS) dialog, in the right panel (under 
Actions), click View Application Pools. 

b) Right-click ASP.NET v4.0 and select Advanced Settings. 

c) Set Enable 32-Bit Applications to True.  

d) Click OK to close the dialog. 
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2. Using Windows Explorer, copy the xboundWebService folder from the XBOUND 
installation path (normally C:\Program Files\ReadSoft\XBOUND) to 
C:\inetpub\wwwroot. 

3. In the Internet Information Services Manager (IIS) dialog, in the left panel (under 
Connections), expand Sites.  

4. Right-click xboundWebService and select Convert to Application. There is nothing 
more to do in the dialog that is displayed; click OK to close it.  

(If xboundWebService is already converted to an application, the command is not visible, 
and you can skip this step.) 

5. Right-click xboundWebService and select Manage Application > Advanced Settings 
(or Manage Web Site > Advanced Settings). 

6. Select Application Pool and click  to open the Select Application Pool dialog. 

7. Select ASP.NET v4.0 and click OK. 

8. Select xboundWebService in the left pane (under Connections).  

9. In the middle pane, double-click Connection Strings in the ASP.NET section. 

10. Double-click Xbound.Server.XboundDB to open the Edit Connection String dialog. 

11. Select SQL Server and specify the location and name of the main XBOUND database. (If 
you are using an Oracle or DB2 database, this step and the next one are a little different.) 

12. If the database is set up to use Windows Authentication, select Windows Integrated 
Security. Otherwise, select Specify credentials, click Set, and specify the user name and 
password. 

13. Test the function by using a local browser to visit this address:  

http://localhost/xboundWebService/Mobile.asmx  

The WebMobile page should display a list of operators. 

14. Test the function from another computer by visiting this address (replacing 
ComputerName with the name of the computer where you configured Mobile Rescan):  

http://ComputerName/xboundWebService/Mobile.asmx  

 Note: The firewall on the computer where the web service is running must be 
correctly configured. (Http must be permitted.) 

15. If HTTPS is to be used, install a certificate and configure IIS to use the certificate.  
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More on Monitoring 

 You must possess a valid XBOUND SLA Reporting license. 

 In order to see the log messages, you must add this entry to the C_DBInfo table in the 
main XBOUND database: 

Item=LoggingServer 

Val=the Platform service by which the log messages are retrieved, for example 
tcp://localhost:4445 

 The Platform service that retrieves the log messages must be active.  

 Microsoft Windows 8.1 is required on the mobile device. 

 In order to find the app in the Store, the Region of the mobile device must be set to United 
Kingdom.  

For further information please see the Microsoft app web page. 
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Setting up the report server for viewing 
SSRS-based reports in XBOUND 
Reports is one of the XBOUND Report Manager’s two sub-programs. Based on Microsoft 
SQL Server Reporting Services (SSRS), it is directly linked to the report server and displays 
reports from the specified folder. 

If you want to view these reports in XBOUND, use the below setup procedure described 
further below. SSRS is required. 

Schematic of the Reporting Services Windows service 

 

The security sublayer is responsible for determining the requestor's identity and whether the 
user has the required rights for the request to be fulfilled. 

All requests sent via HTTP are targeted to the Report Manager and the Web Service 
applications. Both applications are hosted from within the Reporting Services Windows 
service.  

Reporting Services’ core processing features – scheduling, subscription management, 
delivery and reporting processing – are performed by a collection of components hosted 
within the Reporting Services service. 

Service Management ensures that resources are available and that the service works 
properly. 
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Setting up Microsoft SQL Server 

Reporting Services is included in all versions of Microsoft SQL Server version 2005 and 
later. If you use the Express Edition, select the version with Advanced Services.  

Install SQL Server according to the instructions from Microsoft, also taking into 
consideration the following details: 

 Be sure to select Reporting Services in Feature Selection: 

 

 XBOUND Installation Guide | © ReadSoft | page 51 of 79 



 

 

 Configure the service accounts to be used for each service to be installed. It is generally 
recommended that you use the local service or (generated) network service accounts for 
the SQL Server Database Engine and SQL Server Reporting Services Windows 
service. If needed, you can change the service account after installation. 

 

 In Reporting Services Configuration you can select from three installation options. For 
most basic installations, the best choice is Install the native mode default configuration.  

 

 XBOUND Installation Guide | © ReadSoft | page 52 of 79 



 

 

 In Ready to Install, review the selected options carefully: 

 

About SSRS Report Manager 

SSRS Report Manager is a web-based report access and management tool that allows you to: 

 View, search, and subscribe to reports 

 Create and manage folders, linked reports, report history, schedules, data source 
connections, and subscriptions 

 Set properties and report parameters 

 Manage role definitions and assignments that control user access to reports and folders 

SSRS Report Manager provides access to your report server via web pages and controls. 
There are pages for viewing items, setting properties, and creating and modifying 
subscriptions, schedules, shared data sources, and roles. You access items that are stored in a 
report server by navigating the folder hierarchy and clicking items to view or update. 
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Depending on how you configure role assignments, viewing and navigation operations can be 
exposed to users who have minimal access to a report server. Management features are 
available to users who have appropriate permissions.  

 Tip: You can also perform management operations using Microsoft SQL Server 
Management Studio. 

Setup procedure 

1. Start SSRS Configuration Manager.  

2. The server name and instance of the SSRS server are displayed in the Reporting Services 
Configuration Connection dialog. You can change them if they are not correct for some 
reason. 

3. Click Connect. 

4. Click Web Service URL in the navigation pane (on the left) of the Configuration 
Manager. 
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5. In SSRS, URLs are used to access the Report Server Web Service and SSRS Report 
Manager. Before you can use either application, you must configure at least one URL 
each for the web service and SSRS Report Manager.  

If you installed the default configuration, URLs were created automatically using the 
default values. If not, you must configure a URL for the Report Server Web Service by 
specifying all of the fields in the above dialog. For more information how to configure a 
URL, please see http://technet.microsoft.com/en-us/library/bb630447.aspx. 

Creating a role assignment 

In SSRS, role assignments determine access to stored items and to the report server itself. A 
role assignment consists of: 

 A securable item for which you want to control access. Examples of securable items 
include folders, reports, and resources. 

 A user or group account that can be authenticated by Windows security or another 
authentication mechanism. 

 Role definitions that define a set of tasks.  

Role assignments are inherited within the folder hierarchy. The role assignment that is defined 
for a folder is automatically inherited by all reports, shared data sources, resources, and 
subfolders contained within that folder. 

Each user who requires access to a report server must have a role assignment that defines the 
level of access. You can create role assignments at the root node, or on a specific report, 
model, folder, resource, or shared data source.  

SSRS security is enforced through role assignments that you apply to items. A role 
assignment matches a group or user to a role definition, where each role definition identifies 
the tasks that groups or users can perform with regards to a specific item. 

1. Using SSRS Configuration Manager, click Report Manager URL in the navigation pane 
(on the left). 

2. If needed, configure or modify the URL used to access SSRS Report Manager. By default, 
the prefix, IP address, and port of the Report Server Web Service URL are inherited.  

3. Click the URL to access SSRS Report Manager, which opens in the default browser. (You 
can also access the Report Manager by typing its URL in the address bar of a browser.) 

4. Click Folder Settings. 
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5. Click New Role Assignment. 

 

6. To perform an action against a Reporting Services item, you must have permission to do 
so. Reporting Services supports a fixed set of permissions associated with each type of 
item. To simplify things, Reporting Services organizes these permissions into a more 
condensed set of item-level tasks:  

• Browser (for running reports and navigating through the folder structure) 

• Content Manager (for defining a structure for storing reports and other items, setting 
security at the item level, and viewing and managing the items stored by the server) 

• Report Builder (for building and editing reports in Report Builder) 

• Publisher (for publishing content to a report server) 

• My Reports (for build reports for personal use or storing reports in a user-owned 
folder) 

Create the role assignments that suit your organization. 
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Uploading reports to a report server 

Use this procedure to add reports (.rdl files) to the report server: 

1. Using SSRS Configuration Manager, click Report Manager URL in the navigation pane 
(on the left). Then click the URL. 

Alternatively, access the Report Manager by typing its URL in the address bar of a 
browser. 

2. Most Reporting Services items are housed within a folder hierarchy. This provides a 
simple, familiar structure for organizing content. To create a folder for the reports, click 
New Folder. Then type a folder name and click OK.  

 

 

3. Click Upload File. 

4. Type a new name for the item, for example Backlog Report or Processing Report.  

5. Click Browse and navigate to the location of the reports that are provided with 
XBOUND. By default, they are located in this folder: 

C:\Program Files (x86)\ReadSoft\xbound\Reports 

6. Select the desired report and click Open. 

 XBOUND Installation Guide | © ReadSoft | page 57 of 79 



 

 

 

7. Click OK. 

Adjusting report properties 

After a report is published, check the properties that specify: 

 The text that appears in the XBOUND Report Manager user interface. 

 How users access the report. 

 How the report server connects to external data sources. (The connection string is 
important because it establishes the initial connection to an external data source. You must 
change the connection string if you move a data source to another computer, or if you 
created reports using test data but you want to deploy the reports with a production 
database. See screenshot on page 59.)  

 Whether the report runs on demand or on a schedule.  
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Use this procedure: 

1. Still using SSRS Report Manager, click the drop-down arrow of a report and select 
Manage. 

 

2. Adjust the properties as desired.  

For example, if needed, adjust how the report connects to its data source: Click Data 
Sources in the left pane and define how the current report connects to an external data 
source. 
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Adding reports in XBOUND 

Before SSRS-based reports can be viewed for the first time, you must add them to XBOUND 
using the XBOUND Reports plug-in. Please refer to the XBOUND Help topic “Setting up a 
report to display in the Reports plug-in” for instructions. 

RCC Document Capture 
Adding activities to the Process Designer 

If you need them, these RCC Document Capture activities must be added manually to the 
Process Designer:  

 Knowledge Processing – xBoundActivityKSFeedback.dll 

 Knowledge Processing must be added first. The others can be added in any order.  

 Classification – xBoundActivityDU.dll  

 Inspection – xboundActInspectClient.dll 

 Interpretation – xboundActExtract.dll 

 (The Import Solution activity will be added in a different way – see the next section). 

Use the this procedure:  

1. Create an XBOUND Process Designer console:  

a) Start the XBOUND Management Center by selecting Start menu > All Programs > 
ReadSoft > ReadSoft XBOUND Management Center.  

b) When the Management Center is displayed, click the link for adding a new console. 

c) Double-click Process Design. 

2. In the Process Designer, select File > New Activity. 

3. In the Choose Activity Group dialog, select an activity group to add the new activity to. 
(The far right pane of the Process Designer is divided into different activity groups.) 

4. In the New Activity dialog, after Path to DLL, select the path to the DLL file containing 
the activity. Then the system fills in the name, version, and class name. Adjust the other 
settings if desired. 
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5. Click OK. 

6. Assign the activity to at least one instance of the XBOUND Activities Service. 

Adding the Import Solution activity to the XBOUND global 
parameter set 

1. Using the XBOUND Process Designer, select Tools > Global Parameter Sets. 

2. Right-click in the left pane and select New Activity.  

3. In the dialog that is displayed, select xBoundActDOXImport.dll and click Open. 

This registers the Import Solution activity in XBOUND. It can now be used in all clients and 
processes.  

 At this point, close all programs and reboot the computer. 

RCC Administration 
User authorization 

RCC Administration has a user authorization system (login system) that is disabled by 
default. The default user Administrator, which has no password, should be deleted after you 
set up your own users. Adjust user management settings according to instructions in Capture 
Components Administration Help. 

Additional setup 

The Capture Components Administration Help topic “Setting up the system after installation” 
describes the necessary steps. 

 Tip: To view online help at any time while using RCC Administration, press F1. You can 
also access help by selecting Start menu > All Programs > ReadSoft > Capture 
Components > Admin Help. 
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Knowledge Processing 
Follow the instructions below if your XBOUND system includes Knowledge Processing 
(described on page 6). 

Starting the Knowledge Processing Service 

Initially, you must start “ReadSoft Knowledge Processing Service” on the server where you 
installed it. (See instructions on page 74). After that, the service should restart automatically if 
the PC is rebooted. 

 Important: As stated under “Prerequisites” on page 12, the ReadSoft Knowledge 
Processing service must run on a 64-bit operating system. 

Enabling Knowledge Processing  

Activate Knowledge Processing in the Global policies > Persistence policy dialog. Please 
refer to the Capture Components Administration Help topic “Using Knowledge Processing to 
aid extraction.” 

Upgrading from Version 3.x 

The current release allows an upgrade from any XBOUND 3.x version (3.0, 3.1, etc.). Older 
XBOUND installations must be updated to a 3.x version before upgrading to this version.  

The upgrade process is divided into these procedures, which are described in the sections that 
follow: 

1. Preparing to upgrade. 

2. Stopping the production process 

3. Backing up the databases 

4. Installing the new software 

5. Upgrading the databases 

6. Updating an ABBYY installation 

7. Migrating the database contents. 

8. Continuing the production process. 
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Preparing to upgrade 
If you run XBOUND in production, plan the upgrade carefully. It is important to note the 
following: 

 Before the upgrade is scheduled, all processes run by XBOUND should be thoroughly 
tested in a test system of the new version to resolve possible questions or problems before 
upgrading. Budget and schedule these tests sufficiently. 

 Production must be stopped before the upgrade begins. Plan the production stop and give 
all XBOUND users sufficient notice. Do not forget remote users. 

 A complete database backup should be done before upgrading. Ensure that all media for 
saving and recovery (storage medium, backup tools, etc.) are kept ready. 

If upgrading RCC Document Capture 

Recommended: Save a copy of the ReadSoft.Du.KnowledgeStore.Service.exe.config 
file in your existing installation. By default, the file is located in C:\Program Files (x86)\ 
ReadSoft\Capture Components.  

 The above file is overwritten during the upgrade process. Therefore, do not skip that step 
unless you know that you are using a default version of the file.  

If upgrading a previous version of RCC Document Capture and RCC Administration, you will 
need to know the names, location, passwords, and type of authentication of all of the 
databases used by your system: 

Required databases: 

 XBOUND database6 

 License database 

 Logging database  

 RCC configuration database 

 RCC production database  

66 These first three databases are sometimes combined into a single database – see page 20. 

Optional databases: 

 Statistics database 

 Audit trail database 

 Knowledge Processing database 
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Stopping the production process 
Before upgrading, production must be stopped: 

1. Give all users sufficient notice about stopping the production process. 

2. If RCC Document Capture is included in the upgrade, process or delete all documents in 
your XBOUND system. 

3. Recommended if RCC Document Capture is included in the upgrade: Back up the 
installed XBOUND processes and Capture Components solutions. 

4. Exit all XBOUND clients, application servers, and related programs including RCC 
applications and RCC Administration. 

5. Stop all XBOUND-related Windows services. (There are instructions on page 74.) Do not 
forget the ReadSoft Knowledge Processing Service and the XBOUND WebService, if 
used. 

If upgrading RCC 
1. Using Windows Control Panel > Add or Remove Programs, uninstall ReadSoft Capture 

Components (Document Capture). 

2. Uninstall Capture Components Administration. 

Backing up the databases 
 Back up all XBOUND-related databases, including the Knowledge Processing database, if 

used. 

Installing the new software 
Using the setup program, update the software on all computers where the old XBOUND 
version was running. Follow the on-screen instructions. 

 Note: During an upgrade you must run the Custom installation and manually select all of 
the components you need, including third-party components such as ABBYY or RecoStar. 
For RCC Document Capture you must install OmniPage. 

Then, if it was not done in advance, set up licensing (see “Setting up licensing” on page 42). 
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Upgrading the databases 
Upgrading the XBOUND database (main database)  

 Important: In order to upgrade an IBM DB2 database from a version older than 3.7 to 
3.8.2, both the main database and the statistics database must have a page size greater than 
4 KB. If the page size is smaller, no update is possible. (Note that the page size of an 
existing DB2 database cannot be changed, as IBM does not support this procedure.) 

Select and execute one of the following SQL scripts on your XBOUND database, depending 
on the database supplier and previous XBOUND version. (Upgrading from 2.0 is not 
supported.) The scripts update tables, indices, and stored procedures corresponding to the new 
software. They are found in C:\Program Files\ReadSoft\xbound\Sql.  

To do this: Use this script: 

Upgrade from 3.7.0.1 on SQL Server XBOUND_update_3.7.0.1_3.8.2.0.sql 

Upgrade from 3.7.0.1 on Oracle XBOUND_update_oracle_3.7.0.1_3.8.2.0.sql 

Upgrade from 3.7.0.1 on DB2 XBOUND_update_db2_3.7.0.1_3.8.2.0.sql 

Upgrade from 3.7 on SQL Server XBOUND_update_3.7.0.0_3.8.2.0.sql 

Upgrade from 3.7 on Oracle XBOUND_update_oracle_3.7.0.0_3.8.2.0.sql 

Upgrade from 3.7 on DB2 XBOUND_update_db2_3.7.0.0_3.8.2.0.sql 

Upgrade from 3.6 on SQL Server XBOUND_update_3.6.0.0_3.8.2.0.sql 

Upgrade from 3.6 on Oracle XBOUND_update_oracle_3.6.0.0_3.8.2.0.sql 

Upgrade from 3.6 on DB2 XBOUND_update_db2_3.6.0.0_3.8.2.0.sql 

Upgrade from 3.5 on SQL Server XBOUND_update_3.5.0.0_3.8.2.0.sql 

Upgrade from 3.5 on Oracle XBOUND_update_oracle_3.5.0.0_3.8.2.0.sql 

Upgrade from 3.5 on DB2 XBOUND_update_db2_3.5.0.0_3.8.2.0.sql 

Upgrade from 3.1 on SQL Server XBOUND_update_3.1.0.0_3.8.2.0.sql 

Upgrade from 3.1 on Oracle XBOUND_update_oracle_3.1.0.0_3.8.2.0.sql 

Upgrade from 3.1 on DB2 XBOUND_update_db2_3.1.0.0_3.8.2.0.sql 

 XBOUND Installation Guide | © ReadSoft | page 65 of 79 



 

 

To do this: Use this script: 

Upgrade from 3.0 on SQL Server XBOUND_update_3.0.0.1_3.8.2.0.sql 

Upgrade from 3.0 on Oracle XBOUND_update_oracle_3.0.0.1_3.8.2.0.sql 

Upgrade from 3.0 on DB2 XBOUND_update_db2_3.0.0.1_3.8.2.0.sql 

 Important: If you have distributed tablespaces on Oracle, you must adjust the script 
accordingly before use. Change the TABLESPACE_DATA and TABLESPACE_IND 
variables on lines 2 and 3 of the script from USERS to your new tablespace names. 

Upgrading the RCC databases 

When upgrading from ReadSoft Capture Components 1.2 or earlier to RCC 1.2.2, use the 
following procedure to upgrade the configuration and production databases.  

 Note: Regardless of which RCC version you are upgrading from, the Knowledge 
Processing database must be recreated. For help with migrating an existing Knowledge 
Processing database, contact your ReadSoft representative.  

1. Open Microsoft SQL Server Management Studio as database administrator. 

2. Open this SQL script (for example using drag and drop) from the XBOUND installation 
directory: 

\Capture Components\SqlScripts\Upgrade.sql 

3. Replace the placeholder $(database) with the name of the configuration database. 

4. Replace the placeholder $(user) with the name of the database user that will log in to the 
database. 

5. Execute the script (press F5). 

6. Change the database name to the name of corresponding production database. 

7. Execute the script again. 
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Updating an ABBYY installation  
This section describes what you must do before and after updating an ABBYY installation in 
connection with an update from XBOUND 3.6.0.1 to the most recent version. (These steps are 
not needed if you upgrade from XBOUND 3.6 R2 or later.) 

Before updating ABBYY 

1. Uninstall ABBYY FlexiCapture 9.0 and ABBYY FlexiCapture 9.0 Engine (if you use it). 
Do this from the Windows Control Panel > Add or Remove Programs: 

 

2. Uninstall ABBYY FineReader Engine 10 (if you use it): 

• Stop the “ABBYY FineReader Engine 10 License Server” service. (There are 
instructions on page 74.) 

• Uninstall the “ABBYY FineReader Engine 10 License Server” service. To do this, go 
to this folder in case of a 32-bit OS: 

Program Files\Common files\ABBYY\SDK\10\Licensing 

Or this folder in case of a 62-bit OS: 

Program Files(x86)\Common files\ABBYY\SDK\10\Licensing 

• From the \Licensing folder run this command: 

DeinstallLicensingservice.cmd 

 XBOUND Installation Guide | © ReadSoft | page 67 of 79 



 

 

3. After that all the FlexiCapture Engine-related folders can be deleted: 

Program Files\ABBYY SDK\10\FineReader Engine 

Program Files\Common Files\ABBYY\SDK\10\Licensing 

Or 

Program Files(x86)\Common Files\ABBYY SDK\10\FineReader Engine 

Program Files(x86)\Common Files\ABBYY\SDK\10\Licensing 

After updating ABBYY 

1. Using Windows Explorer, check whether this file is present: 

Program Files (x86)\ABBYY SDK\10\FineReader Engine\frengine.ini 

2. If you cannot find this file, copy it from XBOUND setup subfolder xFC_2 to the folder 
shown above. 

Migrating the database contents 
Several database records must be adjusted to the new software. 

 Important: This is absolutely required. Ensure that it is done without any errors. 

1. Open a command prompt.  

2. Change directory to C:\Program Files (x86)\ReadSoft\xbound. 

3. Enter the command xboundMigration with these parameters: 

• Eventlog, if the program is to log in the Event Log, or another string if the program 
output is to be done on a console. 

• Native if the application server is available via the XBOUND Native Protocol, 
Remoting if the application server is available via remoting, or WebService if it is 
available via WebService. 

• The URL of the application server. 

(The last two arguments can be copied from the foxconfig configuration file and pasted 
into the command line.) 
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If statistical data is to be acquired, set up a new statistics database and link it to the production 
database. The necessary steps are described “Collecting statistical data” in XBOUND Help. 

The statistics collector of older XBOUND versions and the statistical databases created with it 
are no longer supported. 

Additional procedure if you upgraded RCF 

The RCF configuration and runtime data must be migrated to the current version. You must 
do this after upgrading the installation or importing older XBOUND processes. Use this 
procedure: 

1. Important: At this point the xboundOcfMigration.exe program must be run once. This 
program requires call-up parameters. Therefore, adjust the file xboundOCFMigration.cmd 
file and then start xboundOcfMigration.exe. 

2. Now xboundOcfValidationBase must be updated: 

a) Open the Business Logic Designer and select File > Libraries.  

b) Open xboundOcfValidationBase. 

c) In the dialog that is displayed, enter the path of xboundOcfValidationBase.dll 
(normally C:\Program Files\ReadSoft\xbound). 

d) Update by clicking OK. 

 Note: If “OCR Mapping” does not work in the RecoStar parameter set or at runtime, see 
“Known Problems” in XBOUND RCF Release Notes. 

 Note: If you import processes that were exported from the old system, you must again execute 
XBOUNDMigration.exe and then xboundOcfMigration.cmd (adjusted for your system).  
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Additional procedure if you upgraded RCC 

1. If you upgraded from RCC 1.1 (otherwise skip to step 2): Using the Process Designer, 
open each RCC Document Capture process step, select DOX in the Parameter set drop-
down list, and click OK. 

2. Ensure that the ReadSoft Knowledge Processing service is stopped.  

3. Recreate the Knowledge Processing database using the SQL script provided. Follow the 
step-by-step instructions that begin on page 32. 

4. Looking at the ReadSoft.Du.KnowledgeStore.Service.exe.config file that you saved 
from your previous installation (see page 63): If you previously changed any of the values 
in the following elements, make the corresponding changes in the new .config file: 

    <add key="ConfidenceInClassWords" value="2" /> 
    <add key="ConfidenceCertainWordsToBeGood" value="3" /> 
 
    <!-- Settings for LDPData --> 
    <add key="MaxNumber" value="100000" /> 
    <add key="MaxNumberPerClass" value="110" /> 
    <add key="RemoveActiveNumber" value="100" /> 
    <add key="RemoveActiveNumberPerClass" value="10" /> 
 

5. Select Start menu > All Programs > ReadSoft > Capture Components > 
Configuration.  

6. In the navigation panel, select Capture Components > Database Configuration.  

7. Add the settings for the configuration database.  

8. Test and save.  

Continuing the production process 
If the upgrade was successful, the system should be tested briefly. Then production with 
XBOUND can be continued: 

1. Restart all XBOUND clients and application servers, and restart all XBOUND-related 
Windows services. (There are instructions on page 74.) Do not forget the ReadSoft 
Knowledge Processing Service and the XBOUND WebService, if used. 

2. Inform users that production can resume. 
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Additional information 

Silent installation 
XBOUND and RCF 

If XBOUND is to be installed in the uncontrolled mode, then start installation using the 
following command. The possible values for “para” are shown in the table below.  

Setup.exe /s TARGETDIR=”C:\Program Files\ReadSoft\xbound” para1 para2 … 

 Ensure that you run the console as an Administrator.  

Value  Meaning 

INSTALL_GAC_4_0=TRUE Installs the XBOUND runtime 
environment in the global assembly cache 
as well. These object use Microsoft .NET 
Framework 4.0.  

INSTALL_REGISTRATION=TRUE Installs the XBOUND Registration. 

INSTALL_PROCESSDESIGNER=TRUE Installs the XBOUND Process Designer. 

INSTALL_PROCESSMONITOR=TRUE Installs the XBOUND Process Monitor. 

INSTALL_DOCUMENTVERIFIER=TRUE Installs the XBOUND Document Verifier. 

INSTALL_RCF=TRUE Installs ReadSoft Capture Framework 
(RCF). 

INSTALL_RCFPLUGINS=TRUE Installs the RCF plug-ins (Business logic 
Designer, Form Designer, and Master Data 
Designer). 

INSTALL_RCFVERIFY=TRUE Installs RCF Verification. 

INSTALL_CAPTURECOMPONENTS=TRUE Installs RCC Document Capture. 

INSTALL_CAPTURECOMPONENTS_Admin=TRUE Installs ReadSoft Capture Components 
Administration. 
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Value  Meaning 

ICE_DEFAULT_OCRENGINE=TRUE 
ICE_DEFAULT_OCRENGINE=FALSE 

Sets OmniPage or (if FALSE) ABBYY as the 
default interpretation engine. If the 
parameter is not included, OmniPage is 
used.  

INSTALL_OP=TRUE Installs OmniPage. 

INSTALL_DOCUMENTATION=TRUE Installs the XBOUND documentation. 

INSTALL_SDKTEMPLATES=TRUE Installs the samples for the SDK. 

Example that installs the XBOUND Process Monitor on the D drive in the ReadSoft\xbound 
directory: 

Setup.exe /s TARGETDIR=”D:\ReadSoft\xbound” INSTALL_PROCESSMONITOR=TRUE 

Example that creates a local XBOUND Activities Service with the Sc.exe command-line 
program. The service will be operated under the “Domain\acct” user with the password “123”: 

Sc.exe create “xbound Activity Service” 
binPath=“D:\ReadSoft\xbound\xboundActivities.exe xbound Activity 
Service” obj=Domain\acct password=123 

Example that installs RCF Verification on the D drive in ReadSoft\xbound directory: 

Setup.exe /s TARGETDIR=”D:\ReadSoft\xbound” INSTALL_RCFVERIFY=TRUE 

RCC  

 Ensure that you run the console as an Administrator.  

RCC Administration and RCC Document Capture 

RCC Administration and RCC Document Capture can be installed separately by running their 
respective MSI files. Examples:  

msiexec /i “ReadSoft Capture Components Administration.msi” /L*v log.txt /qn 

msiexec /i “RCC Document Capture.msi” /L*v log.txt /qn 

 Important: RCC Administration must be installed before RCC Document Capture. 
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If installed in the wrong order 

If you install RCC Administration and RCC Document Capture in the wrong order, the 
XBOUND activities are not installed. Among other things, you will be unable to import a 
Capture Components solution. A typical error message:  

Could not retrieve deployed solutions. Please make sure that the DOCUMENTS database is 
properly installed.  

If the two programs are already installed in the wrong order, use this procedure to solve the 
problem: 

1. Run RCC Document Capture.msi again.  

2. When the setup dialog is displayed, click Change.  

3. Add the Activities feature to the custom setup. 

4. Proceed with the installation. 

Error message and rollback 

Installing RCC Document Capture using ReadSoft.Capture.Components.msi can cause the 
following error to be displayed and the installation to roll back: 

Calling custom action CreateDiagnosticsCategory!CreateDiagnosticsCategory.CustomActions. 
CreatePerformanceCounterCategory 

This error is caused by corrupt performance counters in the operating system. Although it is 
not related to any ReadSoft product, it prevents RCC Document Capture from installing. 

To solve this problem, recreate the corrupted performance counters by running this command 
from the command prompt: run lodctr /r 

OmniPage 

OmniPage is the interpretation engine used by RCC Document Capture.  

By default, OmniPage is installed in Program Files\ReadSoft\Engines. To install it in a 
different folder, you can use the OMNIPAGE_19_11 parameter in a silent install. Example: 

msiexec /i "Omnipage Ultimate 19.msi" OMNIPAGE_19_11="d:\temp" /L*v 
instlog.txt /qn 
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(Re)starting or stopping Windows 
Services 
XBOUND services manage all non-interactive (automatic) processes within XBOUND. At 
different times while installing, uninstalling, or setting up XBOUND, you need to start, stop, 
or restart Windows Services. Use this procedure: 

1. Select Start menu > Control Panel > Administrative Tools > Services. 

2. In the list of services that is displayed, right-click the service and select Start or Stop or 
Restart. 

These are the XBOUND-related Windows services. For a description of these services, see 
XBOUND Help. 

 XBOUND Collect Service 

 XBOUND Activities 

 XBOUND System Agent Service 

 XBOUND License Service 

 XBOUND Platform 

 XBOUND WebService 

 ReadSoft Knowledge Processing Service 

 ABBYY FineReader Engine 10 License 
Server 

Reinstalling the same version 
If you need to reinstall the same version of XBOUND, RCF or RCC, there is no need to 
uninstall it, delete databases, etc. Simply run the installation program again. 
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Uninstalling XBOUND and related 
components 
If XBOUND was installed to a non-default location (that is, not C:\Program Files 
(x86)\ReadSoft), then RCC (if present) must be uninstalled first. The orders listed below are 
best practice even if XBOUND was installed in the default location. 

Installation order 

1. XBOUND 

2. ReadSoft Capture Framework (RCF) 

3. OmniPage (can also be installed after RCC components) 

4. RCC Administration  

5. RCC Document Capture  

Uninstallation order 

1. RCC Document Capture 

2. OmniPage 

3. XBOUND 

4. ReadSoft Capture Framework (RCF) 

5. RCC Administration 

If XBOUND is uninstalled first, the information about where it was located is no longer 
available, and the system will try to uninstall RCC from the default location (C:\Program 
Files (x86)\ReadSoft). 

Encrypting communication 
You can encrypt the communication between XBOUND applications and the XBOUND 
server. The Native protocol offers two additional communication modes in addition to the 
standard communication over an unencrypted TCP connection: 

 TCPE: Windows supports encrypting the communication in addition to authentication. 

 TCPS: The communication is encrypted using an additional Secure Socket Layer (SSL). 
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Encryption by Windows (TCPE) 

The mechanism used for authentication is also used for encrypting the communication 
channel. The encryption parameters are adjustable in Windows. For details, contact your IT 
department. 

To use TCPE encryption: 

1. In the xboundPlatform.exe.config file, comment the entry containing 
Xbound.Server.TcpPort to inhibit unencrypted communication. 

2. Uncomment the entry containing Xbound.Server.TcpePort to activate encrypted 
communication. 

3. Restart the XBOUND Platform service. (There are instructions on page 74.) 

4. Configure the XBOUND applications to use a Unified Resource Identifier (URI) with the 
tcpe scheme and the configured port when logging in. Example: tcpe://myserver:5555 

Encryption by SSL (TCPS) 

In this case, encryption is done by an additional SSL (Secure Socket Layer). The encryption 
parameters are defined by the certificate that you use. 

To use TCPS encryption: 

1. Create a certificate for encrypting on the computer running the XBOUND Platform 
service in the certificate store of the local computer, in My Certificates. 

2. Start XBOUND Management Center by selecting Start > All Programs > ReadSoft > 
XBOUND > XBOUND Management Center.  

3. Load the Common Configuration Manager plug-in. 

4. Click XBOUND Platform Service and select the XBOUND Connection tab. 

5. Select Use SSL. 

6. In the Certificates list, select the certificate that you created. 

7. Click Save. 

8. Restart the XBOUND Platform service. (There are instructions on page 74.) 

9. Configure the XBOUND applications to use a Unified Resource Identifier (URI) with the 
tcps scheme and the configured port when logging in. Example: tcps://myserver:6666 
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Database maintenance and backup 
It is essential that you establish and carry out 
maintenance and backup routines that are appropriate to 
your system.  

RCC: For information about maintenance and backup, 
as well as error prevention and troubleshooting, please 
refer to Installing and Configuring Microsoft SQL 
Server For Use With ReadSoft Capture Components, a 
ReadSoft document that is available in the same folder 
as this installation guide. 

If there is a power failure, or if an RCC Administration 
process is terminated unnaturally for any other reason, 
the databases can become corrupt. In most cases, the 
network database server handles such situations and you 
need only restart the process.  

Additional information about databases can be found in the different help files (see page 79). 
For a list of topics related to databases, click the Index tab in a help file and type databases in 
the box. 

Switching between RCC databases 
If you have two or more pairs of RCC Document Capture databases (see page 26), for 
example a test system and a production system, use the below procedure to switch.  

 Note: The database configuration tool currently cannot be used to switch between 
Knowledge Processing databases. 

1. If it is open, close RCC Administration.  

2. Select Start menu > All Programs > ReadSoft > Capture Components > 
Configuration.  

3. In the navigation panel, select Capture Components > Database Configuration. 
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4. Adjust the settings to reflect the database that you want to switch to. The settings are 
described in detail starting on page 27. 

 

5. Click Test to test the connection. 

6. Click Save. This updates the Windows Registry.  

Restarting Windows services 

After switching databases, you must restart all relevant Windows services, namely ReadSoft 
Knowledge Processing Service and/or XBOUND Activities.  

Instead of clicking Restart, we recommend this procedure: 

1. Click Stop. 

2. Wait 10 seconds. 

3. Click Start. 
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Additional SQL scripts 
The following additional scripts can be found in the Sql folder in your XBOUND installation 
(default location C:\Program Files\ReadSoft\xbound\Sql).  

xbound_sequence_update_oracle_3.8.2.0.sql 

This helper script can be used if for any reason the sequences in your Oracle database do not 
reflect the maximum ID of your records. 

DocManager_Oracle.sql 

This script creates helper indices which can improve the performance of DocManager in an 
upgraded database (since the upgrade scripts do not create them). 

*_drop_*.sql 

These scripts delete all database objects that the xbound_create_*.sql scripts create.  

Where to find more product information 
Various help files (CHM files) and other documents (PDF files) are available in each 
installation of XBOUND. Select Start menu > All Programs > ReadSoft > ….  

The help files also contain a topic called “Additional documentation.” That topic contains 
links to most available documents. 
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