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Overview 

This document describes how to install an XBOUND system, which includes: 

 XBOUND (required) 

 ReadSoft Capture Framework (RCF) 

 ReadSoft Capture Components (RCC) 

 Capture Components Administration 

 Various databases 

XBOUND  
A minimum operational XBOUND system consists of: 

 An administration workstation, where the XBOUND Management Center is installed and 
from which documents can be processed interactively. 

 The XBOUND database server containing an XBOUND database and the required 
XBOUND licenses. 

 An “application server” on which the XBOUND Platform service runs. 

 A “worker server” on which the remaining XBOUND services run. 

Recommended: Install all XBOUND components on all computers, and specify by 
configuration which ones are actually used. This makes the system very flexible in 
production. 

How to design processes is explained in “Processes: Overview” in XBOUND Help. 

ReadSoft Capture Framework (RCF) 
ReadSoft Capture Framework (RCF) provides full OCR results to XBOUND, including the 
positions where text was found.  
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ReadSoft Capture Components (RCC)  
ReadSoft Capture Components includes: 

 Activities – Contains all of the assemblies for the Import Solution, Classification, 
Inspection, Interpretation, and Knowledge Processing activities.  

 Knowledge Processing – Includes the “ReadSoft Knowledge Processing Service” and the 
Database Configuration for creating and configuring the Knowledge Processing database. 
Using Knowledge Processing results in better interpretation of machine-printed character 
fields, date fields, and amount fields. It is recommended in solutions that include semi-
structured documents.  

 Inspection – Contains the Inspection client, used for examining documents, rearranging or 
separating documents and sheets, and classifying or canceling documents. 

 Database Configuration – For creating and configuring the two databases used by RCC. 

Capture Components Administration  
The Capture Components Administration module is used to set up the solution which is then 
imported into XBOUND. This module is a variant of the Administration module of 
ReadSoft’s DOCUMENTS product, and for those who are familiar with that, its setup is 
similar.  

You must install Capture Components Administration on all computers where RCC will run, 
since those components require some DLLs that are included with Administration.  
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Prerequisites 

XBOUND 
 Microsoft .NET Framework 4.0 

 Microsoft SQL Server Reporting Services (SSRS) is needed if you want to view the 
SSRS-based reports in XBOUND (using the Reports plug-in). For further information, see 
“Setting up the report server for viewing SSRS-based reports in XBOUND” on page 43. 

 Note: If you are using a 64-bit operating system, see “64-bit installation” on page 64. 

ReadSoft Capture Framework (RCF) 
 DocCat (part of RCF) needs the 32-bit version Microsoft Access Drivers. If these are not 

yet installed, please install them from Microsoft’s Download Center. 

 DocCat needs at least one of the following versions of Microsoft .NET Framework: 

• .NET Framework 3.5 (recommended) 

• .NET Framework 3.0 

• .NET Framework 2.0 

ReadSoft Capture Components (RCC) 

Operating systems 

RCC (including Capture Components Administration) can run on: 

 Microsoft Windows 7 SP1 (32-bit & 64-bit) 

 Microsoft Windows 8 (64-bit) 

 Microsoft Windows Server 2008 R2 (64-bit)  

 Microsoft Windows Server 2012 (64-bit)  

 Note: If you are using a 64-bit operating system, see “64-bit installation” on page 64. 

The operating system should be updated to the latest service pack. 

http://www.microsoft.com/en-us/download/details.aspx?id=13255�


 

 XBOUND Installation Guide | © ReadSoft | page 8 of 72 

 Important 

• 64-bit XBOUND installations are not supported by RCC. 

•  The ReadSoft Knowledge Processing service is a 64-bit service and must run on a 64-
bit operating system. 

• Microsoft .NET Framework 4.5 is required. If XBOUND is installed, then .NET 
Framework 4.0 is also already installed. Version 4.5 is an update that Capture 
Components Administration requires. 

• To install RCC and configure its databases, you need to be logged on as an 
administrator. 

Knowledge Processing Service hosts 

 The ReadSoft Knowledge Processing service is a 64-bit service and must run on a 64-bit 
operating system. 

 Recommended: Use one dedicated Knowledge Processing Service host computer per 
solution:  

• Multiple XBOUND processes running different solutions with Knowledge Processing 
should each have their own service host. 

• If within a single process there are process steps that use different solutions, there 
should be one service host per solution. 

Minimum RAM requirements  

Depends on how many document classes are to be used for the solution: 
≤ 50 classes: 4 GB 
≤ 200 classes: 8 GB 
≤1000 classes: 16 GB 
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Application servers 

Minimum recommended requirements for an application server 
(Normally used for automatic activities such as Interpretation and Classification) 

CPU Quad core. Any brand PC with an Intel or AMD processor is acceptable. 
Hyper threading is supported. 

RAM Min. 1 GB per core (min. 4 GB per application server). 

Disk space 4 GB, with an additional 1GB per extra core for running large operations on 
multicore servers. 

Workstations 

Minimum recommended requirements for workstations 
(Normally used for manual activities such as the Import Solution and Inspection activities)  

CPU Dual core. Any brand PC with an Intel or AMD processor is acceptable. 
Hyper threading is supported. 

Display 19” display with 1600 x 1200  resolution or better. 

RAM 2 GB  

Disk space 2 GB 
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Minimum recommended requirements for workstations 
(Normally used for manual activities such as the Import Solution and Inspection activities)  

Scanner 
interfaces 

Each Capture Components Administration workstation where documents are 
to be scanned requires one of the following scanner interfaces, depending on 
which scanner is chosen: 

Kofax and SCSI cards 
 Capture Components Administration supports the same scanner 

cards and drivers as DOCUMENTS 7. Please refer to the 
DOCUMENTS 7 Fact Sheet, available from ReadSoft Marketing, for 
the latest list of supported cards and drivers. 

FireWire 
 Certain scanners require FireWire, for example Kodak scanners in 

the i200 and i600 series. 

USB 2.0 
 Certain scanners have an additional USB port, for example Kodak 

i30/i40, and Canon 2580C.  

For information about installing scanner interfaces, see the instructions 
supplied with the scanner. 

Drivers for 
scanner interfaces 

Kofax 
 Image Controls 3.65 or later 

 VRS 4.2 or later. See the help topic “Using VRS with Capture 
Components Administration” in Capture Components Administration 
Help. 

SCSI cards 
 ISIS or ISIS-compatible driver 

FireWire and USB 2.0 
 ISIS or ISIS-compatible driver. The drivers that are included with 

scanner manufacturers’ standard installation are supported. 

Microsoft SQL Server 

RCC requires Microsoft SQL Server databases.  

 Important: Install and set up SQL Server before installing Capture Components 
Administration. Please refer to Installing and Configuring Microsoft SQL Server For Use 
With ReadSoft Capture Components for instructions. 



 

 XBOUND Installation Guide | © ReadSoft | page 11 of 72 

Creating an XBOUND system 

Use the procedures described in the following sections.  

 Note: If you are using a 64-bit operating system, see page 64. 

Setting up an administration workstation 
You must first install XBOUND on a workstation where the initial XBOUND activities are to 
be executed. This also provides the SQL scripts for creating the XBOUND database. 

To install the administration workstation: 

1. Highly recommended: Create an XBOUND user account as described below. 

2. Run the XBOUND software setup as described on page 12. Select all XBOUND plug-ins 
and all of their subcomponents for installation. 

3. XBOUND saves all information on processes and documents in a relational database. 
Create the XBOUND databases as described on page 14. 

4. Install an application server as described on page 29, and assign it as described on page 
34. 

5. Initialize the XBOUND platform and database as described on pages 35–36. 

Creating an XBOUND user account 
XBOUND accesses its data via an application server on a relational database. For accessing 
the data, create a dedicated user account (called XBOUND user from now on) to which all 
access rights to the XBOUND database can be assigned.  

 Note: This XBOUND user is exclusively intended for data access of the application server 
and is not related to the end users who work with XBOUND. The end users can work with 
XBOUND using their regular user accounts. 

 Important: Make this a user that is centrally administered in the domain controller or 
Active Directory. Using local user accounts can cause problems that are difficult to 
resolve. Recommended: Prevent interactive login. This makes it more difficult for 
unauthorized users to access XBOUND data directly via the database. 
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Installing XBOUND and related 
components 
This section explains how to install XBOUND software components on a computer. 
Depending on what is selected for installation, some of the steps described below may not be 
needed. 

 Note: Microsoft .NET Framework 4.0 is required. Before installing XBOUND, ensure 
that .NET Framework 4.0 is installed. If ReadSoft Capture Components (RCC) is to be 
installed, update to .NET Framework 4.5. 

1. Exit all Windows programs. (Always close all other programs before installing any part of 
XBOUND.) 

2. Log in as user with administrator rights. 

3. Insert the XBOUND DVD. 

4. To start a 64-bit installation, double-click x64\Setup.exe.  

Or, to start a 32-bit installation, double-click x86\Setup.exe. 

 Important: The 64-bit version does not support all XBOUND components (for 
details, see “64-bit installation” on page 64.) 

5. Select English and click OK. (Note: The language applies only to the installation 
program.) 

6. If you also want to install RCF or RCC, select them in the dialog that is displayed: 
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 Note: ReadSoft Capture Components requires Capture Components Administration, 
and the latter must be installed first. Circumventing this requirement leads to 
problems. For more information see page 67.  

7. Click Next twice. 

8. Accept the terms of the license agreement and click Next. 

9. Enter your name and company and click Next. 

10. Select Custom and click Next. 

11. Select the software components to install and click Next. 

12. Optional: Change the installation path. Click Next. 

13. Optional: Change the settings for the shortcuts. Click Next. 

14. If you chose to install services, enter the user name, the password (twice) and the domain 
of the XBOUND user account that you created in the previous section. Click Next. 

15. If you chose to install XBOUND ABBYY FineReader, enter the installation path and 
click Next.  

16. Now that all required information has been collected, click Next to launch the installation 
actions. 

17. When the installation procedure has completed, click Finish.  
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Creating the databases 

XBOUND databases 

Depending on how the system is set up, XBOUND stores data in three to five databases: 

Required databases 

XBOUND database This is the main database. 

License database Contains information about your XBOUND license. 

Logging database Contains the XBOUND log. Also contains audit trail 
data, if that is activated. 

Optional databases 

Statistics database (optional) XBOUND can collect statistical data and save it in 
this separate database during the processing of 
documents. These statistics provide the basis of the 
Processing Report and the BPO Invoice 
Preparation Report. You can also interpret these 
statistics using common analysis tools. 

Recommended: Run the statistics database on an 
separate database server so that the performance of 
the XBOUND database is not adversely affected. 

After creating the statistics database, activate 
statistics collection in XBOUND (see 
“Synchronizing” on page 21).  

Audit trail database (optional) If XBOUND is set up to collect audit trail data, it is 
saved in the logging database by default. However, 
you can also (optionally) select to save that data to 
this separate audit trail database for archiving.  

After creating the audit trail database, activate the 
functionality in XBOUND (see “Synchronizing the 
audit trail database” 21). 

 Important: Data is not automatically deleted from the statistics database or the audit trail 
database. From time to time, old data must be deleted manually from these databases 
using an appropriate database maintenance program.  
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Supported database servers 

 Microsoft SQL Server 2008 and 2012 

 Oracle 9.2.0.1 and later Oracle 9 versions 

 Oracle 10.1.0.2 and later Oracle 10 versions 

 Oracle 11.2.0 and later Oracle 11 versions 

 IBM DB/2 Express-C Version 9.5 or later. 

The sections below describe how to install the XBOUND databases on these database servers. 
The procedure is the same for all of the databases; only the SQL scripts to use are different: 

To create this database: Default location of the SQL script to use: 

XBOUND database (main database) C:\Program Files\ReadSoft\xbound\Sql 

License database C:\Program Files\ReadSoft\xbound\Sql\License 

Logging database C:\Program Files\ReadSoft\xbound\Sql\Logging 

Statistics database (optional) C:\Program Files\ReadSoft\xbound\Sql\Statistics 

Audit trail database (optional) C:\Program Files\ReadSoft\xbound\Sql\Logging 

Basic knowledge of database administration is required. 

Creating XBOUND databases on SQL Server 2008 or 2012 

1. Install SQL Server on the XBOUND database server. 

2. Start SQL Server Management Studio and connect to the XBOUND database server. 

3. Right-click Security and select New > Login. Enter the XBOUND user details. 

 Important: Using Windows Authentication is strongly recommended in order to 
avoid the transmitting or saving of passwords in the connection string. 

4. Right-click Databases and select New Database. The XBOUND application server will 
save its data in this database. Assign suitable parameters under Database files. You will 
find details on database tuning in your SQL Server documentation. 

Click OK when you have set all parameters. 
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 Optional: To manage very high data traffic, you can distribute the database file 
groups on two or even three different physical devices. This allows the database server 
to parallelize the I/O requests. If you want to do this, create dedicated file groups for 
data, indices, and/or image data. 

5. Click the icon of the new XBOUND database. Right-click Security and select New > 
User. 

6. Enter the name of the XBOUND user under User name. 

7. Select the XBOUND user under Login name. 

8. Under Database role membership, select db_datareader and db_datawriter. 

9. Click OK. 

10. Right-click the XBOUND database icon and select Properties. 

11. Click Permissions and select the XBOUND user. 

12. Select Grant in the lower table of the Execute line. 

13. Click OK. 

14. Open the xbound_create_3.7.1.0.sql file in SQL Server Management Studio. It is 
found in C:\Program Files\ReadSoft\xbound\Sql on the administration workstation. 

15. If you created database file groups on different physical devices in step 4, change the 
TABLESPACE_DATA, TABLESPACE_IND, and/or  TABLESPACE_BLOB variables 
on lines 5 – 7 from PRIMARY to your new file group names. 

16. Click Connect. 

17. Select the new database. 

 Warning: This step is important, because otherwise the XBOUND database objects 
are created in the master database! 

18. Make sure you are in the correct database for the script, and click Execute. 

19. Check your messages. You should see a “Query executed successfully” message. 



 

 XBOUND Installation Guide | © ReadSoft | page 17 of 72 

Creating XBOUND databases on Oracle 9.2.0.1 

1. Install Oracle 9.2.0.1 on the XBOUND database server. 

2. Optional: To manage very high data traffic, you can distribute the tablespaces on two or 
even three different physical devices. This allows the database server to parallelize the I/O 
requests. If you want to do this, create dedicated tablespaces data, indices, and/or image 
data. 

3. Create a user for XBOUND and give that user all access rights to the tablespaces in which 
data and indices are to be saved (in the simplest case UNLIMITED TABLESPACE). 

 Important: Using Windows authentication is strongly recommended in order to avoid 
the transmitting or saving passwords in the connection string. You will find more 
details of setting up Windows authentication regarding your database in the Oracle 
documentation or suitable third-party products. 

4. Start SQL*Plus Worksheet and log in as the XBOUND user. 

5. Open the xbound_create_oracle_3.7.1.0.sql. file. By default this is found in 
C:\Program Files\ReadSoft\xbound\Sql on the administration workstation. 

6. If you created tablespaces on different physical devices in step 2, change the 
TABLESPACE_DATA, TABLESPACE_IND, and/or TABLESPACE_BLOB variables 
on lines 2 – 4 from USERS to your new tablespace names. 

7. Execute the SQL script. 

Creating XBOUND databases on Oracle 10.2.0.1 or 11.2.0 

1. Install Oracle on the XBOUND database server. 

2. Optional: To manage very high data traffic, you can distribute the tablespaces on two or 
even three different physical devices. This allows the database server to parallelize the I/O 
requests. If you want to do this, create dedicated tablespaces data, indices, and/or image 
data. 

3. Create a user for XBOUND and give that user all rights to create, change and delete tables 
as well as to create procedures, indices and sequences. In the simplest case, use at least 
these rights: 

• ALTER ANY TABLE 

• CREATE ANY INDEX 

• CREATE ANY PROCEDURE 

• CREATE ANY SEQUENCE 

• CREATE ANY TABLE 

• DROP ANY TABLE 

• UNLIMITED TABLESPACE 
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 Important: Using Windows authentication is strongly recommended in order to avoid 
transmitting or saving passwords in the connection string. You will find more details 
of setting up the Windows authentication regarding your database in the Oracle 
documentation or suitable third-party products. 

4. Start a program like SQL Developer which you can use to execute SQL scripts on your 
Oracle database. 

5. Log in as the XBOUND user to Oracle and load xbound_create_oracle_3.7.1.0.sql. 
By default this file is found in C:\Program Files\ReadSoft\xbound\Sql on the 
administration workstation. 

6. If you created tablespaces on different physical devices in step 2, change the 
TABLESPACE_DATA, TABLESPACE_IND, and/or TABLESPACE_BLOB variables 
on lines 2 – 4 from USERS to your new tablespace names. 

7. Execute the SQL script. 

Creating XBOUND databases on IBM DB/2 Express 10.x  

1. Install IBM DB/2 Express on the XBOUND database server.  

2. Start IBM Data Studio. 

3. Expand  All Databases > localhost. 

4. Right-click DB2 and select New Database. Create a database for XBOUND.  

 Optional: To manage very high data traffic, you can distribute the database tables on 
two or even three different physical devices. This allows the database server to 
parallelize the I/O requests. If you want to do this, create dedicated database tables 
data, indices, and/or image data.  

 Important: Change the Page size of the default buffer pool and table space setting 
to 8 KB.  

5. Select the DB Users folder of this database. 

6. Add the XBOUND user and select every access option. 

7. Under DB2, select the new database and click the SQL button ( ). 
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8. In the configuration screen, select the connection to use for executing the script. 

 

9. Click the Select script button ( )and select the XBOUND_create_db2_3.7.1.0.sql file. 
By default this file is found in C:\Program Files\ReadSoft\xbound\Sql on the 
administration workstation.  

 Note: The script creates the database object in the XBOUND schema. To create the 
objects in another schema, you must first change the script by replacing all 
occurrences of XBOUND by your desired schema. 

 If you created tables on different physical devices in step 3, search for  IN 
USERSPACE1 in the entire file and replace it with the name of the new table, for 
example IN TABLENAME. 

10. As Statement termination character, enter a hash symbol (#). 

11. Execute the script ( ). 

12. A dialog displays the log result. Check the results.  



 

 XBOUND Installation Guide | © ReadSoft | page 20 of 72 

Creating XBOUND databases on IBM DB/2 Express-C 9.5 to 9.8 

1. Install IBM DB/2 Express-C on the XBOUND database server. 

2. Start DB2 Control Center. 

3. Create a database for XBOUND. 

 Optional: To manage very high data traffic, you can distribute the database tables on 
two or even three different physical devices. This allows the database server to 
parallelize the I/O requests. If you want to do this, create dedicated database tables 
data, indices, and/or image data. 

4. Select the DB Users folder of this database. 

5. Add the XBOUND user and select every access option. 

6. On the database, select Selected > Queries. 

7. Select Selected > Open and open xbound_create_db2_3.7.1.0.sql. By default this file 
is found in C:\Program Files\ReadSoft\xbound\Sql on the administration 
workstation. 

 Note: The script creates the database object in the XBOUND schema. To create the 
objects in another schema, you must first change the script by replacing all 
occurrences of XBOUND by your desired schema. 

 If you created tables on different physical devices in step 3, search for  IN 
USERSPACE1 in the entire file and replace it with the name of the new table, for 
example IN TABLENAME. 

8. As Statement termination character, enter a hash symbol (#). 

9. Click Execute. 
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Synchronizing XBOUND databases 

If you created a statistics database, you must synchronize it with the main database. Likewise, 
if you created an audit trail database, you must synchronize it with the logging database. 

These databases may need to be synchronized at other times, as well, for example if they were 
offline. 

Synchronizing the statistics database 

1. Using the XBOUND Management Center, open a console containing the Data Manager 
plug-in.  

2. In the Statistics area, click the link that says Click here for reading or changing the 
settings. 

3. Specify the connection data for the statistics database, and click Check connection  to test 
the connection.  

4. If it is not selected already, select Activate statistics. 

5. Click Synchronize now and confirm with Yes. The statistical data from the production 
database  starts synchronizing to  the statistics database. Wait until the action finishes.  

 This can take several minutes or even hours, depending on the amount of production 
data and the database server's performance. 

6. Click OK. 

7. Check the status line in the Process Designer to see whether synchronization was 
successful. If there was an error, double-click the error message to see a more detailed 
description and resolve the problem. 

Now any changes to the statistics data are automatically kept synchronized in the statistics 
database. 

 The linking of the production database to the statistics database is specified in the 
StatisticsDB keyword of the C_DBInfo table in the main database. That keyword stores 
the connection string for the statistics database.  

Synchronizing the audit trail database 

1. Using the XBOUND Management Center, open a console containing the Data Manager 
plug-in.  

2. In the Audit area, click the link that says Click here for reading or changing the 
settings. 

3. Specify the connection data for the statistics database, and click Check connection to test 
the connection. 
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4. If it is not selected already, select Activate Audit Synchronization. 

5. Click Synchronize now and confirm with Yes. The audit messages from the logging 
database are start synchronizing to the audit trail database. Wait until the action has 
finished.  

 This can take several minutes or even hours, depending on the number of audit 
messages and the database server's performance. 

6. Click OK. 

Now any audit messages are automatically kept synchronized in the audit trail database. 
Exception: If the audit trail database goes offline, you should synchronize the audit messages 
again when the database is running again. 

Databases for ReadSoft Capture Components and Capture 
Components Administration 

Setting up the configuration and production databases 

Use the below procedure to create and initialize the two databases that are required by RCC:  

 The configuration database will contain the Capture Components Administration 
configuration data, and the solutions that you create. 

 The production database will contain the solutions that you deploy to it using Capture 
Components Administration.  

(A third database is optional – see “Setting up the Knowledge Processing database” on page 
27.) 

 Note: To create a database that uses Windows authentication, you must log in as a 
Windows user with administrator rights. 

Even if the database will not use Windows authentication, you must still at least be an 
administrator on the computer. If not, it is sometimes (depending on UAC settings) 
possible to enter administrator details and proceed. 

 Tip: You can also set up the databases manually – see “Setting up the configuration and 
production databases manually, using SQL scripts” on page 25. 

This procedure requires Database Configuration, part of the RCC installation. 
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1. Select Start menu > All Programs > ReadSoft > Capture Components > 
Configuration.  

2. In the navigation panel, select Capture Components > Database Configuration.  

3. Specify the server installation (Server setting) where the databases are to be created.  

4. In the Database name box, specify the name of the database to create. (When you click 
Create, two databases are created, one with the name you specify and one with the 
extension _PRODUCTION.) 

5. Now you must select how to connect to the database: 

• To use Windows authentication—both when creating the database and when accessing 
the database from Capture Components Administration: 

a) Select Use Windows authentication. 

b) At the bottom of the dialog, fill in the domain and user name (or Active Directory 
user group) that will need access to the database.  

Continue to the next step.  

• Or, specify the following details: 

c) In the Server login and Server password boxes, specify an administrator login 
name and password for the server installation that you specified in step 3. This 
user is used only to: 

 Create the user that RCC will always use (no matter which user is using the 
program) to connect to the databases (see step d). 

 Create the databases (step 7). 
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d) In the DatabaseLogin and DatabasePassword boxes, specify a login name and 
password that RCC will always use (no matter which user is using the program) to 
connect to the databases.  

 Note: The password will not be encrypted in the Windows Registry. If you 
need more security, use Windows authentication (see above). 

6. Click Test to test the connection. 

7. Click Create. (Save is used when switching databases – see page 64.) Two databases are 
created, and the Windows Registry is updated. 
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Using a dedicated database server 

After setting up the databases, follow this procedure to dedicate the server to the database:  

1. Select Start menu > Settings > Control Panel > System. 

2. Click the Advanced tab. 

3. Under Performance, click Settings. 

4. On the Advanced tab, in the Processor scheduling box, select Background services.  

 

Setting up the configuration and production databases manually, using 
SQL scripts 

You can manually create the databases, and then configure them using the SQL script files 
provided. This is an alternative to the procedure described under “Setting up the configuration 
and production databases” on page 22. 

 Note: This procedure should only be performed by a database administrator or a ReadSoft 
consultant. 

Before you begin 

 Copy the three script files (CreateTables.sql, GrantUser.sql, and CreateData.sql) 
from the configuration tools folder (by default this is C:\Program 
Files\ReadSoft\Configuration Tools\Bin) to another location.  

Do not delete or move the original files. They are used by the configuration tools and you 
may need them later. 

 Ensure that you have database permission to create databases and logins and to execute 
database scripts in SQL Server Management Studio.  
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Script What it does 

CreateTables.sql Creates the database structure for RCC.  

Execute this script for each of the databases. 

GrantUser.sql Adds the roles db_datawriter, db_datareader and db_ddladmin to 
the user, and grants Execute rights for all stored procedures to the 
user.  

Execute this script for each of the databases. 

CreateData.sql Updates the runtimesystems table with server name, database 
name, user name, and password.  

Execute this script on the configuration database.  

Use this procedure 

1. Start SQL Server Management Studio. 

2. Create the first database named (for example) RSCaptureComponents.  

This “configuration database” will contain the Capture Components Administration 
configuration data, and the solutions that you create.  

3. Create a second database named (for example) RSCaptureComponents_PRODUCTION.  

4. Create or add a SQL Server login. This login will also be used as the database user for 
both databases. If you want to use a Windows user name or Windows group name, then 
the user or group must exist in the Active Directory. 

5. For each database, execute the SQL script CreateTables.sql. 

6. In the GrantUser.sql script, change these parameters:  

• $(databasename) – the name of the configuration database that you created in step 2 
(for example RSCaptureComponents). 

• $(user) – the user name (same as the SQL Server login that you created in step 4). 

7. Execute GrantUser.sql for each database. 

8. In the CreateData.sql script, change these parameters: 

• $(server) – the name of the SQL Server. 

• $(databasename) – the name of the production database that you created in step 3. 
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• $(user) – the user name (same as the SQL Server login, see step 4). Leave this empty 
if you are using Windows authentication. 

• $(encpwd) – the user password. Leave this empty if you are using Windows 
authentication. 

9. For the configuration database that you created in step 2, execute the SQL script 
CreateData.sql. 

Setting up the Knowledge Processing database 

Use the below procedure to create and initialize the Knowledge Processing database (the 
database will contain the Capture Components Knowledge Processing data.) This procedure 
requires that you installed Knowledge Processing, which includes the Knowledge Processing 
database configuration tool.  

 Tip: You can also set up the database manually – see “Setting up the configuration and 
production databases manually, using SQL scripts” on page 29. 

Important notes about the Knowledge Processing database 

 The user created by the database configuration tool is given “read” and “write” 
permissions. To run stored procedures, “execute” permission is also needed, and you must 
grant that permission manually. 

 The database created by the database configuration tool has the same recovery model as 
the “model” database. For the Knowledge Processing database, the “Simple” recovery 
model is recommended. 

 Knowledge Processing does not automatically clean up after itself during production. 
Therefore, we recommending creating a job that removes inactive LDPs. (See “Removing 
inactive LDPs” in ReadSoft Capture Components Help for instructions.) 

Use this procedure 

1. Select Start menu > All Programs > ReadSoft > Capture Components > 
Configuration.  

2. In the navigation panel, select Knowledge Processing > Database Configuration.  

3. Type in the settings: 

• Server* – the server where Knowledge Processing will have its database. 

• Server login and Server password – a user login name and password for accessing 
the database server. The user must be an administrator with permission to create the 
database and add other database users. 
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The server login details are not saved with the settings, so these details must be 
entered each time you want to test or update these settings. 

• Database name* – a name for the Knowledge Processing database. (This will be 
created when you click Create.) 

• Database login* and Database password* – a user name and password that the 
ReadSoft Knowledge Processing Service can use to access the database.  

The user you specify will be created if you click Create. The user will have read/write 
access to the database. It is only used by the ReadSoft Knowledge Processing Service 
and does not need to be specified anywhere else (for example inside XBOUND). 

 

4. Click Test to test the connection. 

5. Click Create to create the database and the database user. (Save is used when switching 
databases – described on page 64 – or updating the stored settings.) 

* The settings are saved in a configuration file: C:\ProgramData\ReadSoft\Documents\ 
KnowledgeStore\ReadSoft.KnowledgeStore.Database.config. 
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Setting up the Knowledge Processing database manually, using a script 

You can manually create the Knowledge Processing database, and then configure it using the 
SQL script file provided. This is an alternative to the procedure described under “Setting up 
the Knowledge Processing database” on page 27. 

 Note: This procedure should only be performed by a database administrator or a ReadSoft 
consultant. 

Before you begin, make sure that you see the two required script files in C:\Program Files 
(x86)\ReadSoft\Capture Components\SqlScripts\KnowledgeStore: 

Script What it does 

00 Create Script.sql Creates the database structure for ReadSoft Capture Components 
Knowledge Processing.  

01 Upgrade Script.sql Creates indexes and stored procedures. If you have an older version 
of the software, only run this script to upgrade an existing database. 

Use this procedure 

1. Start SQL Server Management Studio. 

2. Create the database named (for example) CapComponents_KP. 

3. Create or add a SQL Server login. This login will also be used as the database user, so 
grant it read and write permissions.  

4. Execute the SQL script 00 Create Script.sql. 

5. Execute the SQL script 01 Upgrade script.sql. 

Installing the application server 
Two alternatives of running the application server are offered by XBOUND: 

 Within XBOUND Platform Service. 

 As XML Web Service in Internet Information Server (IIS). 

The same server-side code (XBOUND Server) is executed with both alternatives, only the 
communication (the so-called binding) and the execution environment in which the 
XBOUND Server runs differs. 

The XBOUND Platform Service supports all communication possibilities (bindings) except 
WebService (see below) offered by XBOUND and can be configured very easily. 
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XML Web Services use the IIS infrastructure and communicate using HTTP requests, which 
contain the data to be transmitted in XML format (Binding WebService). 

The following sections describe the installation and configuration of both alternatives. 

XBOUND Platform Service 

1. Complete the XBOUND software setup as described on page 12, selecting XBOUND 
Platform Service to install. 

2. Start XBOUND Management Center by selecting Start > All Programs > ReadSoft > 
XBOUND > XBOUND Management Center.  

3. Open a console containing the Common Configuration Manager plug-in.  

4. Click XBOUND Platform Service and select the XBOUND Connection tab. 

5. Select in Database Provider whether to use Microsoft SQL Server, Oracle or DB/2. 

6. Select in Database Server Name the database server (for SQL Server and DB/2) or the 
service (Oracle). 

7. Select in Authentication Type whether the integrated security of Windows is to be used 
for logging in (recommended). If not, enter user name and password. 

8. If an SQL Server or DB/2 is used, enter the name of the database in Database Name. 

9. Click Check connection to see if a connection to the database can be established. 

 Note: If you work with Windows authentication (recommended), please be aware that 
this connection test is done from your Windows session. It must also be ensured that 
the user who runs the XBOUND Platform Service has all required rights to access the 
database. 

10. Select XBOUND Service Logging Connection and configure the connection to the 
XBOUND logging database in the same way. 

11. Click Save. 

12. Start the XBOUND Platform Service. (There are instructions on page 66.) 

13. If it is not possible to start the XBOUND Platform Service because of an incorrect login, 
open this service in the Windows Service Manager and reenter the data of the XBOUND 
user account. Restart the XBOUND Platform Service. 
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14. If the Platform service immediately closes again, include the XBOUND user in the group 
of the application server's local administrators, start the platform service once and stop it. 
Now you can take the XBOUND user out of the local administrator group and start the 
service successfully. 

WebService 

 Note: There are numerous ways in which the XBOUND application server could be 
configured. However, consider the following advice: 

• Avoid the Activate anonymous access option. Enforce authentication of the end user 
to your domain or to another trusted domain. 

• The XBOUND Server should run using the XBOUND user, in order to avoid giving 
database rights to any other user account. 
 

1. To install the WebService application server support, complete the XBOUND software 
setup as described on page 12, selecting XBOUND WebService for installation. (Note 
that XBOUND WebService is only available if Internet Information Server (IIS) is 
installed on the computer.) 

Alternatively, use the INSTALL_XBOUNDWEBSERVICEAPI property to install the 
WebService API in the IIS website xboundWebService. The preconfigured settings are 
as follows: 

• ASP.NET Version = 4.0.30319 

• Anonymous access = true 

• TCP Port = 5555 

• Virtual Path = xboundWebService 

• Handler Mapping Feature permissions: 

o Read = true 

o Script = true 

o Execute = true 
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2. If you are using Internet Information Server (IIS) version 7.0, register .NET Framework 
4.0 using this procedure:  

a) Open a command prompt and run this command:  

C:\Windows\Microsoft.NET\Framework\v4.0.30319\aspnet_regiis.exe –I 

b) Restart the web server. 

 Note: IIS versions 7.5 and 8.0 are also supported. 

3. To configure ASP.NET 4.0 for the XBOUND website, open the Internet Information 
Services dialog. 

4. Expand Sites and select xboundWebService. 

5. Under ASP.NET, double-click Connection Strings.  

6. Double-click xbound.Server.xboundDB. 

7. If you are using a Microsoft SQL Server database: 

a) In the Edit connection string dialog, select SQL Server for SQL Server 
authentication. 

 

b) Enter the host name of the XBOUND database server and database. 

c) Select Specify credentials and click Set. 

d) In the Specify credentials dialog, specify the user name and password (twice) and 
click OK. 

e) Click OK to close the Edit connection string dialog. 
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If you are using an Oracle database: 

a) Ensure that the Oracle client software for your Oracle system has been installed. 

b) Click Xbound.Server.ConnectionType in the lower table and then Edit. 

c) Replace 0 with 1 in the Value field and click OK. 

d) Enter the connection string to the XBOUND database in the Connection 
parameter field. 

In the simplest case (integrated Windows security), this has the following format: 

 "Data Source=orcl;Integrated Security=yes;" 

It replaces orcl with the Oracle service name you specified when you installed the 
database server.  

If the integrated Windows security is not used (though we recommend that you use 
it), the connection string has this format:  

"Data Source=orcl; User Id=xbound; Password=xboundpwd; 
Integrated Security=no;",  

Here you replace the values for the user name and password. 

e) Click OK. 

If you are using a DB/2 database: 

a) Ensure that the DB/2 client software has been installed. 

b) Click Xbound.Server.ConnectionType in the lower table and then Edit. 

c) Replace 0 with 2 in the Value field and click OK. 

d) Enter the connection string to the XBOUND database in the Connection 
parameter field. If you created the database object in a schema that differs from 
XBOUND’s schema, specify the schema using CurrentSchema in the connection 
string. 

e) Click OK. 

8. Click Application. 
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9. Enter the user name and the password of the XBOUND user. 

 Warning: The password is saved as plain text in the Web.Config file. Ensure that the 
file system path to the xboundWebService directory is not shared on the network and 
that only administrators can log in interactively to the XBOUND Application Server. 

10. Click OK.  

11. Test the configuration by entering http://localhost:5555/Mobile.asmx in the local browser. 
This should display the WebMobile Web Service website and a list of operations. 

Assigning an XBOUND application server 
Before you can initialize the XBOUND database using the XBOUND Process Designer, you 
must assign an application server to XBOUND applications. Use this procedure: 

1. Log in to the workstation with the XBOUND applications. 

2. Start XBOUND Management Center by selecting Start > All Programs > ReadSoft > 
XBOUND > XBOUND Management Center.  

3. Load the Common Configuration Manager plug-in. 

4. Select Enterprise Common Properties and click the Binding tab. 

5. If you are using the XBOUND Platform Service, select Native and enter the base URL 
tcp://host:4444 as server name, replacing host with the application server’s host 
name. 

If you are using the WebService application server, select WebService and enter the base 
URL  http://host/xboundWebService as server name, replacing host with the 
application server’s host name. 

6. Click the Service Logging tab and repeat the configuration described above. Select 
Native and specify port 4445. Activate service logging and select your log level. 

7. Select File > Save All and close the configuration program. 

8. Restart the XBOUND Platform Service. (There are instructions on page 66.) 

http://localhost:5555/Mobile.asmx�
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Initializing the XBOUND platform 
The below procedure does three things: 

 It adds activities to the Activities area (the right pane) in the Process Designer. (Activities 
can of course be added manually, as well, using the procedure described on page 53.) 

 It makes XBOUND collectors available in the Tools > Collectors menu in the Process 
Designer. (Collectors can of course be added manually, as well – see XBOUND Help topic 
“Adding a collector”.) 

 It starts the Security Wizard, where you can (optionally) set up role-based privileges.  

Follow these steps: 

1. Start XBOUND Management Center by selecting Start > All Programs > ReadSoft > 
XBOUND > XBOUND Management Center.  

2. Load the Process Designer plug-in. 

3. Select Tools > Initialize Platform. 

4. Click the XML file folder icon next to the edit box.  

5. Select xboundInitialize.xml and click Open. 

6. Click OK. A confirmation message is displayed. 

7. Click OK again.  

8. The Security Wizard starts automatically. Here you can (optionally) set up role-based 
privileges. If needed, press F1 for help. 

9. Close the XBOUND Management Center. 

Initializing RCF data 
If you installed ReadSoft Capture Framework, use this procedure to “migrate” the database 
for ReadSoft Capture Framework. Among other things, this procedures adds the RCF 
activities to the Activities area (the right pane) in the Process Designer.  

1. Open the XBOUND installation folder. 

2. In the xboundOcfMigration.cmd file, adjust the connection parameter. 

3. Ensure that all processes are checked in, and exit XBOUND Management Center. 



 

 XBOUND Installation Guide | © ReadSoft | page 36 of 72 

4. Execute the xboundOcfMigration.cmd file. After it runs, you should see a message like 
“Migration successfully completed.” 

If execution is not successful, adjust the connection parameter and try again. 

5. After successful execution, restart XBOUND Management Center and add the 
XBOUNDPlugInOcfBusinessLogic plug-in. 

6. In XBOUND Management Center, open the Business Logic Designer. 

7. Register the xboundOcfValidationBase library. (If you need assistance, press F1 in the 
Business Logic Designer.) 

Setting up licensing 
Licenses are necessary for using XBOUND in production. They are managed by the 
XBOUND license server using a separate database. Use the below procedures to install the 
license server and apply the licenses.  

Installing the license server 

1. Complete the XBOUND software setup as described on page 12, selecting XBOUND 
License Service to install. 

2. Start the XBOUND License Service. (There are instructions on page 66.) 

Applying a preliminary license file 

 Warning: Do not apply the license before the platform and database are initialized as 
described on pages 35–36. 

A preliminary license file is included with the delivery of XBOUND. It is valid for 30 days 
from the date of issue. This enables you to immediately start production and gather the 
information that ReadSoft needs to create the permanent license file (see “Requesting a 
permanent license file” on page 37).  

Use this procedure to import the preliminary license file: 

1. Start XBOUND Management Center by selecting Start > All Programs > ReadSoft > 
XBOUND > XBOUND Management Center. 

2. Load the License Information plug-in. 

3. Click Add License. 
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4. In the License Server Address box, enter the base URL to the license server in this 
format, replacing host with the license server’s host name: tcp://host:3333 

You can enter base URLs to more than one license servers separated by the pipe symbol  
( | ) in order to provide a backup. Example: tcp://host1:3333 | tcp://host2:3333  
In this case, the license server on host1 is tried first. If it fails, the license server on host2 
is used. 

5. In XBOUND License File, select the preliminary license file that you received from 
ReadSoft and click OK. 

6. A dialog is displayed where you enter details for connecting to the license database. Enter 
all necessary data. Then click Check connection to ensure that connection succeeds. If so, 
click OK. Otherwise, check the details that you specified and try again.  

 Note: If you are using Windows authentication (recommended), be aware that this 
connection test is done from your Windows session. Make sure that the user who runs 
the XBOUND License Service is authorized to access the database. 

7. Click OK. A message is displayed, saying that the license file was loaded successfully.  

Requesting a permanent license file 

The preliminary license file is valid for 30 days after its date of issue. Check the expiration 
date by selecting Help > License information in the XBOUND Process Designer.  

 The permanent license file must be loaded by the expiry date to avoid interrupting 
production. Therefore, request a permanent license file from ReadSoft without delay. 

Request your license file as follows: 

1. Start XBOUND Management Center by selecting Start > All Programs > ReadSoft > 
XBOUND > XBOUND Management Center. 

2. Load the License Information plug-in. 

3. Click Save License Information. 

4. Save the file xboundLicenseInformation.xml. 

5. Email the xboundLicenseInformation.xml file to ReadSoft. 
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Loading the permanent license file 

 Warning: Do not apply the license before the platform and database are initialized as 
described on pages 35–36 

Load the permanent license file as soon as you receive it. Use this procedure:  

1. Start XBOUND Management Center by selecting Start > All Programs > ReadSoft > 
XBOUND > XBOUND Management Center.  

2. Load the License Information plug-in. 

3. Click Add License. 

4. In XBOUND License File, select the permanent license file that you received and click 
OK. 

5. Check the license by selecting Help > License information in the XBOUND Process 
Designer. 

Installing XBOUND clients 
The server-side XBOUND components are now installed and ready to process requests from 
XBOUND clients, which are services and applications that process documents in the XBOUND 
system. The following sections describe how to install these services and applications. 

Installing XBOUND services 

The XBOUND services manage all non-interactive processes within XBOUND. Use this 
procedure to install them: 

1. Complete the XBOUND software setup as described on page 12, selecting for installation 
all XBOUND services and all subcomponents except Platform Service and License Service.  

2. Assign an application server. The procedure is the same as on the administration 
workstation (see page 34). 

3. Start the following services. (There are instructions on page 66.)  

• XBOUND Collect Service 

• XBOUND Activities  

• XBOUND System Agent Service 

If any of these services does not start because of an incorrect login, open the service in the 
service manager and reenter the XBOUND user account data. Then restart the services. 
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If one of the services stops immediately 

1. Move the XBOUND user to the group of the application server’s local administrators. (In 
the case of the Collect Service, it is enough to move the XBOUND user to the group of 
main users.)  

2. Restart the service. 

Installing an XBOUND workstation 

The interactive processes with documents are done at XBOUND workstations. Install each 
XBOUND workstation as follows: 

1. Run the XBOUND software setup as described in “Installing XBOUND” on page 12. 
Select XBOUND Clients and all subcomponents except XBOUND Process Designer and 
XBOUND Process Monitor Client. 

2. Assign an application server. The procedure is the same as on the administration 
workstation (see page 34). 



 

 XBOUND Installation Guide | © ReadSoft | page 40 of 72 

Post-installation tasks 

Setting up XBOUND for Mobile Rescan 
The following procedures are needed if Mobile Rescan is to be used with XBOUND. The 
instructions assume a Microsoft Windows 7 operating system. The actual steps vary 
according to the operating system. 

Activate and configure IIS  

1. Select Control Panel > All Programs > Windows Features > Turn Windows Features 
on or off. 

2. Expand Internet Information Services > Web Management Tools and select IIS 
Management Console.  

 

3. Expand World Wide Web Services > Application Development Features and select 
ASP.NET.  
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4. Click OK to close the Windows Features dialog. 

5. Select Control Panel > System and Security > Administrative Tools > Internet 
Information Services (IIS) Manager. 

6. In the Internet Information Services (IIS) Manager dialog, ensure that there is an 
ASP.NET section: 

 

7. In the right panel (under Actions), click Change .NET Framework Version. 

8. In the dialog that is displayed, select v4.0.30319.  

9. Click OK to close the Change .NET Framework Version dialog. (Keep the IIS Manager 
open for upcoming steps.) 

10. Open a command prompt and run the following commands to register .NET Framework 
for IIS:  

cd C:\Windows\Microsoft.NET\Framework\v4.0.30319  

aspnet_regiis.exe -i 

11. After completion of the ASP.NET installation, close the command prompt. 

Set up xboundWebService as an application in IIS 

1. If you are performing these steps on a 64-bit computer:  

a) In the Internet Information Services Manager (IIS) dialog, in the right panel 
(under Actions), click View Application Pools. 

b) Right-click ASP.NET v4.0 and select Advanced Settings. 

c) Set Enable 32-Bit Applications to True.  

d) Click OK to close the dialog. 
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2. Using Windows Explorer, copy the xboundWebService folder from the XBOUND 
installation path (normally C:\Program Files\ReadSoft\XBOUND) to 
C:\inetpub\wwwroot. 

3. In the Internet Information Services Manager (IIS) dialog, in the left panel (under 
Connections), expand Sites.  

4. Right-click xboundWebService and select Convert to Application. There is nothing 
more to do in the dialog that is displayed; click OK to close it.  

(If xboundWebService is already converted to an application, the command is not visible, 
and you can skip this step.) 

5. Right-click xboundWebService and select Manage Application > Advanced Settings 
(or Manage Web Site > Advanced Settings). 

6. Select Application Pool and click the  button to open the Select Application Pool 
dialog. 

7. Select ASP.NET v4.0 and click OK. 

8. Select xboundWebService in the left pane (under Connections).  

9. In the middle pane, double-click Connection Strings in the ASP.NET section. 

10. Double-click Xbound.Server.XboundDB to open the Edit Connection String dialog. 

11. Select SQL Server and specify the location and name of the main XBOUND database. (If 
you are using an Oracle or DB2 database, this step and the next one are a little different.) 

12. If the database is set up to use Windows Authentication, select Windows Integrated 
Security. Otherwise, select Specify credentials, click Set, and specify the user name and 
password. 

13. Test the function by using a local browser to visit this address:  

http://localhost/xboundWebService/Mobile.asmx  

The WebMobile page should display a list of operators. 

14. Test the function from another computer by visiting this address (replacing 
ComputerName with the name of the computer where you configured Mobile Rescan):  

http://ComputerName/xboundWebService/Mobile.asmx  

 Note: The firewall on the computer where the web service is running must be 
correctly configured. (Http must be permitted.) 

15. If HTTPS is to be used, install a certificate and configure IIS to use the certificate.  

http://localhost/xboundWebService/Mobile.asmx�
http://computername/xboundWebService/Mobile.asmx�
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Setting up the report server for viewing 
SSRS-based reports in XBOUND 
Reports is one of the XBOUND Report Manager’s two sub-programs. Based on Microsoft 
SQL Server Reporting Services (SSRS), it is directly linked to the report server and displays 
reports from the specified folder. 

If you want to view these reports in XBOUND, use the below setup procedure described 
further below. SSRS is required. 

Schematic of the Reporting Services Windows service 

 

The security sublayer is responsible for determining the requestor's identity and whether the 
user has the required rights for the request to be fulfilled. 

All requests sent via HTTP are targeted to the Report Manager and the Web Service 
applications. Both applications are hosted from within the Reporting Services Windows 
service.   

Reporting Services’ core processing features – scheduling, subscription management, 
delivery and reporting processing – are performed by a collection of components hosted 
within the Reporting Services service. 

Service Management ensures that resources are available and that the service works 
properly. 
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Setting up Microsoft SQL Server 

Reporting Services is included in all versions of Microsoft SQL Server version 2005 and 
later. If you use the Express Edition, select the version with Advanced Services.  

Install SQL Server according to the instructions from Microsoft, also taking into 
consideration the following details: 

 Be sure to select Reporting Services in Feature Selection: 
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 Configure the service accounts to be used for each service to be installed. It is generally 
recommended that you use the local service or (generated) network service accounts for 
the SQL Server Database Engine and SQL Server Reporting Services Windows 
service. If needed, you can change the service account after installation. 

 

 In Reporting Services Configuration you can select from three installation options. For 
most basic installations, the best choice is Install the native mode default configuration.  
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 In Ready to Install, review the selected options carefully: 

 

About SSRS Report Manager 

SSRS Report Manager is a web-based report access and management tool that allows you to: 

 View, search, and subscribe to reports 

 Create and manage folders, linked reports, report history, schedules, data source 
connections, and subscriptions 

 Set properties and report parameters 

 Manage role definitions and assignments that control user access to reports and folders 

SSRS Report Manager provides access to your report server via web pages and controls. 
There are pages for viewing items, setting properties, and creating and modifying 
subscriptions, schedules, shared data sources, and roles. You access items that are stored in a 
report server by navigating the folder hierarchy and clicking items to view or update. 
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Depending on how you configure role assignments, viewing and navigation operations can be 
exposed to users who have minimal access to a report server. Management features are 
available to users who have appropriate permissions.  

 Tip: You can also perform management operations using Microsoft SQL Server 
Management Studio. 

Setup procedure 

1. Start SSRS Configuration Manager.  

2. The server name and instance of the SSRS server are displayed in the Reporting Services 
Configuration Connection dialog. You can change them if they are not correct for some 
reason. 

3. Click Connect. 

4. Click Web Service URL in the navigation pane (on the left) of the Configuration 
Manager. 

 

5. In SSRS, URLs are used to access the Report Server Web Service and SSRS Report 
Manager. Before you can use either application, you must configure at least one URL 
each for the web service and SSRS Report Manager.  
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If you installed the default configuration, URLs were created automatically using the 
default values. If not, you must configure a URL for the Report Server Web Service by 
specifying all of the fields in the above dialog. For more information how to configure a 
URL, please see http://technet.microsoft.com/en-us/library/bb630447.aspx. 

Creating a role assignment 

In SSRS, role assignments determine access to stored items and to the report server itself. A 
role assignment consists of: 

 A securable item for which you want to control access. Examples of securable items 
include folders, reports, and resources. 

 A user or group account that can be authenticated by Windows security or another 
authentication mechanism. 

 Role definitions that define a set of tasks.  

Role assignments are inherited within the folder hierarchy. The role assignment that is defined 
for a folder is automatically inherited by all reports, shared data sources, resources, and 
subfolders contained within that folder. 

Each user who requires access to a report server must have a role assignment that defines the 
level of access. You can create role assignments at the root node, or on a specific report, 
model, folder, resource, or shared data source.  

SSRS security is enforced through role assignments that you apply to items. A role 
assignment matches a group or user to a role definition, where each role definition identifies 
the tasks that groups or users can perform with regards to a specific item. 

1. Using SSRS Configuration Manager, click Report Manager URL in the navigation pane 
(on the left). 

2. If needed, configure or modify the URL used to access SSRS Report Manager. By default, 
the prefix, IP address, and port of the Report Server Web Service URL are inherited.  

3. Click the URL to access SSRS Report Manager, which opens in the default browser. (You 
can also access the Report Manager by typing its URL in the address bar of a browser.) 

4. Click Folder Settings. 

http://technet.microsoft.com/en-us/library/bb630447.aspx�
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5. Click New Role Assignment. 

 

6. To perform an action against a Reporting Services item, you must have permission to do 
so. Reporting Services supports a fixed set of permissions associated with each type of 
item. To simplify things, Reporting Services organizes these permissions into a more 
condensed set of item-level tasks:  

• Browser (for running reports and navigating through the folder structure) 

• Content Manager (for defining a structure for storing reports and other items, setting 
security at the item level, and viewing and managing the items stored by the server) 

• Report Builder (for building and editing reports in Report Builder) 

• Publisher (for publishing content to a report server) 

• My Reports (for build reports for personal use or storing reports in a user-owned 
folder) 

Create the role assignments that suit your organization. 
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Uploading reports to a report server 

Use this procedure to add reports (.rdl files) to the report server: 

1. Using SSRS Configuration Manager, click Report Manager URL in the navigation pane 
(on the left). Then click the URL. 

Alternatively, access the Report Manager by typing its URL in the address bar of a 
browser. 

2. Most Reporting Services items are housed within a folder hierarchy. This provides a 
simple, familiar structure for organizing content. To create a folder for the reports, click 
New Folder. Then type a folder name and click OK.  

 

 

3. Click Upload File. 

4. Type a new name for the item, for example Backlog Report or Processing Report.  

5. Click Browse and navigate to the location of the reports that are provided with 
XBOUND. By default, they are located in this folder: 

C:\Program Files (x86)\ReadSoft\xbound\Reports 

6. Select the desired report and click Open. 
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7. Click OK. 

Adjusting report properties 

After a report is published, check the properties that specify: 

 The text that appears in the XBOUND Report Manager user interface. 

 How users access the report. 

 How the report server connects to external data sources. (The connection string is 
important because it establishes the initial connection to an external data source. You must 
change the connection string if you move a data source to another computer, or if you 
created reports using test data but you want to deploy the reports with a production 
database. See screenshot on page 52.)  

 Whether the report runs on demand or on a schedule.  
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Use this procedure: 

1. Still using SSRS Report Manager, click the drop-down arrow of a report and select 
Manage. 

 

2. Adjust the properties as desired.  

For example, if needed, adjust how the report connects to its data source: Click Data 
Sources in the left pane and define how the current report connects to an external data 
source. 
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Adding reports in XBOUND 

Before SSRS-based reports can be viewed for the first time, you must add them to XBOUND 
using the XBOUND Reports plug-in. Please refer to the XBOUND Help topic “Setting up a 
report to display in the Reports plug-in” for instructions. 

ReadSoft Capture Components (RCC) 

Adding activities to the Process Designer 

If you need them, these RCC activities must be added manually to the Process Designer:  

 Knowledge Processing – xBoundActivityKSFeedback.dll 

 Knowledge Processing must be added first. The others can be added in any order.  

 Classification – xBoundActivityDU.dll  

 Inspection – xboundActInspectClient.dll 

 Interpretation – xboundActExtract.dll 

 (The Import Solution activity will be added in a different way – see the next section). 

Use the this procedure:  

1. Using the XBOUND Management Center, open a console containing the Process 
Designer plug-in.  

2. In the Process Designer, select File > New Activity. 

3. In the Choose Activity Group dialog, select an activity group to add the new activity to. 
(The far right pane of the Process Designer is divided into different activity groups.) 

4. In the New Feature dialog, after Path to DLL, select the path to the DLL file containing 
the activity. Then the system fills in the name, version, and class name. Adjust the other 
settings if desired. 

5. Click OK. 

6. Assign the activity to at least one instance of the XBOUND Activities Service. 
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Adding the Import Solution activity to the XBOUND global 
parameter set 

1. Using the XBOUND Process Designer, select Tools > Global Parameter Sets. 

2. Right-click in the left pane and select New Activity.  

3. In the dialog that is displayed, select xBoundActDOXImport.dll and click Open. 

This registers the Import Solution activity in XBOUND. It can now be used in all clients and 
processes.  

 At this point, close all programs and reboot the computer. 

Capture Components Administration 

User authorization 

Capture Components Administration has a user authorization system (login system) that is 
disabled by default. The default user Administrator, which has no password, should be 
deleted after you set up your own users. Adjust user management settings according to 
instructions in Capture Components Administration Help. 

Additional setup 

The Capture Components Administration Help topic “Setting up the system after installation” 
describes the necessary steps. 

 Tip: To view online help at any time while using Capture Cosmponents Administration, 
press F1. You can also access help by selecting Start menu > All Programs > ReadSoft 
> Capture Components > Admin Help. 
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Knowledge Processing 
Follow the instructions below if your XBOUND system includes Knowledge Processing 
(described on page 6). 

Starting the Knowledge Processing Service 

Initially, you must start “ReadSoft Knowledge Processing Service” on the server where you 
installed it. (See instructions on page 66). After that, the service should restart automatically if 
the PC is rebooted. 

 Important: As stated under “Prerequisites” on page 8, the ReadSoft Knowledge 
Processing service must run on a 64-bit operating system. 

Enabling Knowledge Processing  

Activate Knowledge Processing in the Global policies > Persistence policy dialog. Please 
refer to the Capture Components Administration Help topic “Using Knowledge Processing to 
aid extraction.” 

Upgrading from Version 3.x 

The current release allows an upgrade from XBOUND version 3.0, 3.1, 3.5, or 3.6. Older 
XBOUND installations must be updated to one of the those versions before upgrading to the 
current version.  

The upgrade process is divided into these procedures, which are described in the sections that 
follow: 

1. Preparing to upgrade. 

2. Stopping the production process. 

3. Backing up the databases 

4. Installing the new software 

5. Upgrading the databases 

6. Updating an ABBYY installation 

7. Migrating the database contents. 

8. Continuing the production process. 
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Preparing to upgrade 
If you run XBOUND in production, plan the upgrade carefully. It is important to note the 
following: 

 Before the upgrade is scheduled, all processes run by XBOUND should be thoroughly 
tested in a test system of the new version to resolve possible questions or problems before 
upgrading. Budget and schedule these tests sufficiently. 

 Production must be stopped before the upgrade begins. Plan the production stop and give 
all XBOUND users sufficient notice. Do not forget remote users. 

 A complete database backup should be done before upgrading. Ensure that all media for 
saving and recovery (storage medium, backup tools, etc.) are kept ready. 

If upgrading RCC 

Recommended: Save a copy of the ReadSoft.Du.KnowledgeStore.Service.exe.config 
file in your existing installation. By default, the file is located in C:\Program Files (x86)\ 
ReadSoft\Capture Components.  

 The above file is overwritten during the upgrade process. Therefore, do not skip that step 
unless you know that you are using a default version of the file.  

If upgrading a previous version of RCC and Capture Components Administration to version 
1.1.1, you will need to know the names, location, passwords, and type of authentication of all 
of the databases used by your system: 

Required databases 

 XBOUND database 

 License database 

 Logging database  

 RCC configuration database 

 RCC production database  

Optional databases 

 Statistics database 

 Audit trail database 

 Knowledge Processing database 
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Stopping the production process 
Before upgrading, production must be stopped: 

1. Give all users sufficient notice about stopping the production process. 

2. If RCC is included in the upgrade, process or delete all documents in your XBOUND 
system. 

3. Recommended if RCC is included in the upgrade: Back up the installed XBOUND 
processes and Capture Components solutions. 

4. Exit all XBOUND clients, application servers, and related programs including Capture 
Components applications and Capture Components Administration. 

5. Stop all XBOUND-related Windows services. (There are instructions on page 66.) Do not 
forget the ReadSoft Knowledge Processing Service and the XBOUND WebService, if 
used. 

If upgrading from RCC 1.1 
1. Using Windows Control Panel > Add or Remove Programs, uninstall Capture 

Components Administration. 

2. Uninstall Capture Components Administration. 

Backing up the databases 
 Back up all XBOUND-related databases, including the Knowledge Processing database, if 

used. 

Installing the new software 
Using the setup program, update the software on all computers where the old XBOUND 
version was running. Follow the on-screen instructions. 

Then, if it was not done in advance, set up licensing (see “Setting up licensing” on page 36). 
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Upgrading the databases 

Upgrading the XBOUND database (main database) 

 No database upgrade is necessary if you are upgrading XBOUND from version 3.7 to 
version 3.7.1 – except if you want to work with reporting (see page 59).  

 Important: In order to upgrade an IBM DB2 database from version 3.x to 3.7 or 3.71, 
both the main database and the statistics database must have a page size greater than 4 
KB. If the page size is smaller, no update is possible. (Note that the page size of an 
existing DB2 database cannot be changed, as IBM does not support this procedure.) 

Select and execute one of the following SQL scripts on your XBOUND database, depending 
on the database supplier and previous XBOUND version. (Upgrading from 2.0 to 3.7.1 is not 
supported.) The scripts update tables, indices and stored procedures corresponding to the new 
software. They are found in C:\Program Files\ReadSoft\xbound\Sql.  

To do this: Use this script: 

Upgrade from 3.6 on SQL Server XBOUND_update_3.6.0.0_3.7.0.0.sql 

Upgrade from 3.6 on Oracle XBOUND_update_oracle_3.6.0.0_3.7.0.0.sql 

Upgrade from 3.6 on DB/2 XBOUND_update_db2_3.6.0.0_3.7.0.0.sql 

Upgrade from 3.5 on SQL Server XBOUND_update_3.5.0.0_3.7.0.0.sql 

Upgrade from 3.5 on Oracle XBOUND_update_oracle_3.5.0.0_3.7.0.0.sql 

Upgrade from 3.5 on DB/2 XBOUND_update_db2_3.5.0.0_3.7.0.0.sql 

Upgrade from 3.1 on SQL Server XBOUND_update_3.1.0.0_3.7.0.0.sql 

Upgrade from 3.1 on Oracle XBOUND_update_oracle_3.1.0.0_3.7.0.0.sql 

Upgrade from 3.1 on DB/2 XBOUND_update_db2_3.1.0.0_3.7.0.0.sql 

Upgrade from 3.0 on SQL Server XBOUND_update_3.0.0.1_3.7.0.0.sql 

Upgrade from 3.0 on Oracle XBOUND_update_oracle_3.0.0.1_3.7.0.0.sql 

Upgrade from 3.0 on DB/2 XBOUND_update_db2_3.0.0.1_3.7.0.0.sql 
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 Important: If you have distributed tablespaces on Oracle, you must adjust the script 
accordingly before use. Change the TABLESPACE_DATA and TABLESPACE_IND 
variables on lines 2 and 3 of the script from USERS to your new tablespace names. 

Upgrading databases for reporting  

If you want to work with reporting and are upgrading from XBOUND 3.7 to XBOUND 3.7.1, 
you must run one of the following scripts on both your XBOUND database and your statistics 
database. (This is not necessary when updating from any other XBOUND version to 3.7.1; 
only when upgrading from XBOUND 3.7.) 

Database Script 

SQL Server Update_Reportingmodel.sql 

Oracle Update_Reportingmodel_Oracle.sql 

DB/2 Update_Reportingmodel_db2.sql 

Updating an ABBYY installation 
This section describes what you must do before and after updating an ABBYY installation in 
connection with an update from XBOUND 3.6.0.1 to XBOUND 3.7.1. (These steps are not 
needed if you upgrade from 3.6 R2 or 3.7 to 3.7.1.) 

Before updating ABBYY 

1. Uninstall ABBYY FlexiCapture 9.0 and ABBYY FlexiCapture 9.0 Engine (if you use it). 
Do this from the Windows Control Panel > Add or Remove Programs: 
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2. Uninstall ABBYY FineReader Engine 10 (if you use it): 

• Stop the “ABBYY FineReader Engine 10 License Server” service. (There are 
instructions on page 66.) 

• Uninstall the “ABBYY FineReader Engine 10 License Server” service. To do this, go 
to this folder in case of a 32-bit OS: 

Program Files\Common files\ABBYY\SDK\10\Licensing 

Or this folder in case of a 62-bit OS: 

Program Files(x86)\Common files\ABBYY\SDK\10\Licensing 

• From the \Licensing folder run this command: 

DeinstallLicensingservice.cmd 

3. After that all the FlexiCapture Engine-related folders can be deleted: 

Program Files\ABBYY SDK\10\FineReader Engine 

Program Files\Common Files\ABBYY\SDK\10\Licensing 

Or 

Program Files(x86)\Common Files\ABBYY SDK\10\FineReader Engine 

Program Files(x86)\Common Files\ABBYY\SDK\10\Licensing 

After updating ABBYY 

1. Using Windows Explorer, check whether this file is present: 

Program Files (x86)\ABBYY SDK\10\FineReader Engine\frengine.ini 

2. If you cannot find this file, copy it from XBOUND setup subfolder xFC_2 to the folder 
shown above. 
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Migrating the database contents 
Several database records must be adjusted to the new software. 

 Important: This is absolutely required. Ensure that it is done without any errors. 

1. Open a command prompt.  

2. Change directory to C:\Program Files (x86)\ReadSoft\xbound. 

3. Enter the command xboundMigration with these parameters: 

• Eventlog, if the program is to log in the Event Log, or another string if the program 
output is to be done on a console. 

• Native if the application server is available via the XBOUND Native Protocol, 
Remoting if the application server is available via remoting, or WebService if it is 
available via WebService. 

• The URL of the application server. 

(The last two arguments can be copied from the foxconfig configuration file and pasted 
into the command line.) 

If statistical data are to be acquired, set up a new statistics database and link it to the 
production database. The necessary steps are described “Collecting statistical data” in 
XBOUND Help. 

The statistics collector of older XBOUND versions and the statistical databases created with it 
are no longer supported. 

Additional procedure if you upgraded RCF 

The RCF configuration and runtime data must be migrated to the current version. You must 
do this after upgrading the installation or importing older XBOUND processes. Use this 
procedure: 

1. Important: At this point the xboundOcfMigration.exe program must be run once. This 
program requires call-up parameters. Therefore, adjust the file xboundOCFMigration.cmd 
file and then start xboundOcfMigration.exe. 

2. Now the xboundOcfValidationBase must be updated: 

a) Open the Business Logic Designer and select File > Libraries.  

b) Open xboundOcfValidationBase. 
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c) In the dialog that is displayed, enter the path of xboundOcfValidationBase.dll 
(normally C:\Program Files\ReadSoft\xbound). 

d) Update by clicking OK. 

 Note: If “OCR Mapping” does not work in the RecoStar parameter set or at runtime, see 
“Known Problems” in XBOUND RCF Release Notes. 

 Note: If you import processes that were exported from the old system, you must again execute 
XBOUNDMigration.cmd and then xboundOcfMigration.cmd (adjusted for your system).  

Additional procedure if you upgraded RCC 

1. Using the Process Designer, open each RCC process step, select DOX in the Parameter 
set drop-down list, and click OK. 

2. Ensure that the ReadSoft Knowledge Processing service is stopped.  

3. Restore the ReadSoft.Du.KnowledgeStore.Service.exe.config file that you saved 
from your previous installation (see page 56). By default, the file is located in 
C:\Program Files (x86)\ReadSoft\Capture Components.  

4. Upgrade the Knowledge Processing database using the SQL script provided. In a default 
installation, this script is found in C:\Program Files (x86)\ReadSoft\Capture 
Components\SqlScripts\KnowledgeStore. 

5. In the Knowledge Processing database, the solution GUIDs in the StoreName column 
must be replaced with the solution names. Use this procedure:  

a) Using SQL Server Management Studio, run this command on the RCC 
configuration database to find the GUID that corresponds with each solution name: 

select dbid, name  

from [Your_Database].dbo.specifications  

where botype=40110 

…where name is the name of your solution and dbid is the corresponding GUID 
(the value in the StoreName column). 

b) For each pair (dbid, name), update the Knowledge Processing database using this 
command: 

update [Your_Database].dbo.LDPData 

set StoreName = 'name'  

where StoreName='dbid' 
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Continuing the production process 
If the upgrade was successful, the system should be tested briefly. Then production with 
XBOUND can be continued: 

1. Restart all XBOUND clients and application servers, and restart all XBOUND-related 
Windows services. (There are instructions on page 66.) Do not forget the ReadSoft 
Knowledge Processing Service and the XBOUND WebService,  

2. Inform users that production can resume. 
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Additional information 

64-bit installation 
Installing a 64-bit XBOUND system does not differ in principle from installing a 32-bit 
system. However, there are some issues to take into consideration: 

 You can install and operate the 32-bit XBOUND product on a 64-bit operating system. 

 You can install and operate 32-bit and 64-bit versions on one computer in parallel. 

 The 64-bit version does not support all XBOUND components (for details, see below.) 

 If dongle drivers are necessary, install the 64-bit versions. These are normally available on 
the manufacturer's website. 

XBOUND components 

The following XBOUND components can run as native 64-bit components:

 XBOUND Platform Service 

 XBOUND License Service 

 XBOUND Activities Service 

 XBOUND Collect Service 

 XBOUND Agent Service 

 Activity Build Document Structure 

 Activity Split Batch 

 Activity Merge Batch 

 Activity Adapter for File System 

 Activity Adapter for File System 
(Structure) 

 Activity Barcode classify 

 Activity Document clean up 

 XBOUND Collector for File System 

 XBOUND Collector for SCAN 
CLIENT 

 XBOUND Agent for Session Removal 

 XBOUND Agent for Document 
Resubmit 

 XBOUND Agent for Service Logging 
Removal 

All other components can be installed and used as 32-bit versions on a 64-bit operating 
system. To do this, start the XBOUND 32-bit setup explicitly and choose the desired 
components. 
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RCF components  

The following RCF components can run as native 64-bit components: 

 ReadSoft Capture Verification application (formerly called “Open Capture Verifier”)  

 Business Logic activity 

All other XBOUND RCF components can be installed and used as 32-bit versions on a 64-bit 
operating system. To do this, start the XBOUND 32-bit setup explicitly (see above) and 
choose the desired components. 

RCC components 

 64-bit XBOUND installations are not supported by RCC. 

 The ReadSoft Knowledge Processing service must run as a 64-bit service. 

Silent installation 
If XBOUND is to be installed in the uncontrolled mode, then start installation using the 
following command. The possible values for “para” are shown in the table below.  

Setup.exe /sTARGETDIR=?:\Program Files\ReadSoft\xbound para1 para2 … 

Value  Meaning 

INSTALL_REGISTRATION=TRUE Installs the XBOUND Registration 

INSTALL_PROCESSDESIGNER=TRUE Installs the XBOUND Process Designer 

INSTALL_PROCESSMONITOR=TRUE Installs the XBOUND Process Monitor 

INSTALL_DOCUMENTVERIFIER=TRUE Installs the XBOUND Document Verifier 

INSTALL_DOCUMENTATION=TRUE Installs the XBOUND documentation 

INSTALL_GAC_4_0=TRUE Installs the XBOUND runtime environment in the 
global assembly cache as well. These object use 
Microsoft .NET Framework 4.0.  

INSTALL_RCF=TRUE Installs XBOUND RCF 

INSTALL_RCFVERIFICATION=TRUE Installs RCF Verification 

INSTALL_SDKTEMPLATES=TRUE Installs the samples for the SDK 
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Example that installs the XBOUND Process Monitor on the D drive in the ReadSoft\xbound 
directory: 

Setup.exe /s TARGETDIR=D:\ReadSoft\xbound INSTALL_PROCESSMONITOR=TRUE 

Example that creates a local XBOUND Activities Service with the Sc.exe command-line 
program. The service should be operated under the “Domain\account” user with the password 
“123”: 

Sc.exe create “xbound Activity Service” binPath= 
“D:\ReadSoft\xbound\xboundActivities.exe xbound Activity Service” obj= 
Domain\account password= 123 

Example that installs RCF Verification on the D drive in ReadSoft\xbound directory: 

Setup.exe /s  TARGETDIR=D:\ReadSoft\xbound INSTALL_RCFVERIFICATION =TRUE 
 

(Re)starting or stopping Windows Services 
XBOUND services manage all non-interactive (automatic) processes within XBOUND. At 
different times while installing, uninstalling or setting up XBOUND, you need to start, stop, 
or restart Windows Services. Use this procedure: 

1. Select Start menu > Control Panel > Administrative Tools > Services. 

2. In the list of services that is displayed, right-click the service and select Start or Stop or 
Restart. 

These are the XBOUND-related Windows services. For a description of these services, see 
XBOUND Help. 

 XBOUND Collect Service 

 XBOUND Activities 

 XBOUND System Agent Service 

 XBOUND License Service 

 XBOUND Platform 

 XBOUND WebService 

 ReadSoft Knowledge Processing Service 

 ABBYY FineReader Engine 10 License 
Server 

Reinstalling the same version 
If you need to reinstall the same version of XBOUND, RCF or RCC, there is no need to 
uninstall it, delete databases, etc. Simply run the installation program again. 
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Installing RCC using MSI files  

Installation order 

RCC Administration must be installed before RCC: 

1. First Capture Components Administration.msi 

2. Then ReadSoft.Capture.Components.msi 

If you install them in the wrong order, the XBOUND activities are not installed. Among other 
things, you will be unable to import a Capture Components solution. A typical error message:  

Could not retrieve deployed solutions. Please make sure that the DOCUMENTS database is 
properly installed.  

If RCC and RCC Administration were already installed in the wrong order, use this procedure 
to solve the problem: 

1. Run ReadSoft.Capture.Components.msi again.  

2. When the setup dialog is displayed, click Change.  

3. Add the Activities feature to the custom setup. 

4. Proceed with the installation. 

Error message and rollback 

Installing RCC using ReadSoft.Capture.Components.msi can cause the following error to 
be displayed and the installation to roll back: 

Calling custom action CreateDiagnosticsCategory!CreateDiagnosticsCategory.CustomActions. 
CreatePerformanceCounterCategory 

This error is caused by corrupt performance counters in the operating system. Although it is 
not related to any ReadSoft product, it prevents RCC from installing. 

To solve this problem, recreate the corrupted performance counters by running this command 
from the command prompt: run lodctr /r 
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Uninstalling XBOUND and related 
components 
If XBOUND was installed to a non-default location (that is, not C:\Program Files 
(x86)\ReadSoft), then RCC (if present) must be uninstalled first. The orders listed below are 
best practice even if XBOUND was installed in the default location.  

Installation order 

1. XBOUND 

2. ReadSoft Capture Framework (RCF) 

3. Capture Components Administration 

4. ReadSoft Capture Components (RCC)  

Uninstallation order 

1. ReadSoft Capture Components (RCC) 

2. XBOUND 

3. ReadSoft Capture Framework (RCF) 

4. Capture Components Administration 

If XBOUND is uninstalled first, the information about where it was located is no longer 
available, and the system will try to uninstall RCC from the default location (C:\Program 
Files (x86)\ReadSoft). 

Encrypting communication 
You can encrypt the communication between XBOUND applications and the XBOUND 
server. The Native protocol offers two additional communication modes in addition to the 
standard communication over an unencrypted TCP connection: 

 TCPE: Windows supports encrypting the communication in addition to authentication. 

 TCPS: The communication is encrypted using an additional SSL (Secure Socket Layer). 
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Encryption by Windows (TCPE) 

The mechanism used for authentication is also used for encrypting the communication 
channel. The encryption parameters are adjustable in Windows. For details, contact your IT 
department. 

To use TCPE encryption: 

1. In the xboundPlatform.exe.config file, comment the entry containing 
Xbound.Server.TcpPort to inhibit unencrypted communication. 

2. Uncomment the entry containing Xbound.Server.TcpePort to activate encrypted 
communication. 

3. Restart the XBOUND Platform service. (There are instructions on page 66.) 

4. Configure the XBOUND applications to use a Unified Resource Identifier (URI) with the 
tcpe scheme and the configured port when logging in. Example: tcpe://myserver:5555 

Encryption by SSL (TCPS) 

In this case, encryption is done by an additional SSL (Secure Socket Layer). The encryption 
parameters are defined by the certificate that you use. 

To use TCPS encryption: 

1. Create a certificate for encrypting on the computer running the XBOUND Platform 
service in the certificate store of the local computer, in My Certificates. 

2. Start XBOUND Management Center by selecting Start > All Programs > ReadSoft > 
XBOUND > XBOUND Management Center.  

3. Load the Common Configuration Manager plug-in. 

4. Click XBOUND Platform Service and select the XBOUND Connection tab. 

5. Select Use SSL. 

6. In the Certificates list, select the certificate that you created. 

7. Click Save. 

8. Restart the XBOUND Platform service. (There are instructions on page 66.) 

9. Configure the XBOUND applications to use a Unified Resource Identifier (URI) with the 
tcps scheme and the configured port when logging in. Example: tcps://myserver:6666 
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Database maintenance and backup 
It is essential that you establish and carry out 
maintenance and backup routines that are appropriate to 
your system.  

RCC: For information about maintenance and backup, 
as well as error prevention and troubleshooting, please 
refer to Installing and Configuring Microsoft SQL 
Server For Use With ReadSoft Capture Components, a 
ReadSoft document that is available in the Capture 
Components installation. 

If there is a power failure, or if a Capture Components 
Administration process is terminated unnaturally for 
any other reason, the databases can become corrupt. In 
most cases, the network database server handles such situations and you need only restart the 
process.  

Additional information about databases can be found in the different help files (see page 72). 
For a list of topics related to databases, click the Index tab in a help file and type databases in 
the box. 

Switching between RCC databases 
If you have two or more pairs of RCC databases (see page 22), for example a test system and 
a production system, use the below procedure to switch.  

This procedure can also be used to switch from one Knowledge Processing database (see page 
27) to another. 

1. If it is open, close Capture Components Administration.  

2. Select Start menu > All Programs > ReadSoft > Capture Components > 
Configuration.  

3. In the navigation panel, select Capture Components > Database Configuration (or 
Knowledge Processing > Database Configuration). 
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4. Adjust the settings to reflect the database that you want to switch to. The settings are 
described in detail starting on page 23 (for the Capture Components databases) and 27 (for 
the Knowledge Processing database). 

 

5. Click Test to test the connection. 

6. Click Save. This updates:  

• The Windows Registry, if you selected Capture Components > Database 
Configuration. 

• The configuration file C:\ProgramData\ReadSoft\Documents\ 
KnowledgeStore\ReadSoft.KnowledgeStore.Database.config, if you selected 
Knowledge Processing > Database Configuration.  
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Restarting Windows services 

After switching databases, you must restart all relevant Windows services, namely ReadSoft 
Knowledge Processing Service and/or XBOUND Activities.  

Instead of clicking Restart, we recommend this procedure: 

1. Click Stop. 

2. Wait 10 seconds. 

3. Click Start. 

Additional SQL scripts 
The following additional scripts can be found in the Sql folder in your XBOUND installation 
(default location C:\Program Files\ReadSoft\xbound\Sql).  

xbound_sequence_update_oracle_3.7.0.0.sql   

This helper script can be used if for any reason the sequences in your Oracle database do not 
reflect the maximum ID of your records. 

DocManager_Oracle.sql 

This script creates helper indices which can improve the performance of DocManager in an 
upgraded database (since the upgrade scripts do not create them). 

*_drop_*.sql 

These scripts delete all database objects that the xbound_create_*.sql scripts create.  

Where to find more product information 
Various help files (CHM files) and other documents (PDF files) are available in each 
installation of XBOUND. Select Start menu > All Programs > ReadSoft > ….  

The help files also contain a topic called “Additional documentation.” That topic contains 
links to most available documents. 
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