
Kofax ReadSoft Invoices
FLEXIm Installation Guide
Version: 6.0.2

Date: 2019-07-03



Legal Notice

© 2019 Kofax. All rights reserved.

Kofax is a trademark of Kofax, Inc., registered in the U.S. and/or other countries. All other trademarks
are the property of their respective owners. No part of this publication may be reproduced, stored, or
transmitted in any form without the prior written permission of Kofax.

2



Table of Contents
Legal Notice...................................................................................................................................................2
Chapter 1: Introduction.............................................................................................................................. 4

The four main components of FLEXlm..............................................................................................4
Supported operating systems.............................................................................................................4

Chapter 2: Obtaining a license file........................................................................................................... 5
Chapter 3: Before installation....................................................................................................................6
Chapter 4: Installing and setting up FLEXlm........................................................................................... 7

Choosing a server.............................................................................................................................. 7
Installing FLEXlm................................................................................................................................7
Placing the license file in Invoices and FLEXlm................................................................................7
Configuring and starting FLEXlm....................................................................................................... 8

Chapter 5: How the license request process works............................................................................. 11
Chapter 6: Shutting down the FLEXlm server....................................................................................... 12

Voluntary termination........................................................................................................................ 12
Abnormal termination........................................................................................................................13
Client crashes................................................................................................................................... 13

Chapter 7: The license file.......................................................................................................................14
Full (stand-alone) license versus module-based license................................................................. 14

Full (stand-alone) license...................................................................................................... 14
Module-based license............................................................................................................14

Chapter 8: Checking your license restriction........................................................................................16
Volume-based license.......................................................................................................................16

License with a time limit........................................................................................................16
Chapter 9: Frequently asked questions................................................................................................. 17

What if Invoices is installed on a stand-alone computer (not connected to a network)?..................17
How can I see that FLEXlm started correctly?................................................................................ 17
Is there any way to duplicate licenses by copying lines in the license file?.....................................17
What happens when the license server terminates?.......................................................................17
What is the best troubleshooting procedure?.................................................................................. 17

Chapter 10: Troubleshooting................................................................................................................... 19
Troubleshooting checklist................................................................................................................. 19

3



Chapter 1

Introduction

This document describes how to install, set up, and use FLEXlm, a flexible license manager server from
Flexera Software (previously Macrovision Corporation) that is used with Kofax ReadSoft Invoices. FLEXlm
administers your software licenses.

Important: Anti-virus programs can interfere with normal operation of FLEXlm. You may need to configure
the anti-virus program to recognize FLEXlm as a “friendly” program. The procedure depends on your
anti-virus program and is outside the scope of this document. However, it is known that you cannot run
FLEXlm with Panda.

The four main components of FLEXlm
• The FLEXlm interface in which you both configure your license service and start and stop the FLEXlm

server (lmtools.exe)
• The license manager windows service (lmgrd.exe)
• The vendor windows service (ehlm.exe)
• The license file (license.dat)

Supported operating systems
• Windows 10
• Windows 8 and 8.1
• Windows 7
• Windows Server 2016
• Windows Server 2012 and Windows Server 2012 R2
• Windows Server 2008
• Windows Server 2008 R2
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Chapter 2

Obtaining a license file

The license file (license.dat) allows you to access the components of your system. FLEXlm uses the
license file to manage your different licenses.

Contact your Kofax representative for details on how you can obtain the license file.
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Chapter 3

Before installation

The words “Change_This” are listed in the license.dat file as a temporary server name. Open
license.dat with Notepad, replace “Change_This” with the name of the server where your FLEXlm
software will be located, and save the change before you install FLEXlm.

Important

• The SERVER and VENDOR lines are the only ones that can be changed without damaging the license file.
• Install the Sentinel driver before installing FLEXlm.
• If the license file you received has some numbers in the file name (for example license12345.dat), delete

the numbers. The file name must be license.dat.
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Chapter 4

Installing and setting up FLEXlm

Choosing a server
FLEXlm can be installed on any computer on the network that:
• Can be reached from the Invoices clients.
• Runs one of the required operating systems (see page 5).
• Can run constantly and does not need to be restarted during working hours.

For stand-alone installations, the server is most likely the computer where Invoices is installed.

Installing FLEXlm
1. Exit all Windows programs.
2. Open the \Installation\FLEXlm folder in the Kofax ReadSoft Invoices installation package and

double-click ReadSoft Flexlm Server.msi.
3. In the Welcome dialog, click Next.
4. Click Next to install FLEXlm. The following components are installed in C:\FLEXlm on your system:

lmgrd.exe – the license manager daemon.
lmtools.exe – a console program is used to configure, start and stop the license server.
ehlm.exe – the Vendor daemon.
lmutil.exe – a utility program that assists you in checking in the license of a client computer that has
crashed.
ReadSoft_Invoices_FLEXlm_Install.pdf for Invoices – this document.

5. Click Finish in the InstallShieldwizard Completed dialog to complete the installation process.
6. If you are prompted to do so, restart the computer.

Placing the license file in Invoices and FLEXlm
The FLEXlm server is now installed. The next step is to copy the license file (license.dat) to the global
path folder specified for every client in the system. This folder is specified as GlobalPath in each client’s
Eilocal.ini file.

In most network installations, all Invoices clients share a common global path. In this case, place
license.dat in this one location. In other network installations, the clients do not share a common global
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path. In this case, make copies of license.dat and put them in all of the different locations specified in the
clients’ global path.

After the clients are set up, copy license.dat to C:\FLEXlm.

Configuring and starting FLEXlm
Now it is time to set up the FLEXlm server to automatically manage your Invoices modules.

1. Double-click lmtools.exe, located in C:\FLEXlm.
Note: On the newer operating systems, you must run lmtools.exe as an administrator. Even if you
are an administrator on the server, you must right-click the file and select Run as Administrator.

2. On the Service/License File tab, select Configuration using Services.
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3. Next, click the Config Services tab and ensure that the settings are as shown below. If they are not,
type the path information manually or click the Browse buttons and navigate to the correct locations.

4. Select Use Services.

5. Select Start Server at Power Up to avoid having to restart the FLEXlm server manually each time
you reboot.

6. Click Save Service and then Yes in order to save this configuration.
7. The next step is to start FLEXlm. Click the Start/Stop/Reread tab.
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8. Click Start Server. The settings you specified on the Config Services tab are now available to
FLEXlm.

9. After the “Server Starting” message is displayed in the status bar (lower left corner), select File >
Exit to close the LMTOOLS dialog.
The FLEXlm server is now started. To ensure that it is running, use Windows Explorer to look in the
C:\FLEXlm folder, where you should see the ehlm file (with no extension). This file is created just
after you click Start Server. Alternatively, use the Task Manager > Processes tab to check that
ehlm.exe and lmgrd.exe are listed as running processes. You can also check the log file, Debug.log.
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Chapter 5

How the license request process works

This is what happens when you start Invoices with the FLEXlm server running:

Invoices uses Eilocal.ini to determine the global path defined for the system.

Invoices uses the global path to locate the license file (license.dat), which contains the name of the server
that hosts FLEXlm.

Invoices, the client, establishes a connection with the license manager daemon (lmgrd.exe) on the
FLEXlm server, using an appropriate port (27000 by default) and determines which vendor daemon it
needs to talk to – ehlm.exe in this case.

The license manager daemon determines which computer and port correspond to the vendor daemon and
sends that information back to the client.

The client establishes a connection with the specified vendor daemon and sends its request for a license
(that is, the client is requesting to open an Invoices module that it is licensed to use).

The vendor daemon checks its memory to see if any licenses are available and sends consent or refusal
back to the client.

If a license is available, the client can now run the module. If the license request is refused, the module is
not made available to the client.
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Chapter 6

Shutting down the FLEXlm server

Voluntary termination
The license server is intended for constant use. However, if you need to shut it down for any reason (such
as if you want to move the FLEXlm software to a different server), do the following:

1. Open the FLEXlm dialog again by double-clicking lmtools.exe in C:\FLEXlm.
2. Click the Service/License File tab and select Configure using services
3. Click the Start/Stop/Reread tab and select Force Server Shutdown.
4. Click Stop Server.

5. When you are ready to start the server again, simply click Start Server on this same tab.
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Abnormal termination
If the server crashed or terminated abnormally, follow these instructions:

1. Click the Task Manager’s Processes tab to see if the ehlm.exe and lmgrd.exe processes are
running. If they are running, end these tasks.

2. In the C:\FLEXlm folder, check for a file named Ehlm (without an extension). If you find this file,
delete it.

3. Restart FLEXlm by clicking Start Server on the Start/Stop/Reread tab. Use the Task Manager (or
Windows Explorer) as described on page 10 to make sure the server is running again.

Client crashes
If a client crashes, its license might not be checked in properly. The usual way to resolve this is to restart
the FLEXlm service. However, you can also use the “lmutils” program to check in the license of a client
that has crashed. Use this procedure:

1. Start a command prompt session on the FLEXlm server and move to the C:\FLEXlm folder.
2. Run lmutil lmstat –a to list all the licenses and the users that are connected to them. (Type C:

\FLEXlm>lmutil lmstat –a on the command line.)
3. Note the license feature, the user name, and the computer name of the client that crashed.
4. Run lmutil lmremove <feature> <”user”> <host> <display> to remove the unused feature (<display>

is the same as <host>). Here is an example:
C:\FLEXlm>lmutil lmremove EIVERI “Joe Smith” joes joes
This removes the Invoices Verify module license that the user “Joe Smith” has checked out on the
computer named “joes”.
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Chapter 7

The license file

The license.dat file is set up with a volume limit, and you can see how much has been used by creating a
license-status report clicking Help > About Invoices > License status report and opening the resulting
file.

Full (stand-alone) license versus module-based license
Regardless of whether your Invoices license is based on invoice processing capacity or time, it can be a
full license or a module-based license.

Full (stand-alone) license
A full license lets you run one instance of each Invoices module on one computer at a time. This is also
called a stand-alone license.

With this license, you can install Invoices on more than one computer, but the license manager only
allows Invoices modules to run on one computer at a time, regardless of which modules are running. For
example, if you perform a full installation on two computers, start Manager on one computer, and then
try to start Scan on another computer, Scan will not start because the license is already taken by the first
computer. If you close Manager on the first computer, however, you can start Scan on the other computer.

Example from a full license with a time limit:

SERVER test-server ANY

VENDOR EHLM

FEATURE EIFULL EHLM 1.002 03-Jan-2011 1 BBBBBBBBBBBB DUP_GROUP=UHD

Module-based license
A module-based license lets you run any module you have license for, on any computer on the network.
For example, if the license permits five Verify modules, you can run five instances of Verify on any five
computers on the network where Verify is installed. In this example, if a sixth instance of Verify is started
anywhere on the network, the module will not run because all of the licenses are in use.

Example of modular licensing for one Manager module, three Scan modules, two Interpret modules, etc.:

SERVER test-server ANY

VENDOR EHLM
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FEATURE EIMNGR EHLM 1.002 03-Jan-2011 1 BBBBBBBBBBBB

FEATURE EISCAN EHLM 1.002 03-Jan-2011 3 BBBBBBBBBBBB

FEATURE EIITRP EHLM 1.002 03-Jan-2011 2 BBBBBBBBBBBB

FEATURE EIVERI EHLM 1.002 03-Jan-2011 5 BBBBBBBBBBBB

FEATURE EITRAN EHLM 1.002 03-Jan-2011 1 BBBBBBBBBBBB

FEATURE EIOPTI EHLM 1.002 03-Jan-2011 1 BBBBBBBBBBBB

Previous versions of Invoices used combinations of full licensing and modular licensing, but those
methods are no longer used.
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Chapter 8

Checking your license restriction

Invoices licensing is based on either the volume of invoices processed or time. After the limit of invoices1

specified in the license is reached, or the expiry date is reached, the license must be renewed to continue
using Invoices.

Volume-based license
If you have a volume-based license, the About dialog in Invoices will tell you the capacity of your current
license. You can also see how much of the capacity that has already been used by clicking System info
and looking at the value in brackets that is part of the Capacity value.

Example: Example

Capacity: 100000 [5276] –(FLM/S) means that a total of 100000 invoices can be processed, and 5276 of
those were already used.

License with a time limit
1. Open an Invoices module.
2. Select Help > About Invoices > System info.

After the Version and Build number, the dialog displays Valid until [date] if you have a time-limited
license. (Description continues on the next page.)
The type of license may also be displayed:
After the Version and Build number, the dialog displays Valid until [date] if you have a time-limited
license. (Description continues on the next page.)
The type of license may also be displayed:

Display format License type

Valid until: DD-MM-YYYY (FLM/S) FLEXlm Server time limited

Valid until: DD-MM-YYYY (FLM/L) FLEXlm local file time limited

Capacity: XXXXX (FLM/S) FLEXlm Server with soft license

Note Every time a time-limited license is purchased or renewed, the expiration date is set. In other
words, if you have a time-limited license, the valid until date matches the expiration date in the
license file that you received.

1 Licensing is based on the number of invoices, not the number of pages.
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Chapter 9

Frequently asked questions

What if Invoices is installed on a stand-alone computer (not
connected to a network)?

When the FLEXlm software is to be installed on a stand-alone computer, follow the same installation
procedure as when it is installed on a server. If the stand-alone computer has no name (comparable to a
server name), write this_host in the license file instead of the server name.

How can I see that FLEXlm started correctly?
Use Windows Explorer to look in the C:\FLEXlm folder, where you should see the ehlm file (with no
extension). Alternatively, Windows XP users can use the Task Manager > Processes tab to ensure that
ehlm.exe and lmgrd.exe are listed as running processes.

If you are running FLEXlm as a service, you will find it as ReadSoft in the list of services. Check that its
status is Started.

Is there any way to duplicate licenses by copying lines in the
license file?

Copying the FEATURE line has no effect. The second line is simply ignored by the FLEXlm server.

What happens when the license server terminates?
Invoices sends periodic signals to the FLEXlm server to check if it has terminated. If the server has
terminated, the user cannot start or continue a job in any production module. In addition, the user cannot
create or save form definitions or perform other actions in Manager if the server has terminated.

What is the best troubleshooting procedure?
Start by using the FLEXlm Troubleshooting checklist.
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You can also check FLEXlm™ End Users Guide. It is located on the Documentation folder in your
installation. The file name is enduser.pdf.

If errors persist, contact your Kofax representative.
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Chapter 10

Troubleshooting

Troubleshooting checklist
You can use the following checklist to find problems with FLEXlm and correct them.
• Ensure that the correct server name is listed in the license file (the name after SERVER on the first

line). When you received the file, the words “Change_This” were listed as a temporary server name.
Ensure that it has been changed as described on page 6 and that the file name is license.dat.

• When the FLEXlm server is running, ensure that ehlm (a file with no extension) is located in the C:
\FLEXlm folder.

• Ensure that no Kofax clients have a C:\FLEXlm folder that is not being used as a license server.
• Ensure that all Kofax clients can connect to the global path (defined in their Eilocal.ini files) and have

access to the license.dat file.
• Whenever the FLEXlm server is about to be started (that is, just before you click Start Server), ehlm (a

file with no extension) should not be located in the C:\FLEXlm folder.
• Run LMTools in Windows NT 4.0 (Service Pack 5) Compatibility mode.
• Ensure that the license manager service, lmgrd.exe has the status Started and is set to Automatic on

the computer where FLEXlm is running.
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• When the FLEXlm server is started and running, ensure that these lines can be seen at the beginning
of the Debug.log file. (You specified the path to this file in step 3.)

If there is a message like “Invalid hostID on SERVER line”, and you have already checked the points
listed above, reinstall the Sentinel driver.

• Ensure that no anti-virus program is interfering with normal operation of FLEXlm. For example, an error
message similar to this one can indicate a problem with anti-virus software:
...
12:11:10 (lmgrd) Started EHLM (pid 5632)
12:11:10 (EHLM) Server started on pavranb for: EIFULL
12:11:10 (EHLM) EILineItem DOCCAP EHPDF
12:11:10 (EHLM) IAFULL IAMaxDefinedUsers XMLINPUT
12:11:10 (EHLM) Vendor daemon can't talk to lmgrd ()
12:11:25 (lmgrd) Vendor daemon died with status 28
12:11:25 (lmgrd) Since this is an unknown status, lmgrd will
12:11:25 (lmgrd) attempt to re-start the vendor daemon.
12:11:25 (lmgrd) Restarted EHLM (pid 5188)
...
12:11:25 (EHLM) Vendor daemon can't talk to lmgrd ()
...
You may need to configure the anti-virus program to recognize FLEXlm as a “friendly” program, or
disable functions intended to prevent a TCP/IP attack. The procedure depends on your anti-virus
program and is outside the scope of this document.
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