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Introduction 

This document shows you how to set up and use FORMS’ Face and Signature Analyzer plug-
in, which provides: 

 Automatic digital processing of photographs to optimize their size, positioning, and 
quality. 

 Automatic signature processing, including scaling and optimization of image quality. 

 Mass verification of photographs and signatures. 

 Tools with which to adjust the photographs. 

When you use the Face and Signature Analyzer, there are some things you need to do 
differently when you use the Manager module to prepare for production. In short, these are: 

When you define: Do this: 

The field containing the 
photograph 

 Select Must be filled in and Mass verify on the Standard 
tab of the Field dialog. 

 Add event handlers for OnFieldInterpreted and 
OnFieldComplement to initiate the face analysis process 
during the interpretation and verification stages. 

The field containing the 
signature 

 Select Must be filled in. 

 Optional: Select Mass verify. The plug-in does not allow you 
to edit signatures, but mass verifying them is a convenient way 
to view the results of the automatic processing.  

 Add an event handler for OnFieldInterpreted to initiate 
automatic signature analysis during the interpretation and 
verification stages. 

The transaction description  Include the #Fieldfile variable. 

The job description  Configure FORMS to import scanned image files. 

 Specify how image files are to be displayed for mass 
verification. 

 Configure FORMS to export images. 
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This document explains details of the preparation and production processes that are specific to 
the Face and Signature Analyzer. It does not tell you about other FORMS procedures that are 
not related to the plug-in. Thus, this document assumes that you are familiar with standard 
FORMS functionality and how to use it. 

For information about standard FORMS processes and functionality, refer to FORMS Help. 
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Setup 

As you prepare for production, use FORMS’ Manager module to perform the steps described 
below. 

Defining fields 
Perform these steps after you create an initial form definition from your sample form and are 
ready to create field definitions for the photograph and signature. 

The field containing the photograph 

1. Bring the box provided for the photograph into view using the scroll bars, F3, and F4. 
Draw a frame around it. 

2. Double-click inside the frame. The Field dialog is displayed. 

3. In the Identification section of the Standard tab, select Image as the field type and 
specify a name for the field in the Name box. 

4. In the Category box, assign the field its own category number. For example, assign the 
number “1” if it has not been used for any other fields. Make a note of the category 
number you assign, because you will need it later (in step 2 on page 12). 

5. Select Must be filled in to specify that a photograph must appear in the field. (If none is 
present, FORMS alerts the Verify operator during verification.) 

6. Select Mass verify. (This gives the fields Mass verify status, causing them to be displayed 
as thumbnail images during the verification process as described on page 14.) 

7. On the Events tab, click New. The Event details dialog is displayed. 

8. Using the scroll bar in the Name box, select FieldInterpreted. 

9. In the VBA function box, you can see that a function is automatically defined for 
FieldInterpreted. Click Code to open the Visual Basic Edit window. 
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10. Copy the code below and paste it into the Visual Basic Edit window, replacing all of the 
existing text. 

Function OnFieldInterpreted (  ) As Long 
dim width as integer 
dim height as integer 
dim faceHeight as integer 
dim average as integer 
dim stdDeviation as integer 
dim percentOriginal as integer 
dim backgroundTolerance as integer 
dim correlation as string 
'Size in mm of output image 
width = 25 
height = 32 
'Approximate head height in mm of input and output image 
faceHeight = 25 
'Desired average gray level and std deviation of face 
average = 150 
stdDeviation = 30 
'Blending factor of original image and desired avg/std dev 
percentOriginal = 30 
'Gray level tolerance per color component for background 
'removal 
backgroundTolerance = 50 
'Minimum correlation to define a correct match 
correlation = "0.65" 
'Analyze image 
Application.Field.FaceAnalyze( width, height, faceHeight, average, 
stdDeviation, percentOriginal, backgroundTolerance, correlation ) 
   OnFieldInterpreted = EV_OK  ' Return value to FORMS 
End Function 
 

11. If necessary, adjust the parameters in the event handler to suit your requirements. 

12. Select Compile > Compile in the Visual Basic Edit window. 

13. Select File > Save and exit. 

14. Click OK in the Event details dialog to complete the process. 
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15. Repeat the above steps, this time selecting FieldComplement from the Name box to define 
the second event handler: OnFieldComplement. Copy and paste the following code into the 
Visual Basic Edit window: 

Function OnFieldComplement (  ) As Long 
Application.SetReturnValue( 0, "FA 25 32 25 150 30 50 50 0.65" ) 
'par #1 = output width [mm] 
'par #2 = output height [mm] 
'par #3 = input / output face height [mm] 
'pas #4 = output brightness of skin[0..255] 
'par #5 = output contrast [0..255] 
'par #6 = percent of original  
'par #7 = background removal threshold 
'par #8 = correlation threshold (smallest "matching score" 
'for a correct match) [0.0 .. 1.0] 0.65 is recommended 
   OnFieldComplement = EV_OK_ABORT  ' Return value to FORMS 
End Function 
 

16. If necessary, adjust the parameters in the event handler to suit your requirements. 

17. Select Compile > Compile in the Visual Basic Edit window. 

18. Select File > Save and exit. 

19. Click OK in the Event details dialog to complete the process. 

The field containing the signature 

1. Bring the box provided for the signature into view using the scroll bars, F3, and F4. Draw 
a frame around it. 

2. Double-click inside the frame. The Field dialog is displayed. 

3. In the Identification section of the Standard tab, select Image as the field type and 
specify a name for the field in the Name box. 

4. In the Category box, assign the field the same category number you used for the 
photograph.  

5. In the Field validation section of the Standard tab, select Must be filled in. to specify 
that a signature image must appear in the field. (If none is present, FORMS alerts the 
Verify operator during verification.) 

6. Optional: Select Mass Verify if you want the Verify operators to be able to view multiple 
thumbnail images of the processed signature fields. Processed signatures cannot be edited, 
but choosing this option provides a way to monitor the results more closely. 

7. On the Events tab, click New. The Event details dialog is displayed. 
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8. Using the scroll bar in the Name box, select FieldInterpreted. 

9. In the VBA function box, you can see that a function is automatically defined for 
FieldInterpreted. Click Code to open the Visual Basic Edit window. 

10. Copy the code below and paste it into the Visual Basic Edit window, replacing all of the 
existing text. 

Function OnFieldInterpreted (  ) As Long 
Application.SetReturnValue( 0, "SA 35 15 300 2 2" ) 
'Signature Analysis: 
'SA = Apply signature analysis 
'1st parameter = width in [mm] 
'2nd parameter = height in [mm] 
'3rd parameter = DPI for output image 
'4th parameter = Sensitivity in conversion to b/w: 
'  1 = high sensitivity 
'  2 = medium sensitivity 
'  3 = low sensitivity 
'5th parameter = Algorithm to use: 
'  1 = advanced 
'  2 = standard 
OnFieldInterpreted = EV_OK_ABORT  ' Return value to FORMS 
End Function 

11. If necessary, adjust the parameters in the event handler to suit your requirements—in 
particular the fourth and fifth parameters of SetReturnValue: 

Application.SetReturnValue( 0, "SA 35 15 300 2 2" ) 

You may want to change the last two parameters after testing. Use the information below 
to help you. Your choice of algorithm influences the effect of the sensitivity setting. 

4th parameter, sensitivity 

1 = High Keeps more pixels black. Best for preserving pen strokes with low contrast. 
Risk: Noise around the signature might be preserved. 

3 = Low Keeps fewer pixels black. Best for noise removal. Risk: Parts of the signature 
might be removed. 

2 = Medium A balance between high and low sensitivity. 

4th parameter, sensitivity 

2 = Standard Suitable for most signatures. 

1 = Advanced Try this algorithm if results using the standard algorithm are not satisfactory. 
The advanced algorithm is quite different and can capture signature strokes 
with very weak contrast. However, its complexity increases processing time. 
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12. Select Compile > Compile in the Visual Basic Edit window. 

13. Select File > Save and exit. 

14. Click OK in the Event details dialog to complete the process. 

Adjusting the transaction description 
We recommend inserting the #Fieldfile variable in your transaction description so that you will 
have access to the name of the image file. Use the procedure described in FORMS Help. 

Adjusting the job description 
After you complete and save all of your form definition and transaction description tasks for 
your entire job, you will create your job description, including the steps below. 

Before you start, ensure that the form definition status is Active. (Select Edit > Form 
definition settings, then select Active.) 

Only the settings necessary for the Face and Signature Analyzer are described below. They 
are made in the Job description dialog, which opens when you create a new job description 
or open an existing one. 
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Configuring FORMS to import scanned image files 

1. On the Interpret tab, select Import image files. 

2. Click Configure. The Configure image file source and destinations dialog is displayed. 

3. Select *.* in the Files of type list box. 

4. In the Source directory box, specify the file path for the image files, or click Browse to 
navigate to it. (The default path where FORMS saves image files during scanning is 
C:\Program Files\EHFORMS\Img.) 

5. Click OK to save the settings and close the Configure image file source and 
destinations dialog. 

Specifying how image files are displayed for mass verification 

1. On the Verify tab, click Image display. The Image display dialog is displayed. 

2. In the Color depth section, select True color. (This ensures that the thumbnail images 
displayed during the verification process are of the same color depth as when they were 
scanned.) 

3. Click OK to register the settings and close the Image display dialog. 

4. Click Buffering. The Buffering dialog is displayed. 

5. Select Use buffering. 

6. In the No. of forms box, specify the maximum number of thumbnail images you want to 
be displayed in the mass verification window at one time. We recommend starting with 
20. If necessary, you can adjust the number later. 

7. Click OK to save the settings and close the Buffering dialog. 

8. Optional: Adjust the scale of the thumbnail images that you see during mass verification. 
To do this, click Options and adjust the Image field size (percent of full size) for mass 
verification setting in the Verify job options dialog. 
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Configuring FORMS to export images 

1. On the Export tab, select Export when transferred. (Field images exported during the 
transfer process include any processing you performed. The default path for exported field 
images is usually C:\Program Files\EHFORMS\FieldImg.)  

2. In the Categories boxes, type the category number you gave the image field in step 4 on 
page 6. For example, if the category number you assigned was “1”, then type “1-1” to 
isolate the fields’ images for export after transfer. 

 

3. In the File format box (the one in the Field images group), select PNG. 

4. Select Export form images when scanned. 

After you finish configuring the job description (including your own settings), click OK to 
close the dialog. Save the job description when prompted by FORMS. 
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Production 

Scanning the forms 
Use the Scan module in the usual way: 

1. Place the forms in your scanner’s document feeder 

2. Open your job description. 

3. Run the Scan job. 

Interpreting the forms 
Use the Interpret module in the usual way: 

1. Open your job description 

2. Run the Interpret job. The automatic Face and Signature Analyzer processing takes place 
at this stage, optimizing the image size, positioning, and quality. 

Verifying the forms 
To use the Verify module: 

1. Open your job description 

2. Run the Verify job. 

Fields for which you selected Mass verify (see page 6) are displayed in a mass 
verification window. Images fields (which contain images such as faces and signatures) 
are displayed after other field types, and in a window similar to the one shown below. 
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3. Click the thumbnail image of each photograph that needs manual processing. The images 
you select are highlighted in yellow. Images that you do not select are considered 
approved.  

 Note: Signatures cannot be edited, so clicking their thumbnail images does not have 
any effect other than to highlight it in the window.  

4. When you are satisfied with your choices, click the Continue button on the toolbar. 

 

5. After mass verification, the Face Analyzer dialog is displayed so that you can manually 
adjust the first image that you selected during mass verification. See “Adjusting the 
images of faces” on page 16 for detailed instructions. 

6. When you click OK in the dialog, the next image is displayed. This continues until all of 
the images you selected during mass verification are adjusted. Then you verify 
interpretation errors from the other fields on your form, if any. 
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Adjusting the size of thumbnail images 

If you wish, you can change the scale of the thumbnail images you see during mass 
verification. To do this, adjust the Image field size (percent of full size) for mass 
verification setting in the Verify job options dialog. 

Confirming continuation to a new mass verification view 

To avoid mistakenly skipping an entire screen of images to be verified, you can set FORMS 
to display a dialog when you press Enter or click the Resume job toolbar button while mass 
verifying images. The dialog prompts you to confirm that you want to proceed to the next 
mass verification view.  

1. Use a text editor to open Ehlocal.ini. 

Default location in Windows XP and Windows Server 2003: C:\Windows 

Default location in the newer operating systems: C:\Users\Public\ReadSoft\FORMS 

2. In the [Verify] section, and add this line: 

MassVerifyContinueConfirm=1 

MassVerifyContinueConfirm can be set to 0 (which means that no confirmation dialog is 
displayed, and this is the default value if the setting is missing) or 1 (in which case you are 
prompted to confirm that you want to proceed to the next mass verification view). 

3. Save and close Ehlocal.ini. 

Transferring the forms 
Use the Interpret module in the usual way: 

1. Run the Transfer job 

2. Open your job description 

As specified on the Export tab of the Job description dialog (see page 12), FORMS exports 
the processed images of fields from your job to the FieldImg folder.  
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Adjusting the images of faces 

 

The Face Analyzer dialog is displayed in the Verify module after the mass verification 
process, as described on page 14. This is where you manually adjust images to make them 
conform to your requirements for size and positioning, background, and brightness and 
contrast. 

The dialog displays two images: The Original window displays the original photograph. The 
Processed window displays the image that resulted from processing, and it is updated each 
time you adjust it.  

1. The controls in the Geometry section allow you to adjust the position and size of an 
image. 

2. The controls in the Background section let you adjust the background. 

3. The controls in the Radiometry section are for adjusting image brightness and contrast. 

 Use them in that order! Otherwise, the changes you make may be lost and you will have 
to repeat them. 
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Positioning and scaling the image 
The automatic face analysis process uses the position of the eyes in the original photograph 
image to determine the correct position and scale. Occasionally, the system cannot detect the 
correct eye positions, or it does detect them but the processed result is unsatisfactory. When 
this happens, the image in the Processed window may be lopsided, too large, too small, or 
distorted. Use the controls in the Geometry group to correct the image position and size, as 
described below. If there are problems, see “Troubleshooting” on page 23. 

Measuring the eyes to straighten and/or resize the image 

1. In the Face Analyzer dialog, click Measure eyes. 

2. In the Original window, first click the center of the left eye, then the center of  the right 
eye. The image in the Processed window straightens and resizes. 
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Rotating the image 

If the image in the Processed window is not straight enough, you can further adjust the 
vertical position using the Rotate slider.  

1. Using the mouse, move the slider to the right to rotate the image counter-clockwise, or 
move it to the left to rotate clockwise. 

As soon as the slider is moved from its mid-position, vertical line is displayed on top of 
the image and rotates according to how much you are moved the slider. The line shows 
you the degree to which the image will rotate. 

2. When you are satisfied with the degree of rotation, release the mouse button. The image 
rotates to its new position. 

“Translating” the image: Fine-tuning its position and size 

When the processed image is straight, use Translate to reposition it in any direction, if 
necessary—up, down, right, left, or diagonally. Translate also lets you adjust the size of the 
image. 

Repositioning the image 

1. Click Translate. In the Processed window, a vertical line is displayed over the image. 

2. Press and hold SHIFT on your keyboard, and click the line. An adjustment frame appears 
around the line, as shown below. 
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3. While holding the mouse button down, move the frame to center the image. For example, 
in the image shown above, you see that the frame is not in the center of the face but 
slightly to the right and slightly too low. You would therefore move the frame to the left 
and slightly upward. 

4. Release the mouse button. The image is translated to the new position. 

Adjusting the size 

When you click Translate, the vertical line shows you the ideal face size, from top to bottom, 
as defined in the event handler you defined for the FieldInterpreted event (see page 7). The top 
point of the line also shows you the best distance from the top of the image. If these are not 
correct, you can adjust them. 

1. Click Translate. In the Processed window, a vertical line is displayed over the image. 

2. Press and hold SHIFT on your keyboard, and click the line. An adjustment frame appears 
around the line, as shown above. 

3. Click one of the frame’s top black square corners, drag it to the top of the subject’s head, 
and release the mouse button. 

4. Once again, click Translate, press and hold SHIFT on your keyboard, and click the line. 

5. Click one of the frame’s bottom black square corners, and drag it to the bottom of the 
subject’s head, and release the mouse button. The image rescales to the optimum size. 
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Adjusting the background  
The face analysis process eliminates an image’s original background and gives it a white 
background. Occasionally, the process removes too much or too little background, and you 
must adjust it. In the example below, some background needs to be removed around the 
subject’s hair. 

 

Removing background 

1. Click Remove in the Face Analyzer dialog. 

2. In the Processed window, click the areas where background should be removed.  

The amount of background that is removed depends on the level specified by the 
Tolerance slider, which controls the sensitivity of the background removal in relation to 
the subject (the foreground image), and how much background remains from initial 
processing.  

To intensify the effect of your clicking, move it to the right.  

 Warning: Higher levels may cause parts of the foreground image to also be removed, 
in which case you must start again. 

If you find that too much background is being removed, move the Tolerance slider to the 
left. Use a low tolerance level if you are removing very small background areas that touch 
the foreground image.  

 Note: If Tolerance is too low, background removal is not as effective right around the 
face, and the process takes longer because you are removing smaller bits of the 
background each time you click. 
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Sometimes you will find it necessary to change the tolerance level several times while 
working on a single image. 

3. Continue clicking on the areas until you are satisfied. 

When too much background is removed… 

 

In some cases, too much background is removed from the image. To correct this: 

1. Click Reset. In the Processed window, the background is reset to its original state. 

2. Manually remove the background as described above. 

Note that Reset also resets the image’s brightness and contrast levels to their original state. If 
you use it after adjusting brightness and contrast, you must adjust those qualities again. 

Smoothing edges 

When you are satisfied with the background, click Smooth edges to blur the sharp contrast 
between the white background and the face. This makes the blend between the face and the 
background look more natural. Smoothing only affects the perimeter just around the face. It 
does not affect the image quality of the face. 

 Use Smooth edges after you remove background. Smoothing edges first makes it much 
more difficult to remove background in areas close to the face. 

 If necessary, you can smooth the edges of an image by clicking Smooth edges repeatedly. 
However, the effect gradually decreases. 
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Smoothing the edges of an image is the last step of manual processing. When you are satisfied 
with the image in the Processed window, click OK to close the dialog. 

Correcting brightness and contrast 
If the image is too light, too dark, too sharp, or too flat, adjust these qualities using the 
Brightness and Contrast sliders. The position of these sliders is automatically set to 
correspond with the brightness and contrast of each image. 

Adjust brightness and contrast after you adjust the position, size, and background of the 
image, because those adjustments restore the original brightness and contrast. 

1. Increase brightness by moving the Brightness slider to the right, or decrease brightness by 
moving the slider to the left. 

2. Increase contrast by moving the Contrast slider to the right, or decrease contrast by 
moving the slider to the left. 
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Troubleshooting 

The subjects’ eyes are not found 
When Face and Signature Analyzer is installed, e1.png is copied to FORMS’ Bin folder. The 
program uses this file as a template for finding the subjects’ eyes. If it is missing, the eyes are 
not found.  

The subjects’ eyes are not found often enough, 
or other objects are found instead of eyes 
If the template e1.png described above does not work well on your material, you can create 
your own templates to replace or complement e1.png. The image must: 

 depict a right eye 

 measure 43 x 21 pixels 

 be 300 DPI 

The program uses only images numbered in order (e1.png, e2.png, e3.png, etc.).  

 Warning: Each template that is added increases processing time. In addition, each 
template increases the risk that something other than an eye will match better than the eye 
that is supposed to be found. If you change or add templates, thorough testing is 
recommended. 
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