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Preface
This guide provides a tutorial that explains how to use Document Transformation functionality in a
Kofax RPA environment. The tutorial covers functionality such as OCR, extraction, field formatting, and
validation.
The instructions provided in this document assume that you have successfully downloaded and installed
Kofax RPA on your computer. After you start the Management Console and Development Database from
the Kofax RPA product group, ensure that "Document Transformation - Server Scheduler Service" is
started in the Windows Services panel.
For a detailed explanation of the Document Transformation functionality, see Help for Kofax RPA.

Related documentation
1

The documentation set for Kofax RPA is available here:

https://docshield.kofax.com/Portal/Products/RPA/10.6.0_p2wddr4n2j/RPA.htm
In addition to this guide, the documentation set includes the following items:
Kofax RPA Release Notes
Contains late-breaking details and other information that is not available in your other Kofax RPA
documentation.
Kofax RPA Installation Guide
Contains instructions on installing Kofax RPA and its components in a development environment.
Kofax RPA Administrator's Guide
Describes administrative and management tasks in Kofax RPA.
Help for Kofax RPA
Describes how to use Kofax RPA. The Help is also available in PDF format and known as Kofax RPA
User's Guide.
Kofax RPA Getting Started with Desktop Automation Guide
Provides a tutorial that walks you through the process of using Kofax RPA Desktop Automation to build a
robot.
1

You must be connected to the Internet to access the full documentation set online. For access without an
Internet connection, see the Installation Guide.

4

Kofax RPA Getting Started with Document Transformation

Kofax RPA Desktop Automation Service Configuration Guide
Describes how to configure the Desktop Automation Service required to use Desktop Automation on a
remote computer.
Kofax RPA Developer's Guide
Contains information on the API that is used to execute robots on RoboServer.
Kofax RPA Integration API documentation
Contains information about the Kofax RPA Java API and the Kofax RPA .NET API, which provide
programmatic access to the Kofax RPA product. The Java API documentation is available from both the
online and offline Kofax RPA documentation, while the .NET API documentation is available only offline.
Note The Kofax RPA APIs include extensive references to RoboSuite, the original product name. The
RoboSuite name is preserved in the APIs to ensure backward compatibility. In the context of the API
documentation, the term RoboSuite has the same meaning as Kofax RPA.

Training
Kofax offers both classroom and computer-based training to help you make the most of your Kofax RPA
solution. Visit the Kofax website at www.kofax.com for details about the available training options and
schedules.

Getting help with Kofax products
The Kofax Knowledge Base repository contains articles that are updated on a regular basis to keep you
informed about Kofax products. We encourage you to use the Knowledge Base to obtain answers to your
product questions.
To access the Kofax Knowledge Base, go to the Kofax website and select Support on the home page.
Note The Kofax Knowledge Base is optimized for use with Google Chrome, Mozilla Firefox or Microsoft
Edge.
The Kofax Knowledge Base provides:
• Powerful search capabilities to help you quickly locate the information you need.
Type your search terms or phrase into the Search box, and then click the search icon.
• Product information, configuration details and documentation, including release news.
Scroll through the Kofax Knowledge Base home page to locate a product family. Then click a product
family name to view a list of related articles. Please note that some product families require a valid
Kofax Portal login to view related articles.
• Access to the Kofax Customer Portal (for eligible customers).
Click the Customer Support link at the top of the page, and then click Log in to the Customer Portal.
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• Access to the Kofax Partner Portal (for eligible partners).
Click the Partner Support link at the top of the page, and then click Log in to the Partner Portal.
• Access to Kofax support commitments, lifecycle policies, electronic fulfillment details, and self-service
tools.
Scroll to the General Support section, click Support Details, and then select the appropriate tab.
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Tutorial
This guide is a step-by-step tutorial that explains how to create a Document Transformation
robot similar to the sample robot included in your product. The sample robot, called
DocumentTransformationInvoiceExample, already contains a .tif file that is ready to transform.
You can test the DocumentTransformationInvoiceExample robot provided with the product without creating
a new robot and types. In Design Studio, in the Examples folder, simply open the robot, open the types
invoice and DocumentTransformationInput, and then follow this guide to see how the robot is built.
If you decide to create a new robot from scratch, use the procedure in this guide and be sure to assign the
robot and types unique names that differ from the examples.
The tutorial covers some of the most commonly used Document Transformation functions and consists of
three main parts:
1. Create a transformation robot and types, add required variables, and add a Desktop Automation step
to the robot.
2. Create the Document Transformation workflow in the Desktop Automation step, which includes
setting up the Open Document Transformation Browser step, extracting data from the .tif document,
and configuring human and non-human validation of the transformed document.
3. Validate the transformed document.

Preliminary steps
Create a Transformation robot and types
This section shows how to create a robot and types.
1. Create a robot
a. In Design Studio, click File > New Robot.
b. Name the robot DocumentTransformationInvoiceExample, select a project, and then click
Next > Next.
By default, the Smart Re-execution (Full) execution mode is selected.
c. Click Finish.
By default, the End step is selected in the newly created robot.
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2. Create new types
With this robot, you extract the ID of the vendor, invoice number, invoice date, and total sum. To store
the extracted data, create the following types.
a. Click File > New Type.
b. Name the type invoice, select a project, and then click Finish.
c. Click the plus sign to add new attributes to the type. Add the following attributes and specify
their types:

d. Create another type called DocumentTransformationInput.
e. Add the following attribute and specify its type:

f. Save the changes.
When finished, proceed to the next section.
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Add variables to the transformation robot
In this procedure, you add variables of complex and simple types. A complex variable can contain several
named values, which is useful for extracting diverse data such as from an invoice. A simple variable can
only contain a single value such as a text string.
1. In Design Studio, in the bottom right corner, right-click in the Variables field and click Add Variable
of Complex Type > DocumentTransformationInput.
a. In the new dialog box, rename the DocumentTransformationInput variable to document and
select Use as Input.

b. Click Load and open the invoice document to transform. Navigate to the Kofax RPA Examples
folder of the sample project and select the file InvoiceExampleDocument.tif. This invoice will
be read with the built-in Invoice VAT Transformation project.

2. Right-click in the Variables field and click Add Variable of Complex Type > invoice.
3. Right-click in the Variables field and click Add Variable of Simple Type > Short Text (simple).
Name the new variable ValidationURL.

9

Kofax RPA Getting Started with Document Transformation

4. Save the changes.

When finished, proceed to the next section.

Add a Desktop Automation step
To create a Document Transformation workflow, you need to add a Desktop Automation step to your
transformation robot.
1. In Design Studio, insert an Action Step in the DocumentTransformationInvoiceExample robot.

2. To make it a Desktop Automation step, on the Action tab on the right, click Select an Action and
then select Desktop Automation.

3. Rename the step to Transform Document.
4. In the Input Value section, click the plus sign.
In the drop-down list, click Variable and select document.

5. Click OK.
6. In the Output Mapping section, add the invoice and ValidationURL variables.
7. Save the changes.
When finished, proceed to the next section.
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Upload the robot to Management Console
1. In the Projects tree view, right-click the DocumentTransformationInvoiceExample robot and click
Upload to upload it to the Management Console.
2. Open the URL for Management Console and open the tab Repository > Robots.
In this tutorial, we use http://127.0.0.1:50080 as the URL for Management Console.
3. Select the DocumentTransformationInvoiceExample robot.
4. Scroll to the right of the line and click

under REST.

5. Copy the REST URL. You will need it later to configure Document Transformation.
When finished, proceed to the next section.

Create the Document Transformation workflow
In this procedure, you configure variables, set up an Open Document Transformation Browser step, and
add a guard to wait for the transformed document.
1. In the Transform Document step of the robot, in the Workflow property, click Edit to start designing
the automation workflow.
The Desktop Automation Editor appears.

11

Kofax RPA Getting Started with Document Transformation

2. In Automation Workflow, follow these steps.
a. Ensure that the Input box is configured in this way.

b. This variable will contain the transformed document after it is validated.
c. In the Variables box, add the following variables and specify their types.

d. In the workflow, expand the Return step and add the following variables:
1. Invoice. Ensure that you start the name with a capital letter.
2. ValidationURL.

3. To add an Open Document Transformation Browser step, right-click the program point (small circle)
before the Return step and click Open Document Transformation Browser step.
This step will extract information from InvoiceExampleDocument.tif.
The Open DT Browser step is inserted in your workflow.
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4. Set the properties as follows.

a. In Document File, type input.doc and then click the gray bar on the left so the equal sign
appears, and the variable can be evaluated.

b. In Validation Callback URL, paste the REST URL that you copied in Upload the robot to
Management Console.
The Thin Client Service will call this URL after a document is validated. When validation is
complete, the Management Console uses this URL to start the robot.
Note The REST URL starts with 127.0.0.1 by default. If the Management Console runs on a
different computer than the Document Transformation Service, specify the correct URL for the
service to access the Management Console.
c. Click Step Over

to execute this step.

The status is changed to "Waiting for transformed documents." Wait until it changes to
"Documents transformed."
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5. Click Documents transformed to add a guard to wait for the transformed document.

a. To ensure that the guard looks for the correct text, expand the following label in the XML tree.

Right-click the text "Documents transformed" and click Guard > Location Found.
The Guard step is inserted in your workflow. Rename it to Wait until Transformed.

b. In the Wait until Transformed step, expand the Location Found guard, select Text Match
(Regex) and type Documents transformed.

c. Click Step Over

to execute this step.

d. Save the changes.
When finished, proceed to the next section.

Add a step to check document validity
To check if the transformed document is valid, add the following step to the Document Transformation
workflow. If the document appears to be invalid, it can be sent for human validation (see Configure steps
for human validation).
1. In the XML tree view, locate and right-click the document element, and then click Extract Value
From > Attribute > valid Into > Valid: Boolean.

A new step is inserted in your workflow. Rename it to Extract Document.valid.
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2. Click

Step Over to execute this step.

3. Save the changes.
When finished, proceed to the next section.

Extract data from the document
In this procedure, you extract data from InvoiceExampleDocument.tif into the variables VendorID,
InvoiceNumber, InvoiceDate, and Total. At the end, you add a Return Value step to the robot, so it returns
the extracted values.
1. In the XML tree view, expand the fields element under application/folder/document.
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2. To extract values:
a. Expand the second field, which is for VendorID, to see its values and alternatives.
b. Right-click the field element and click Extract Value From > Attribute > validatedText Into >
Invoice: invoice > VendorID: Text.

Note Ensure that you do not click the text 198000.
A new Extract Value step is inserted in your workflow. Rename it to Extract Vendor ID.
c. Repeat this action for field 17, InvoiceNumber, and for field 18, InvoiceDate.
New Extract Value steps are inserted in your workflow. Rename them to Extract Invoice
Number and Extract Invoice Date, respectively.
d. Right-click the third from the last field, TotalAmount, and click Extract Value From >
Attribute > doubleValue Into > Invoice: invoice > Total: Number.
The transformation project has a number formatter on this field and converts it to a numerical
value.
Another Extract Value step is inserted in your workflow. Rename it to Extract Total Number.
3. Click Start Execution

to execute the workflow to the end.

After the Extract Value steps are executed, you can check the extracted values. In the Workflow
State pane on the right, expand the Variables branch.
4. Save the changes and close the Desktop Automation Editor.
Your Document Transformation robot now has all of the available invoice details. Check the invoice
variable in the Variables section in Design Studio.
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5. In Design Studio, add another Action Step to the robot and make it a Return Value step. On the
toolbar, click Insert Step After Selected Step
> Action Step and then select Return Value on
the Action tab.
In the Variable list, select invoice.

This way the robot debugger will show the invoice parameters.
6. Save the changes.
You now have a valid robot that runs in the Management Console. This robot will be called by the
Document Transformation Client.
Important Ensure that you have a backup copy of your document before the transformation is
completed. If the transformation is completed or an error occurs, the document and data are not stored.
When finished, proceed to the next section.

Configure steps for human validation
In this procedure, you configure guards to handle a scenario for sending the document for human
validation and add a special conditional branch in the workflow for human validation.
You need to re-open the Desktop Automation step of your Document Transformation robot again. Before
doing so, refresh the robot to ensure that the Document Transformation browser window opened in the
previous robot run is now closed.
Tip: Alternatively, you may add a Click step to close the browser window after the robot finishes executing.
To do so, in the Desktop Automation Editor, right-click the Close button for the browser and click Click >
Left. A new step is added to the workflow.
Expand the new step, click the green plus icon in the middle, and add a new Guard.
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Set the new guard to Location Not Found and copy the Component from the Location Found guard to
the Component box for the Location Not Found guard.

The created step closes the Document Transformation Browser immediately if it is open, or continues to
run. Rename the step to Close DT Browser.
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When finished, proceed to the following steps to configure human validation. In this procedure, we handle
the case where the validated document is returned through the Validation Callback from the Document
Transformation Client.
1. Double-click the program point after the Open DT Browser step.
The Location Found guard in the Wait until Transformed step is waiting for the transformed
document.
When Document Transformation Client calls the Validation Callback URL,
http://127.0.0.1:50080/rest/run/Default project/Examples/Transform/
DocumentTransformationInvoiceExample.robot, after human validation, it passes the
transformed document as a .zip file to the input.doc variable in the robot. The .zip file looks similar to
the following:

When the Document Transformation Browser opens the .zip file, the status is changed to
"Transformed document processed."
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2. To configure the guards, in the Wait until Transformed step, create an additional Location Found
guard and then copy the Component box of the first Location Found guard and paste it in the
Component box for the second guard.

Change Text Match (Regex) of the second guard to Transformed documents processed.

With the two guards, the workflow now handles two scenarios: with human validation and without it.
3. Double-click the program point after the Extract Document.valid step to execute to this point.
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4. Add a special branch for human validation. Right-click the program point and click Conditional step.
A new step is inserted in your workflow.
a. Add the following two conditions to the Conditional step.

The exclamation mark in =!Valid denotes "not" ("invalid").
b. Click Step Into

to step into the Conditional step.

As the document in the robot is not valid at this point, the second condition (branch) is
executed.
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5. Now you need to send the document to the Document Transformation Client. In the Recorder View,
right-click the validation button and click Click > Left.

A new step is inserted in the second branch of the Conditional step. Rename it to Send to
Validation. Click Step Over
to execute it.
a. When the status is changed to Submitted, validation URL:, click it, and then click Guard >
Location Found.
A new step is inserted in the second branch of the Conditional step. Rename it to Wait for
URL.
b. In the Wait for URL step, expand the Component box, select Text Match (Regex) and type
Submitted, validation URL:.

c. Click Step Over

.
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6. Right-click the following URL and click Extract Value From > Text Into > ValidationURL: Text.

The Extract Value step is inserted in the Conditional step. Rename it to Extract Validation URL and
then execute it.

7. Select the four Extract Value steps after the Conditional step, and then cut and paste them into the
=Valid branch of the Conditional step.

8. Save the changes.
Your transformation workflow is finished. Click Start Execution
to run the workflow to the end. The
workflow now has three possible paths:
• New document is sent to the Document Transformation Service for extraction and classification and
returns "Valid." The document does not require human validation.
• New document is sent to the Document Transformation Service for extraction and classification and
returns "Invalid." The document requires human validation.
• Document .zip package is sent from the Document Transformation Client after human validation and
returns "Valid." The Validation URL is retrieved.
When finished, close the Desktop Automation Editor and proceed to the next section.
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Configure the robot to handle invalid and valid documents
In this procedure, you configure branches in the robot in Design Studio to handle two scenarios: when the
document is valid or invalid. If the document is valid, the robot sends the values extracted in the Desktop
Automation step in an email to a human. If the transformed document is invalid, it is sent for human
validation.
1. In Design Studio, add a Try Step after the Desktop Automation step.
Click the Transform Document step, and on the toolbar, click Insert Step After Selected Step
Try Step.

>
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2. On the first branch, add an Action Step and make it a Test Value step.
Right-click the Return Value step, click Insert Step Before > Action Step and then select Test
Value on the Action tab.

a. In the Condition section, type ValidationURL=="". Use straight quotation marks.
b. On the Error Handling tab, in the Then list, select Try Next Alternative.
c. On the Action tab, the setting should look similar to the following.

d. In the robot, rename the Test Value step to Document Valid?.
3. Click the Return Value step and make it a Send Email step. On the Action tab, select Output >
Send Email.
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4. Configure the Send Email step as follows.
a. In the FROM Address and TO Address fields, enter the sender and recipient email addresses,
respectively.
b. Set the Message field for this step to Expression and add the following expression:
"VendorID=" + invoice.VendorID + "\n" + "InvoiceNumber=" + invoice.InvoiceNumber +
"\n" + "InvoiceDate=" + invoice.InvoiceDate + "\n" + "Total=" + invoice.Total
c. Set Message Type to Text.
d. In the Subject field, enter text similar to the following: "This is the result of the robot execution."

e. On the Server tab, configure your SMTP server settings and save the changes.
f. In the robot, rename the step to Email Results.
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5. On the second branch, add an Action Step and then also make it a Send Email step.

6. Configure the second Send Email step as follows.
a. In the FROM Address and TO Address fields, enter the sender and recipient email addresses,
respectively.
b. Set the Message field for this step to Expression and add the following expression:
>><a href="<<+ValidationURL+>>">Click me!</a><<
c. Set Message Type to HTML.
d. In the Subject, enter text similar to the following: "Please validate this invoice."

e. On the Server tab, configure your SMTP server settings.
f. In the robot, rename the step to Email Validation URL and save the changes.
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Note The Send Email steps cannot be run in Design mode and you need to execute them in Debug
mode. To switch to this mode, on the toolbar, click Debug
and then click Single Step
.
The robot workflow is now ready for use, and it looks similar to the following:

If the document is valid, the robot emails the values from the transformed document: VendorID, Number,
Date, and Total. If the transformed document is invalid, an email containing the Validation URL is sent to a
human who can click it to validate the document.
Upload the robot to the Management Console. You can now test your robot in Design Studio.
All available documents that require validation can be now found at the following URL:
http://127.0.0.1:50082/Validation.aspx
In this URL, 127.0.0.1 is the IP address of the Thin Client Server, which can be different, depending on
where it was installed.
For an introduction to the human validation procedure, see the next section.

Validate the transformed document
This topic describes basic steps that you can perform to validate the transformed invoice.
After you open the Validation URL http://127.0.0.1:50082/Validation.aspx in a browser, open
the batch containing your transformed document. In the Classification Result pane on the left, you see the
Document Transformation results.
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Tip To facilitate and accelerate the process of validating the document, we recommend that you use the
keyboard whenever possible. For example, press Ctrl+O to open a batch or Ctrl+S to suspend a batch
(save and close until later). To use a shortcut, press the keys consecutively (one after the other), not
simultaneously.
1. The field next to the ID Number field is selected requiring you to confirm the ID.

To confirm that the correct ID is extracted, press Enter.

2. The next potentially invalid field, Invoice Number, is now selected.

You can check the number in the top right corner of the document. It is marked red to notify you that
it needs validation.

To validate the field and confirm that the correct invoice number is extracted, press Enter.
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3. The next potentially invalid field, Invoice Date, is shown.

In the top right corner of the document, you can see that the actual date is 06.11.2011. The extracted
date was deliberately made invalid for training purposes.
To fix the date, you can follow one of the following methods.
• Use automatic field completion. First, clear the incorrect date using the Backspace key. Type "0" to
see all of the numbers in the document that start with a zero. Press the Down Arrow key to select
"06.11.2010".

The invoice date in the document is now marked green.

Press Enter to confirm the new date.
Tip When validating documents, you can enable the Online Learning feature to increase the rate
of field recognition on similar documents. This feature is based on remembering the layout of a
sample document, such as an invoice. By using automatic field completion, manually typing or
selecting the correct value in the document (such as the correct invoice date), you contribute to
the knowledge base. As a result, when you work on a similar document next time, the invoice
date will be correct automatically.
The feature is enabled on the General tab in the Project Settings.
• In the document, click or lasso the invoice date to select it, and then press Enter.

4. The next potentially invalid field, PO Number, is now shown.

Confirm that the extracted number is correct. After you confirm that the PO number is correct, the
value of the Document Type field, which used to be marked as invalid, is automatically confirmed.
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5. The Currency field is now selected.

Confirm that the extracted currency is correct.
After you confirm all of the values, you receive a notification that the batch is valid. You can now close
it. The extracted values will be sent in an email to a human as you configured in Configure the robot to
handle invalid and valid documents.
You have now completed the tutorial.
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