Kofax RPA

Getting Started with Document Transformation
Version: 10.4.0

Date: 2019-01-27

©

2019 Kofax. All rights reserved.

Kofax is a trademark of Kofax, Inc., registered in the U.S. and/or other countries. All other trademarks
are the property of their respective owners. No part of this publication may be reproduced, stored, or
transmitted in any form without the prior written permission of Kofax.

Table of Contents
Preface.......................................................................................................................................................... 4
Related Documentation...................................................................................................................... 4
Training............................................................................................................................................... 5
Getting help for Kofax Products.........................................................................................................5
Chapter 1: Tutorial...................................................................................................................................... 6
Create a Transformation robot and types.......................................................................................... 6
Add variables to the transformation robot..........................................................................................7
Upload the robot to Management Console........................................................................................8
Add a Desktop Automation step........................................................................................................ 8
Create the Document Transformation workflow.................................................................................9
Check the transformed document validity........................................................................................11
Extract data.......................................................................................................................................12
Configure human validation..............................................................................................................13
Configure the robot to handle invalid and valid documents.............................................................19

3

Preface
This guide provides a tutorial that explains how to use Document Transformation functionality in a Kofax
RPA environment, including OCR, classification, extraction, field formatting, and validation.
The instructions provided in this document assume that you have successfully downloaded and installed
Kofax RPA on your computer. After you start the Management Console and Development Database from
the Kofax RPA product group, ensure that "Document Transformation - Server Scheduler Service" is
started in the Windows Services panel.

Related Documentation
1

The documentation set for Kofax RPA is available here:

https://docshield.kofax.com/Portal/Products/RPA/10.4.0_rp4hrvtqrq/RPA.htm
In addition to this guide, the documentation set includes the following items:
Kofax RPA Release Notes
Contains late-breaking details and other information that is not available in your other Kofax RPA
documentation.
Kofax RPA Installation Guide
Contains instructions on installing Kofax RPA and its components in a development environment.
Kofax RPA Administrator's Guide
Describes administrative and management tasks in Kofax RPA.
Help for Kofax RPA
Describes how to use Kofax RPA. The Help is also available in PDF format and known as Kofax RPA
User's Guide.
Kofax RPA Getting Started with Desktop Automation Guide
Provides a tutorial that walks you through the process of using Kofax RPA Desktop Automation to build a
robot.
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You must be connected to the Internet to access the full documentation set online. For access without an
Internet connection, see the Installation Guide.
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Kofax RPA Desktop Automation Service Configuration Guide
Describes how to configure the Desktop Automation Service required to use Desktop Automation on a
remote computer.
Kofax RPA Developer's Guide
Contains information on the API that is used to execute robots on RoboServer.

Training
Kofax offers both classroom and computer-based training to help you make the most of your Kofax RPA
solution. Visit the Kofax website at www.kofax.com for details about the available training options and
schedules.

Getting help for Kofax Products
Kofax regularly updates the Kofax Support site with the latest information about Kofax products.
To access some resources, you must have a valid Support Agreement with an authorized Kofax Reseller/
Partner or with Kofax directly.
Use the tools that Kofax provides for researching and identifying issues. For example, use the Kofax
Support site to search for answers about messages, keywords, and product issues. To access the Kofax
Support page, go to www.kofax.com/support.
The Kofax Support page provides:
• Product information and release news
Click a product family, select a product, and select a version number.
• Downloadable product documentation
Click a product family, select a product, and click Documentation.
• Access to product knowledge bases
Click Knowledge Base.
• Access to the Kofax Customer Portal (for eligible customers)
Click Account Management and log in.
To optimize your use of the portal, go to the Kofax Customer Portal login page and click the link to
open the Guide to the Kofax Support Portal. This guide describes how to access the support site, what
to do before contacting the support team, how to open a new case or view an open case, and what
information to collect before opening a case.
• Access to support tools
Click Tools and select the tool to use.
• Information about the support commitment for Kofax products
Click Support Details and select Kofax Support Commitment.
Use these tools to find answers to questions that you have, to learn about new functionality, and to
research possible solutions to current issues.
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Tutorial
This step-by-step tutorial shows how the Document Transformation robot called
DocumentTransformationInvoiceExample, which is included in your installation, is created. The robot
already contains a .tif file to transform. You can use this tutorial to closely examine the existing robot or
create a similar robot from scratch.

Create a Transformation robot and types
Note You can test the DocumentTransformationInvoiceExample robot provided with the product
without creating a new robot and types. In Design Studio, in the Examples folder, simply open the robot,
open the types invoice and DocumentTransformationInput, and then follow this guide to see how the
robot is built.
If you decide to create a new robot from scratch, use the procedure in this guide and be sure to assign
the robot and types unique names that differ from the examples.
1. Create a robot
a. In Design Studio, click File > New Robot.
b. Name the robot DocumentTransformationInvoiceExample, select a project, and then click
Next > Next.
c. Click Finish.
By default, the End step is selected in the created robot.
2. Create new types
To store the extracted data, create the following types.
a. Click File > New Type.
b. Name the type invoice, select a project, and then click Next.
c. Click the plus sign to add new attributes to the type. Add the following attributes and specify
their types:
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Document Transformation provides a string and date format for dates, and string and number
formats for numbers.
d. Create another type called DocumentTransformationInput.
e. Add the following attribute and specify its type:

f. Save the changes.
When finished, proceed to the next section.

Add variables to the transformation robot
1. In Design Studio, in the bottom right corner, right-click in the Variables field and click Add Variable
of Complex Type > DocumentTransformationInput.
a. In the new dialog box, rename the DocumentTransformationInput variable to document and
select Use as Input.

b. Click Load and open the invoice document to transform. In the Projects view, in the Examples
folder, select the file InvoiceExampleDocument.tif. This invoice will be read with the built-in
Invoice VAT Transformation project.

Save the changes.
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2. Right-click in the Variables field and click Add Variable of Complex Type > invoice.
3. Right-click in the Variables field and click Add Variable of Simple Type > Short Text (simple).
Name the new variable ValidationURL.
4. Save the changes.

When finished, proceed to the next section.

Upload the robot to Management Console
1. In the Projects tree view, right-click the DocumentTransformationInvoiceExample robot and click
Upload to upload it to the Management Console.
2. Open the URL for Management Console and open the tab Repository > Robots.
In this tutorial, we use http://127.0.0.1:50080 as the URL for Management Console.
3. Select the DocumentTransformationInvoiceExample robot.
4. Scroll to the right of the line and double-click

under REST.

5. Copy the URL. You will need it later to configure Document Transformation.
When finished, proceed to the next section.

Add a Desktop Automation step
To create a Document Transformation workflow, you need to add a Desktop Automation step to your
transformation robot.
1. In Design Studio, insert an Action Step in the DocumentTransformationInvoiceExample robot.

2. To make it a Desktop Automation step, on the Action tab on the right, click Select an Action and
then select Desktop Automation.
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Rename the step to Transform Document.
3. In the Input Value section, click the plus sign.
In the drop-down list, click Variable and select document.

4. Click OK.
5. In the Output Mapping section, add the invoice and ValidationURL variables in the same way.
When finished, in the Desktop Automation step of the robot, in the Workflow property, click Edit to start
designing the automation workflow. When the Desktop Automation Editor appears, proceed to the next
section.

Create the Document Transformation workflow
1. In the Automation Workflow, in the Variables box, add the following variables and specify their
types.

2. Expand the Return step and add the following variables:
a. Invoice. Ensure that you start the name with a capital letter.
b. ValidationURL.
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3. Right-click the program point (small circle) before the Return step and click Open Document
Transformation Browser step.
The Open DT Browser step is inserted in your workflow.
4. Set the properties as follows.

In Document File, type document.doc and then click the gray bar on the left so the equal sign
appears, and the variable can be evaluated.

In Validation Callback URL, paste the REST URL that you copied in Upload the robot to
Management Console.
Note The rest URL starts with 127.0.0.1 by default. If the Management Console runs on a different
computer than the Document Transformation service, specify the correct URL for the service to
access the Management Console.
5. Click Step Over

to execute this step.
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The status is changed to "Waiting for transformed document..." Wait until it changes to "Documents
transformed."
6. To add a guard, click Documents transformed.

7. To ensure that the guard looks for the correct text, expand the following label in the XML tree.

8. Right-click the text "Documents transformed" and click Guard > Location Found.
The Guard step is inserted in your workflow. Rename it to Wait until Transformed.

9. In the Wait until Transformed step, expand the Location Found guard, select Text Match (Regex)
and type Documents transformed.

10. Click Step Over

to execute this step.

When finished, proceed to the next section.

Check the transformed document validity
You can check if the transformed document is valid. If it is invalid, it can be sent to human validation.
1. In the XML tree, expand the document element, right-click it and click Extract Value From >
Attribute > valid Into > Valid: Boolean.

A new step is inserted in your workflow. Rename it to Extract Document.valid.
2. Click

Step Over to execute this step.
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When finished, proceed to the next section.

Extract data
To extract data from the invoice document, follow these steps.
1. In the XML tree, expand the fields element under application/document.

2. Expand the second field, which is for VendorID, to see its values and alternatives.
3. Right-click the field element and click Extract Value From > Attribute > validatedText Into >
Invoice: invoice > VendorID: Text.

Note Ensure that you do not click the text 198000.
A new Extract Value step is inserted in your workflow. Rename it to Extract Vendor ID.
4. Repeat this action for field 17, Invoice Number, and for field 18, Invoice Date.
New Extract Value steps are inserted in your workflow. Rename them to Extract Invoice Number
and Extract Invoice Date, respectively.
5. Right-click the third from the last field, TotalAmount, and click Extract Value From > Attribute >
doubleValue Into > Invoice: invoice > Total: Number.
The transformation project has a number formatter on this field, and converts it to a numerical value.
Another Extract Value step is inserted in your workflow. Rename it to Extract Total Number.
6. Click Start Execution

to execute the workflow to the end.

After the Extract Value steps are executed, you can check the extracted values. In the Workflow
State pane on the right, expand the Variables branch.
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7. Save the changes and close the Desktop Automation Editor.
Your Document Transformation robot now has all of the available invoice details. Check the invoice
variable in the Variables section in Design Studio.
8. In the editor, add another Action Step to the robot and make it a Return Value step. On the toolbar,
click Insert Step After Selected Step
> Action Step and then select Return Value on the Action
tab.
In the Variable list, select invoice.

This way the robot debugger or Kapplet will show the invoice parameters.
9. Save the changes and upload the robot to the Management Console.
You now have a valid robot that runs in the Management Console. You may add it to a Kapplet. This
robot will be called by the Document Transformation Client after a human has completed validating the
document.
Important Ensure that you have a copy of your document before the transformation is completed. If the
transformation is completed or an error occurs, the document and data are not stored.
When finished, proceed to the next section.

Configure human validation
Follow this procedure to create a step responsible for validation interaction with a human.
In this part, you need to open the Desktop Automation step of your Document Transformation robot again.
Before doing so, refresh the robot to ensure that the Document Transformation Browser window opened in
the previous robot run is now closed.
Tip: Alternatively, you may add a Click step to close the browser window after the robot finishes executing.
To do so, in the Desktop Automation Editor, right-click the Close button for the browser and click Click >
Left. A new step is added to the workflow.
Expand the new step, click the green plus icon in the middle, and add a new Guard.
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Set the new guard to Location Not Found and copy the Component from the Location Found guard to
the Component box for the Location Not Found guard.

The created step closes the DT Browser immediately if it is open, or continues to run. Rename the step to
Close DT Browser.
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When finished, proceed to the following steps to configure human validation. In this procedure, we handle
the case where the validated document is returned through the Validation Callback from the Document
Transformation Client.
1. Double-click the program point after the Open DT Browser step.
The Location Found guard in the Wait until Transformed step is waiting
for the transformed document. When Document Transformation Client calls
http://127.0.0.1:50080/rest/run/Default project/Examples/Transform/
DocumentTransformationInvoiceExample.robot after human validation, it passes it as a ZIP
file to document.doc in the robot. The ZIP file looks similar to the following:

When the Document Transformation Browser opens the ZIP file, the status is changed to
"Transformed document processed."
2. In the Wait until Transformed step, create an additional Location Found guard and then copy
the Component box of the first Location Found guard and paste it in the Component box for the
second guard.
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Change Text Match (Regex) of the second guard to Transformed documents processed.

The workflow now handles two scenarios: with human validation and without it.
3. Double-click the program point after the Extract Document.valid step to execute to this point.
4. Add a special branch for human validation. Right-click the program point and click Conditional Step.
A new step is inserted in your workflow.
5. Add the following two conditions to the Conditional step.
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The exclamation mark in =!Valid denotes "not" ("invalid").
6. Click Step Into

to step into the Conditional step.

As the document in the robot is not valid at this point, the second condition (branch) is executed.

7. Now you need to send the document to the Document Transformation Client. In the Recorder View,
right-click the validation button and click Click > Left.

A new step is inserted in the second branch of the Conditional step. Rename it to Send to
Validation. Click Step Over
to execute it.
8. When the status is changed to Submitted, validation URL:, click it, and then click Guard >
Location Found.
A new step is inserted in the second branch of the Conditional step. Rename it to Wait for URL.

17

Kofax RPA Getting Started with Document Transformation

9. In the Wait for URL step, expand the Component box, select Text Match (Regex) and type
Submitted, validation URL:.

Click Step Over

.

10. Right-click the following URL and click Extract Value From > Text Into > ValidationURL: Text.

The Extract Value step is inserted in the Conditional step. Rename it to Extract Validation URL and
then execute it.

11. Select the four Extract Value steps after the Conditional step, and then cut and paste them into the
=Valid branch of the Conditional step.

Your Transformation workflow is finished. Click Start Execution
to run the workflow to the end. There
are now three possible paths in the workflow:
• New document is sent to Document Transformation Service for extraction and classification and returns
"Valid." The document does not require to be sent to human validation.
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• New document is sent to Document Transformation Service for extraction and classification and returns
"Invalid." The document must be sent to human validation.
• Document ZIP package is sent from Document Transformation Client after human valdiation and
returns "Valid." The ValidationURL is retrieved.
When finished, upload the robot to the Management Console. Close the Desktop Automation Editor.

Configure the robot to handle invalid and valid documents
You can configure the robot to handle invalid and valid documents.
1. In Design Studio, add a Try Step after the Desktop Automation step. Click the Desktop Automation
step, and on the toolbar, click Insert Step After Selected Step
> Try Step.
2. On the first branch, add an Action Step and then make it a Test Value step. Right-click the Return
Value step, click Insert Step Before Selected Step
> Action Step and then select Test Value on
the Action tab.

In the Condition section, type ValidationURL=="". Use straight quotation marks.
Rename the Test Value step to Document Valid?.
3. To the Document Valid? step, add Error Handling set to Try Next Alternative.
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4. On the second branch, add an Action Step and then make it a Send Mail Step. On the toolbar, click
Insert Step After Selected Step
> Action Step and then select Output > Send Email on the
Action tab.

5. Set the Message field for this step to Expression and add the following expression: >><a href="<<
+ValidationURL+>>">Click me!</a><<
Set Message Type to HTML.

6. On the Server tab, configure your SMTP server settings and save the changes.
Note The Send Email step cannot be run in Design mode and you need to execute it in Debug
mode. To switch to this mode, on the toolbar, click Debug
and then click Single Step
.
The robot workflow is now ready for use, and it looks similar to the following:
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Upload it to the Management Console. You can now test your robot in Design Studio, a schedule, or a
Kapplet.
All available documents that require validation can be now found at the following URL:
http://127.0.0.1:50082/Validation.aspx
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