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Introduction

This guide helps you install Kofax Kapow in a development environment. For installation in a production
environment see the Administration Guide. This guide covers both interactive and "silent" installation of
Kofax Kapow on Windows, as well as normal and "headless" installation on Linux.

For production environment, Kofax strongly recommends deploying the Management Console on a stand-
alone Tomcat server. This recommendation is based on, but not limited to the following.

» Derby is used as a system database in embedded mode, which is not recommended for production
environment.

* A Management Console on Tomcat:
» Can use an enterprise class database for improved performance and data security.
+ Can Integrate with LDAP.

» Tomcat can be configured to customer requirements.

Before installing Kapow, you must decide whether to install the 32-bit or the 64-bit version. The key issues
to consider are:

» Your operating system may only support one of the versions. 64-bit Windows supports both. On Linux
only 64-bit version is supported.

» The 64-bit version is mainly useful on servers where you want to run RoboServer that uses significant
RAM. (You will need to configure the allowed amount of RAM after installation, as described in the
"Changing the RAM Allocation" section in the Administrator's Guide).

This guide describes:

* How to install Kapow, either interactively or "silently" (without user interaction).

» How to enter license information so that you can start Kapow.

* How to configure Kapow.

* How to set up Kapow server applications to start automatically when the computer restarts.
* How to upgrade from earlier versions.

Getting Help for Kofax Products

Kofax regularly updates the Kofax Support site with the latest information about Kofax products.

To access some resources, you must have a valid Support Agreement with an authorized Kofax Reseller/
Partner or with Kofax directly.

Use the tools that Kofax provides for researching and identifying issues. For example, use the Kofax
Support site to search for answers about messages, keywords, and product issues. To access the Kofax
Support page, go to www.kofax.com/support.


http://www.kofax.com/support
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The Kofax Support page provides:

Product information and release news

Click a product family, select a product, and select a version number.
Downloadable product documentation

Click a product family, select a product, and click Documentation.
Access to product knowledge bases

Click Knowledge Base.

Access to the Kofax Customer Portal (for eligible customers)

Click Account Management and log in.

To optimize your use of the portal, go to the Kofax Customer Portal login page and click the link to
open the Guide to the Kofax Support Portal. This guide describes how to access the support site, what
to do before contacting the support team, how to open a new case or view an open case, and what
information to collect before opening a case.

Access to support tools

Click Tools and select the tool to use.

Information about the support commitment for Kofax products
Click Support Details and select Kofax Support Commitment.

Use these tools to find answers to questions that you have, to learn about new functionality, and to
research possible solutions to current issues.



Chapter 1

System Requirements

The tables below provide system specification for different platforms. The requirements may depend

on the application, so these should only be taken as guidelines and not as absolute numbers. The
recommendations for servers are for one server. The number of servers used for a given application
(the size of a cluster) is a completely different matter and should be estimated using methods described

elsewhere.

IDE requirements:

Minimum

Recommended

Windows

Intel Core Duo 1.8 GHz CPU (or

AMD equivalent), 4GB RAM, 1GB
free disk space for installation and
5GB free disk space for operation

Intel Core Duo 2.66 GHz CPU (or
AMD equivalent), 8GB RAM, 1GB
free disk space for installation and
5GB free disk space for operation

Linux (64-bit)

Intel Core Duo 1.8 GHz CPU (or

AMD equivalent), 4GB RAM, 1GB
free disk space for installation and
5GB free disk space for operation

Intel Core Duo 2.66 GHz CPU (or
AMD equivalent), 8GB RAM, 1GB
free disk space for installation and
5GB free disk space for operation

Server requirements:

Minimum

Recommended

Windows (32-bit)

Intel Xeon L5520 CPU (or equivalent
AMD Opteron), 2GB RAM, 500MB
free disk space for installation and
5GB free disk space for operation

Intel Xeon X5680/X5677 CPU (or
equivalent AMD Opteron), 8GB
RAM, 500MB free disk space for
installation and 5GB free disk space
for operation

Windows (64-bit)

Intel Xeon L5520 CPU (or equivalent
AMD Opteron), 4GB RAM, 500MB
free disk space for installation and
5GB free disk space for operation

Intel Xeon X5680/X5677 CPU (or
equivalent AMD Opteron), 8GB
RAM, 500MB free disk space for
installation and 5GB free disk space
for operation

Linux (64-bit)

Intel Xeon L5520 CPU (or equivalent
AMD Opteron), 4GB RAM, 500MB
free disk space for installation and
5GB free disk space for operation

Intel Xeon X5680/X5677 CPU (or
equivalent AMD Opteron), 8GB
RAM, 500MB free disk space for
installation and 5GB free disk space
for operation

Real-time data: If you have a solution where users are waiting for results in real-time, CPU speed is
normally the bottleneck, and you should buy the fastest CPU available for your hardware platform.
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Dedicated hardware: For best performance, we recommend that you always run RoboServer on dedicated
hardware. That means that you should not run database servers and other services on the same
hardware as your RoboServer.

Supported Platforms

This is the list of supported platforms. Kofax Kapow was tested on the listed versions. To determine if
Kapow works on a version that is not listed, contact Kofax for more information.

IDE Platforms

Windows Windows Server 2008 R2, Windows Server 2012,
Windows Server 2012 R2, Windows Server 2016,
Windows 7, Windows 8.1, Windows 10

Linux (64-bit) CentOS/Red Hat Enterprise Linux 6.x and 7.x
Ubuntu 14.04 LTS with 1ibgt5webkit5 library

Server Platforms

Windows Windows Server 2008 R2, Windows Server 2012,
Windows Server 2012 R2, Windows Server 2016

Linux (64-bit) CentOS-7, Red Hat Enterprise Linux 6.x and 7.x, Debian
8.2

Linux installation dependencies

The minimal Linux installation must include the following packages to be able to run Robots created with
default browser engine.

¢ 1ibX11l.s0.6

¢ 1ibGL.so.1l

* libXext.so0.6

To use cross-platform authentication (Negotiate and NTLM protocols), your Linux installation must include
Generic Security Service APl (GSS-API) libraries:

* libgssapi_krb5.s0.2

* libgssapi.so.4

* libgssapi.so.2

* libgssapi.so.1

Use the yum install or sudo apt-get command to install necessary libraries on a Linux platform.
You must also install fonts on a headless Linux server for the webkit robots to work.

* Instructions for installing fonts for CentOS / RedHat

* Instructions for installing fonts for Ubuntu


https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/5/html/International_Language_Support_Guide/add_fonts_all_users.html
https://wiki.ubuntu.com/Fonts
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Databases

Oracle* Version 11g, 12c
Requires Unicode and case sensitivity. For case-
sensitive comparison, ensure that NLS_COMP is set to
BINARY.

IBM DB2 9.7

Microsoft SQL Server Version 2012, 2014, and 2016

Sybase* Adaptive Server Enterprise 15.5 using the jConnect for
JDBC 3.0 version 6.05 driver

MySQL* Version 5.5-5.7

* Be aware that loss of data may occur when storing data in Oracle, Sybase or MySQL. On Oracle, an
empty string is converted to null. On Sybase, an empty string is converted to " " (a single space). On
MySQL, millisecond precision is lost when storing dates. For details, see the ObjectKey Caveats section
in the Storing Data in Databases topic in the Kapow help.

Note Microsoft SQL Server with Windows Authentication cannot be used as a logging (logdb) database.

Oracle Connection URL must use $ {ServerName} :${Schema}. Using ${ServerName} :
S{ServiceName} is not supported.

You can use PostgreSQL database only for storing your data. PostgreSQL cannot be used as a
Management Console system, logging, or audit database.

APls

Java Java 8 including J2EE servers such as Oracle WebLogic
11, IBM WebSphere, and JBOSS

JMX Java 1.6

.NET C#, .NET Version 4.0

Note For correct display of data in the Kofax Insight Dashboard, make sure Java correctly sets the
time according to your time zone on RoboServers and computers running Management Consoles. See
the Timezone Data Versions in the JRE Software on the Oracle web site for the latest updates in time
zones. If necessary, use the Timezone Updater Tool to update the time zone information.

Management Console Portals

Tomcat Version 7.0.63 or later. Minimum Java version 1.8 with
the latest update.

Other Supported Technologies

Supported browsers for Management Console and Internet Explorer version 9, 10, and 11; Chrome version

KappZone/Kapplets 58 and later; Firefox version 54 and later; Safari version
10.

Supported JMS message brokers Apache ActiveMQ 5.11, 5.12, 5.13, 5.14; Red Hat JBoss

A-MQ 6.2.1.
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Device Automation requirements and prerequisites

Device Automation Platforms

Windows Windows 7, Windows 8.1, Windows 10 (64-bit), Windows

Server 2008, Windows Server 2012, Windows Server
2016

Device Automation on Windows

If you get the error: "Module automationnative not found," install the following update.
https://support.microsoft.com/en-us/kb/2999226

On some systems Windows Update is not available, but there is a workaround to install updates.

1.
2.

Create a c: \temp\ 976571 folder.

Use the following command to extract the contents of the MSU file:
Expand -F:* c:\kb976571\Windows6.1-KB976571-v2-x64.msu c:\temp\976571
This command extracts multiple files, from Windows6.1-KB976571-v2-x64.cab.

Run the following command:

DISM.exe /Online /Add-Package /PackagePath:c:\temp\976571\Windows6.1-
KB976571-v2-x64.cab

For more information, see How to use DISM to install a hotfix from within Windows on the Microsoft
Technet website https://blogs.technet.microsoft.com.

The following sections list components that must be installed and configured on the Automation Devices
(remote computers you want to automate) before you can use Device Automation feature in Kofax Kapow.

Java Access Bridge

To automate Java programs or Java applets on remote devices with Kofax Kapow, install Java 32-bit
on your device (JRE or JDK) and enable the Java Access Bridge in the Java Runtime Environment
used by the application. We recommend using the latest available Java version.

For JRE 7 or Later
To enable Java Access Bridge for Java version 7 or later, navigate to the bin directory in the Java
installation directory and run the following command.

jabswitch -enable

For JRE6

Follow this procedure to install Java Access Bridge 2.0.2 on a Windows 32-bit system. For older
applications that require Java version 1.6, copy the following files to the specified destination
directories, where %WINDOWSHOME% is the directory where Microsoft Windows is installed (for
example, C:\WINDOWS), and %JAVAHOME% is the directory where your JDK or JRE is installed.
The following are examples of directory names for Java SE 6 Update 24.

* JDK: C:\Program Files\Java\jdkl.6.0 24\jre

* JRE: C:\Program Files\Java\jre6

The following table lists Java Access Bridge Windows libraries and related files for Windows 32-bit
systems.

Java Access Bridge File Destination Directory

WindowsAccessBridge.dll SWINDOWSHOMES%\SYSTEM32



https://support.microsoft.com/en-us/kb/2999226
https://blogs.technet.microsoft.com
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Requirements for Linux-based platforms

Java Access Bridge File

Destination Directory

JavaAccessBridge.dll $JAVAHOMES$\bin
JAWTAccessBridge.dll $JAVAHOMES \bin
accessibility.properties $JAVAHOMES$\1ib
access-bridge.jar $JAVAHOMES$\1lib\ext
jaccess.jar $JAVAHOMES$\1ib\ext

For more information, search the Downloads page on the Oracle web site ( http://www.oracle.com/

technetwork/javal/javase/downloads/) to locate and download jab-2-0-2. For installation
instructions, see installing-jab-32-bit on the http://docs.oracle.com website.

Perform the following to test that you have installed Java Access Bridge properly.
1. Run the SwingSet2 application and then run the JavaMonkey.exe application.

2. Select File > Refresh Tree in the Java Monkey application and the SwingSet2 application

should appear.

Alternatively, you can use the JavaFerret.exe application.

To use Device Automation, install the 1ibxs1t1.1 package.
To use built-in browser in Device Automation, install the following packages.

« Ubuntu-based distributions

gconf-service
libasound2
libatk1.0-0

libc6

libcairo2

libcups2
libdbus-1-3
libexpat1
libfontconfig1
libgcc1
libgconf-2-4
libgdk-pixbuf2.0-0
libglib2.0-0
libgtk2.0-0
libnsprd

libnss3
libpango-1.0-0
libpangocairo-1.0-0
libx11-xcb1
libxcb1

10
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http://www.oracle.com/technetwork/java/javase/downloads
http://docs.oracle.com
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« Distributions based on Red Hat and CentOS

libxcomposite1
libxcursor1
libxdamage1
libxfixes3
libxi6
libxrandr2
libxrender1
libxss1

libxtst6

Xvfb

libX11-xcb.so0.1
libfontconfig.so.1
libpango-1.0.s0.0
libpangocairo-1.0.s0.0
libcairo.so.2
libXcomposite.so.1
libXcursor.so.1
libXdamage.so.1
libXfixes.s0.3
libXi.s0.6
libXrender.so.1
libXtst.s0.6
libXrandr.so.2
libXss.s0.1
libgconf-2.s0.4
libgio-2.0.s0.0
libasound.so.2
libcups.so.2
libdbus-1.s0.3
libatk-1.0.s0.0
libgtk-x11-2.0.s0.0
libgdk-x11-2.0.s0.0
libgdk_pixbuf-2.0.s0.0
libnspr4.so
libnss3.s0
libnssutil3.so
libsmime3.so
libexpat.so.1
libxcb.so.1

1
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+ xorg-x11-server-Xvfb

Prerequisites for Internet Explorer
To automate Internet Explorer using the Device Automation feature, check the following requirements.

* In Internet Explorer 7 and higher on Windows 7, set the same value (either On or Off) in the
Protected Mode settings for each zone. To open the Protected Mode settings in Internet Explorer,
select Tools > Internet options and click the Security tab. For each zone, select the Enable
Protected Mode option and select the same security level.

« For IE 10 and higher, disable the Enhanced Protected Mode in the Security settings on the
Advanced tab of the Internet Options window.

» For IE 11 only, check that a FEATURE BFCACHE subkey with a DWORD value named
iexplore.exe is present in the registry on the target computer. This subkey enables the driver
to maintain a connection to the instance of Internet Explorer it creates. For 32-bit Windows,
examine the HKEY LOCAL MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main
\FeatureControl\FEATURE BFCACHE key in the registry editor. For 64-bit Windows, examine
the HKEY LOCAL MACHINE\SOFTWARE\Wow6432Node\Microsoft\Internet Explorer
\Main\FeatureControl\FEATURE BFCACHE key. If the FEATURE BFCACHE subkey is not
present, create it and create a DWORD value named iexplore.exe with the value "0" in the key.

» Set the browser zoom level to 100% to align the native mouse events with the correct coordinates.

Note In some cases, out-of-browser Silverlight applications can interfere with Device Automation.
The cause of the problem is the Internet Explorer subdriver. To disable the IE subdriver, clear the
Extended Internet Explorer Support option on the Windows tab of the Device Automation Service
configuration window.

SAP prerequisites
To automate SAP application using the Device Automation feature, enable scripting on both the server
and the client sides.

» On the client, go to SAP GUI Options and enable scripting. Also, turn off notifications, because
they interrupt the automation process.

» To enable scripting on the SAP server, perform the following steps. Note that you must have
administrative privileges to change the sapgui/user scripting parameter.

1. Log on to your SAP server.

2. Run transaction RZ11. Specify the parameter name sapgui/user scripting and click
Display. If Parameter name is unknown appears in the status bar, this indicates that you
are missing the current support package. Check your installed packages.

3. Change the value to TRUE.
4. Click Save.

Note that some elements, such as scroll bars, are only available if you run the SAP clienton a
machine with a Windows Classic desktop theme.

12



Chapter 2

Install Kapow

This chapter describes how to install Kofax Kapow on a single computer in a developer setup. See the
Administration Guide for installation and deployment in a production environment.

For the Windows platform, Kofax Kapow has four installers that install different parts of the software:

» Kapow Design Studio installer: Installs Design Studio and documentation (including SQL scripts for
database tables), but does not install RoboServer, Management Console or API. Use this installer if you
have a central Management Console/License Server and need a separate copy of Design Studio.

» Kapow RoboServer installer: Installs RoboServer only and does not install Management Console,
Design Studio, documentation, or API. This installer is useful, if you need to set up dedicated
RoboServer machines.

» Configurable full Kapow installer: Installs all the components, or you can select which ones to install.
» Kapow Device Automation installer: Installs Device Automation Agent to automate remote devices.

The three limited installers can be run using the silent installation process. If you run a silent installation of
the full installer, you get the typical install. See Silent Installation on Windows for details.

For Linux, Kapow provides a full installer as well as RPM and DEB packages for installing RoboServer as
a service. See Install on Linux for details.

Upgrading from Earlier Versions

In the interest of stability, different versions of Kofax Kapow may be installed side by side on the same
computer without interfering with each other (except that they must be configured to use different port
numbers for the Management Console if run simultaneously). This means that you can install a newer
version and get acquainted with it while still doing your daily work with the older version.

You can copy important data such as uploaded robots, execution schedules and so on from one version of
Management Console to another by making a backup of the old installation and "restoring" it into the new
one. Making a backup varies in different versions of Kofax Kapow, so check help or User's Guide to learn
how to create a backup.

Install on Windows

The full Kapow installer provides the following installation options. Optional items are listed with an
asterisk.

» Design Studio: Installs Design Studio and its required components
* RoboServer: Installs RoboServer

+ Embedded Management Console: Installs components needed to run an embedded Management
Console on the RoboServer

13
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* Management Console: Creates the WAR file for manual installation of the Management Console
» Documentation: Installs documentation (including the SQL script files)
* API*: Installs necessary APl components

The following files install separate Kapow components.

If you are installing Design Studio only, download and save the

Kapow DesignStudio 10.3.0.3 x32.msi or Kapow DesignStudio 10.3.0.3 x64.msi fileto
your hard disk. After the download is completed, run the file to start the installation and follow the installer
prompts.

To install a RoboServer, download and save the Kapow RoboServer 10.3.0.3 x32.msi or
Kapow RoboServer 10.3.0.3 x64.msi file to your hard disk. After the download is completed, run
the file to start the installation and follow the installer prompts.

To install the Device Automation Service, download and save the

Kapow DeviceAutomation 10.3.0.3 x32.msi. After the download is completed, run the file on
the computer you want to automate and follow the installer prompts. For more information, see Install the
Device Automation Service.

As another option, you can use the silent installation to automate the installation process.

Note You need administrator rights to install Kapow on Windows.

Install the Device Automation Service

To install the Device Automation Service, download and save the

Kapow DeviceAutomation 10.3.0.3 x32.msi file to your hard disk. After the download is
completed, run the file on the computer you want to automate to start the installation. The Device
Automation Service is installed in autostart mode. Note that you do not need to install the Device
Automation Service to automate terminals.

Important The Device Automation Service version must match the version of other Kapow components,
such as Design Studio and Management Console.

Install Components for Device Automation Service

Device Automation Service is designed to automate any work process involving computer applications
on Windows systems. The following components and configuration steps are required for the Device
Automation Service to access applications on Windows.

Make sure that the latest Windows operating system updates are installed. For Windows 7, 8, and 8.1,

the KB2999226 update is required. If this update is not installed on your system, download it from the

Microsoft website and install according to the provided instructions.

To work with Java applications, check the following.

« Install the latest Oracle Java 32-bit (JRE or JDK) that installs the Java Access Bridge 32-bit dlls. The
Java applications started by the robots can run in a 64-bit JVM, but the 64-bit installer does not include
the 32-bit dlls. If your corporate policy does not allow upgrading the Oracle Java, manually install the
files needed for Java Access Bridge support as follows.

14
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Java Access Bridge Installation on Windows 64-bit

1.

Ensure JAWS 13 or later is installed on your system. Note that JAWS version 13.0.527 or
later is required for Windows 7 64-bit. You can download this component from the Java SE
Downloads page http://www.oracle.com/technetwork/javal/javase/downloads/index.html.

Download Java Access Bridge 2.0.2 from the Java Access Bridge download page at the
following URL:
http://www.oracle.com/technetwork/java/javase/downloads/jab-2-0-2-download-354311.html

Extract the Java Access Bridge to a folder in your drive and copy
WindowsAccessBridge-32.d11 to [WINDOWSHOME] \SYSwowe4. Where
WINDOWSHOME is the directory where Microsoft Windows is installed, for example, C:
\WINDOWS.

Java Access Bridge Installation on Windows 32-bit

1.

Ensure JAWS 13 or later is installed on your system. You can download this component from
the Java SE Downloads page http://www.oracle.com/technetwork/java/javase/downloads/
index.html.

Download Java Access Bridge 2.0.2 from the Java Access Bridge download page at the
following URL:
http://www.oracle.com/technetwork/java/javase/downloads/jab-2-0-2-download-354311.html

Extract the Java Access Bridge to a folder in your drive and copy
WindowsAccessBridge-32.d11 to $WINDOWSHOMES\SYSTEM32. Where $WINDOWSHOMES
is the directory where Microsoft Windows is installed, for example, C : \WINDOWS.

Note For detailed Java Access Bridge installation instructions, see Installing Java Access Bridge on
the Oracle web site.

« Enable the Java Access Bridge by selecting the Enable Java Access Bridge option in the Control
Panel > Ease of Access Center > Use the computer without a display or by running the
following command prompt command in the bin directory of the Java JRE installation directory:
jabswitch.exe /enable.

Install on Linux

Kapow provides two installers:
* Atar.gz file containing all the components.
» Kapow RoboServer installer: Installs the roboserver service only.

Full Installation

The installation is performed by extracting the contents of the tar.gz file. In most Linux distributions, this
can be done by right-clicking the file and selecting the appropriate extraction option. The file can also be
extracted from the command line as follows:

Star xzf Kapow 10.3.0.3 x64.tar.gz

Alternatively, to extract the file to a specific directory, use the following command:

15
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Star xzf Kapow 10.3.0.3 x64.tar.gz -C /destination directory

When the file is extracted, run the following commands under user with root privileges. The commands
help to manage chrome-sandbox file permissions and set the creator and owner of chrome-sandbox as
root and enable SUID mode.

* chown root:root chrome-sandbox

¢ chmod 4755 chrome-sandbox
Proceed to enter license information as described in Provide License Information.

Note You can install Kapow as an unprivileged user on Linux.

Running RoboServer Installer

The RoboServer only installers are created for the deb and rpm packages. The default installation folder
for these packages is /opt/Kapow/.

Each of the RoboServer packages contains a RoboServer launcher that is used to run RoboServer as a
Linux /etc/init.d service. This makes it automatically start on system boot.

The packages create a kapow user and group in the system used when running the roboserver /
etc/init.d service. The configuration files (most importantly roboserver.settings) for the
RoboServer service are located in the kapow users home directory (/home/kapow/) under the hidden
directory .Kapow/<version>.

The roboserver.settings file can also be accessed through /etc/opt/Kapow/
RoboServer.conf.

To see all available commands, just run RoboServer from /etc/init.d without any arguments.

By default, the RoboServer starts with an SSL port listening (the port number is defined in the
roboserver.settings file). Keep in mind that this is a RoboServer only install; it is not possible for the
service to be configured to start a Management Console, such as with the -MC parameter, which is done
via the full installation of Kapow.

To run roboserver as a init.d service:
1. Install the RPM or DEB package.
2. Change the roboserver configuration (optional).

3. Run #service RoboServer start, or restart the machine to start the service automatically.

Silent Installation on Windows

A silent installer runs without user interaction. This is convenient if, for instance, you need to automate the
installation process in a script.

Using Full Installer

To perform a silent installation of Kofax Kapow, run the following command with administrative rights:
msiexec /gn /i Kapow 10.3.0.3.msi

This installs the program to the default location. To specify another location, use a command as follows:

msiexec /gn /i Kapow 10.3.0.3.msi INSTALLDIR="dir"
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where "dir" is the location where you want to install. For example:

msiexec /gn /i Kapow 10.3.0.3.msi INSTALLDIR="C:\Kapow 10.3.0.3 x64\"
To specify a file to log the installation process, use the following parameter:
msiexec /gn /i Kapow 10.3.0.3.msi /1 msilog.txt

After installation, proceed to enter license information as described in Provide License Information.

Using Limited Installers

The following are examples of using different installers in silent mode.
msiexec /gn /i Kapow DesignStudio 10.3.0.3.msi

msiexec /gn /i Kapow RoboServer 10.3.0.3.msi

msiexec /gb /i Kapow DeviceAutomation 10.3.0.3 x32.msi

Important Folders in Kapow

We recommend that you become familiar with the folders and files described in this section.

Installation Folder

The installation folder is the folder where Kofax Kapow is installed. On Windows, the installation folder
defaults to:

C:\Program Files\Kofax Kapow 10.3.0.3
On Linux it will be a directory named Kapow_10.3.0.3 in the directory where you extracted the archive.
The installation folder contains the following important folders:

bin

Contains all executable programs for Kofax Kapow.

API

Contains files and documentation related to the Kofax Kapow Integration APIs.

lib/jdbc

Contains the installed JDBC database drivers. These drivers are always available in Kofax Kapow

applications. Normally, you should manage JDBC drivers as described in the Database Drivers topic
in the Management Console section of the online help.

Project Folder

The project folder contains your library of robots and types, as described in the Design Studio topic of the
online help. Configure the location of the project folder with the Settings application as described in the
Working with Projects and Libraries topic of the Design Studio help. On Windows, the default location is
similar to the following, depending on your Windows version:

C:\Documents and Settings\ username\My Documents\My Robots\10.3.0.3
C:\Users\ username\Documents\My Robots\10.3.0.3

On Linux the default location of the project directory is:

~/Kapow/10.3.0.3

The project directory must contain a single subdirectory named Library.
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Application Data Folder

The application data folder contains files that are private to the Kofax Kapow but which differ for different
users of the same computer. On Windows, the application data folder is (depending on your Windows
version):

C:\Documents and Settings\ usernamel\Local Settings\Application Data\Kapow
\10.3.0.3

C:\Users\ username\AppData\Local\Kapow\10.3.0.3
On Linux the application data folder is:
~/.Kapow/10.3.0.3

To change the location of the application data folder, you can edit the common . conf file in the
installation\bin folder. Add the following two lines:

* wrapper.java.additional.<NUMBER>=-Dkapow.applicationDataFolder="Folder
containing Configuration folder"

* wrapper.java.additional.<NUMBER>.stripquotes=TRUE
Where <NUMBER> is a unique integer.

Make sure that the user running Kofax Kapow has read and write access to the folder.

Under normal circumstances, you should never modify or delete files or folders within this folder directly;
the GUI tools should be used instead. The application data folder contains the following important folders:

Certificates

Contains the HTTPS certificates known by Kofax Kapow. See the "Certificates" section in the
Administrator's Guide for more information.

Configuration

Contains configuration files, which are maintained as described in the section Configuring Kofax
Kapow.

Data

Contains the embedded Derby database used by the Management Console (except when installed
as a web application in a Tomcat web server). See "Management Console on Tomcat" chapter in the
Administrator's Guide.

DemoDatabase

Contains the Development Database used in the Management Console Beginner Tutorial, and which
you can also use in "toy projects" during your introduction to Kofax Kapow.

Logs

Contains log files.
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Provide License Information

The first step after basic installation is to enter license information. The Management Console in Kapow
can work in two different ways. In a development environment you enter the development license
information in Design Studio. In the enterprise mode a shared Management Console is used as a license
server. This chapter provides information about the development environment license. See Administrator's
Guide for using the Management Console as a license server in the enterprise environment.

Note that it is not necessary to enter license information in RoboServers, as they automatically receive the
necessary license information from Management Console.

To use the Device Automation feature, obtain a separate license for this feature from Kofax.

License Keys

There are three different kinds of license key:

Production key
Permits production use of the Kapow system.

Non-Production key
Permits use of the Kapow system for non-production use like test and staging.

Developer Seat key

A special kind of non-production key that allows you to run all the Kapow programs on your own computer
as part of the same installation. There are, however, some performance limitations, as this it intended to
be used only for development or as a trial installation.

A license key (no matter which kind) also describes which Kapow features you have, and how many
KCUs you have bought. A Developer Seat key always contains 1 KCU, while the two other kinds may
contain more.

If you have both a Production key and a Non-Production key, you may install them into the same Kapow
system (that is, in the same Management Console). You may also choose to set up one system for each
key. In both cases, you need to set up at least two different clusters (either on the single system or one
cluster on each of the two systems), configured as Production and Non-Production, respectively. The
KCUs in your licenses can then be assigned to these clusters.

Do not use one key in more than one Management Console.
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Concurrent Robot Execution License

The Kofax Kapow Concurrent Robot Execution (CRE) licensing centers around a Kapow Robot license,
where the Kapow Robot license controls how many robots can execute on a Kapow RoboServer at one
time concurrently. For example, if an organization is licensed for five Kapow Robots, then five robots can
be executed concurrently.

There is no limit to the number of robots that can be designed and deployed into production, and robots
can be as simple or complex as they need to be. For example, a robot can consist of a few or many steps
that execute a set of business workflow actions, such as inputting and outputting data, transforming data,
writing data to an Excel worksheet or calling a RESTful Service API.

When you add a CRE-based license and you go to the RoboServers tab in the Management Console, you
need to assign licenses to a cluster. For example, if you have 9 licenses that you assigned to a cluster and
there is one RoboServer in the cluster, the RoboServer can run nine robots. If there are two RoboServers,
they can run four robots each, because a CRE license cannot be split. If you start three RoboServers,
each can run three robots.

Kapow licensing is available as a perpetual or annual term license. Kapow licensing is independent of the
target hardware environment and physical CPUs, and a robot license is not tied to a physical desktop or
virtual machine, allowing you the flexibility to choose cloud-based or on-premise, virtualized or physical
CPU environments.

Learn more about Kofax Kapow licensing at kofax.com

Kapow Compute Units

Another way to license Kofax Kapow is to use capacity-based pricing based on Kapow Compute Units
(KCUs). This pricing model is completely independent of the chosen hardware configuration.

What are KCUs?

A KCU is a Kapow Compute Unit and is defined as a unit of measure for how many operations (or steps)
a Kapow RoboServer can perform in one second (and it is unrelated to underlying server capacity).

A step is the smallest unit of action which can be performed within a RoboServer. Examples of steps
are, loading a web page, writing a data record to a database, or performing a transformation on a data
element.

One KCU represents a total of 5000 KCU points per second. The number of Kapow steps that make up
one (1) KCU depends on the type of Kapow steps involved, as each step consumes a different amount of
the KCU. The steps are divided into groups the most important groups are listed here:

1. Steps that both do 1/0 and execute JavaScript, 10000 KCU points, for example, 2 page loads per
second with 4 KCUs

2. Steps that do either I/O or execute JavaScript (but not both), 1000 KCU points, for example, 20 Call
REST Web Service Steps per second with 4 KCUs

3. Extraction and transformation steps 1 KCU point, for example, 40,000 extract or assign steps per
second with 4 KCUs
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4. Device Automation step costs 5000 KCU points.

5. Looping in Device Automation costs 5000 KCU points per iteration.

The complete list is available in Design Studio by clicking Help > Show KCU Information.
You should have enough CPU power and sufficiently low response time from the source server.

Note We have empirically measured the average page load time on a powerful CPU over the 23000
most visited web sites to 6.7 seconds

The total number of KCUs a robot uses can be seen in the Design Studio Debugger Summary information
after running the robot.

Deploying and Assigning KCUs
With KCUs we can deliver the needed computing capacity independent of the target hardware

environment and physical CPUs. This allows the flexibility of choosing, cloud-based or on-premise,
virtualized or physical CPU environments without the need to control the number of allocated CPUs.

The available KCUs are assigned to the RoboServer Clusters in the Management Console and
automatically distributed between the RoboServers available within the Cluster.

Enter License in Design Studio

If Design Studio is not already started, do as follows:

Windows
Use the Design Studio item in the Start menu.

To start the Design Studio from the command line, run the following command in the bin subfolder of the
installation folder.

DesignStudio

Linux

Start Design Studio from the command line by launching the DesignStudio program in the bin directory
under the installation directory (see Important Folders in Kapow) as follows:

$./DesignStudio

On the next screen, enter your license information.
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rEIG Enter License Information @1
Kapow Design Studio

A R E

Please enter the license information you have received, ar the UREL of the license server that
will provide this information.

Trial License E

Marme: |

Campanty: |

|
E-mail: | |
|
|

Licenze Key: |

|_tep | o || cancer |

You have three choices, depending on what information you have been provided from Kofax Kapow and/
or your system administrator:

License Server

If your administrator provided you with the URL to a central license server (Management Console)

that administers the license for all Design Studio users, select License Server and enter the URL and
credentials for that server. The license server must be running and have available Design Studio seats in
order for you to use Design Studio. If your policies forbid storing the license server password, clear the
Remember Password option and you will have to type your password every time you open the Design
Studio.

See the Administrator's Guide for using the Management Console as a license server.

Developer License

The developer license is a combined license key for both Management Console and Design Studio. You
can either enter the license key in your local (embedded) Management Console, or use the dialog box in
Design Studio. Whenever you start Design Studio, the Management Console will automatically start as
well.
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Trial License

For the trial license you only need to fill the name, email and company. You do not enter a license key.
Design Studio starts without contacting the Management Console and with limited capabilities. This
license is intended for short-time use for trial/demonstration purposes.

Normally, Design Studio displays the Enter License Information dialog box only the first time it is started.
It will, however, display this dialog box again if the license server cannot be contacted because it has been
moved, is not running, or is unavailable for another reason.
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Kapow Initial Configuration

After installing Kofax Kapow, configure the installation to suit your needs. Some configuration is

done using the Settings application as described in the "RoboServer Configuration" section of the
Administrator's Guide.

Other configuration tasks, relevant mostly for administrators of the Kofax Kapow system, are done via
Management Console, more specifically via the Servers tab, the Projects tab and the Options tab. It is
especially important to set up the necessary RoboServers and clusters on the Servers tab. Refer to the

Administrator's Guide and the Management Console section in the Kapow help for information on Kapow
configuration.
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Chapter 5

Upgrade Kapow

In the interest of stability, different versions of Kofax Kapow may be installed side by side on the same
computer without interfering with each other. This means that you can install a newer version and get
acquainted with it while still doing your daily work with the older version. While doing so, you will probably
want to open the older version's default robot project in the newer Design Studio. If you save a robot with
the newer version, you will not be able to open it with the older version of Design Studio.

Important If you use the APl in your Kapow environment, the Java and .NET files must be updated
when upgrading Kapow. The new API files are located in the API folder of your Kapow installation folder,
such as C:\Program Files\Kofax Kapow 10.3.0.3 x64\API.

Below we will list the most important differences between Kofax Kapow versions that you should take into
account when upgrading.

Upgrade a RoboServer Service Installation

Read the Upgrade a RoboServer Service Installation topic if you are upgrading to a newer version of a
RoboServer service.

10.2

Version 10.2 of Kapow is backward compatible with 10.1. Your current robots should run in Kapow version
10.2.

10.1

Version 10.1 of Kapow is backward compatible with 10.0. Your current robots should run in Kapow version
10.1. See Changes in Behavior in Kapow Release Notes.

9.7

Version 9.7 of Kapow is backward compatible with 9.6. Your current robots should run in Kapow version
9.7.

9.6
Read Upgrade from Version 9.3-9.5 topic if you are upgrading to Kapow version 9.6.

Upgrade From Assisted Entry to Manual Entry
In Kofax Kapow version 10.3.0.1 the Call SOAP Web Service step does not support Assisted Entry mode.
If you are upgrading from an earlier version of Kapow, update the step as described below.

1. Open the robot in an earlier version of Design Studio, for example 10.3.0.0. Create a copy of the
robot to ensure that you have a backup and because it is easier to upgrade. In the following steps we
will update the step in the copy of the original robot.
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2. Open the copy of the robot in Design Studio, execute it to the Call SOAP Web Service step, and

change the entry mode to Manual Entry.

3. Switch to the original robot. Execute to the Call SOAP Web Service step. Open the Browser Tracer
from the Tools menu or by pressing F12. In the Browser Tracer click the red button to start trace

recording.

Execute the Call SOAP Web Service step by clicking the step after it.

If the original step has a specified Web Service URL, copy it from the step in the original robot to the
step in the updated robot. Otherwise, select the original robot in the editor to ensure that what you
see in the Browser Tracer is for that robot. In the Browser Tracer, click the single HTTP event entry,

copy the URL, and paste to the Web Service URL property of the updated step.

6. In the Browser Tracer, click the single HTTP event entry and find the header property called
SOAPAction on the Request tab. The Browser Tracer should look similar to the following:

File Trace Help

Trace
» W
HTTP JavaScript
i Time Load . et | LRL [ Status
| 018-04-1913... 5 POST  hitpc/focalhost S10800rowserengineichardump 2000 O
Request Reguest Data Response Response Data

Tirrs: ]ED’I B8-04-19 13:52:55

Load Time: |5 ms

Method  [POST
URL:  [hitp:ilocalhost: 51080/rowserengineichardump
Headers: Marmie [ Value
Accept "

Accept-Encoding azip, deflate
Accept-Language BN-Us

Cache-Control no-cache

Connection Hmp-Akve

Conkent-Length 499

Content-Type tesditoml, charset=UTF-5

Host localhost: 51080

SOAPACton hitpc Shgraphical weather gosvfoml TV genwsdlindfdiML wedi#LatlonList ZpCode
Uzer-Agent Mazillasd 0 (compatinle, MSIE 5.0, Windows NT 6.1, Trident/d 0)

Copy the value of the SOAPAction header, switch to the updated robot and paste it to the property
called SOAP Action. To copy the value, double-click the header in the list and copy its value from

the Show HTTP Header dialog box.

7. In the Browser Tracer, find the event again, click the Request Data tab, copy the entire text of the

request, and paste it to the SOAP Request property of the updated step.
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8. Ensure that the updated step uses the correct SOAP version by looking at the WSDL file used by
the original step. If this WSDL file uses the namespace http://schemas.xmlsoap.org/wsdl/
soap/, the version is 1.1. If it uses the namespace http://schemas.xmlsoap.org/wsdl/
soapl2/, the versionis 1.2.

9. Make sure that Output, Options, and other properties on the updated step have the same value as
on the original one.

10. Test the updated robot, save it. Open it in Kapow 10.3.0.1 and test it.

11. All the previous steps assumed that parameter values in the step are static, that is, do not depend
on variables. If parameter values in your step are taken from variables, create the value of the SOAP
Request property using an expression instead of a static value.

Start by taking a copy of the request. Change the option from XML to XML from Expression and
paste the request into the Expression text field. This will produce an expression with an error. You
fix this by surrounding it with >> and <<.

Dynamic property values

All the previous steps assumed that parameter values in the step are static, that is they are hardcoded
and do not change during the execution of the robot. If parameter values in your step are taken from
variables, create a value of the SOAP Request property using an expression instead of a static value.

Start by making a copy of the request. Change the option from XML to XML from Expression and paste
the request into the Expression text field. This should produce an expression with an error. Fix it by
surrounding the request with double greater-than and less-than signs (>> <<).

For instance, if the value of the parameter zipCodeList is taken from a variable that is also called
zipCodelList, the SOAP Request surrounded by >> << should look as follows (some details are left out).

>><?xml version="1.0" encoding="UTF-8"?>

<soapenv:Envelope ...>
<soapenv:Body>
<nsl:LatLonListZipCode ...>

<zipCodelList xsi:type="xsd:string">90210</zipCodelList>
</nsl:LatLonListZipCode>
</soapenv:Body>
</soapenv:Envelope><<

The value of the zipCodeList parameter in the example is static and equals 90210. To use the value of
the zipCodelList variable instead of the hardcoded value, replace the actual value of the parameter with
the variable name in the following format:

<< + zipCodeList + >>
The code example looks like the following:

>><?xml version="1.0" encoding="UTF-8"?>

<soapenv:Envelope ...>
<soapenv:Body>
<nsl:LatLonListZipCode ...>

<zipCodelist xsi:type="xsd:string"><< + zipCodelist + >></zipCodelList>
</nsl:LatLonListZipCode>
</soapenv:Body>
</soapenv:Envelope><<

Continue this process to replace all parameters with variables.

If a parameter depends on an expression and not just a variable, use that expression instead of the
variable. For example, if a parameter depends on the expression x+1, replace the value with << + (x
+1) + >>.
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Upgrade a RoboServer Service Installation

This section provides details about how to upgrade a RoboServer service.
Perform the following steps to upgrade your Linux installation of Kapow.

Stop the roboserver manually and wait for robots to finish executing (optional).
Update the packages.

Change the configuration in the new roboserver.settings file (optional).

P o b=

Restart the computer or use RoboServerService start command to restart the roboserver.

Note the following when upgrading Kapow on Linux:
» Upgrading a package replaces all the files in the /opt /Kapow/ directory.

* When you start the upgrade procedure, the init.d service is stopped and replaced with a new
version. The service is stopped immediately without waiting for robots to finish executing. If you do not
want to interrupt the execution of the robots, stop the roboserver manually before upgrading.

* Anew roboserver.settings file is created for the new service. The new file is created in /
home/kapow/ .Kapow/<release version>/Configuration/ similarly to the old one. That
means a new directory is created for the new release so that the old configuration file remains intact
in the folder with the older release name. The link to the configuration file in /etc/opt/Kapow/
RoboServer.conf points to the settings file in the last installed release.

* The configuration from the old roboserver.settings file is not transferred to the new one, this must
be done manually.

Upgrade from Version 9.3-9.5

When a robot from one of the previous versions (9.3, 9.4, 9.5) is opened, a legacy wait criteria is added
to the robot using the "Max. Wait for Timer Events" and "Wait Real-Time for Timer Events" ensuring the
same behavior as in 9.5. This cannot be edited, but it can be removed and replaced with new criteria to
improve performance if possible.

. o
Continue when: Legacy Timing (wait mse. 10000 ms real-time for timer ...

L= B

To switch to the new default settings when updating an existing robot to 9.6, go to the File > Configure
Robot dialog box, click the Advanced tab and clear the Use Pre 9.6 Default Waiting check box.
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-
D5 Robot Configuration 2
* Basic * Advanced De=ign Mode Version
Proxy Server. Use Proxy Server: [
Host: | |
Port number: | |
zername: | |
Pazsword: | |
Excluded hosts: |localhost
127.0.01
Use Pre 9.5 Defautt Waiting: *
Erable Private HTTR Cache:
Private HTTP Cache Size (KB |2E|43 |
Help [ QI ] I Cancel l

Customers Upgrading From 9.2

Kapow version 10.2 is fully backward compatible with 9.2 and your current robots will run with the Classic
Browser Engine as in 9.2, there is no need to migrate existing working robots to the new Default browser.
We recommend building new robots using the Default browser, but in case the web site does not render in
the Default browser, we recommend switching to Classic. This will particularly be the case for legacy web

applications designed specifically for old versions of Internet Explorer.

Note that the Default browser is using Chrome as the browser to emulate, while the Classic browser
emulates Internet Explorer. This can cause Classic and Default to render pages differently and return a
different Document Object Model (DOM), so when migrating from a Classic to a Default robot, the tag-

finders may be different and require modification.
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Chapter 6

Quick Start Guide

This chapter explains how to get started using Kofax Kapow.

Prerequisites

» The examples below use a standalone Management Console (NOT deployed into Tomcat) and
RoboServer that are on a different computer than Design Studio.

» This chapter assumes you have at least a non-production key for running a Management Console.

» All Kofax Kapow documentation files can be downloaded from the Kapow Product Documentation
(Master). After Kofax Kapow is installed, the documentation files can also be found in the
Documentation folder from the Kapow installation folder.

Install the software

1. Make sure that the system requirements are met. See System Requirements.

2. Install the Kapow software on the computer where you will use Management Console and
RoboServer. Follow the Install Kapow section for your OS.

3. Install the software on the computers where Design Studio will be running. You can use the installer
that only installs Design Studio (since we will use Management Console for licensing).

Start the Management Console and RoboServer

To start a Management Console and RoboServer in the same Java Virtual machine, either run Start
Management Console from the Start menu on Windows or run the following command from the bin folder
of the Kapow installation folder.

* On Windows: RoboServer -MC -p 50000
¢ On Linux: ./RoboServer -MC -p 50000

Notes
» All RoboServer command parameters are listed in the Runtime chapter of the Administrator's Guide.

* You can reach Management Console on http://<ServerNameOrIP>:50080. Additional settings
(different port, HTTPS usage, and so on) are available in the RoboServer Settings application.

* You can start RoboServer on different ports (default is 50000). By default, Kapow registers the
RoboServer on the port specified in the command for this Management Console.

 ltis possible to start Management Console and RoboServer in separate JVMs by running the
RoboServer command with separate parameters.
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Refer to the RoboServer parameters in the Administrator's Guide.
RoboServer -MC command starts Management Console only.

RoboServer -p 50000 -mcUrl http://ServerName:50080 -cl "Production"
command starts a RoboServer on port 50000 and registers it to the Management Console at
ServerName: 50080 under the Production cluster.

* A Kapow environment always has one Management Console that can control multiple RoboServers. Do
not configure multiple Management Consoles to control the same RoboServer.

 ltis possible to configure Kapow Management Console and RoboServers to start automatically. See the
Kapow Initial Configuration chapter for more information.

Access Management Console and enter the license key

Use your browser to start the Management Console. Example:
http://MCServerName:50080.

The first time you access the Management Console, it prompts for the license key. Make sure that the
keys and the company name match exactly the data you received from Kofax. The license data can later
be replaced in the Management Console > Admin > License tab.

Note Click the Help icon (7]) on any tab to get more information about the open window. The icon is
usually on the top right corner.

Configure Management Console settings

Management Console security settings are configured on the Management Console tab of the
RoboServer Settings application. You can open the application from the Kapow group on the Start menu
or from the bin folder in the Kapow installation folder.

It is very important to run the RoboServer Settings application as the same user that runs Management
Console. Otherwise, the changes are not applied.

Change Management Console port: change "HTTP Port Number™
To change the default port number, on the Management Console tab in the RoboServer Settings
application, edit the HTTP Port Number property.

Enable Management Console authentication (optional)
1. On the Management Console tab, select Enable User Management.

2. Enter the Admin username. This is your initial admin user; you can add additional users and create
groups later from the Management Console itself.

3. Click Enter password and set the admin password.

31



Note If user management is enabled, check the documentation for the correct way to set the
RoboServer to register to this Management Console. See the "Start RoboServer" section in the
Administrator's Guide.

Upload JDBC driver

The JDBC Driver Upload option changes the way the JDBC drivers are uploaded. By default, only an
admin user is allowed to upload a JDBC driver and only while accessing the Management Console on
the computer it is running (localhost). If you are accessing the Management Console from a different
computer and if you need to upload JDBC drivers (to use with databases), change this option to Admin
from any host.

More detailed information, including information about the other tabs in the RoboServer Settings
application, is available in the "Runtime" section in the Administrator's Guide.

Important The Management Console and RoboServer must be restarted for changes done in the
RoboServer Settings application to take effect.

Management Console with authentication

When authentication is set up, the Management Console prompts you for a user name and password.
Enter the user name and password set in the RoboServer Settings application. When you are logged in,
the user name is shown in the top right corner.

Create users and groups

Create new users and groups (or assign users to groups) from Management Console > Admin > Users &
Groups tab.

Note that there is no connection between users/groups and your Active Directory/LDAP/Domain users
and groups. If users change their domain password, it has no effect on the user credentials for the
Management Console.

Although it is possible to integrate Kapow Management Console with LDAP, this is an advanced
configuration that only works when Management Console is deployed as an application in a stand-alone
Tomcat web server. For details, see the Tomcat Management Console topic in the Kapow Administrator's
Guide.

Add users to groups
There are two ways to add users to groups.

» Select a user, click Edit User and use the arrows to add the groups the user should be a member of.
» Select a group, click Edit Group and use the arrows to add members.

Assign rights to users
Important A user created in the Management Console is able to log in to the Management Console
only if the user is part of a group that has been assigned rights to at least one project.

To assign rights to access projects, follow these steps:

1. Go to Management Console > Admin > Projects.
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2. Create a project or open the existing project properties by clicking the Edit icon (E2).
Go to the Permissions tab and click Add Permission.

Select a project role in the Project Role drop-down list.
See "Manage Users and Groups" in help or in the Kofax Kapow User's Guide.

5. Select the group in the Security Group drop-down list.

Add other groups if needed and click Save.

Configure Management Console before running robots

JDBC database drivers

Kapow has a default database that can be used for logging (logdb) and for robots to store data (objectdb).
To use this database, start it from the Kapow program group under (Start > Programs) using Start
Development Database. An executable can be found in the bin folder (in the installation folder) too.

If you want to use a custom database (which is recommended even when testing), do the following first.
1. Check Supported Platforms to see the database systems that Kapow supports.

2. Get the JDBC driver for the database. Kapow does not provide these drivers, but you can download
them from the database provider, such as Microsoft, Oracle, or other.

3. Upload the JDBC driver in the Management Console > Admin > Settings > Database Drivers by
clicking the Upload Driver Jar button.

Note If the Upload Driver Jar button is disabled, you might be accessing the Management Console
from a different computer than the one on which it is running and you have not changed the setting
to allow driver upload from a different computer. See "Upload JDBC driver" in the Configure
Management Console settings and change the "JDBC driver upload" to "Admin from any host".
Restart Management Console (the process itself) and the "Upload Driver Jar" button should be
enabled.

4. Click Save to save the JDBC driver in Management Console. You can see it listed under "Database
Drivers."

To use multiple types of databases in the same Management Console, upload the driver they should use.

RoboServer log database

By default, the RoboServer log database in set to 1ogdb (which can be accessed if you start the
Development database only).

You can configure the RoboServer log database as a custom database. If the user you provide has rights
to create tables in this database, Kapow creates all the tables it needs.

If the user cannot create tables, a database administrator has to create them before the database is
configured as a RoboServer log database. See "Scripts for Creating Database Tables" in Kapow help or
the Kapow User's Guide to get the queries needed to create the log tables (make sure to get the one that
applies to your database type).

Your user must be able to write to these tables.
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After the RoboServer Log Database is configured, you can see all the logs in the Management Console >
Logs tab.

Harvest database
Robots can store data in databases or query tables for data. By default, objectdb is used (Development
Database). To use a custom database, follow these steps:

1. In Management Console, go to Admin > RoboServers and open Cluster Settings (click the icon or
right-click the cluster to see the option).

2. Click Databases and then Add a Database.

Fill in the information, click Test to make sure Management Console connect to the database, and
click OK to save the settings.

Note The Name option is the name of the mapping, not the database (you specify the actual
database name in the Schema option). The mapping name differ from the database name and you
can keep it different if you do not want robot developers to know the real name of the database. If
security is not a concern, you can keep the mapping name the same as the database name (less
confusion).

Data stored by robots in this database can be viewed from Management Console > Data tab. Only tables
created from types are shown. If a table is created in SQL Manager, you will not see it in Management
Console (even if you have robots configured to query it or add/change data in it).

Shared Databases (between Management Console and Design Studio)
Management Console can push database mappings created under Cluster Settings to Design Studio
instances. If you have multiple clusters, only one cluster can push database mappings.

To configure Shared Databases, follow these steps.

1. Select which clusters will push the databases: go to Management Console > Admin > Settings >
Design Studio > Shared Databases.

2. Create your database mappings under Cluster settings (see the "Harvest database" topic for details).
3. Assign database mappings to projects as follows:
a. Go to Management Console > Repository > Databases and click New Database Mapping.

b. Fill in the information.

* Mapping Name: It can be the same as the name given when creating the mapping in Cluster
Settings (it can be different too, but might cause more confusion).

» Project: Set to the project where this mapping will be used.

Note Keep in mind project permissions when using authentication (see Management
Console with authentication for details). If a mapping is assigned to a project, only users
with rights to that project will be able to use it (and see its data when opening Management
Console > Data tab).

» Cluster: Must be the same as the one you already set for "Shared Databases."

» Database Configuration: Select the mapping created in Cluster Settings from the drop-down
list.
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4. After you save these settings, the users that have Design Studio connected to this Management
Console can right-click the Management Console connection under Databases, select Refresh and
have the mapping available as in the following example.

| Databazes

= | LocalBdC
& Devedopment Database
My apowDE

Build Robots

Robots are built in Design Studio. See Enter License in Design Studio for more information on how to start
Design Studio and configure a license for it.

Then see "Tutorials" in the User's Guide for more information about building robots. From any step in
Design Studio you can click the help icon (&) to open help and read more information about that specific
step.

Design Studio also has a default project (its name is the name of the version, such as 10.3.0_166) where
you can find robot examples for common operations.

Upload Robots

It is easier to upload robots from Design Studio. To upload a robot, right-click the robot under My Projects
and select Upload. In the Upload to Management Console dialog box, select the Management Console
and the Project where the robot should be uploaded.

Notes

* You cannot create a project from the Upload dialog box; it must be created in the Management Console
in advance.

* When using this option, you only need to select the robot. Design Studio automatically sends all the
types and snippets that it uses.

* You can share a project between Management Console and Design Studio by selecting "Remember
this (as a shared project)." You can find more information about shared projects and how to work with
them in the "Projects and Libraries" topic in the Kapow User's Guide.

* You can also upload the robot files directly in the Management Console but you have to select the robot
and each type and snippet one by one. Go to Management Console > Repository tab and you can see
the Add buttons on each tab (Robots, Types, Snippets).
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Run robots

Run robots from Repository

Each robot in Repository has a "Run Now" icon ( +)). However, only robots that do not require input can be
run this way. If your robots require input, they can only be run by a schedule (by Management Console),
API or REST/SOAP services. See the next sections for more information.

If you have multiple clusters, you will be asked to select a cluster on which to run.
Run robots from a schedule

You can create a schedule from the Management Console > Repository > Robots tab by right-clicking a
robot and selecting Create Schedule.

This automatically adds the robot to the schedule. The other option (easier to use when you want to add
multiple robots to a schedule) is to use the “Add” button on the Management Console > Schedules tab.

Run robots via API
You can see the API icon ([ ;) in Management Console > Repository > Robots.

Clicking the APl icon opens the sample code for Java and .NET APIs that you can use to call this robot.
More information is available in the Kofax Kapow Developer's Guide.

Run robots using REST/SOAP
Click the REST/SOAP icons (=2/<*) in Management Console > Repository > Robots to get a service
example that you can use to call that specific robot.

Performance graphs in Management Console

Management Console has a few basic performance graphs on the Dashboard tab.

By default, only the most used ones are open, but you can open additional graphs by selecting them in the
drop-down list and clicking Add.

More types of graphs are available when using Kofax Analytics for Kapow, which is a separate software
that you can purchase. Contact your sales representative for more information.
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