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Preface

Introduction
This guide contains essential information about configuring and operating Kofax Import
Connector.

This guide assumes that you have a thorough understanding of Windows standards,
applications, and interfaces. It also assumes that you have a thorough understanding of the
Internet, your network configuration, and Kofax Capture.

This guide is for system administrators who are configuring and operating Kofax Import
Connector, or who need a description of the configuration procedures and operation.

Related Documentation

In addition to this  Kofax Import Connector Administrator's Guide, the following additional
documentation is available:
▪ Kofax Import Connector Installation Guide
▪ Kofax Import Connector Developer's Guide
▪ Message Connector Help
▪ KC Plug-In Help
▪ Release notes

Help

The online Help systems included in Kofax Import Connector provide online assistance for
system administrators and operators alike. You can access online Help from any application
window by clicking Help.

Release Notes

Late-breaking product information is available from release notes. You should read the
release notes carefully, as they contain information that may not be included in other Kofax
Import Connector documentation.

Training
Kofax offers both classroom and computer-based training that will help you make the most of
your Kofax Capture solution. Visit the Kofax website at www.kofax.com for complete details
about the available training options and schedules.



Preface

6 Kofax Import Connector  Administrator's Guide

Getting Help for Kofax Products
Kofax regularly updates the Kofax Support site with the latest information about Kofax
products.

To access some resources, you must have a valid Support Agreement with an authorized
Kofax Reseller/Partner or with Kofax directly.

Use the tools that Kofax provides for researching and identifying issues. For example, use the
Kofax Support site to search for answers about messages, keywords, and product issues. To
access the Kofax Support page, go to www.kofax.com/support.

The Kofax Support page provides:
▪ Product information and release news

Click a product family, select a product, and select a version number.
▪ Downloadable product documentation

Click a product family, select a product, and click Documentation.
▪ Access to product knowledge bases

Click Knowledge Base.
▪ Access to the Kofax Customer Portal (for eligible customers)

Click Account Management and log in.
To optimize your use of the portal, go to the Kofax Customer Portal login page and click
the link to open the Guide to the Kofax Support Portal. This guide describes how to access
the support site, what to do before contacting the support team, how to open a new case or
view an open case, and what information to collect before opening a case.

▪ Access to support tools
Click Tools and select the tool to use.

▪ Information about the support commitment for Kofax products
Click Support Details and select Kofax Support Commitment.

Use these tools to find answers to questions that you have, to learn about new functionality,
and to research possible solutions to current issues.

http://www.kofax.com/support
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Chapter 1

Overview

Kofax Import Connector is an add-on to Kofax Capture responsible for importing messages
and files in many electronic formats.

It has two main components:
▪ Message Connector is usually installed on a standalone computer. It retrieves documents

from various sources, converts them to Kofax Capture compatible format and saves them
in its internal storage.

▪ KC Plug-In is installed at the Kofax Capture computer. It connects to one or more Message
Connectors and imports documents to Kofax Capture for further processing.

Kofax Import Connector can import messages and files from many sources:
▪ email messages including attachments using various email protocols (SMTP, POP3, IMAP,

EWS)
▪ fax messages (via internal fax over IP server or external fax servers: Kofax Communication

Server, RightFax, Biscom)
▪ files from a local or network folder
▪ files via web services

This guide provides important information about configuring and operating Kofax Import
Connector, including:
▪ Instructions for configuring Kofax Import Connector
▪ Instructions for integrating with third party environment, such as fax servers or email

servers
▪ Instructions for operating and monitoring Kofax Import Connector

Concepts
Kofax Import Connector uses a unified workflow for documents from all sources. Older
import connectors have used various approaches for importing documents to Kofax Capture.
This section describes the concepts that you need to understand before configuring Kofax
Import Connector.
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Storage
Before importing to Kofax Capture, documents from all sources are saved to the internal
storage of Message Connector. KC Plug-In periodically polls all connected Message
Connectors and imports the documents to Kofax Capture. Processed documents in
the storage are automatically deleted when the space is required for new documents.
Administrators can access the documents in the storage; refer to Viewing Messages in the
Storage and Managing Failed Messages Manually.

Conversion
Message Connector can convert the documents from the storage before importing them
to Kofax Capture. The conversion tools have to be installed on the same computer as
Message Connector. Refer to Kofax Import Connector Installation Guide.

Destination
Destinations tell Kofax Capture how it should handle documents received from
Kofax Import Connector. In a destination, you select things like the desired document
conversion, what part of document do you want to import (e.g. only attachments in
case of emails), what batch class to use, and much more. You can also map metadata
of imported documents to Kofax Capture batch / folder / document fields. Refer to
Configuring Destinations for Imported Documents.

Connection between Message Connector and Kofax Capture
The KC Plug-In component of Kofax Import Connector is directly integrated with Kofax
Capture. The Message Connector is usually installed on another computer. However,
these two components must communicate. Therefore, a connection to Message Connector
must be defined in KC Plug-In. Refer to Connecting KC Plug-In to Message Connector.
You can also define how often should KC Plug-In poll for new documents and you can
restrict the operating time of this connection. Even when the connection is inactive,
documents delivered via SMTP email, fax over IP, and web service are accumulated in
Message Connector storage.
When you define a connection, you must select the default destination. All documents are
handled accordingly... unless you specify different rule.

Rule
Formerly called destination mappings in Kofax Capture Import Connector - Advanced
Email and Fax, rules allow you to filter documents and assign them to destinations.
Rules override the default destination of a connection. For example, you can decide
that all email messages go to destination 1. All faxes from number starting with 123 use
destination 2. Refer to Configuring Rules.
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Chapter 2

Configuration

This chapter lists the most common tasks necessary to configure Kofax Import Connector.

The tasks below do not mention all parameters; you can configure much more than what’s
listed here. The Message Connector configuration utility shows a brief description of all
parameters inline. The KC Plug-In offers tooltips. All parameters are described in the online
help.

A general procedure for configuring Kofax Import Connector is here:

1 Add at least one batch class to Kofax Capture and publish it. Refer to Kofax Capture
documentation for information about batch classes. If you want to use sample batch
classes, refer to Importing Batch Classes.

2 Optionally, if you want to differentiate between XML documents and handle them
differently, you can define XML types. Kofax Import Connector can identify XML
documents with a particular namespace and root element. Refer to Configuring XML
Types.

3 Create a destination using a batch class and, optionally, an XML type. Refer to
Configuring Destinations for Imported Documents.

4 Connect KC Plug-In to Message Connector. Refer to Connecting KC Plug-In to Message
Connector.

5 Select and configure one or more sources to import documents from:
▪ Import via fax over IP. Refer to Configuring Message Connector as FoIP Server.
▪ Import via SMTP. Refer to Configuring Message Connector as SMTP Server.
▪ Import via web services. Refer to Configuring Message Connector for Web Service

Input.
▪ Import from an IMAP, POP3, or EWS mailbox. Refer to Accessing Mailboxes (IMAP,

POP3, EWS).
▪ Import from a folder. Refer to Accessing Folders.
▪ Import from a fax server. Refer to Accessing Fax Servers.

6 Optionally, if you want to differentiate how to handle specific messages, add rules that
change the default destination. Refer to Configuring Rules.

7 Set up the tools for document conversion. Refer to Configuring Document Conversion.

8 Select what to do in case of failures. Refer to Managing Failed Messages Manually.

9 Start the KC Plug-In service. Refer to Starting and Stopping the KC Plug-In Service.

Configuring Incoming Documents
Use this chapter to configure:
▪ From where should Kofax Import Connector import documents (e.g., email, fax, folder)
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▪ What tools should be used for converting documents

Configuring Message Connector as FoIP Server

Message Connector can act as a fax over IP device and accept incoming faxes. To receive
faxes, fax over IP infrastructure must be available and configured properly.

1 On the KC Plug-In computer, create or edit a connection between KC Plug-In and
Message Connector. Click Add and select FoIP Import to add fax over IP to the list of
import connectors. Refer to Connecting KC Plug-In to Message Connector.

2 Contact the administrator of your fax over IP network. On the FoIP gateway, the IP
address of Message Connector must be assigned an extension. In the ideal case, no
further configuration is necessary and faxes sent to that extension will automatically end
up in Message Connector storage. If not, proceed with the next steps.

3 Start Message Connector Configuration utility from the Kofax Import Connector group in
the Windows Start menu.

4 Optionally, on the General tab, enter the Own Fax Number. This number is displayed on
the fax device that sends a fax to you as your fax number.

5 Click Advanced to display additional configuration options.

6 On the Security Options tab, verify that Disable FoIP is not selected.

7 On the List of Call Peers tab, specify the protocol supported by your FoIP gateway (H.323
or SIP, with or without registration), its IP address and port, and other parameters as
required by the gateway.

8 Review the settings in the tabs VoIP/FoIP Network, Voice Codecs, Fax, H.323 Signaling,
and SIP Signaling.

9 Click Save. Click Exit and restart service.

 Connecting KC Plug-In to Message Connector

A single instance of KC Plug-In can connect to multiple Message Connectors.

At least one destination must exist before connecting to Message Connector. Refer to
Configuring Destinations for Imported Documents.

1 Start KC Plug-In configuration. Do one of the following
▪ On a Kofax Capture Network Server remote site, start KC Plug-In from the KIC -

Electronic Documents group in the Windows Start menu.
▪ On other Kofax Capture installations, start Kofax Capture Administration and select

Electronic Documents > Configuration.

2 On the Connection Tasks menu, click Add Connection.

3 Enter a descriptive Connection name.

4 Change the Message Connector URL to your installed Message Connector host name.

5 If a password for the Process user is configured in Message Connector, enter it into the
Password field (blank by default).

6 Click Test Connection to verify that KC Plug-In can connect to Message Connector.

7 Select a Default Destination.
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Note  The default destination must not have an XML type specified.

8 Enable one or more import connectors to tell Kofax Import Connector what kind of
documents should it import:

a Click Add and select SMTP Import to enable import via SMTP email. Refer to
Configuring Message Connector as SMTP Server.

b Click Add and select Web Service Import to enable import via web service interface.
Refer to Configuring Message Connector for Web Service Input.

c Click Add and select FoIP Import to enable import via fax over IP. Refer to
Configuring Message Connector as FoIP Server.

d Click Add and select Mailbox Import to enable importing of POP3, IMAP, and EWS
email. Refer to Accessing Mailboxes (IMAP, POP3, EWS).

e Click Add and select Fax Server Import to enable importing of fax messages from
compatible fax servers. Refer to Accessing Fax Servers.

f Click Add and select Folder Import to enable importing of documents from a local or
network folder. Refer to Accessing Folders.

You can add and operate multiple import connectors in parallel (up to 100). However,
you can select FoIP, SMTP, or web service import only once.

9 Click OK. Restart the KC Plug-In service.

Note  Connecting multiple KC Plug-Ins to a single Message Connector is not supported.

Configuring Message Connector as SMTP Server

Message Connector can act as an SMTP gateway and accept incoming SMTP emails.

1 Start Message Connector Configuration utility from the Kofax Import Connector group in
the Windows Start menu.

2 Go to the General tab and enter the Own Computer Name (might be necessary for SSL).

3 Optionally, on the Email Inbound via SMTP tab, specify the Local IP Address (IP address
of the used network adapter; required e.g. in clustered environment) and port. You can
also enable SSL.

4 Verify that SMTP input is not disabled:

a Click Advanced.

b Go to the Security Options tab.

c Make sure that Disable SMTP Server is not selected.

5 Click Save. Click Exit and restart service.

6 On the KC Plug-In computer, create or edit a connection between KC Plug-In and
Message Connector. Click Add and select SMTP Import to add SMTP email to the list of
import connectors. Refer to Connecting KC Plug-In to Message Connector.

7 Next, you need to configure your email server (e.g. Microsoft Exchange) to forward
messages to Message Connector via SMTP. Contact your mail server administrator.

E.g., with Microsoft Exchange 2010, use a new logical domain (e.g. user1@kic.ed.com)
and create a send connector for this domain. The address space of the send connector
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must contain the domain (e.g. kic.ed.com). Then configure the Message Connector (e.g.
192.168.10.10) as smart host for the new send connector. Exchange users can now send to all
addresses in the domain kic.ed.com.
 

 

For testing, you can configure Message Connector’s IP address as the outgoing SMTP
server in your mail client software. As a mail client, you can use e.g. Mozilla Thunderbird
or Windows Live Mail. In the examples below, 172.20.148.110 is the IP address of Message
Connector.

In Thunderbird, set up a new outgoing SMTP server, then create a new account and choose
the new SMTP server.
 

 

In Live Mail, select to manually configure server settings and specify the outgoing server
address.
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An even simpler test email can be sent via the Message Connector monitor tool. Refer to
Sending a Test Email.

Configuring Message Connector for Web Service Input

Message Connector can accept documents via web services.

1 Start Message Connector Configuration utility from the Kofax Import Connector group in
the Windows Start menu.

2 Go to the General tab and enter the Own Computer Name (might be necessary for SSL).

3 Go to the Web Service Input tab.

a Specify Local IP Address (IP address of the used network adapter; required e.g. in
clustered environment).

b Make sure that either HTTP or HTTPS port has a non-zero value.

c Optionally, if you want to use the web service calls GetContentTypeList and
GetContentTypeDescription to retrieve information from Kofax Capture, specify
KC Plug-In URL, e.g. http://localhost:8001/KIC-Electronic-Documents. The URL
must include the same port number as the one configured in KC Plug-In. Refer to
Configuring KC Plug-In Web Service Interface.

4 If you are using network load balancing and you want to track the status of documents
send via web service, different instances of Message Connector need to communicate
together. You need to configure additional parameters on each computer:

a Select MC Cluster Enabled to enable the communication between Message Connectors
in order to track documents.

b In the Local MC Cluster IP Address field, enter the local IP address. This address must
be reachable from other Message Connector computers.

c In the MC Cluster Port field, enter the port for internal communication between
Message Connectors.

d In the MC Cluster Members field, list the IP addresses and ports of other Message
Connectors, e.g. “10.10.10.1:25099, 10.10.10.2:25099”.

5 Verify that web service input is not disabled:

a Click Advanced.
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b Go to the Security Options tab.

c Make sure that Disable Web Service Input is not selected.

6 Click Save. Click Exit and restart service.

7 On the KC Plug-In computer, create or edit a connection between KC Plug-In and
Message Connector. Click Add and select Web Service Import to add web service to the
list of import connectors. Refer to Connecting KC Plug-In to Message Connector.

Customers must provide their own application to send documents to Kofax Import Connector
via web services interface. The WSDL file describing the interface is available in the
installation directory (by default <programs>\Kofax\KIC-ED\MC\web\import.wsdl).

A sample application for sending documents is available on the installation ISO: Samples
\WebService\CSharpClient.zip. Both source code and compiled application are provided.
For more information about using the tool, refer to readme.txt (part of the zip package). For
additional information about the interface, refer to Kofax Import Connector Developer's Guide.

The web services interface is not compatible with Kofax Capture Import Connector - Web
Services. Existing customer applications have to be updated.

Accessing Mailboxes (IMAP, POP3, EWS)
1 Start KC Plug-In configuration. Do one of the following

▪ On a Kofax Capture Network Server remote site, start KC Plug-In from the KIC -
Electronic Documents group in the Windows Start menu.

▪ On other Kofax Capture installations, start Kofax Capture Administration and select
Electronic Documents > Configuration.

2 Connect KC Plug-In to a Message Connector or edit one of the existing connections. Refer
to Connecting KC Plug-In to Message Connector.

3 In the Connection configuration window, click Add and select Mailbox Import.

4 Enter a descriptive Display name.

5 In the “Poll cycle in seconds” field, specify how often should the mailbox be checked for
new documents. The maximum value is 86400 seconds, i.e. 24 hours.

6 In the Host field, enter one of the following:
▪ Host name or IP address of the IMAP/POP3 server, e.g. pop3.gmail.com
▪ URL of the Exchange Web Services end point in the format http[s]://<host>[:port]/

ews/exchange.asmx

7 Select the Protocol for accessing the mailbox.

8 Enter the credentials in User name and Password.

9 For IMAP and EWS, you can additionally configure how processed messages should be
handled. If you select to Keep messages on server, you must specify a Processed folder
name. Processed messages will not be deleted from the server, instead, they will be
moved to the specified folder.
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10 For IMAP and EWS, select the Mode which determines whether the same inbox can be
polled by multiple Message Connectors simultaneously.
▪ Select Single Instance if you know that you will poll this mailbox with only one

Message Connector. Using this value and running multiple connections in parallel
might cause that the same message is imported to Kofax Capture multiple times.

▪ Select Multiple Instance to allow multiple connections to a single mailbox, without
risking duplicate imports. However, not all IMAP servers support this option (rename
inbox function). The Test Mailbox button verifies if this option is available on your
IMAP server.

11 Click Test Mailbox to verify the connection. Click OK to close the folder settings
window.

12 Click OK to close the connection configuration window. Restart the KC Plug-In service.

 

 

Additional parameters related to POP3/IMAP/EWS import are available in the Message
Connector configuration, in the Security Options tab.
▪ Disable POP3/IMAP - If you need to disable the polling of POP3/IMAP completely.
▪ Disable EWS - If you need to disable the polling of EWS completely.
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Note  When Message Connector receives a message via POP3, it always tells the POP3 server
to delete the message. However, POP3 servers can be configured to perform a different action
when a delete is requested, e.g. they move the message to a different folder. This behavior is
mail server specific and cannot be controlled by Kofax Import Connector.

Also, it is not recommended to poll a single POP3 mailbox from multiple Message
Connectors. While a strict implementation of the POP3 protocol should allow a reliable
locking mechanism needed to prevent reception of duplicates, many common POP3 email
providers lack these.

Accessing Folders
1 Start KC Plug-In configuration. Do one of the following

▪ On a Kofax Capture Network Server remote site, start KC Plug-In from the KIC -
Electronic Documents group in the Windows Start menu.

▪ On other Kofax Capture installations, start Kofax Capture Administration and select
Electronic Documents > Configuration.

2 Connect KC Plug-In to a Message Connector or edit one of the existing connections. Refer
to Connecting KC Plug-In to Message Connector.

3 In the Connection configuration window, click Add and select Folder Import.

4 Enter a descriptive Display name.

5 In the “Poll cycle in seconds” field, specify how often should the folder be checked for
new documents. The maximum value is 86400 seconds, i.e. 24 hours.

6 Enter the Watched folder, either by typing the path or via the Browse... button. Use UNC
syntax for network paths.

7 In the User and Password fields, enter the Windows credentials needed for accessing
the watched folder. The user accessing the watched folder needs Modify or Full Control
rights.

Note  From one computer, only a single Windows user may access a network folder
simultaneously. If you have another connection active (e.g., a Windows Explorer window
displaying the folder) with a different user, Message Connector might have trouble
accessing the folder (especially if the active user does not have sufficient rights).

8 Click Test folder import to verify that Kofax Import Connector can connect to the
specified folder. (If you are testing a network folder, having a Windows Explorer
window open displaying the content of the folder might occasionally prevent the test
button to connect.)

9 Optionally, go to the Advanced tab to configure additional parameters. If not, continue
with step 15.

10 Select Process subfolders to monitor the immediate subfolders of the watched folder.
Select Include watched folder to monitor the watched folder itself.

Note  When a subfolder becomes empty after all files from it are imported, the subfolder
is deleted.

11 In the File mask field, enter a comma separated list of files that should be imported from
the folder. You can use wildcards: The asterisk character ("*") substitutes for any zero or



Configuration

Kofax Import Connector  Administrator's Guide 17

more characters, and the question mark ("?") substitutes for any one character. If you are
using trigger files, this field is disabled (see below).

12 Select the File Detection Mode. Use this setting to make sure that files are completely
copied to the watched folder before importing. Select one of the options:
▪ Select Wait for file to force Kofax Import Connector to wait for the specified number

of seconds after the file was last accessed.
▪ Select Use trigger if you want first copy a document (or a folder containing

documents) to the watched folder and then create a trigger file that tells Kofax Import
Connector that the document (or folder) is ready for importing.

13 If you selected to use trigger files:

a In the Trigger file mask field enter a trigger file, e.g. "*.trg" (or a comma separated list
of trigger files). You can use wildcards: The asterisk character ("*") substitutes for any
zero or more characters, and the question mark ("?") substitutes for any one character.

b Decide whether the trigger refers to documents or folders:
▪ Select Files in the same directory with the same base name. Kofax Import

Connector cuts the extension from the trigger file name and searches for documents
with the same base name in the same folder. For example, with trigger file mask
"*.trg" and trigger file "001.trg", all documents matching "001.*" (except the trg file)
are imported.

▪ Select All files in the same directory to import all documents from the same folder
(except the trigger file). For example, when the trigger file ready-to-be-imported.trg
appears in a watched folder, all other documents in the folder are imported to
Kofax Import Connector.

▪ Select All files in the subfolder with the same base name. Kofax Import Connector
cuts the extension from the trigger file name and searches for a subfolder with the
same name. All documents from the subfolder are imported.

Note  The trigger file must have an extension.

▪ Select Import all files in a folder matching file mask. Kofax Import Connector
looks for a folder with name that matches the trigger file mask. All documents from
the folder are imported.

c Decide what to do with the trigger files after import:
▪ Select Delete to delete it.
▪ Select Rename extension to and specify an extension to rename it.

d Select Import trigger file if you want import the content of the trigger file. When
cleared, the content of the trigger file is not relevant and it is deleted/renamed after
the other documents are imported.

14 Select the File Import Mode. Use this setting to determine how XML documents should
be handled.
▪ Select Automatic to tell Kofax Import Connector to parse the XML documents. If an

XML document is identified as one of the configured XML types, it will be handled
accordingly. If the document structure does not match any of the configured XML
types, it is seen as a binary document.

▪ Select Custom to restrict what type of XML is accepted. E.g., if you select only “Kofax
Capture XML”, all incoming XML are treated as XML Import Connector compatible
files.

15 Click OK to close the connection configuration window. Restart the KC Plug-In service.
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Additional configuration options related to folder import are available in the Message
Connector configuration, in the Security Options tab.
▪ Disable Folder Import - If you need to disable the feature completely.
▪ Folder Input Base Directory - If you want to restrict which folder can be configured as the

watched folder.

Note  Kofax Import Connector cannot import documents if the combined number of
characters in file path and file name exceeds 211.

When you import EML and MSG files via folder import, Kofax Import Connector keeps the
metadata of the email message, not the metadata of the file on disk.

Accessing Fax Servers

Before you connect to the fax servers, make sure that you have the necessary environment
available.
▪ For Kofax Communication Server, refer to Connecting to Kofax Communication Server.
▪ For RightFax server, refer to Connecting to RightFax Fax Server.
▪ For Biscom server, refer to Connecting to Biscom Fax Server

1 Start KC Plug-In configuration. Do one of the following
▪ On a Kofax Capture Network Server remote site, start KC Plug-In from the KIC -

Electronic Documents group in the Windows Start menu.
▪ On other Kofax Capture installations, start Kofax Capture Administration and select

Electronic Documents > Configuration.

2 Connect KC Plug-In to a Message Connector or edit one of the existing connections. Refer
to Connecting KC Plug-In to Message Connector.

3 Click Add and select Fax Server Import.

4 In the Type field, select the fax server you want to connect to.

5 Enter a descriptive Display name.

6 Specify how often should Message Connector poll the fax server for new messages. The
maximum value is 86400 seconds, i.e. 24 hours.

7 Enter the host name of the fax server.

8 Enter the fax server login credentials.

9 For Biscom server, enter also the Windows credentials for accessing the file share.

10 Click Add to specify a user and/or extension. Fax messages to that user/extension will
be imported to Kofax Capture. Alternatively, select a user and click Remove to stop
polling the user/extension.

11 Click Test fax server connection to verify that Kofax Import Connector can connect to the
specified fax server.

12 Click OK to close the fax server import settings window.

13 Click OK to close the connection configuration window. Restart the KC Plug-In service.

14 For connections to Biscom server when the Message Connector is installed on Windows
XP and Windows Server 2003 operating systems, the Message Connector service must be
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running under the Windows account with local administration rights and write access on
the Biscom server’s network share.

a Run services.msc on the Message Connector computer.

b In Log On tab of the properties of the Message Connector service, specify the
Windows account.

c Click OK to confirm the changes.

d Restart the Message Connector service.

15 Make sure that support for RightFax or Biscom servers is not disabled in the Message
Connector configuration. Start the configuration, click Advanced. In the Security Options
tab, verify that the support for your fax server is not disabled.

Note  RightFax does not support access rights to users/extensions based on group
membership via the ComAPI (which is used by Kofax Import Connector). This works only
for the client access. So either RightFax Administrator login credentials have to be specified
(which is not recommended) or enter as login user the owner of the extension.

Rarely, messages from the RightFax cannot be imported to Kofax Capture, with the error
"Compressed data error" or "End of image encountered". As a workaround, enable image
normalization, e.g. "Convert to: TIF" and "Conversion Mode: Convert all content" and "Image
format: 200 x 200 dpi". (SPR00092052)

Configuring Document Conversion

Kofax Import Connector can convert text, HTML, OpenOffice.org and Microsoft Office
documents to a format readable by Kofax Capture. It can also convert images. Supported
formats depend on the available convertor tools. Refer to Kofax Import Connector Installation
Guide for details.

1 Start Message Connector Configuration utility from the Kofax Import Connector group in
the Windows Start menu.

2 Expand the Document Conversion tab.

3 Select Enable Decompression if you want extract documents from compressed files.
The following formats/extensions are supported: zip, rar, 7z, tar, gzip. Extraction
happens before regular document conversion, i.e., a Word document extracted from a
zip file can be further converted into PDF. Extraction is repeated if the extracted file is
another compressed file (e.g., zip within zip), until all compressed files are extracted. The
following restrictions apply:
▪ Password-protected compressed files are not extracted.
▪ Archives split to multiple volumes are not supported.
▪ EML documents from compressed files are not subject to further extraction/document

conversion.
▪ If the extraction ends without error, the compressed file is discarded. When archiving

to folder is enabled, the extracted files are archived, not the compressed ones.

4 Select the tool for converting Microsoft Office documents.

5 Select the tool for converting HTML documents.

6 If you selected OpenOffice.org in step 3, make sure that you have installed the necessary
extension. Refer to the Installation Guide.
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7 If you selected Microsoft Office in either step 3 or step 4, and you are using the operating
system Windows Server 2008, Windows Vista, or later, you need to select the Windows
user account to be used for Microsoft Office DCOM automation. For initial tests and
troubleshooting, you may use the interactive user. For production use, you must specify
an administrator user.

8 Click Advanced. In the Security Options tab, verify that document conversion is not
disabled.

9 Click Save. Click Exit and restart service.

These steps set up the general document conversion capabilities of a Message Connector.
Use destinations and rules to configure what document conversion should be performed
for a particular document. Refer to Configuring Destinations for Imported Documents and
Configuring Rules.

Configuring Processing in Kofax Capture
Use this section if you want to configure how to import messages into Kofax Capture and
which batch classes should be used.

Importing Batch Classes

Two sample batch classes are installed with KC Plug-In. You can use the sample batch classes,
or you can create your own. The benefit of the sample batch classes is that they already have
the message metadata provided by with Kofax Import Connector mapped to Kofax Capture
fields. Either way, a batch class is necessary for successfully running Kofax Import Connector.

Note  If you are using Kofax Capture Network Server, you can only to perform batch class
configuration on the central site.

1 Start Kofax Capture Administration module from the Kofax Capture group in the
Windows Start menu.

2 On the menu, select File > Import.

3 Browse to <programs>\Kofax\KIC-ED\KCPlugIn\BatchClass.

4 Open ElectronicDocumentsBatchClass.cab. Wait until the batch classes are unpacked.
Click OK.

5 Click Add All, then click Import. Wait until importing is completed. Click OK.

6 Publish the new batch classes.

Configuring XML Types

Kofax Import Connector can be configured to identify XML documents with a particular
namespace and root element. The combination of a namespace and root element is referred as
an XML type. Importing of each XML type can be handled differently.

To define an XML type, you need to provide the XML schema definition file and a sample
XML document. XML types can be used in the following situations:
▪ The values of XML elements can be mapped to the batch / folder / document index fields

of your batch class. Refer to Using XSL Transformation to Map Metadata and XML Data.
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▪ The values of XML elements can be rendered as a TIFF or PDF. Refer to Rendering XML
Documents.

▪ Additionally, XML types are used as filters in rules. Refer to Configuring Rules.

Note  There is a built-in XML type called ImportSession. The purpose of this XML type is to
support the standard Kofax Capture XML Import Connector compatible XML format. You do
not need to import this XML type, it is available automatically.

1 Start KC Plug-In configuration. Do one of the following
▪ On a Kofax Capture Network Server remote site, start KC Plug-In from the KIC -

Electronic Documents group in the Windows Start menu.
▪ On other Kofax Capture installations, start Kofax Capture Administration and select

Electronic Documents > Configuration.

2 Go to the XML Types tab.

3 On the XML Type Tasks menu, click Add XML Type.

4 Browse to your XML schema definition file (.xsd).

5 Browse to a sample XML file that uses the specified schema.

Now you can create a destination that uses this XML type. Refer to Configuring Destinations
for Imported Documents.

Additional information about custom XML types can be found in the Kofax Import Connector
Developers Guide.

Kofax Import Connector does not change the logical structure of the XML documents, but the
text presentation is often modified:
▪ The XML code page is changed to UTF-8.
▪ Insignificant whitespace can be removed or changed.
▪ Character quotes or CDATA sections can be removed or changed.

Validating XML Types in Message Connector

Message Connector can be configured to reject received XML documents that cannot be
validated against an XML schema. This feature is primarily useful for web service input,
where the invalid document is immediately rejected and the web service sender is informed
about the reasons (failed validation). However, it applies to documents from all connectors -
non-valid XML will not be imported to Kofax Capture.

1 Copy the folder C:\ProgramData\Kofax\KIC-ED\KCPlugIn\XMLTypes from the KC
Plug-In computer to the Message Connector installation folder (by default <programs>
\Kofax\KIC-ED\MC\). You need to repeat this step whenever you change the
configured XML types in KC Plug-In.

Note  The built-in XML type called ImportSession (standard Kofax Capture XML Import
Connector compatible format) is available on Message Connector automatically, i.e. if
you are not using custom XML types, you can skip this step.

2 Start Message Connector Configuration utility from the Kofax Import Connector group in
the Windows Start menu.

3 Go to the Structured (XML) Input Handling tab.
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4 In the Types field, enter a comma or blank separated list of MIME types or file extensions
that should be treated as XML documents for the purpose of automatic schema
validation. This setting applies to import from email and folder (binary and XML file
import mode only).

5 In the Schema Validation field, select one of the options:
▪ Select Disabled if you don't want Message Connector to validate XML documents. All

incoming XML documents will be handled according to the configuration in KC Plug-
In.

▪ Select Optional if you want validate those XML documents for which an XML type
has been defined. Documents that have a defined XML type but are not valid are
handled according to the setting of the “If Validation Fails” parameter.

▪ Select Required if you want to validate all XML documents (a matching XML type
must exist). Documents that don't have a matching XML type as well as documents
that fail validation are handled according to the setting of the “If Validation Fails”
parameter.

6 In the “If Validation Fails” field, select what to do when an XML document is not valid:
▪ Select Do not apply XML handling to treat the document as a non-XML document. It

is also marked with a document conversion error.
▪ Select Reject the message to mark the document as invalid. Such documents are not

imported to Kofax Capture. In case of web service input, the sender is immediately
informed about the reason of rejection. Even invalid documents are temporarily stored
in Message Connector for troubleshooting.

7 Click Save. Click Exit and restart service.

Configuring Destinations for Imported Documents

Destinations tell Kofax Capture how it should handle documents received by Kofax Import
Connector.

1 Start KC Plug-In configuration. Do one of the following
▪ On a Kofax Capture Network Server remote site, start KC Plug-In from the KIC -

Electronic Documents group in the Windows Start menu.
▪ On other Kofax Capture installations, start Kofax Capture Administration and select

Electronic Documents > Configuration.

2 On the Destination Tasks menu, click Add Destination.

3 On the Import settings tab, enter a Name of this destination. Optionally, add a
description.

4 Optionally, select an XML Type if you want to restrict the destination to that particular
XML type (i.e., only XML documents with matching namespace and root element are
accepted by this destination).

Note  The default destination cannot have an XML type.

5 Select the Import content of this destination, i.e. what parts of a document should be
imported, and their order. Optionally, you can select to import the original content or the
complete message as EML.
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6 Configure the Import Mode.
▪ Select what content do you want to convert (images versus non-image content), into

which format (TIFF, PDF), and select the scaling, resolution, and color of the converted
image.

▪ Select Message Rendering if you want to convert XML documents or metadata as
images. Refer to Rendering XML Documents.

▪ Enable VRS to preprocess incoming documents. This option is recommended for
improving the quality of scanned images. Refer to Configuring VRS. You can also
process PDF documents in VRS.

7 On the Import mappings tab, select the batch class and document class. Optionally, select
a folder class and form type.

Note  The selected batch class can be overwritten if you are importing XML documents
that contain batch class information. If the batch class from the XML document does
not exist in Kofax Capture, the following error message is displayed in the Message
Connector storage: Batch class required for XmlAutoImport or generic Xml
mapping does not exist.

8 Optionally, you can map metadata of the imported document to Kofax Capture batch /
folder / document fields. Do one of the following:
▪ Set XML mapping to None and use the table below to map metadata. For each batch /

folder / document field defined in the batch class, you can select a value. Refer to
Message Fields.

▪ Select XML mapping if you want to map metadata for XML documents using XML
types. Refer to Using XSL Transformation to Map Metadata and XML Data.

9 Optionally, on the Advanced tab you can configure custom scripts, error handling, and
advanced PDF settings.

10 Optionally, on the Email Notification and Archiving tab you can configure sending
notifications to message originators and archiving of documents in a particular folder.

11 Click OK to create the destination. Restart the KC Plug-In service.

Note  If you modify a batch class or form type used in an existing destination, the mappings
might be lost. You have to remap the fields.

Sending Email Notifications

Kofax Import Connector can send notifications about incoming documents to a fixed email
address. These notifications are available for all import connectors.

Additional notifications can be sent to the originator of email messages. This function is only
available for incoming email import (where the email address of the originator is known).

1 Create or edit a destination. Go to the Email Notifications and Archiving tab.

2 Decide what notifications do you need and select the appropriate option:
▪ Click Successfully imported for successfully created batches.
▪ Click Partially imported for batches created with problems (e.g. errors during

document conversion, faxes with reception error, documents failed during XML
schema validation when the option “Do not apply XML handling” is selected).
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▪ Click Not imported when no batch has been created (e.g. invalid batch name, fax
message without image pages, invalid XML documents when “Reject Message” is
selected, etc.).

3 Select Send email to originator if you want to send notifications about emails to the
email sender.

4 Select Send email to and type an email address if you want to send notifications about
documents to a fixed address.

5 Enter the subject (Subject) and the body (Message text) of the notification message. You
can use metadata from the original message when populating these fields. Doubleclick a
line from the Fields table to insert it into message text or subject.

6 Repeat steps 2 to 5 for other types of notification as needed.

7 Click OK.

Kofax Import Connector tries to deliver the notification email messages via SMTP. If all retry
attempts fail, there is no further notification. Active and processed notifications can be viewed
with the Message Connector Monitor (processed notifications are deleted when storage space
is required for new documents).

Note  To send messages, Kofax Import Connector must know your outgoing SMTP server. Go
to the Message Connector configuration,  Email Outbound tab. Work with your email server
administrator to set these options.

Archiving Documents

Kofax Import Connector can save processed documents to a folder for archiving.

1 Create or edit a destination. Go to the Email Notifications and Archiving tab.

2 Decide what documents do you want to archive and select the appropriate option:
▪ Use Successfully imported for successfully created batches.
▪ Use Partially imported for batches created with problems, e.g. during document

conversion.
▪ Use Not imported when no batch has been created (e.g. batch name is invalid).

3 Select Save to folder.

4 In the “Folder location” field, enter the fixed part of the path, e.g. C:\archive\ok\.

5 In the “Subfolder and file prefix” field, enter subfolder(s) and file prefix, e.g. {Import-
Date-Long}\{Batch-Id} _{Batchclass}\prefix_. {Batch-Id} must be always included
in this field.

6 Select one of your configured connections to Message Connector and click Test to verify
that the destination folder is reachable.

7 Select at least one format that should be used for archived documents.
▪ File - archive the message body and all attachments in separate files
▪ EML - archive message body and the attachments as a single EML file
▪ XML - archive the message metadata as a single Kofax-specific XML file (an XML

schema is available on request)

8 Repeat steps 2 to 7 to set up archiving for different set of documents.

9 Click OK.
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10 Additionally, in the Message Connector configuration, Security Options tab, it is possible
to disable archiving completely, restrict archiving to a specific folder, and to configure
Windows user name and password. These credentials are used to access the archiving
folder. If these credentials are not set, the archiving folder must be accessible for the
Network Service user.

Using XSL Transformation to Map Metadata and XML Data

Kofax Import Connector can parse incoming XML documents and/or the metadata of
incoming messages and use the information from them to populate message fields. XML
documents can also include links to other documents to be imported. There are three types of
mapping:
▪ XML Import Connector compatible is a specific variant of the generic mapping. It is

compatible with the Kofax Capture XML Import Connector. It is only available if you select
ImportSession as the XML type for the destination. It maps the input XML data in the same
way as XML Import Connector would do.

▪ Simple mapping maps metadata and/or XML document data to the particular fields of the
batch/folder/document classes that are configured for the destination where the mapping
occurs. It is not possible to control the batch/folder/document class names through the
input XML data.

▪ Generic mapping takes into account that the information on batch/folder/document
classes may come in along within the customer’s XML document (and the class names
configured for the destination are only used as fallback if the particular class name is
missing). The XML format in generic mapping is not restricted and it can be configured for
virtually any customer XML data structures.

The mapping itself (for both simple and generic methods as well) is performed by the means
of an XSL transformation. The transformation file can be written manually by an XSLT
expert or it can be generated by the visual tool called Altova MapForce. This tool offers a
user-friendly GUI, can perform even complex XML mappings and the XSL transformation
is generated automatically. MapForce can be installed on any computer. Kofax Import
Connector does not need it at run time.

1 Before setting up XML mapping, at least one XML type must be defined; unless you
are using the XML Import Connector schema <ImportSession> - that is available
automatically. Refer to Configuring XML Types.

Note  You don't need to specify an XML type if you only want to map document
metadata.

2 Edit a destination. Refer to Configuring Destinations for Imported Documents

3 On the Import settings tab, select an XML Type (not necessary if you only want to map
document metadata).

4 On the Import mappings tab, configure XML mapping:
▪ Select XML Import Connector compatible for XML documents compatible with Kofax

Capture XML Import Connector. Continue with step 12.
▪ Select Simple to map XML data and message metadata to the batch/folder/document

fields assigned to the destination that you are currently editing.
▪ Select Generic if the information about batch/folder/document classes is included in

the XML document. The information from the XML overrides the destination settings.



Configuration

26 Kofax Import Connector  Administrator's Guide

If the class names are not specified in the XML, the settings of the destination are used.
Generic is also necessary in the following use cases:
▪ Kofax Tables should be filled with the content of the input XML
▪ The content of any index field should be evaluated by an expression
▪ Other features possibly supported by the Kofax XML Import Connector format

5 Click Show files for Visual Designer to display the folder where Kofax Import
Connector stores the files required for mapping.

Note  It is the same folder that contains the files for XML rendering.

6 If Altova MapForce is not installed locally, copy the entire folder to the Altova MapForce
computer.

7 Open the .mfd project file in Altova MapForce.

8 Map XML data and metadata to Kofax Capture batch / folder / document fields.
 

 

9 Save the project file. On the File menu, click Save.

10 Save the result to an XSLT file. On the File menu, expand Generate code in and select
XSLT 1.0. You must save the file to the same directory where the .mfd file is located.
Change the file name to XmlMapping.xslt.

11 If Altova MapForce is not installed locally, copy the entire folder back to KC Plug-In
computer (to the original location).

12 Close the destination configuration window and restart KC Plug-In.

You can use other tools to generate the necessary XSL transformation file that governs
metadata mapping. Simple transformations can also be written using a text editor.
Alternatively, you can also contact Kofax to create the mapping for you. For additional
information, refer to Kofax Import Connector Developers Guide.
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Note  When using the XML type "ImportSession", you do not need to create any XSL
transformation. The mapping is available automatically.

There is a significant difference in importing of document's body and attachments (including
XML document itself) between simple and generic mapping:
▪ With simple mapping all parts of a document are automatically handled according to the

destination’s configuration (e.g., converted to TIF, ...) and then imported as pages into the
same folder/document class (or loose pages) of the batch. The XML document itself may
be imported as original XML (if Include Original Content is selected) or rendered as TIF or
PDF (if rendering is configured).

▪ With the XML Import Connector compatible generic mapping, the attachments are only
imported if they are explicitly linked in the XML file. The controlling XML file is never
imported.

▪ When using the generic mapping, attachments (and the XML document itself) are only
imported if explicitly instructed so in the XSL transformation. For additional information,
refer to Kofax Import Connector Developer's Guide.

Altova MapForce is a third-party software that requires a license. This software is not
included with Kofax Import Connector. Also, the licenses for Kofax Import Connector will not
help you operating Altova MapForce.

Rendering XML Documents

Kofax Import Connector can be configured to render structured XML data as PDF and/or
TIFF. Two basic use cases are foreseen:
▪ Render incoming XML documents.
▪ Render only the metadata of any document as some kind of cover sheet.

The rendering itself is performed via an XSL transformation that has to be generated by the
visual tool called Altova StyleVision. This tool can be installed on any computer. It is not
required during run time of Kofax Import Connector.

1 Edit a destination. Refer to Configuring Destinations for Imported Documents.

2 Go to the Import settings tab.

3 If you want to render XML documents, select XML Type. (If you only want to create
cover sheets from document metadata, this is not required.)

4 Select Message rendering.

5 Select the preferred image type (TIFF or PDF), resolution and color.

6 Click Show Files for Visual Designer to display the folder where Kofax Import
Connector stores the files required for XML rendering.

Note  It is the same folder that contains the files for XML mapping.

7 If Altova StyleVision is not installed locally, copy the entire folder to the Altova
StyleVision computer.

8 Open the .sps project file in Altova StyleVision.

9 Use the XML elements from the Schema Tree to create an XSLT style sheet that defines
how information should be organized in PDF/TIFF format.
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Note  If Altova StyleVision is not installed locally and you add graphics (images) to
the style sheet, copy them to the folder where the project file (*.sps) is located. When
importing the graphics, make sure that you are using relative paths (clear the Absolute
Path checkbox).

10 Save the project file. On the File menu, click Save.

11 Save the result to an XSLT file. On the File menu, expand Save Generated Files and select
Save Generated XSLT RTF File. You must save the file to the same directory where
the .sps file is located. Change the file name to Render.xslt.

12 If Altova StyleVision is not installed locally, copy the entire folder back to the KC Plug-In
computer (to the original location).

13 Optionally, click Preview to view how a rendered XML document (or metadata) will look
like.

14 Close the destination configuration window and restart KC Plug-In.

Altova StyleVision is a third-party software that requires a license. This software is not
included with Kofax Import Connector. Also, the licenses for Kofax Import Connector will not
help you operating Altova StyleVision.
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Configuring VRS

VRS is used to improve the quality of incoming images in order to make it easier for Kofax
Capture to understand them. In Kofax Import Connector, each destination can have its own
VRS settings.

However, you can use the image conversion of import connector to modify the resolution/
color of an image and then use VRS for further processing.

1 Edit a destination. Refer to Configuring Destinations for Imported Documents.

2 Go to the Import settings tab.

3 Optionally, configure color conversion or image scaling that should occur before VRS.

4 Select one of the VRS options:
▪ Select VRS only original images content if want to apply VRS processing to

documents that reached the import connector in image format (but not to documents
that were converted to image format by import connector).

▪ Select VRS all images if you want to apply VRS settings to all images. This means that
also those documents that were converted to image format by import connector are
processed by VRS. Usually, this is not recommended for Word or Excel documents.
Also, use this option if you want to apply VRS to PDF documents.

▪ Select None to disable VRS for all content.

5 Select Apply VRS to PDF files if you want to convert PDF documents to TIFF format
using VRS.

Note  You must select PDF as your Convert to format to use this feature. Otherwise the
PDF is converted to TIFF before reaching VRS.

This option allows you to process larger PDF documents.

6 Click VRS Settings. The VRS Settings window is displayed.
The window is divided into 4 main parts:
▪ The top left part shows a sample image.
▪ The top right part shows the sample image after VRS processing.
▪ The bottom left part shows the menu.
▪ The bottom right part lists the various VRS parameters.

7 Configure the VRS parameters and test them:

a Click Open File for Testing and select an image.

b Modify the VRS parameters.

c Click Test Current Settings to see the results of VRS processing.

d Use the commands from the View menu to modify the zoom and switch pages (for
multipage TIF documents).

e Repeat steps b to d until you are satisfied with the results.

8 Click Save VRS Parameters to apply the changes for this destination.

9 Optionally, click Save VRS Parameters to Profile if you want to reuse the same settings
in other destinations; or for backup.
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Note  All VRS profiles are stored in the file KCIC ElectronicDocuments KC Plug-
In VRSProfiles.xml in the folder %ALLUSERSPROFILE%\Kofax\KCIC - Electronic
Documents\KC Plug-In\Config\. Take this file if you need to transfer your profiles to
another computer.

10 Click Exit to conclude VRS configuration.

Configuring Rules

Each configured Message Connector has a default destination. Rules are used to filter
documents and assign them to different destinations. For example, email messages from a
particular recipient can be handled differently than documents imported from a folder.

1 Start KC Plug-In configuration. Do one of the following
▪ On a Kofax Capture Network Server remote site, start KC Plug-In from the KIC -

Electronic Documents group in the Windows Start menu.
▪ On other Kofax Capture installations, start Kofax Capture Administration and select

Electronic Documents > Configuration.

2 On the Connection Tasks menu, click Add Rule. Alternatively, select one of the existing
rules and click Edit Rule.

3 In the Service filter field, select one of the services if you want to filter documents
depending on how they reach Message Connector; e.g., via email or fax.

4 In the Recipient list field, enter the original recipient (as specified by the message sender).
You can use the asterisk wildcard * to specify all addresses. You can add multiple
recipients, separated by comma.
▪ For emails, specify an email address from the To or Cc list, such as john@kofax.com.

This also applies to MSG and EML files imported via folder import.
▪ For faxes, specify the extension number on the fax server, such as 555*, 444*, 3333.
▪ For other import connectors, this filter is not available.

5 In the Address field, type the address from which Message Connector received the
document. You can use the asterisk wildcard * to specify all addresses.
▪ For POP3/IMAP mail, specify a mail box name, such as john@kofax.com.
▪ For EWS email, specify a mail box name, such as lena@kofax.com or asia\rajesh.
▪ For SMTP email, specify the final routed email address, such as *@kofax.com.
▪ For faxes, specify the user name on the fax server, such as biscom_user1.
▪ For FoIP, specify the extension number, such as *555.
▪ For folders, specify the path including the file name, such as C:\myFolder\*.xml. Note

that using C:\myFolder will not match files in the myFolder directory, you have to
specify an asterisk at the end: C:\myFolder\*.

▪ For web service input, specify any string. This string must match the optional Address
parameter of the Import web service call. Refer to Kofax Import Connector Developer's
Guide.
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Tip  The difference between the filter options Recipient list and Address is
subtle but potentially important. For example, Adam sends an email to Bob,
CC Cindy. Cindy has email forwarding enabled, sending all mail to the SMTP
server of Kofax Import Connector (for example, invoice@KIC.com). In this case,
you can use Bob's (or Cindy's) address as Recipient list filter. However, only the
address invoice@KIC.com can be used for the Address filter. Or another example:
Deborah’s POP3 mailbox (Deborah@example.com) has an additional address alias
(DeborahBusiness@example.com). Deborah can use the Recipient list field to filter her
private and business mail.

6 In the Destination field, select the destination that should be used for the documents
matching the specified criteria.

Note  If you select a destination with an XML type, the XML type becomes an additional
filter criterion. I.e., if the document is not an XML file or the namespace/root element
don't match, the rule does not apply.

7 Click OK to save changes.

8 Optionally, select a rule and click Move Rule Up or Move Rule Down on the Connection
Tasks menu to establish rules priority. The following applies to rules priority:
▪ Rules higher on the list take precedence over lower rules; first matching rule wins.
▪ If none of the filter criteria match, the default destination is used.

9 Optionally, select a rule and click Remove Rule on the Connection Tasks menu to delete
it.

10 Restart the KC Plug-In service to apply the configuration changes.

Configuring Behavior When Message Import to Kofax Capture Fails
1 Start Message Connector Configuration utility from the Kofax Import Connector group in

the Windows Start menu.

2 Go to the General tab.

3 If you want to forward messages that could not be imported to Kofax Capture to an
operator, enter the email address in the field Operator Email. In the Email From field,
enter the email address that should be used as the originator of the forwarded messages.

4 Select Keep Failed if you want to prevent deletion of messages that neither have been
imported into Kofax Capture nor forwarded to an operator. These messages will remain
in Message Connector storage until you manage them manually. This setting can cause
the storage to run out of disk space—at that point, all importing into Kofax Capture
stops! Refer to Managing Failed Messages Manually for recommended handling.

5 In the Storage Size field, enter the size of the Message Connector storage database.
Decreasing the value below the default 100 MB is not recommended. Consider increasing
the value, especially if you have not configured the Operator Email and you selected to
Keep Failed messages. Maximum storage size is 64000 MB. Excessively large and full
storage might require several minutes to initialize. The minimum recommended value
is the total size of documents received within 30 minutes during peak hours; preferably
more.
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6 If you configured an Operator Email, you need to update the values in the Email
Outbound tab. Your email server administrator should be able to provide the necessary
information.

7 Click Save. Click Exit and restart service.

Configuring KC Plug-In Web Service Interface
Use this window to specify details about KC Plug-In web services connection. This web
services connection is used in two applications:
▪ Kofax Monitor uses it to monitor KC Plug-In. Refer to Using Kofax Monitor.
▪ Message Connector may use it internally to retrieve information from Kofax Capture.

For details about the web service functions, refer to Kofax Import Connector Developers Guide.

1 Start KC Plug-In configuration. Do one of the following
▪ On a Kofax Capture Network Server remote site, start KC Plug-In from the KIC -

Electronic Documents group in the Windows Start menu.
▪ On other Kofax Capture installations, start Kofax Capture Administration and select

Electronic Documents > Configuration.

2 On the Assistance Tasks menu, click Web Services Configuration.

3 In the Port Number field, type the port number of the web services interface of KC Plug-
In.

4 Select Use SSL if you want to use SSL for connecting to the web services interface of KC
Plug-In.

5 In the Thumbprint field, copy the thumbprint of your SSL certificate. Refer to Installing
Certificate.

6 Click OK to save changes.

7 Restart the KC Plug-In service to apply the configuration changes.

8 Optionally, if you want to use the web service functions GetContentTypeList and
GetContentTypeDescription from external applications to retrieve batch class
information from Kofax Capture, Message Connector must be properly configured. Refer
to Configuring Message Connector for Web Service Input.

Installing Certificate
1 Obtain a server certificate from a certification authority. The subject of this certificate

must be the name of the computer hosting KC Plug-In. Use the real name of the server,
do not use localhost.

2 You also need certificate issuer's root certificate.

3 Start Certificates MMC Snap-In for computer account:

a Start MMC, e.g. by running mmc.exe from the Start menu.

b On the File menu, select Add/Remove Snap-In.

c Click Add and select Certificates. Click Add again.

d Select "Computer account". Click Next.
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e Select "Local computer". Click Finish.

f Click Close, then click OK.

4 Use the snap-in to install the root certificate of the certification authority as a trusted root
certification authority:

a Expand Console Root > Certificates (Local Computer) > Trusted Root Certification
Authorities > Certificates.

b Right-click Certificates and select All Tasks > Import  from the context menu. The
Certificate Import Wizard starts.

c Import issuer's root certificate (only if it is not yet part of the list).

5 Use the snap-in to install the server certificate:

a Expand Console Root > Certificates (Local Computer) > Personal > Certificates.

b Right-click Certificates and select All Tasks > Import  from the context menu. The
Certificate Import Wizard starts.

c Import the server certificate.

6 Double-click the server certificate.

7 Go to the Details tab.

8 Scroll down and select the Thumbprint field. You can now copy the thumbprint to the
KC Plug-In web services configuration.

Configuring SSL Connection
Kofax Import Connector can be configured to operate in a secure environment, using SSL
connections.

1 Create a SSL certificate for each Kofax Import Connector component that you want to
connect securely. You can use e.g. the following tools:
▪ Microsoft Active Directory Certificate Services
▪ OpenSSL

2 Configure each Kofax Import Connector component that you want to connect securely.
▪ For Message Connector, you need to convert the certificate to .pem format so that you

can copy the private key and the certificate to the configuration utility.
▪ For KC Plug-In, you must install the certificate via MMC (local account) and copy the

thumbprint to the configuration utility.

3 Install the certificates on all computers that connect to a secure server.

See also two example procedures in section Certificates.

Securing Connection Between Message Connector and KC Plug-In
1 In Message Connector configuration, HTTP tab, select SslActive to enable SSL, or clear

the check box to disable SSL.

2 If SSL is enabled: In Message Connector configuration, SSL Certificate tab, edit the fields
as necessary. Message Connector comes with a test certificate; you might wish to update
it for production use.
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3 In KC Plug-In configuration, edit the connection to a Message Connector. In the Server
URL field, use the prefix “http” for a non-secure connection or “https” for a secure
connection.

4 Click Test connection to verify the connection.

Securing Connection for Incoming SMTP Mail
1 In Message Connector configuration, Email Inbound via SMTP tab, SSL Active field,

select ONREQUEST or ALWAYS.

2 In Message Connector configuration, SSL Certificate tab, edit the fields as necessary.

Securing Connection for Outgoing SMTP Mail
In Message Connector configuration, Outbound Email tab, SSL Active field, select
ONDEMAND or ALWAYS.

Securing Connection for POP3/IMAP Mail
1 In KC Plug-In configuration, edit the connection to a Message Connector.

2 Select the POP3/IMAP mail box and then click Edit.

3 In the SSL field, select Always or Negotiate.

Securing Connection for Exchange Web Services
1 In KC Plug-In configuration, edit the connection to a Message Connector.

2 Select the POP3/IMAP mail box and then click Edit.

3 The prefix of the EWS URL in the Host field determines whether the connection is secure.
Use https for secure connections.

Configuring Kofax Capture Integration
Use this window to specify details about how Kofax Capture and Kofax Import Connector
interact.

1 Start KC Plug-In configuration. Do one of the following
▪ On a Kofax Capture Network Server remote site, start KC Plug-In from the KIC -

Electronic Documents group in the Windows Start menu.
▪ On other Kofax Capture installations, start Kofax Capture Administration and select

Electronic Documents > Configuration.

2 On the Assistance Tasks menu, click Kofax Capture Settings.

3 If you are using the User Profiles feature of Kofax Capture, specify the parameters User
ID and Password. Click Test credentials to verify that you can correctly connect.

4 If you want to keep Kofax Import Connector connected to Kofax Capture and log off
only on service shutdown, select Cache import process instance. Selecting this option
improves performance. If not selected, Kofax Import Connector will log on to Kofax
Capture each time a batch is imported, and it will log off afterwards.
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5 The parameter “Import pool size” is deprecated. Use the default value (1). To improve
performance, use the parameter “Number of KIC process instances” instead.

6 If you want to improve performance of KC Plug-In by running multiple instances of the
process (vertical scaling), you can increase the value of the parameter “Number of KIC
process instances”. The extra instances may fail to start if not enough hardware resources
are available.

Note  With multiple processes running in parallel, your batch structure might change.
E.g., if a customer always copies a group of 5 documents to the import folder, has a batch
size of 5 configured, and expects to see the group in one batch, this will not work. The
documents will be split among processes and each creates its own batch. In such cases
where batch structure should be constant, trigger files should be used in conjunction
with vertical scaling. This will ensure that only one KC Plug-In process can access the
imported content at any given time.

7 If you want to use UTC time for all imported documents, select Use UTC time. When not
selected, the local time of Kofax Capture is used.

8 Click OK to save changes.

9 Restart the KC Plug-In service to apply the configuration changes.

Enabling SecurityBoost
SecurityBoost is a feature that improves the safety of the connection between the Kofax
Capture server and workstation.

1 Enable SecurityBoost in Kofax Capture. Refer to Kofax Capture documentation for
details.

2 Set a log on user account for the KC Plug-In service. This user must have read access to
the following folders:
▪ \\%SERVER%\capturesv\config

▪ \\%SERVER%\capturesv\BatchDb (and subfolders)
▪ \\%SERVER%\capturesv\PubTypes (and subfolders)

3 If the Save to Disk option in KC Plug-In configuration is selected, write access is also
necessary to the following folder: \\%SERVER%\capturesv\images.

4 The user to be used with the SecurityBoost option requires the "Local Launch" and "Local
Activation" COM permission. COM permissions can be modified with Control Panel >
Administrative Tools > Component Services. Select COM Security tab in properties of
Console Root\Component Services\Computers\My Computer. Click Edit Default under
Launch and Activation Permissions. Select the user and modify the permissions.

5 The user requires Full Control access to the following registry key:
HKEY_LOCAL_MACHINE\SOFTWARE\Kofax\KIC-ED\KCPlugIn

6 If you want to use KC Plug-In web service interface (Configuring KC Plug-In Web
Service Interface), additional steps are necessary:
▪ Reserve the namespace http://+:<port>/KIC-Electronic-Documents
▪ Reserve the namespace https://+:<port>/KIC-Electronic-Documents and register the

thumbprint of the certificate for the IP address:port (if you want to use SSL)
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For example, on Windows Server 2003, use the command httpcfg:
▪ Namespace reservation syntax:

httpcfg set urlacl u/ URL /a ACL

The /u parameter takes a string containing a fully qualified URL that identifies the
reservation. The /a parameter takes a string containing an Access Control List in the
form of a Security Descriptor Definition Language (SDDL) string.
▪ Namespace reservation for port 8001

httpcfg set urlacl /u http://+:8001/KIC-Electronic-Documents /a D:
(A;;GX;;;WD)

▪ Namespace reservation for port 8002 (SSL):
httpcfg set urlacl /u https://+:8002/KIC-Electronic-Documents /a D:
(A;;GX;;;WD)

▪ SSL thumbprint registration syntax:
httpcfg set ssl /i Ip:Port /h SSL_Hash /g "{GUID}"

The /i parameter takes a string that specifies the IP Address:port combination. The /
h parameter takes a string of hexadecimal digits specifying the thumbprint hash of
the certificate being added. The /g parameter takes a string representing a Globally
Unique Identifier (GUID) that identifies the application that added the certificate.
▪ SSL thumbprint registration:

httpcfg set ssl /i 0.0.0.0:8002 /h
 a9f05807bb757c41ba2e1c457ac2a78f00395a69 /g"{4f38c942-c7e7-421b-
bcec-bd3290c3b921}"

The IP address 0.0.0.0 matches every IP address on the local computer.

On Windows Server 2008 or Windows 7, use the command netsh:
▪ Namespace reservation syntax:

Netsh http add urlacl  url=URL user= User

The url parameter specifies the fully qualified Uniform Resource Locator (URL). The
user parameter specifies the user or user-group name.
▪ For port 8001:

netsh http add urlacl url=http://+:8001/KIC-Electronic-Documents/
 user=\EVERYONE

▪ For port 8002 if SSL is enabled:
netsh http add urlacl url=https://+:8002/KIC-Electronic-Documents/
 user=\EVERYONE

▪ SSL thumbprint registration syntax:
netsh http add sslcert ipport= IPAddress:port certhash=CertHash
 appid=GUID

The ipport parameter specifies the IP address and port for the binding. A colon
character (:) is used as a delimiter between the IP address and the port number. The
certhash parameter specifies the SHA hash of the certificate. This hash is 20 bytes long
and is specified as a hexadecimal string. The appid parameter specifies the GUID to
identify the owning application.
▪ For port 8002:

netsh http add sslcert ipport=0.0.0.0:8002
 certhash=a9f05807bb757c41ba2e1c457ac2a78f00395a69 appid={4f38c942-
c7e7-421b-bcec-bd3290c3b921}
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If SecurityBoost is not enabled, the folder access permissions should be set according to the
Kofax Capture documentation.

Message Fields
Message fields are metadata related to a document, e.g. message subject. These values can be
mapped to Kofax Capture batch/folder/document fields.

If a field is mapped to a Kofax Capture field, it will be automatically populated with the
proper value during importing to Kofax Capture.

The message fields mapping can be configured in KC Plug-In, for each destination. Refer to
Configuring Destinations for Imported Documents.

Message field Description

KfxMessageCorrelation The correlation information of the message (for internal
use).

KfxMessageDeliveryPriority The priority of the message. Reserved for future use.
Currently static value 1.

KfxMessageDeliverySuspectedDupli Reserved for future use. Currently static value 0.
KfxMessageDeliveryType The type of delivery of the message. Reserved for

future use. Currently static string TO.
KfxMessageFileName The file name of the document. For fax servers, this

returns server-specific file names.
KfxMessageID The unique ID of the message given by the Message

Connector on message arrival.
KfxMessageOwnerReference For email documents: mime-header/message-id

For faxes: server-specific message ID
KfxMessagePages The number of fax pages in the message.
KfxMessageReceptionCallerId The number of the sending fax machine. (Optionally

available for FoIP, Biscom, KCS)
KfxMessageReceptionErrorInfo Provides an additional description if

KfxMessageReceptionErrorLevel is non-zero.
KfxMessageReceptionErrorLevel Describes the error level of the received document

using the following values: 0 = OK, 1 = partially OK or
incomplete, 2 = failed

KfxMessageReceptionTimeCreated For emails, this is the time when the Message
Connector retrieved the message.
For faxes, this is the time when the message was
received by the fax server.

KfxMessageSubject The subject of the message. For faxes, this is “Fax
from” + TSI.

KfxMessageTimePosted Only available for email messages, this field contains
the date and time when the message was sent.

KfxOriginalRecipients Contains a list of the original recipients as specified by
the message originator. For KCS, it contains the original
number before forwarding by event. For mailbox emails,
it contains the To/Cc recipients.
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Message field Description

KfxOriginatorName The full name of the message originator. For faxes,
this is the TSI. For SMTP/POP3/EWS, it’s the
originator display name (mime-header/from/mailbox/
displayname).

KfxOriginatorNumber The fax number of the originator (caller ID) or originator
email (mime-header/from/mailbox/address) for POP3/
SMTP/EWS mail.

KfxOriginatorService The service name of the originator. In case of fax FAX
and in case of email EMAIL.

KfxRecipientName The full name of the message recipient. For POP3, this
is the mailbox display name.

KfxRecipientNumber The recipient fax number (called party number) or email
address (for SMTP it’s the first active email recipient, for
POP3 the mailbox user name).

KfxRecipientsTo Comma separated list of To recipients.
KfxRecipientsCc Comma separated list of Cc recipients.
KfxRecipientService The service name of the recipient. In case of fax FAX

and in case of email EMAIL.
KfxRoutingNumber The meaning of this message field is different for

various inputs
▪ FAX: Extension (called-party-number)
▪ SMTP: active email recipient
▪ POP3/IMAP/EWS: mailbox user name
▪ FOLDER: full path of the imported file
▪ WEBSERVICE: empty string

The message extension fields are reserved for future versions.

Document metadata are also available in Kofax Capture as custom storage strings (for
documents and folders) with the prefix ED_CSS_. Custom storage strings can be read via
the Kofax Capture API and could be used for example in an export connector or in custom
scripts. Please refer to Kofax Import Connector Developers Guide for more information about
custom storage strings.
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Chapter 3

Features and Integration Examples

This section provides examples on how to integrate Kofax Import Connector with third party
software and hardware and describes some advanced features of the product.

Connecting to Biscom Fax Server
In addition to configuring the connection to the Biscom fax server in KC Plug-In, Biscom
client software must be installed and a user/extension should be identified on the fax server
for use with Kofax Import Connector. Work with your fax server administrator to complete
the following steps.

Configuring Biscom Server
1 On the Biscom fax server, start the FAXCOM Administrator tool.

2 Create (or reserve) a user/extension for use with Kofax Import Connector.

3 Enable the network share connection to the Biscom server and note the service path.

4 Close the tool.

Installing FAXCOM Client
1 On the Message Connector computer(s), install the Biscom client software, the FAXCOM

Client.

2 If the computer where the FAXCOM Client is installed belongs to a Windows domain,
run this command (only necessary when the domain user lacks access rights to the
Biscom share):
Net Use <Biscom_service_path> /USER:<Biscom_user> <password>

3 Start the FAXCOM Client from the FAXCOM group of the Windows Start menu.

4 Type the login information and click OK. You must be able to connect.
On successful login, the FAXCOM Client window is displayed.
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5 Close the client.

Connecting to RightFax Fax Server
In addition to configuring the connection to the RightFax fax server in KC Plug-In, RightFax
client software must be installed and a user/extension should be identified on the fax server
for use with Kofax Import Connector. Work with your fax server administrator to complete
the following steps.

Configuring RightFax Server
1 On the RightFax fax server, start the Enterprise Fax Manager tool.

2 Create (or reserve) a user/extension for use with Kofax Import Connector.

3 Close the tool.

Installing RightFax Client
1 On the Message Connector computer(s), start the RightFax Product Suite setup.

2 When prompted for setup type, select Typical Client.

3 In the RightFax Server Name field, type IP address or name of the fax server.

4 Click Install and finish the installation.

5 Start RightFax FaxUtil from the Windows Start menu.

6 Type the login information. Do not select to Remember password! Click OK. You must be
able to connect.
On successful login, the RightFax FaxUtil window is displayed.
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7 Close the client.

Forwarding Faxes from Multiple Mailboxes to a Single Queue User

In KC Plug-In, you can only configure a single user for accessing RightFax. If you need to
access multiple mailboxes, this would have to be the administrator user. As a workaround,
if you don't want to use administrator user for security reasons, consider setting up fax
forwarding to a dedicated user, and use the credentials of this dedicated user in KC Plug-In.
Each fax user must configure fax forwarding using RightFax FaxUtil.

1 Start RightFax FaxUtil from the Windows Start menu and log in.

2 On the Tools menu, click Options.

3 On the Receiving tab, select Forward Received Faxes to User.

4 Select the dedicated user as the recipient of the forwarded faxes.

5 Confirm the changes and close FaxUtil.

Connecting to Kofax Communication Server
In addition to configuring the connection to the Kofax Communication Server in KC Plug-In,
a user/extension should be identified on the fax server for use with Kofax Import Connector.
Work with your fax server administrator to complete the following steps.

1 On the Kofax Communication Server, start the TCfW Communication Server Client.

2 Create (or reserve) a user/extension for use with Kofax Import Connector.

3 Optionally, if you want to import faxes received by multiple KCS users, set up fax
forwarding for each of the user; and forward the faxes to the user created in step 2.

4 Close the client.
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Handling of Multipage TIF Files
Kofax Capture Import Connector - Folder has the function to split incoming multipage TIF
files into pages before importing them to Kofax Capture. Kofax Import Connector uses a
different approach and leverages existing Kofax Capture batch class options to achieve
similar results.

Note  If you are using Kofax Capture Network Server, you can only to perform batch class
configuration on the central site.

1 Start Kofax Capture Administration from the Kofax Capture group in the Windows Start
menu.

2 Select your batch class and edit its properties:

a In the Separation and Form Identification tab, select Kofax fixed pages.

b In the Advanced tab, edit the parameter Process documents as independent batches.
▪ Clear it if you want to treat each page of a multipage TIF as a separate document.
▪ Select it if you want to treat each page of a multipage TIF as a separate batch.

3 Select your form type and edit its properties:

a Select Fixed number of pages.

b Enter “1” in the field below.

4 Publish the batch class to make the changes effective.

5 In Kofax Capture Administration, on the menu, select Electronic Documents >
Configuration.

6 Select your destination and click Edit Destination.

a Go to the Import Mappings tab.

b In the Batch class field, select the batch class configured in step 2.

c In the Document class field, select Loose Pages.

7 Restart the KC Plug-In service to make the changes effective.

The behavior in Kofax Capture is almost identical to KCIC Folder behavior, only the batch
names in Kofax Capture Batch Manager are can be different.
 

 

As Kofax Import Connector combines multiple previous import connectors, TIF splitting
in now available to any input document. If you want to restrict this feature to documents
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imported from folder, create an exclusive destination and set up an appropriate rule. Refer to
Configuring Rules.

Split TIF files behave differently when archived. It is not possible to save each page to a
separate folder. The original, unsplit TIF file is archived instead.
 

 

Image Normalization
The following rules are used for handling the resolution and dimension. The first matching
rule governs the conversion:

1 If the resolution of an incoming image matches the requested resolution, the image is not
changed.

2 If the x and y resolutions differ, the image is resampled to the requested resolution (non-
quadratic pixel case).

3 If the resolution value is most likely wrong, it is set to the requested value without
resampling the image. This will change the printing size of the image. Such images are
not resampled in order to avoid quality loss. A wrong resolution is expected if one of the
following conditions are true:
▪ The resolution is below 96 dpi. (ImageMagick returns 72 dpi if the resolution is not

set.)
▪ The resolution exceeds 200 dpi and the width is less than 1500 pixel (19.5cm@200dpi).
▪ The resolution exceeds 200 dpi and the height is less than 2000 pixel (25.4cm@200dpi).

4 If the resolution is higher than requested, the image is down-sampled to the requested
resolution.

5 If none of the listed rules applies, the image conversion depends on the configuration
in the script file image2tif.bat in the folder C:\Program Files (x86)\Kofax\KIC-
ED\MC\Scripts. Open the file with a text editor and change the value in the line Set
ResetResolution=0. The following values are supported:
▪ 0: Resample image and change resolution. This is the default option, same behavior

as in 1.0.0 and 2.0.0 or Kofax Capture Import Connector - Folder. Image file size is
increased without improving image quality. Resampling can be a time-consuming
operation that often results in lower performance.

▪ 1: Change the resolution without resampling. This reduces the print size of the image.
This is the same behavior as in 2.1.0.

▪ 2: Image is not changed. Best performance.

PDF Normalization
Kofax Import Connector can convert documents to an ISO-standardized version of PDF
documents, PDF/A.
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Enabling Conversion to PDF/A
1 Configure a destination. See Configuring Destinations for Imported Documents for the

general procedure.

2 On the Advanced tab, select Normalize PDF documents to PDFA.

3 Click OK to save changes.

4 Click Restart Service.

Configuring PDF/A Variant
1 Open the folder C:\Program Files (x86)\Kofax\KIC-ED\MC\Scripts (assuming

default installation path on a 64-bit operating system).

2 Edit the file KFXConverter.bat in a text editor.

3 Edit the line set ConvertToType="PDFA1B". The following values are supported:
▪ PDFA1A

▪ PDFA1B (default)
▪ PDFA2B

4 Save the file and close it.

Certificates
This section lists two sample procedures for generating certificates for use with Message
Connector and KC Plug-In.

Requesting a Certificate for Message Connector Using Microsoft Active
Directory Certificate Services

In this example, we are using Microsoft Active Directory Certificate Services to generate a
certificate for Message Connector and OpenSSL to extract the private key and certificate.
Review the following requirements and tips.
▪ Microsoft Certification Services

▪ Server must be configured for https binding (https://[CAName]/certsrv/)
▪ Server must be configured to archive the key
▪ Create a template which allows to export the private key

▪ OpenSSL is used for
▪ Exporting a decrypted private key
▪ Creating a PKCS#12 file

1 Use Microsoft Certification Services to request a certificate:

a Use a web browser to connect to the CA Server (https://CAName/certsrv).

b Click “Request a certificate”.

c Click “advanced certificate request”.

d Click “Create and submit a request to this CA”.
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e Fill out the form, select the correct Certificate Template and select “Mark keys as
exportable”. Enter the correct Message Connector server name in the Name field (for
Windows Failover Cluster configuration, use the name of the clustered MC service).

f Click Submit. Wait until the certificate is issued.

g Click “Install this certificate”. Wait until the certificate is installed.

2 Use Internet Explorer to export the certificate:

a Go to Tools > Internet Options > Content > Certificates > Personal tab.

b Select your certificate and click Export.

c Select to export the private key. Select PKCS #12 as the format.

d Type a password to protect the key.

e Specify the location and file name. Click Finish.

3 Use OpenSSL to extract the private key and the certificate to .pem format, e.g.:
openssl.exe pkcs12 -in "c:\certif.pfx" -out 
    "c:\certif.pem" -nodes

You will need to provide the password you used in step 2d.

4 Open the pem file in a text editor. In the file you will find the certificate and private key
needed for configuring Message Connector. Refer to Configuring SSL Connection.

Requesting a Certificate for KC Plug-In Using OpenSSL

In this example, we are using OpenSSL to generate a certificate for KC Plug-In.

1 Use OpenSSL to request a certificate (assuming Windows binary distribution of
OpenSSL):

a Generate an RSA private key.
C:\Openssl\bin\openssl.exe genrsa -out my_key.key 2048

This command generates a private key file with the file name my_key.key and the key
length of 2048 bits.

b Generate a Certificate Signing Request (CSR).
C:\Openssl\bin\openssl.exe req -new -key my_key.key -out
 my_request.csr -config C:\Openssl\bin\openssl.cnf

This command uses the my_key.key to create the CSR my_request.csr.

c Generate a self-signed public certificate based on the request.
C:\Openssl\bin\openssl.exe x509 -req -days 3650 -in my_request.csr -
signkey my_key.key -out my_cert.crt

This command uses the private key and certificate signing request to create a self-
signed public certificate (my_cert.crt).

d Generate a PKCS#12 file.
C:\Openssl\bin\openssl.exe pkcs12 -keypbe PBE-SHA1-3DES -certpbe PBE-
SHA1-3DES -export -in my_cert.crt -inkey my_key.key -out my_pkcs12.pfx
 -name "my-name"

2 Start Certificates MMC Snap-In for computer account:

a Start MMC, e.g. by running mmc.exe from the Start menu.
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b On the File menu, select Add/Remove Snap-In.

c Click Add and select Certificates. Click Add again.

d Select “Computer account”. Click Next.

e Select “Local computer”. Click Finish.

f Click Close, and click OK.

3 Install the certificate to the Personal\Certificates folder for computer account.

4 Display the details of the certificate and copy the value of its thumbprint into KC Plug-In
configuration. Refer to Configuring KC Plug-In Web Service Interface.

5 Restart KC Plug-In.
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Chapter 4

Operation and Maintenance

This chapter contains information about operating and maintaining of Kofax Import
Connector.

Starting and Stopping the KC Plug-In Service
The KC Plug-In service must be restarted after each configuration change to make the changes
effective.

1 Start Kofax Capture Administration module from the Kofax Capture group in the
Windows Start menu.

2 On the menu, select Electronic Documents > Configuration.

3 On the Assistance Tasks menu, click one of the commands:
▪ Restart Service
▪ Start Service
▪ Stop Service

Note  If no connection is marked active, the KC Plug-In service does not start.

Converting PST Files
Personal storage table (PST) files are used by Microsoft Outlook and other Microsoft products
to store messages and other items. Use this procedure to extract all messages from a PST file
to a folder. Kofax Import Connector can then import the extracted messages to Kofax Capture.

1 Start Windows Command Prompt in the Message Connector installation folder (by
default C:\Program Files (x86)\Kofax\KIC-ED\MC\bin\KFXConverter\, assuming
64-bit operating system).

2 Run the command
KFXConverter.exe –s <sourcepath>\<filename> –f <destinationpath>\ –type
 msg

As <sourcepath>, enter the folder where your PST file is located.
As <filename>, enter the name of the PST file to be converted.
As <destinationpath>, enter the folder where the MSG files should be extracted.

3 Wait until the extraction is complete.

You can now move the extracted files to a watched folder to import them to Kofax Capture.
See Accessing Folders.

Note  MSG files where attachments have been removed by any Microsoft Outlook archive
tool cannot be imported.
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Tip  You can convert multiple PST files simultaneously. However, when running multiple
KFXConverter instances in parallel, some information about the second and later instances
might be missing from the log file. To ensure that your logs are complete, you can specify
different log files for each instance using the command line switch -logfile <logfilename>.

Message Connector Status Monitor
Message Connector provides a monitoring interface with the following main functions:
▪ Sending test messages
▪ Viewing documents in storage
▪ Managing failed documents
▪ Monitoring Message Connector status

Sending Test Messages

Use this section if you want to verify the functionality of the Message Connector by sending
a test fax or email. Both tests work by sending a message in a loop (Message Connector ->
Message Connector). KC Plug-In will then import the message to Kofax Capture.

Sending a Test Fax
1 Start Message Connector Monitor utility from the Kofax Import Connector group in the

Windows Start menu.

2 On the menu, click Test Fax.

3 In the Number to Dial, enter a number. For a test message this can be any number.

4 Click Send Fax.

5 Wait until the text “Server returned ok” is displayed.

6 On the menu, click Outbound > Processed. After some time you will find the sent
fax. Optionally, you can click Inbound > Pending and view the message there, if the
KC Plug-In service is not running. Otherwise, you will find the test fax in Inbound >
Processed.

Sending a Test Email
1 Start Message Connector Monitor utility from the Kofax Import Connector group in the

Windows Start menu.

2 On the menu, click Test Email.

3 In the To, enter an email address. For a test message this can be any address.

4 Click Send Email.

5 Wait until the text “Server returned ok” is displayed.

Message Connector Storage

Message Connector stores all messages and files received from various sources to its internal
storage before they are imported to Kofax Capture.
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The storage is managed automatically. Files and messages that are correctly imported to
Kofax Capture are marked for deletion and they are removed when the storage fills.

Files and messages that could not be correctly imported to Kofax Capture may fill the storage.
Refer to Managing Failed Messages Manually.

The storage is divided into multiple folders:
▪ Click Inbound Status > Active to list active documents, i.e. documents that have been

received by Message Connector but not yet delivered to Kofax Capture. When the archive
to folder function is activated, documents remain in this folder until the archiving has been
concluded.

▪ Click Inbound Status > Active > Failures to list documents that have been received by
Message Connector but could not be delivered to Kofax Capture. Documents appear
this folder only if the configuration setting Keep Failed is selected. When the archive to
folder function is activated, documents remain in this folder until the archiving has been
concluded.

Note  Documents remain in this folder until they are handled manually by an operator
(reactivated or deleted). If not monitored, this can cause full storage and stop processing of
documents.

▪ Click Inbound Status > Processed to list documents delivered to Kofax Capture. If Keep
Failed is cleared, this folder also contains documents that permanently failed to import
to Kofax Capture. Processed documents are deleted automatically from the storage when
space for active messages is needed.

▪ Click Inbound Status > Processed > Failed to list documents that permanently failed to
import to Kofax Capture (Keep Failed must be cleared). As all processed documents, they
are deleted automatically from the storage when space for active documents is needed.

▪ Click Outbound Status > Active to list test fax messages which are queued for sending or
are currently being sent.

▪ Click Outbound Status > Processed to list test fax messages sent out by Message
Connector, as well as messages that could not be sent.

▪ Click Outbound Status > Processed > Failed to list test fax messages that could not be
sent.

Viewing Messages in the Storage
1 Start Message Connector Configuration utility from the Kofax Import Connector group in

the Windows Start menu.

2 On the menu, go to any of the storage folders (Inbound or Outbound).

3 Select the message and click View/Save .

4 Email messages are available as EML files and can be displayed with Outlook Express
or Windows Live Mail or any other mail client that supports EML. Fax messages are
available in multipage TIFF format (a special viewer might be required to view this
format properly)

Note  You can also view EML files in Microsoft Outlook. In Outlook 2007, please follow these
instructions: http://support.microsoft.com/kb/956693. Outlook 2010 can open these files
without any additional effort.
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Managing Failed Messages Manually

Use this section if you want to manually manage messages that could not be delivered to
Kofax Capture. Depending on the Keep Failed configuration, problematic messages can be
found either in the storage folder Inbound > Active > Failures or Inbound > Processed >
Failures.

Reactivating Messages

In particular, it is important to monitor the Inbound > Active > Failures folder, as messages
in this folder can potentially fill in the entire storage. These messages can be reactivated and
Kofax Import Connector will retry to import them to Kofax Capture.

1 Start Message Connector Monitor utility from the Kofax Import Connector group in the
Windows Start menu.

2 On the menu, click Inbound > Active > Failures.

3 You can view the contents of a message to investigate the problem (click View/Save ).

4 Then either reactivate the message  or to delete it . A reactivated message is moved
back to the Inbound > Active folder. A deleted message is moved to folder Inbound >
Processed > Failures.

Rerunning Messages

Messages in the Inbound > Processed > Failures folder are already marked for deletion.
When the storage gets too full, these messages are lost. However, as long as they are
available, you can attempt to rerun them, i.e., create a copy of the message in the Inbound >
Active folder (as if it had just arrived).

1 Start Message Connector Monitor utility from the Kofax Import Connector group in the
Windows Start menu.

2 On the menu, click Inbound > Processed > Failures.

3 You can view the contents of a message to investigate the problem (click View/Save ).

4 You cannot delete these messages; they are already deleted. However, you can try to
rerun the message . A copy of this message is created in the Inbound > Active folder.

Monitoring Message Connector
1 Start Message Connector Monitor from the Kofax Import Connector group in the

Windows Start menu.

2 On the menu, click Status.

3 In the right frame you can see the status of Message Connector and its internal
components and connections.

Using Kofax Monitor
Kofax Monitor 6.5 can be used to monitor the operation of Kofax Import Connector. Web
service interface is used to provide information to Kofax Monitor.

The following counters are available for monitoring Message Connector.
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Web Service Parameters Description

GetRunState Shows the run state of Message Connector.

▪ 0 = not running,

▪ 80 = storage full, no documents accepted into
storage; import to Kofax Capture continues

▪ 100 = running

GetStorageVisible Shows how full is the storage of Message
Connector, in percent.

GetMessagesFailed Shows the number of messages that could not
be imported to Kofax Capture and need to be
processed.

GetMessagesWaiting MediaType Shows the number of messages waiting to be
imported to Kofax Capture per media type. The text
parameter MediaType may have to following values:

▪ ALL (default)

▪ FAX

▪ EMAIL

▪ FOLDER

▪ WEB-SERVICE

The following counters are available for monitoring KC Plug-In. Full description of the
counters is available in Kofax Import Connector Developers Guide.

Web Service Parameters Description

GetAllState Shows the state of feature licenses and a list of
connections.

GetConnection ConnectionName Shows if the specified connection is active and
connected.

GetConnectionNames Shows the names of all connections.

GetFeatureLicenseState Shows the state of Kofax Import Connector feature
licenses.

You can use the Web Service Wizard from the Kofax Monitor Admin Console to set up these
counters.

1 Start Message Connector Configuration utility from the Kofax Import Connector group in
the Windows Start menu.

2 On the General tab, enter the Own Computer Name.

3 Click Advanced and review the settings on the HTTP tab.

4 Click Save. Click Exit and restart service.

5 Start Kofax Capture Administration from the Kofax Capture group in the Windows Start
menu.
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6 On the menu, select Electronic Documents > Configuration and review the Web Services
Configuration. Restart KC Plug-In service if you do any changes.

7 Start the Kofax Monitor Admin Console.

8 Click Add Test Using Wizard and select Web Service Wizard.

9 Use the wizard to configure the counter.

a Enter the Web Service WSDL, e.g.: https://messageconnector:25086/file/
Monitor.wsdl or http://kcplugin:8001/KIC-Electronic-Documents?wsdl. Use the
information from steps 3 and 6.

b Select one of the methods. Use only the web services listed in the table above.

c Configure the details of the test. E.g., you can create a “Connectivity” test, using the
GetRunState method, with “100” as the expected response.

d Click Add Test and conclude the wizard.

Log Files
Kofax Import Connector provides log files that can help with troubleshooting. Log files are
stored in the application / program data folder of all users. The exact path (<path>) depends
on the operating system:
▪ C:\Documents and Settings\All Users\Application Data\Kofax\KIC-ED (Windows

Server 2003 and Windows XP)
▪ C:\ProgramData\Kofax\KIC-ED (Windows Server 2008, Windows Vista and later)

Managing Logs in Message Connector
1 Start Message Connector Configuration utility from the Kofax Import Connector group in

the Windows Start menu.

2 Click Advanced to display additional configuration options.

3 Edit the settings on the Advanced tab.
▪ The default values (TraceLevel 10 and MessageTraceSize 1) provide basic trace

information (that is often sufficient) without negatively impacting performance.
▪ Troubleshooting values (TraceLevel 40 and MessageTraceSize 100000) provide lot of

information; these are more suitable when duplicating error situations in controlled
environment.

Refer to Message Connector Help for more information about the parameters.

4 Find log files in <path>\MC\log

5 Click Save, then click Exit and restart service.

Managing Logs in KC Plug-In
1 Go to the folder <path>\KC Plug-In\logconfig.

2 Open the file log4net.config in a text editor.

3 Edit the line starting with “<level value=”. Use INFO for normal operation; use DEBUG
for troubleshooting.

4 Find log files in <path>\KC Plug-In\log.



Operation and Maintenance

Kofax Import Connector  Administrator's Guide 53

5 Restart the KC Plug-In service to make the changes effective.

Managing Logs in KFXConverter

The default name of the log file is KFXConverter.log. The default location is the same folder
as the executable. The maximum log file size is 5 MB. The file is overwritten when the
maximum size is reached. You can specify another log file using the command line option -
logFile <path>\<filename>, for example -logFile C:\temp\mylog.log.
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