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Chapter 1

Preface

KCS EasyConfig is a tool designed to simplify installation, deployment, and configuration of Kofax
Communication Server (KCS).

The classic installation of KCS is still supported; in fact, many of the more complex installations still
require the classic, interactive approach. However, some of the most important use cases of KCS are
already covered by EasyConfig.

Supported KCS Components
Currently, the following KCS components can be deployed using EasyConfig:
• TCOSS
• Document Converter
• TC/LINK-FI
• TC/LINK-SC
• KCS Fax over IP v3
• Line Server (LS1)
• KCS Backup

In addition, the following applications are installed:
• License Maintenance Tool
• MAKETCOSS (WConfig)
• Line Server Diagnostics Tool
• KCS Monitor (TCMon)
• TCPMeter Tool
• TC15 Tool
• LS1 Com Trace Tool

Advantages
• Single user interface for configuring various KCS components

Many of the most common use cases with KCS can now be configured from a single configuration user
interface. Previously used tools, such as WConfig, Windows Registry Editor, or FoIP Configuration
Utility can still be used.
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• Simple configuration of multiple link instances
Without EasyConfig, installing multiple instances of links requires manual editing of a configuration
file and the installer has to be started once for each link instance. With EasyConfig, creating another
instance is much easier!

• Automatic installation without user interaction.

Overview
Installation via EasyConfig behaves differently to previous KCS installations.

This high-level procedure describes the general installation procedure.
1. Install KCS via EasySetup.exe. All KCS components supported by EasyConfig are installed in an

unattended mode.
2. Start EasyConfig tool from the Start menu.
3. Select which KCS components do you want to use.
4. Configure the selected components.
5. Save and deploy the configuration.
6. Use License Maintenance Tool to configure your licenses.
7. Start (or restart) the affected KCS processes to apply the changes.
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Chapter 2

Installation

This chapter describes how to install KCS using the EasyConfig tool.

Prerequisites
EasyConfig requires Microsoft .NET Framework 3.5 SP1 or higher.

The EasyConfig tool is supported on the same operating systems as Kofax Communication Server.
Please refer to the Environment Guide - Platform System Manual for details.

With EasyConfig, the supported link and server components of Kofax Communication Server are installed.
Refer to chapter Supported KCS Components.

Please refer to the manuals of the particular KCS components for more information on required software
and hardware.

Note Do not install EasyConfig and Kofax Capture on the same computer.

Installing EasyConfig
Kofax Communication Server offers a new mode of installation: the EasyConfig silent setup mode. In the
silent mode, no KCS configuration windows appear.

To install KCS with EasyConfig:
1. Browse to your Kofax Communication Server installation disk.
2. Start EasySetup.exe. Alternatively, start Setup.exe /e.
3. Setup asks if you want to proceed with silent installation. Click OK to proceed with setup. Clicking

Cancel stops the setup.
4. Wait until Kofax Communication Server is installed.
5. The computer must be restarted after the installation. Click OK to do this immediately; or click

Cancel to restart your computer later.
A setup log file is generated automatically: C:\KCSSetup.log.

Logging
The EasyConfig tool saves trace information to the directory CommonAppData\Kofax\KCS\EC\Log.
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You can configure trace options by editing the file log4net.config in the directory CommonAppData\Kofax
\KCS\EC\LogConfig. For more traces, change the level value from the default “INFO” to “DEBUG”.

8



Chapter 3

Configuration Data

This chapter describes how the EasyConfig tool deals with the configuration data.

Managed Versus Non-Managed Configuration Parameters
There are many different physical configuration parameters of a KCS system located in the Windows
registry, KCS Core (TCOSS) configuration files, diverse INI files, and so on.

EasyConfig tool provides an abstraction layer by defining a subset of logical configuration parameters that
map correspondingly to their “EC-managed“ physical counterparts. Those physical parameters that are
not explicitly assigned to any logical parameters are referred to as non EC-managed. They are created
and set to proper default values during the EasyConfig setup.

EC configuration of the KCS system is stored in the C:\ProgramData\Kofax\KCS\EC
\Configurations directory, with two subdirectories:
• Current – Contains the latest EC configuration which is being loaded during the EC tool startup.
• Deployed – Contains all configurations which have ever been deployed to the physical KCS system

saved in separate subdirectories.

After starting EasyConfig, the current configuration can be modified and saved back to the Current
sub-directory. After it has been deployed to the physical KCS system, new sub-directory (such as
“13-01-2011_13.23.02.0861”) is created in the Deployed directory and all files from the Current are copied
there.

Any changes of physical configuration parameters using the traditional tools such as registry editor,
WConfig are possible, but the following rules apply:
• If any non-managed parameters have been modified on the physical KCS system, subsequent

deployment of the configuration by the EC tool does not modify their values (and it is not possible to
detect such a configuration change in the EC tool).

• If any of the EC-managed parameters were changed on the physical KCS system, subsequent
deployment of the configuration by the EC tool overwrites their values. It is possible to detect such a
configuration change in EasyConfig (Tools > Integrity Check). This function compares the last deployed
EC configuration (in the Deployed directory) with EC-managed parameters on the physical KCS
system.
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Configuration Files
EasyConfig uses following configuration files:
• ecConfig.xml

The configuration of the particular KCS system

• diverse xml schema files (*.xsd)
Configuration parameter definition and mapping among the logical higher level parameters and their
physical counterparts (registry, TAMCONF values).

• diverse xslt files (*.xsl)
XSLT transformations being used to generate and control the GUI views and configuration upgrades.

The relationship between logical and physical parameters is documented in the file
easyconfig_parameters.htm (part of KCS documentation).
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Chapter 4

Configuration

This chapter describes how to use the EasyConfig tool to configure Kofax Communication Server
applications.

Configuration with EasyConfig
Launch EasyConfig by selecting Start > Programs >  Kofax Communication Server > KCS
EasyConfig Tool.

The following optional command line parameters are supported:

Ec.exe [-configuration <path>] [-noupdate] [-help]

Parameter Description Defaults

-configuration
<path>

specify a directory where EasyConfig
should load the configuration

C:\ProgramData\Kofax\KCS\EC\Configurations

-noupdate do not check for new schema versions New schema versions are checked

-help show a message box with available
command line arguments

None

The EasyConfig user interface looks like the following.
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The EasyConfig user interface has five main parts:
• Menu and toolbar are the main controls, located in the top part of the window.
• Component tree: KCS components configurable by EasyConfig are listed in a tree view in the left part

of the window.
• Item list: In the top right part of the window lists the existing items in the currently selected category of

the component tree
• Configuration panel: This panel in the bottom right part of the window displays the parameters of the

currently selected entry in the item list.
• Status bar at the bottom of the page shows important hints.

Tip Hover the mouse pointer over various user interface elements or parameters to display tooltips.

These are some of the actions you can perform:
1. Select an item in the component tree. The item can be a TCOSS server, a channel, a link type, node

type, etc.
2. Optionally, you can use the collapse all  /expand all  buttons from the toolbar (or select the

option from the View menu), or the collapse  / expand  buttons in the component tree to navigate
to the item you need.
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3. Do one of the following:
• Click Add  (or select Edit > Add; or use context menu commands) to add a new empty item to

the component tree. Usually, you need to provide some parameters in the configuration panel.
For server channels only, you can use Add multiple command in the context menu to add multiple
channels at once.

• Click Clone  (or select Edit > Clone) to create a copy of the selected item. You might want to
edit some parameters in the configuration panel.

• Click Delete  (or select Edit > Delete) to delete the selected item.

• Click Undo  to undo.

4. Then, click Save  (or select File > Save) to confirm the newly added item and save the
configuration changes to the internal XML file.

5. Select Tools > Integrity Check to verify whether any EC-managed parameters were modified
outside the EC tool on the physical KCS system.

6. Click Deploy  (or select File > Deploy) to apply the changes. See chapter Deployment via
EasyConfig for details.

The Component Tree
Even before adding any modules/items to the configuration, the component tree contains container
placeholders for all modules that are supported by current EC tool version:

The numbers in the parenthesis denote the number of items/modules configured within particular
container. For example, FI Links (0) shows there are no TC/LINK-FI instances in the current configuration.
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Note The Servers container does not have any number in parenthesis, as it is possible to add only a
single KCS Core server instance there.

The container “Views” offers a read-only access – it contains some views on the current configuration, but
does not allow adding any items/modules.

To start configuring the system, follow the steps described in the topic Configuration with EasyConfig to
add or delete items/modules.

The Configuration Panel
You can change the parameter values of the selected item/module in the configuration panel.

When you add new items, EC tool proposes most suitable default values for the most of parameters
and denotes those which are recommended to be explicitly changed with the red asterisk  in front of
parameter’s description.

Each module has a “Label” parameter. Use it to assign a descriptive name for that module, such as “TC/
Link-FI Instance 1”.

Certain modules have a few crucial parameters that can be configured only once, immediately after being
created such as the TCOSS file path.

After saving the configuration change, these parameters become grey; it is not possible to change them
any more (the only way to change them is to delete the corresponding module in the tree or item list view).

If any of the displayed parameters have been modified, the only allowed actions are Save and Undo; the
rest of the commands in the toolbar are deactivated.
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Parameter Input Validation
Most configuration parameters are validated against pre-defined rules after each keystroke. This helps
to identify invalid values immediately. For example, the IP address field below is red because the string
“10.0.0.” entered so far is not a valid IP address.

Adding the last missing digit solves the problem.

As long as any of the parameter input fields is marked as invalid (red color), it is not possible to save this
configuration change.

Furthermore, there are situations where a parameter appears valid during editing, but its value cannot
be saved into the configuration due to some further requirements, such as its uniqueness. For example,
assume there is already one KCS node “L.1” in the configuration and we attempt to add another one with
the same name.

When you click Save, an error message box informs that the node name must be unique.
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Configuring TCOSS Channels and Channel Groups
When you add a new server (“TCOSS”), following items are added to the component tree:

The server configuration consists of:
• Common server parameters: You can select the TCOSS component in the tree and change parameters

in configuration panel.

Note If the TCOSS file structure already exists, it is not modified during deployment and the settings
in EasyConfig are ignored. This is to prevent unwanted loss of information. To use new values, you
have to delete the existing file structure or select a different name/path.

• Master, LS1 and FoIP nodes: This is where you can add communication channels.
• UC0 Client-Server (channel type CS), TCUAS and Null channels on the master node.
• Fax channels on the LS1 or FoIP node.
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• Fax channel groups: Use them to configure fax related parameters for fax channels.

Note The channels themselves do not have any configuration data. To configure particular fax
parameters (such as the fax header line), create a corresponding fax group and assign it to a number
of fax channels that should share this configuration. See Use Case: FoIP and LS1 Channels for
details.

TCOSS File Structure Partitioning
In a classic, interactive installation, the TCOSS file structure has many configuration options. With
EasyConfig, there are only the following parameters:
• File size
• Maximum count of users
• Unicode mode
• TCOSS codepage
• Windows Unicode font

For other file structure variables, either the default values are used, or they are calculated automatically
from the provided parameters. The following guidelines apply:
• Number of reserved directory entries: one per 16 KB data block, max. 16 million.
• Number of used directory entries: 25% of reserved directory entries, min. 30 000.
• Tech area: fixed size (1200 entries, 25600 kB)
• User area:

• Two entries per user, max. 25% of remaining (total - Tech) entries
• 128 kB per user, max. 25% of remaining (total - Tech) data space

• Mail area: remaining entries (total - Tech - User), remaining disk space

Kofax Communication Server automatically calculates the suitable values for user entries, address book
entries, mail entries, and size of log file (short-term archive). Refer to TCOSS Configuration Manual
(Sysconf line 13).

TCOSS Channel Number Allocation
TCOSS channels are traditionally being assigned the TCOSS channel number expressed in terms of
two-character code, with valid ranges 00 ..99, A0 ..A9, B0 ..B9, .., Z0 ..Z9, 0A ..0Z, 1A ..1Z, .., 9A ..9Z,
AA ..AZ, BA ..BZ, .., OA ..OZ. Unlike the WConfig tool, EC does not allow you to explicitly assign TCOSS
channel number to a particular channel.

Instead, the following TCOSS channel code allocation scheme is being used:
• All master channels are automatically configured in the bottom up manner starting with the lowest

unallocated channel code (OZ, OY, OX, …). The only exception is the pre-configured TCUAS channel,
which is assigned the TCOSS channel number 00.
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• Fax channels are assigned in the top down way, starting with the first unallocated channel code, such
as 01, 02, 03, …

Fax channels configured for a particular FoIP node and particular LS1 node/line combination must occupy
the contiguous TCOSS channel number range (TCOSS restriction). That is why if configuring any lower
channel count than the maximum supported for a particular node/line combination, the EC tool allocates
the maximum possible channel count, which makes it easy to add additional channels later for a particular
line.

Maximum fax channel count per node/line combination.

Node/Line Max. channel count

FoIP/- 60

LS1/ISDN BRI 2

LS1/ISDN PRI E1 30

LS1/ISDN PRI T1 23

LS1/analog 1

To illustrate this concept, use the “All used channels” view to display the list of all allocated TCOSS
channels configured on the KCS server.

Example 1 – Pre-configured channels after creating the new server item
Note that there is one TCUAS channel with TCOSS channel code 00 assigned, and 30 client-server
channels assigned channel codes NW- OZ.
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Example 2 – Add two ISDN PRI lines with 8 channels each
Take the default configuration from Example 1 as the basis and configure two LS1 nodes each with one
ISDN PRI E1 line with 8 channels.

Note The first line has been assigned 8 channel codes 01-08 (but internally the range 09-30 has been
allocated for future channel extension on this line).

That is why the second line has been assigned 8 channel codes 31-38 but again the range 38-60 has
been reserved internally.)

Example 3 – Add 8 channels to first ISDN PRI E1 line:
Take the configuration from Example 2 above as the basis and 8 channels to the first ISDN PRI E1 line.

Note These 8 channels were added to the channel codes 09-16, and the channel codes of the other
channels were not changed at all.
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Chapter 5

Deployment via EasyConfig

This chapter describes how to use EasyConfig to deploy the configuration to the KCS system.

If there are any configuration changes that have not yet been deployed, this is indicated in the status bar.

To deploy a configuration:
1. Click Deploy .

2. Select how to deploy the configuration:
• Select All if you want to deploy the whole configuration including modules whose configuration

was not changed. Use All if this is the first deployment of a new KCS system. Also, use All if some
physical KCS parameters have been modified with classic tools (e.g., regedit) and you want to
overwrite these changes.

• Select Changes if you want to deploys only modules with modified configuration. This is the
default option recommended for most configuration changes.
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3. Click OK. One of the following happens:
• If the TCOSS server is not running, the EasyConfig deploys the configuration directly to the

TCOSS file structure (TFS) without prompting for the user credentials.
• If the TCOSS server is already running, you need to log in. Tech user rights are required (by

default: “TCTECH”, “TCTECH”).

EasyConfig deploys the changes.
4. Look at the deployment log for further instructions.

The log displayed by EasyConfig lists recommended actions that need to be performed to make the
changes effective. Usually it is necessary to restart / reload some components.

Note There may be situations where no application restarts are necessary as the configuration
changes activate automatically!
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Chapter 6

Use Cases

This section describes use cases.

Use Case: Basic TCOSS and TC/LINK-FI
In this sample use case, we describe how to deploy TCOSS and a single instance of TC/LINK-FI. Make
sure your computer meets the prerequisites necessary to run TCOSS and TC/LINK-FI.

To install TCOSS and TC/LINK-FI:
1. Install KCS as described in section Installing EasyConfig.
2. Start the EasyConfig tool by selecting Start > All Programs > Kofax Communication Server  >

KCS EasyConfig Tool.
3. Configure a new TCOSS server:

a. In the component list, select Servers.

b. Click Add  to add a new TCOSS server.

c. In the configuration panel, type a descriptive label for your TCOSS server.

d. In the configuration panel, type the size of your TCOSS file structure.

e. In the configuration panel, modify any other parameters if necessary.

f. Click Save . The new server is added and the complete configuration is saved to the XML
file. The status bar shows this message:

Current configuration has been modified, please deploy it to make changes effective.
4. Configure a new TC/LINK-FI:

a. In the component list, select FI Links.

b. Click Add  to add a new TC/LINK-FI.

c. In the configuration panel, type a descriptive label for your link.

d. In the configuration panel, provide KCS connection parameters.

e. In the configuration panel, modify any other parameters if necessary.

f. Click Save  .
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5. Click Deploy . Select All. Click OK. The following things happen:
• Configuration values are written to the Windows registry.
• KCS file structure is created, formatted, and initialized.
• TCOSS configuration is stored in the file structure.

6. Start TCSRV using KCS Monitor (TCMon).
7. Use KCS License Maintenance Tool to apply the necessary licenses (or switch to Test Mode).

Use Case: FoIP and/or LS1 Channels
In this sample use case, we describe how to configure fax channels for use with KCS Fax over IP v3 and
Line Server. A working TCOSS deployed using EasyConfig is assumed (see Use Case: Basic TCOSS
and TC/LINK-FI).

To configure FoIP and/or LS1 Channels:
1. Start the EasyConfig tool by selecting Start > All Programs  > Kofax Communication Server >

KCS EasyConfig Tool.
2. Configure a new fax channel group (only if fax group not yet available):

a. In the component list, select Fax Channel Groups. Click Add .

b. In the configuration panel, type a descriptive label for your fax group.

c. In the configuration panel, choose proper fax channel type (ISDN, analog or FoIP).

d. In the configuration panel, choose country.
This is especially important for analog groups as the country setting controls country-specific
analog line parameters!

e. In the configuration panel, modify any other parameters if necessary.

f. Click Save .
3. Configure FoIP or LS1 Node (only if not yet available):

a. In the component list, select FoIP Nodes or LS1 Nodes. Click Add .

b. In the configuration panel, type a descriptive label for your node.

c. In the configuration panel, type a node name (L.1, L.2, …, L.176).

d. In the configuration panel, type an IPV4 or IPV6 address of your node.

e. In the configuration panel, modify any other parameters if necessary.
Note that for a local FoIP node, you can configure its Call Peer settings here instead of running
the FoIP configuration utility afterwards.

f. Click Save .
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4. Configure Lines on LS1 Node (only if not yet available):

a. In the component list, select Lines under the corresponding LS1 node. Click Add .

b. In the configuration panel, type a descriptive label for this line.

c. In the configuration panel, choose proper LS1 slot (S0A, S0B, …).

d. In the configuration panel, choose proper channel type (ISDN or analog).

e. In the configuration panel, modify any other parameters if necessary (especially ISDN protocol
and access type in case of ISDN channel).

Note that with the analog channel type, all necessary analog line parameters are being set
automatically based on the related fax group’s country configuration.

5. Add channels on FoIP or LS1 Node:

a. In the component list, select Channels under the corresponding FoIP node or LS1 line.

b. Click Add  to add a single or Add multiple (context sensitive menu) to add multiple
channels.

c. In the configuration panel, type a descriptive label for your channels.

d. In the configuration panel, choose proper fax group.

e. Click Save .
6. Click Deploy  and select Changes. The following things happen:

• Configuration values are written to the TCOSS.
• The instruction to reboot TCOSS is displayed in the deployment log.

7. Use KCS License Maintenance Tool to apply the necessary licenses (or switch to Test Mode).
8. Restart TCOSS to make the changes effective.

Use Case: Configure Channel Sub-Groups on a Single PRI Line
In this sample use case, we describe how to configure two or more sub-groups of fax channels with
different settings on the same PRI E1 or T1 line. Working TCOSS using EasyConfig is assumed. See
chapter Use Case: Basic TCOSS and TC/LINK-FI.

To configure two channel sub-groups on one ISDN PRI line:
1. Start the EasyConfig tool by selecting Start > All Programs > Kofax Communication Server >

KCS EasyConfig Tool.
2. Configure a new fax channel group for inbound faxes, labeled such as “FaxInbound” (refer to

Configuring TCOSS Channels and Channel Groups):

a. In the component list, select Fax Channel Groups.

b. In the item list, select the FaxInbound group.

c. In the configuration panel, modify any of its parameters as desired (such as switch on fax
reception n the Fax Reception panel).

d. Click Save .
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3. Configure new fax channel group for outbound faxes, as labeled, such as “FaxOutbound”:

a. In the component list, select Fax Channel Groups.

b. In the item list, select the FaxOutbound group.

c. In the configuration panel, modify any parameters as desired (such as switching off fax
reception in the Fax Reception panel).

d. Click Save .
4. Configure LS1 Node L.1 and add ISDN PRI E1 line on the slot S0A.
5. Add fax outbound channels on the LS1 Node L.1 Slot S0A:

a. In the component list, select Channels under the L.1 node and PRI line S0A.

b. Select Add multiple via a context-sensitive menu, type required number of channels (such
as 15), type the channel label (such as “FaxOutbound”) and choose the channel group
FaxOutbound.

c. Click OK.

d. Click Save .
6. Add fax inbound channels on the LS1 Node L.1 Slot S0A:

a. In the component list, select Channels under the L.1 node and PRI line S0A.

b. Select Add multiple via a context sensitive menu, type the required number of channels
(such as15), type a channel label (such as “FaxInbound”) and choose the channel group
FaxInbound.

c. Click OK.

d. Click Save .
7. Click Deploy  and choose Changes. The following things happen:

• Configuration values are written to the TCOSS.
• The instruction to reboot L.1 node is displayed in the deployment log.

8. Use KCS License Maintenance Tool to apply the necessary licenses (or switch to Test Mode).
9. Reboot L.1 node via KCS Monitor.

Use Case: Configure Modem Traces on Particular Fax Channel
In this sample use case, we describe how to configure modem traces on a single fax channel on PRI E1
or T1 line. Working TCOSS using EasyConfig with LS1 node L.1 with 30 fax channels is assumed. See
chapter Use Case: Configure Channel Sub-Groups on a Single PRI Line.

Assume we want to configure the modem traces on one of the fax outbound channels while keeping all
other settings of this channel.

To configure modem traces on a single or more fax channels on a ISDN PRI line:
1. Start the EasyConfig tool by selecting Start > All Programs > Kofax Communication Server >

KCS EasyConfig Tool.
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2. Clone “FaxOutbound” to create a new fax channel group, such as “FaxOutboundTrace”:

a. In the component list, select Fax Channel Groups.

b. In the item list, select the FaxOutbound group.

c. Select Clone via the context menu.

d. In the configuration panel, type a descriptive label for your test fax group (such as
“FaxOutboundTrace”). 
When cloning, you can only modify parameters in expanded panels. The cloned item must be
saved to make further changes.

e. Click Save .
3. Change trace settings of the new channel group:

a. In the item list, select FaxOutboundTrace  group.

b. In the configuration panel, modify any of its parameters as desired (such as modem traces).

c. Click Save .
4. Assign the new fax channel group to chosen fax channel:

a. In the component list, select Channels under the L.1 node and PRI line S0A.

b. In the item list, select the chosen fax channel or even more of them (by pressing the CTRL +
clicking the desired channel line).

c. In the configuration panel, select the FaxOutboundTrace group.

d. Click Save .
5. Click Deploy  and choose Changes. The following things happen:

• Configuration values are written to the TCOSS.
• The instruction to reboot L.1 node is displayed in the deployment log.

6. Reboot the L.1 node via KCS Monitor.

Use Case: Clone TC/LINK-FI Link Instances
In this sample use case, we describe how to add additional link instances by cloning the already
configured “parent” instance. Working TCOSS with one TC/LINK-FI instance using EasyConfig is
assumed. See chapter Use Case: Basic TCOSS and TC/LINK-FI.
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To Clone the Parent TC/LINK-FI Instance:
1. Clone the TC/LINK-FI instance:

a. In the component list, select FI Links.

b. In the item list, select the parent TC/LINK-FI instance.

c. Select Clone via the context menu.

d. In the configuration panel, type a descriptive label for your link.

e. In the configuration panel, modify any other parameters in expanded panels as required.

f. Click Save .

Note Note that in the “Clone” mode, you can only modify parameters in expanded panels. The
cloned item must be saved prior to making any changes.

2. Click Deploy  and choose Changes. The following things occur:
• Configuration values are written to the Windows registry.
• The instruction to reload supervisor process list is displayed in the deployment log.

3. Use KCS License Maintenance Tool to apply the necessary licenses (or switch to Test Mode).
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Chapter 7

Compatibility with Interactive Setup, Registry
Editor and WConfig

This section describes the compatibility with Interactive Setup, Registry Editor and WConfig.

Installing Unsupported Applications
Currently, only a subset of KCS applications is managed by EasyConfig. These are listed in Supported
KCS Components.

You can use the classic, interactive setup to install other KCS applications and components. You must use
the classic tools to configure them.

Changing Non EasyConfig-Managed Configuration Parameters
Currently, only a subset of configuration parameters is managed by EasyConfig. You can modify other
values as necessary, which do not affect your EasyConfig configuration. Furthermore, any changes of
non EasyConfig-managed parameters by classic tools are preserved during any subsequent EasyConfig
configuration deployment.

Note If you changed any of the non EasyConfig-managed parameters on the KCS server (per registry
editor, WConfig) the EasyConfig tool’s integrity check function (Tools > Integrity Check) will not find
any configuration inconsistency.
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Changing EasyConfig-Managed Configuration Parameters
You can also modify EasyConfig-managed parameters with the classic tools on the KCS server, but these
changes will be not preserved during any subsequent EasyConfig configuration deployment.

If any changes with the classic tools have been done on the KCS server prior to the EasyConfig
configuration deployment, it is a good idea to at first double-check whether any EasyConfig-managed
parameters had been changed by using the EasyConfig tool’s integrity check function (Tools > Integrity
Check).

In the case any differences would have been found, the list of differences would be displayed with two
options:
• Continue to leave the configuration unchanged.
• Revert to overwrite the KCS server configuration deployed the last time by the EasyConfig tool.
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WConfig Compatibility
It is possible to load the EC-managed TCOSS configuration to the WConfig (by using the get configuration
command). You can see in the caption of the WConfig window that the TCOSS is managed by
EasyConfig.

You can use WConfig to change any of the parameters in the system configuration or in any of already
configured channels. However, it is not possible to add or delete any of the configured channels. The
following error message is displayed.

Furthermore, it is not possible to create a new TCOSS configuration with WConfig and install it to a
TCOSS running an EC-managed configuration. The following error message is displayed.
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The information that the TCOSS configuration is EC-managed is stored in the Sysconf file (line 10 position
1). See the TCOSS Configuration Manual for details.

It is possible to change an EasyConfig managed configuration into a WConfig-managed. This change is
permanent; returning to EasyConfig is not supported.

To permanently migrate to WConfig:
1. An EasyConfig-managed TCOSS must be running. TCfW Communication Server Client (part of KCS

Client Applications) must be connected to the server.
2. Log in to TCOSS as a tech user (system folder write access required).
3. In the System folder, open the file ASYSCONFCCCC.
4. In line 10, change the first character from “1” to “0”.
5. Save the file and close TCfW.
6. Start WConfig.
7. Enter the path to the new TCOSS configuration.
8. Select Get configuration via net. Ignore all warnings.

Your TCOSS is now configurable solely via WConfig.
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Conflict with Standard Setup
When you try to configure a KCS system with EasyConfig on a computer where KCS components had
been installed before using standard KCS setup, this inconsistency is detected by the EasyConfig tool.
The following warning is displayed before deploying.

Click Yes to proceed with the deployment.

Click No to stop the deployment.
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Chapter 8

Hints and Restrictions

This chapter lists hints and restrictions.
• No upgrade of classic systems.

EasyConfig cannot be used to import configuration from existing KCS systems. It can only be used for
new installations.

• Support for a subset of KCS functions.

Only a subset of Kofax Communication Server functions listed in chapter can be managed by
EasyConfig. However, you can use the classic tools (interactive setup, registry editor, WConfig) to add
other features.

• Parameters managed by EasyConfig must not be changed by other tools (registry editor, TCfW,
WConfig). EasyConfig is able to detect such changes.

• EasyConfig nodes limitation
EasyConfig supports a maximum of 58 KCS nodes (FoIP/LS1).
EasyConfig supports a maximum of 16 FoIP nodes.

• Validation error when EasyConfig starts

In rare cases, it may happen that the current configuration becomes corrupt, EasyConfig displays
a validation error and shuts down. In that case, delete the content of the current directory (refer to
Managed Versus Non-Managed Configuration Parameters). Then, copy the last deployed configuration
into the current folder.

• If you are using KCS Monitor (TCMon) to clone TC/LINK-SC instances, you must identify the KCS
server with server name or IP address (but not with “localhost” or “.”). Refer to the TC/LINK-SC Manual
for details.

Note You can use EasyConfig to clone link instances to avoid this problem.
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