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1. INTRODUCTION 
SAP is one of the most important suppliers of business applications all over the world. The SAP software 
products like R/2 and R/3 are state-of-the-art application systems for large and medium sized 
organizations. 
Kofax is the leading manufacturer of high-end enterprise messaging servers with integration into email 
and application platforms and has thousands of installations with leading companies world-wide. 
Hundreds of Kofax Communication Server installations are linked to SAP applications today. 
As business cycles become shorter and shorter (e.g., just-in-time manufacturing), the importance of fast 
electronic communications increases. Thus quick and secure communication is a must – with deep 
integration into application platforms to avoid manual faxing of printed application. 
Sending of messages has to be possible from applications (e.g., automatic transmission of purchase 
orders, order confirmations by fax) and by individuals who create and compile individual messages within 
email and word processing applications. Status reports have to be available immediately to the sending 
users within the application. Inbound messages have to be routed to individuals and applications within 
the SAP applications environment by the existing routing technologies (such as DID from fax and Telex, 
User IDs from any email services and other platforms). 
 
With SAP R/3 Release 3.1 there is a new interface called SAPconnect for linking external communication 
components to the R/3 system.  
SAPconnect is a standard interface for external communication between R/3 systems and external 
partners. The communication takes place via telecommunications services, for example FAX, Internet, 
X.400. 
With SAPconnect, links can be established to various types of communication components (nodes), for 
example: 
 
 to other R/3 systems 
 to Kofax Communication Server 
 to Microsoft Exchange Servers 
 
The SAPconnect RFC interface is no longer supported as of SAP NetWeaver 7.2. Use TC/LINK-SC7 
instead. 
 
Basic characteristics of SAPconnect interface: 
 
 offers open and full integration with email and messaging platforms. 
 is a messaging interface to partner applications, which offers a broad range of functionality 
 has been developed by SAP as successor to SAPcomm 
 offers a single, central point of access for any communications system wishing to connect to R/3 based 

on SAP’s Remote Function Call technology 
 works together closely with SAPoffice, which provides message storage, message routing and user 

interface 
 is configured and monitored completely within the R/3 system, except for connectors to communication 

components (for example TC/LINK-SC) 
 
Important! The Kofax Communication Server and its components formerly used the name 
TOPCALL. Some screen shots and texts in this manual may still use the former name. 



TC/LINK-SC Version 2.04.01 LINKSC_MAN.doc 

 

Kofax  8/178 
 

2. FUNCTIONALITY 

2.1 Overview 
The KCS server interconnects with R/3 application server via the SAPconnect messaging interface. 
SAPconnect data structures (messages, notifications) are exchanged with the R/3 server by the means of 
SAP’s Remote Function Call  technology. A Remote Function Call (RFC) is a call to a function module 
running in a system different from the caller’s. The remote function can also be called from within the 
same system (as a remote call), but usually caller and callee will be in different systems. 
 
There are two kinds of RFC programs: RFC client and RFC server programs. 
RFC client is the instance that calls up the RFC to execute the function provided by an RFC server. In 
other words, RFC client is the sender, that sends objects and RFC server is the receiver to receive and 
execute objects sent by RFC client. 

 
The RFC interface uses the CPI-C (Common Programming Interface – Communications) as a low-layer 
communication protocol to interact with the R/3 application server. CPI-C was first defined as a 
standardized communications interface by IBM, as part of the SAA standard. Then CPI-C was modified by 
X/Open to include additional functions. SAP’s CPI-C implementations support the X/Open Developers’ 
Specification – CPI-C. 
 
The CPI-C communication with the R/3 application server must always run via CPI-C Handler (SAP 
gateway). 
As a network transport, the TCP/IP protocol stack is being used.  
 
SAP gateway may run anywhere in the TCP/IP network. But the most preferred method is to run it on the 
SAP R/3 application server. This will be probably the most typical situation at the R/3 customer site since 
the default SAP gateway is always running at every R/3 application server. 
 
Optionally, the communication between TC/LINK-SC and SAP gateway may run via SAProuter.  
SAProuter is a SAP software product available on all R/3-based UNIX and Windows NT/95 platforms. It 
acts like a firewall system by regulating access from/to customer’s network.   
 

 
 
TCLINK-SC is the preferred link to connect the KCS System to SAP/3. By using SAPconnect, it provides 
the most direct link to SAPoffice, the messaging service of R/3. In this way it makes the full KCS 
messaging functionality (FAX, Telex, SMTP, X.400, …) available to SAPoffice and all SAP R/.3 
applications. 
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2.2 General Link Functionality 
TC/LINK-SC has been implemented according to the KCS Link architecture and provides full TC/LINK 
functionality:  
 
 Attachment conversion with learn mode 
 Cover sheets and templates 
 All ++commands (++to, ++cover, etc) in messages transferred from R/3 to the KCS System are 

processed by the TC/LINK-SC. This includes also ++commands embedded with attached PostScript 
files. 

 
Please refer to the TC/LINK manual for detailed description. 

2.3 Address Mapping 

2.3.1 SAPoffice Addressing 

All addresses necessary for the operation of SAPoffice are stored and maintained in the address 
management. 
On the one hand there are the address specifications necessary for external transmission (to mail 
recipients outside the particular SAPoffice), for example X.400 addresses or Internet addresses.   
On the other, internal users (within the particular SAPoffice) also have an address in the address 
management.  
Internal SAPoffice users can be assigned several addresses of different types: RML (internal SAPoffice 
address type), FAX, SMTP and X.400. Each of used address types must be assigned to the specific 
communication method, like SAPconnect, SAPcomm etc. (see chapter 4).  
 
SAPconnect interface supports 3 address types: FAX, SMTP and X.400. 
 
On sending outbound messages via SAPconnect interface, SAPoffice user can address fax, SMTP and 
X.400 recipients directly. Other mail recipients (MS Exchange, Lotus Notes) must be embedded into either 
X.400 or SMTP address type. 
If a SAPoffice user sends a message to recipient with specific address type (e.g., FAX), the message’s 
originator will be set to originating SAPoffice user’s address with the same address type. 
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On receiving inbound messages via SAPconnect interface, SAPoffice recipients may be addressed by 
either of FAX, SMTP or X.400 address types. The only condition is that the addressed SAPoffice user 
must have been assigned an address of particular type. 
 
TCLINK-SC performs address mapping of all 3 SAPconnect address types (FAX, SMTP, X.400) to the 
corresponding KCS services and vice versa. 

2.3.2 Virtual Domains for KCS Server 

Once connected via SAPconnect interface to the KCS server, SAPoffice users may use all services 
provided by the KCS: they can send faxes, telexes, X.400, SMTP, MS Exchange messages etc.  Faxes, 
X.400 and SMTP messages can be addressed directly using SAPconnect’s native address types. All other 
addresses (Exchange, Lotus Notes, telex) must be embedded into either X.400 or SMTP address type.       
 
As to be able to distinguish if the X.400 or SMTP address is a real X.400 or SMTP address or if such an 
address only contains another embedded address, virtual domains are being used. 
X.400 and SMTP virtual domains are configured during TC/LINK-SC setup (see chapter 4). 
 
Corresponding registry settings: 
 
SMTP virtual domain:  
TCLINKSC\SAP\SCLinkSMTPDomain 

 
X.400 virtual domain: 
TCLINKSC\SAP\SCLinkX400Country 

TCLINKSC\SAP\SCLinkX400ADMD 

TCLINKSC\SAP\SCLinkX400PRMD 

TCLINKSC\SAP\SCLinkX400Org 

TCLINKSC\SAP\SCLinkX400OU1 

 
SMTP virtual domain comprises the domain part of the SMTP type address.   
X.400 virtual domain comprises following fields of the X.400 address type: 
Country, ADMD, PRMD, Organization and Organizational Unit 1. 
 
On receiving messages from SAPoffice, all recipient addresses with X.400 or SMTP types are being 
checked if belonging to own virtual domain. 
If not, the message is being sent further to the default service for X.400 or SMTP, respectively (of course, 
these X.400/SMTP services must have been configured to point to the TC/LINK-X4 and TC/LINK-SM link 
modules). 
If the address does belong to the own virtual domain, TC/LINK-SC’s address mapping mechanism will be 
used to extract the embedded address of another KCS service (telex, KCS user, MS Exchange) from the 
X.400 or SMTP.     
 
SMTP and X.400 virtual domains are being setup only with Advanced Installation (see 4.2.6). 
During Easy Install (see 4.2.5), dedicated for fax operation only, the SMTP domain is set to “topcall” by 
setup, X.400 domain remains undefined. 
Setting SMTP domain even with Easy Install for pure fax installations is that it makes sending from TCfW 
to SAP R/3 users for test purposes possible (any defined SMTP domain is necessary for this send 
operation, please see 2.3.4). 
 
Example 
Assume the KCS server running TC/LINK-SC, TC/LINK-X4, TC/LINK-SM. 
Default services for TC/LINK-X4 and TC/LINK-SM are X400 and SMTP, respectively. 
Own (virtual) SMTP domain is charlie.topcall.co.at, own X.400 domain C=at;A=umi-at;P=topcall; 
O=charlie 
 
An incoming message(s) with X.400/SMTP recipients will be handled like: 
 

Recipient Flintstone@charlie.topcall.co.at will be mapped to KCS user 
flintstone 
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Any recipient with 
other domain 

Flintstone@bedrock.us will be send further via SMTP 
service 

Recipient C=at;A=umi-at;P=topcall;S=FLINTSTONE will be mapped to KCS user 
flintstone 

Any Recipient C=US;P=BEDROCK;A=X400NET;S=FLINTSTONE  will be sent further via X400 
service. 

 
Note: The way how KCS addresses are being embedded into X.400/SMTP address types is described in 
detail in the following chapters. 

2.3.3 Addressing from KCS to SAPoffice 

General address format:  tc_queue:address_type:address,  
where address type may be either of 3 SAPconnect address types: FAX, SMTP or X400. 
 
Example (sending to SAPoffice fax recipient) 
tclsci:fax:12345 
 
Example (sending to SAPoffice SMTP recipient) 
tclsci:smtp:fred.flintstone@bedrock.us 
 
The message’s originator is being set according to following rules: 
 
 If the originator is KCS user, the SAPconnect message originator will be the first active KCS address 

(KCS UserId) embedded into SMTP address type like TCUserId@virtual_domain 
 

 If the originator is fax (incoming fax), the SAPconnect message originator will be the fax number of 
originating fax machine and will be of fax address type. 
 

 If the originator is telex/teletex (incoming telex/teletex), the SAPconnect message originator will be 
embedded into SMTP address type like  
 TLX#number#answerback@virtual_domain 
 or  
 TTX#number#answerback@virtual_domain 
 where TLX/TTX is KCS service for telex/teletex. 
 

 If the originator is SMTP mail user (incoming mail from TC/LINK-SM), his SMTP address will be copied 
into SAPconnect message originator of address type SMTP, without any changes. 
 

 If the originator is X.400 mail user (incoming mail from TC/LINK-X4), his X.400 address will be copied 
into SAPconnect message originator of address type X.400, without any changes. 
 

 If the originator is of free address type, the SAPconnect message originator will be embedded into 
SMTP address type like FREE#number@virtual_domain 

2.3.4 Addressing from SAPoffice to KCS 

There are the following rules how the message recipients are being evaluated: 

2.3.4.1 Addressing Without Virtual Domains 

 Fax recipients are being directly mapped to default service for FAX (configured during TC/LINK-SC 
setup) and fax number. 

 Those SMTP recipients not belonging to the own virtual SMTP domain are being sent using the default 
service for SMTP (TC/LINK-SC’s configuration value, currently pre-set to “SMTP” service). 

 Those X.400 recipients not belonging to the own virtual X.400 domain are being sent using the default 
service for X.400 (configured during TC/LINK-SC setup). 
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2.3.4.2 Addressing Using Virtual Domains 

Those SMTP recipients, belonging to the own virtual SMTP domain, are considered to contain one of the 
following embedded addresses (‘service’ is the KCS service and ‘#’ is the separator between different 
address parts): 
 
service#number#answerback@virtual_domain 

service#number@virtual_domain 

TCUser@virtual_domain 

(Where TCUser may be the KCS UserId or one of KCS user’s SMTP addresses) 
 
Those X.400 recipients, belonging to the own SMTP domain are considered to contain one of the 
following embedded addresses: 
 
 KCS number and KCS’s service (e.g., FAX, TLX, TOPCALL etc.) is extracted from the first Domain 

Defined Attribute (DDA) of the X.400 address, the DDA type contains the service (e.g., “FAX”) and 
DDA value contains the fax/telex number or KCS UserId in the case of KCS user. The KCS’s service 
specified must be valid and defined on the KCS server before the TC/LINK-SC has been started. 
 
Example (sending to the fax number 6613321) 
DDA type :”FAX” 
DDA value: “6613321” 
 
Example (sending to the KCS user ‘MAX’ )  
DDA type : “TOPCALL” 
DDA value: “MAX” 
 

 The recipient is a KCS user or KCS recipient (from address book) with UserId (Recipient Id) created 
from X.400’s given name and surname. 
 
Example (sending to the KCS user Anton Mayer): 
X.400 Given Name = Anton 
X.400 Surname = Mayer 
(The KCS’s UserId is “Anton Mayer”). 
 

 The recipient is a KCS user or KCS recipient (from address book) with UserId (Recipient Id) created 
from X.400’s surname. 
 
Example (sending to the KCS user Mayer): 
X.400 Surname = Mayer (any name, is not considered) 
KCS’s UserId is “Mayer”). 

2.3.4.3 Message Originator 

On the other hand, the message’s originator is being evaluated in the following way: 
 
 Originator (with FAX, X.400 or SMTP address type) is a KCS user with matching fax, X.400 or SMTP 

proxy address. This feature is being referred to as Enhanced originator mapping and is supported with 
TCOSS 7.22 or higher. Please see 2.3.5. 
 

 Originator  (with X.400 address type) is a KCS user with UserId built up from X.400’s given name and 
surname. 
Note: 
If the X.400-type originator has his equivalent on the KCS, the notifications from the KCS are sent to 
this internal KCS user and not directly to TC/LINK-SC. Therefore, with the user’s profile on the KCS, 
the appropriate action on delivery/non-delivery notifications must be defined as to send them to his 
X.400 address via TC/LINK-SC. 
 

 Originator (with X.400 address type) is a KCS user with UserId built up from X.400’s surname. 
Note: 
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If the X.400-type originator has his equivalent on the KCS, the notifications from the KCS are sent to 
this internal KCS user and not directly to TC/LINK-SC. Therefore, with the user’s profile on the KCS, 
the appropriate action on delivery/non-delivery notifications must be defined as to send them to his 
X.400 address via TC/LINK-SC. 
 

 Originator (with SMTP address type) is a KCS user with UserId built up from the local part of SMTP 
address. 
Note: 
If the SMTP-type originator has his equivalent on the KCS, the notifications from the KCS are sent to 
this internal KCS user and not directly to TC/LINK-SC. Therefore, with the user’s profile on the KCS, 
the appropriate action on delivery/non-delivery notifications must be defined as to send them to his 
SMTP address via TC/LINK-SC. 
 

 If there is no corresponding KCS user (mail originator has no “KCS equivalent”) then the originator is 
defined by the message originator’s (SAPconnect) address type and address: address_type:address, 
where address_type may be FAX, SMTP or X400  
 
The KCS service used for the originator is given by the default notification‘s image format configured 
for the TC/LINK-SC like following: 
- The service will be that assigned to the corresponding prefix. If there is no service assigned to this 
prefix, the default service for FREE address type will be taken. 
- The address type is FREE. 

2.3.5 Enhanced Originator Mapping 

The SAP R/3 user originator address (of fax, SMTP or X.400 address type) can be used now to find a 
KCS shadow user according to (one of) its proxy addresses with the same address type. 
 
 (Proxy addresses are all addresses specified for a specific user within the KCS user profile). 
 
KCS shadow user’s addresses may be active or inactive.  
 
Concerning enhanced fax originator mapping, there is a possibility to take only last n digits (DID digits) of 
SAP originator’s fax number into account and to find corresponding shadow user only according to the 
DID number. 
The length of DID is configured with the registry key TCLINKSC\SAP\SCLinkDIDLen,  default=3.  
If set to a great value like for example 1000 (or missing), the whole originator’s fax number is taken into 
account. Not used at all during SMTP or X.400 originator mapping. 
 
Example 
 
The SAP R/3 user SAPTEST has following own addresses (defined within his SAP user profile): 
 
fax number  0166133852 
SMTP address  separat.bartalsky@sap.topcall.co.at 
X.400 address  C=AT;A=UMI-AT;P=TOPCALL;O=SAP;S=BARTALSKY;GI=NORBERT 
 
KCS user profile TCTEST has the same proxy addresses: 
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The registry key TCLINKSC\SAP\SCLinkDIDLen is set to 3. 
 
If the SAP user SAPTEST sends a fax, SMTP or X.400 via KCS, the message’s originator will be the KCS 
user TCTEST. 

2.3.6 Routing Incoming Faxes to R/3 Users (Example) 

This example shows a possibility how to route incoming faxes to R/3 users without creating and 
maintaining their KCS shadow users. As there is no possibility to make DirSync with TC/LINK-SC, 
operation without shadow users will be the most typical situation in the field. 
 
Requirement 
 
 Assume 600 R/3 users with own fax numbers 0166133-100, 0166133-101, …, 0166133-699 defined 

within their R/3 user profiles.  
 If any incoming fax could not be delivered to appropriate R/3 user (wrong or not defined DID, e.g., 

0166133-900) it should be delivered to SAP System Administrator’s fax number 0166133-000. 
 Incoming faxes should be converted to TIFF G4 format. 
 
Solution 
 
 Create KCS service FXI with prefix S:  
 Set the config line 235 of fax module(s) to FXI$ 
 Create TIFF G4 queue user TCLSCQ4 (if not created automatically by TC/LINK-SC)   
 Add following line to the **ROUTE section of RR99: 

 
**ROUTE 

S:~,TCLSCQ4:FAX:0166133~\TCLSCQ4:FAX:0166133000 

 
This line prepares complete R/3 recipient’s fax number from its fix part 0166133 and DID got from fax 
module (R/3 users must be addressed by their complete fax numbers, not only by DID extensions). 
If R/3 returns non-delivery notification, the fax would be sent to the alternate R/3 fax recipient 
0166133000. 

2.4 Attachment Conversion 
SAPconnect interface provides for full support of binary attachments and also for attachment type 
consisting of three-character long extension (DOC, BMP, TIF etc.) 
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On sending documents from KCS to SAPoffice users, images are converted to the graphical format 
preferred by the mail user (e.g., TIFF, please refer to the TCLINK Manual). 
 
For receiving documents from SAPoffice to KCS, the KCS’s SAPconnect node must be configured for all 
by KCS supported attachment types and the RAW format (which stands for unstructured text data). 
 
These attachment types are defined within SAPconnect node’s format group and should contain: 
 
 all attachment types recognized as images by the TC/LINK-SC (those file extensions configured with 

the “File extension Configuration” screen during TC/LINK-SC setup). 
 all attachment types handled by TCDC (e.g., Word attachments type DOC) 
 
The SAPoffice internal document formats (BIN, GRA, IDC and OTF) need not to be known by the KCS, 
since SAPconnect interface provides their conversion to either Postscript or PCL5 image formats (see 
chapter 4). 

2.5 Notifications 
 TCLINK-SC provides full exchange of delivery and non-delivery notifications between KCS and SAP 

R/3.  
 Read and non-read notifications are supported only from SAP to KCS. (That is, read notification sent 

by SAP will be processed.) 
 
TC/LINK-SC can even force KCS server to send delivery/non-delivery notifications to SAP users, even if 
they had not been requested. 
 
The reason for implementing this feature is a weakness with SAPoffice 3.1G. On sending messages 
SAPoffice users cannot explicitly specify requested notifications from email system. Further, depending on 
different addressing methods used (address book entry, direct addressing), requests for notifications are 
being set differently: no notification requested, or only delivery notification requested (without request for 
non-delivery notification).  
 
The delivery and non-delivery notifications can be forced by setting the following registry value to 1 (by 
Windows registry editor): 
 
Registry: TCLINKSC\SAP\TCDElNotifAlways   (Default: 1) 
 
Attention: The SAP Connect Interface restricts the message text send with notifications to 50 characters. 
So the original mail will not be included to the notification. But it stays in the R/3 system anyhow. 
 

2.5.1 Read Notification Handling 

Registry setting <link>\SAP\ReadNotif = 0  Forces to ignore the sent option ‘registered’ for all mails sent 
in TC  SAP direction. (That is, no read notification will be requested from SAP, and the KCS send order 
termination condition will be set always to ‘delivered’ and not to ‘read’.) 
 
Registry setting <link>\SAP\ReadNotif = 1  Allows the sending of registered mails. 
 
Attention!  If using the <link>\SAP\ReadNotif = 1 setting, then also 
<link>\Topcall\FetchSingleSendOrder=1 must be set for the correct read-notification handling. (Otherwise, 
the separation of read-notifications (sent by SAP) to KCS send orders for mails having more than 1 
recipient and using other addressing then the SAP INTERNET address type addressing (e.g. FAX or 
SMS) is not possible, because the SAP sends the INTERNET address of the recipient as identification of 
the read-notification which is not known in the original send order.) 
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2.6 SAP Message Send Time and Date 

2.6.1 Overview 

The former R/3 3.1x implementation of free configurable “Send Attribute Classes” (=responsible for 
sending later) was so complicated that it was hardly used. 
 
SAP R/3 4.0B or higher reduces the free configurable priorities to 3 possibilities.  
0 – Urgent  ( Dringend ) 
1 – Normal ( Normal ) 
2 – Favorable ( Günstig ) 
 
On SAP, it is possible to assign to each of these send priorities a time-window, which specifies, when the 
message will be sent. Individual time-window definition is possible per RFC node / per address type / per 
send priority. 
 
One such a time-window definition contains the following fields: 
 The field “StartTime” allows to configure when the message will be sent (where as 00:00:00 means 

send immediately) 
 The field “EndTime” allows to configure when the message must be sent latest or be deleted (This has 

no meaning on KCS so it is ignored)  
 The checkbox “Next day” allows to configure that the message will be send on the next day 
 
SAPOffice (prior to 4.6) uses only Urgent – “Send immediately” or Favorable (Low Priority) – “Send at 
night”. Other SAP applications may also use the normal priority. 
 
The SAP applications communicate with SAPconnect by telling only which priority this message has (0, 1, 
2). SAPconnect is responsible for filling the fields correctly. 
 
By default, send time and date for send class 1 is set to 00:00:00 (the midnight) and current day, 
respectively. This means all faxes are sent immediately. 
Send time and date for send class 9 is set to 02:00:00 (2 o’clock am) and next day, respectively. 
So all faxes sent with this class will be sent at 2 in the morning at the next day. 
 

2.6.2 Configuring Send Times on SAP 

SAP send time can be configured on the according RFC nodes. 
 
SAP 3.1 G or higher  see chapter  4.4 
 
SAP 4.0 B or higher  see chapter  4.5 
 
SAP 4.6, 6.x, 7.x  
 
Send times can be configured per RFC node and per address type and per message priority: 
 
 Go to SAPconnect administration: SAP menu: Tools => Business Communication => Communication 

=> SAPconnect (or call transaction SCOT) 
 Go to View => Node 
 Double-click the RFC node you configured for TC/LINK-SC. The node configuration dialog opens. 
 Click the Set button next to the address type (Eg. Fax), you want to configure. It opens a dialog box, 

where the address type parameters can be set. 
 Click to the Restrict button below. The Send times definition window opens: 
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2.6.3 Send Time Support in TC/LINK-SC 

If configured (with the registry setting <link>\SAP\AcceptSAPSendTime=1), TC/LINK-SC takes over the 
send time and date fields belonging to the message. This information will then be used by KCS to delay 
the sending of the message accordingly. The end time and date (latest delivery) fields are not supported 
by TC/LINK-SC. It will not be taken over by TC/LINK-SC and consequently, it will not have any effect on 
the send separate.  
 
Notes: 
 The send time definition does not have any effect on the send separate on SAP side. It is up to the 

KCS system alone to interpret these fields and realize the send separate according to them. 
 

 When sending a message from SAP Business Workplace, SAPConnect sends always the StartTime 
value belonging to the “Normal” priority, even if Priority = “Low” or “High” was set in the mail (Attributes 
tab). Also, setting the ‘Express mail’ flag has no effect. This seems to be an error on SAP side. It was 
recognized with SAP 4.6 and also with SAP 7.0. This separated is a significant restriction on the usage 
of the SAP send time at all. 
 

 If the SendTime support is activated (<link>\SAP\AcceptSAPSendTime=1), then using the relative 
“Latest delivery time” setting in the coversheet of the shadow user/guest user can cause “Delivery 
timeout error”. Reason: the absolute value of the latest delivery time will be computed based on the 
StartTime sent by SAP. So, the “Latest delivery time” setting must be switched off! 
 

 Troubleshooting note: the StartTime are separated in the l_recipients()/set_entry_rs/time_of_day (used 
time-part only, date-part filled with dummy data) and l_recipients() / set_entry_rs / time_date (used 
date-part only, time-part is dummy) TCSI fields. 

2.7 Summary of Error Conditions  
There are certain conditions when a message cannot be converted and delivered to SAP R/3. 
There are three possibilities how the outgoing message from KCS may be handled: 
 
 R/3 may send delivery/non-delivery/read/non-read notification with specific status code 
 R/3 may raise RFC communication exception (on some heavy RFC communication problems) 
 TC/LINK-SC itself may recognize some RFC communication problems that occur during message 

transmission. 
 
All these outgoing messages handling scenarios are converted to appropriate KCS notifications.  
 
The general part of the Link fills the “Error” field with a more general error indication (e.g., “LV … message 
cannot be delivered to mail recipient”). This string comes from the language file, while all “Response” 
messages either come from R/3 or are hard coded English messages. 
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In the following tables, all possible outgoing messages handling scenarios are listed.  
 
R/3 acknowledges the message with delivery/non-delivery, read/non-read notification. 
 
For notifications, there are several “Status codes” defined with SAPconnect interface. Almost all-
corresponding “Response” messages are hard coded English messages. The only exception is the SAP 
Status Code “812”, where the actual “Response” message is provided by R/3. 
 

Action SAP 
Status 
Code 

TCfW Outbox “Response” 
field(TS_LAST_MDA_NOTE) 

Delivered to recipient 701 Delivered successfully 

At next node* 702 No info about delivery 

Read by recipient 703 Read by recipient 

Read by recipient 704 Processed by recipient 

Read by recipient 705 Deleted by recipient 

Not read by recipient 706 Not read by recipient 

Not read by recipient 707 Not processed by recipient 

At next node* 708 Recipient forbids notif. 

Not read by recipient 709 Receiver rejects message 

At next node* 710 Transferred to node 

At next node* 711 Transf. to  epar. System 

At next node* 712 General message from node 

At next node* 713 Transmission costs for message 

At next node* 714 Node started 

At next node* 715 Node finished 

At next node* 716 Status sent successfully 

At next node* 717 Node not resp.for recip. 

KCS retries (BREAK=2) 751 Temporary RFC error 

 752 Partial system error 

 753 Temporary RFC error 

No retries – “inactive-problems” 801 Status cannot be sent 

 802 Recipient not found 

 803 Message has expired 

 804 Invalid transfer params 

 805 Too many recipients 

 806 Recipient address invalid 

 807 Recipient no longer valid 

 808 No route found 

 809 Recipient not contacted at present 

 810 Max.send attempts reached 

 811 Mess. Part can’t be sent 

 812 <Response From R/3> 

 813 Originator address invalid 

 814 Orig address type invalid 

 815 Reference not readable 

 816 Permanent RFC error 

 817 Can’t be proc. In R/3 

 818 Can’t be proc. In node 

 819 Recipient is invalid 

 820 Message can’t be encoded 

 821 Parameters can’t be converted 

 822 Not trans.to separ.system 

 823 Node reports system error, system stopped 

 824 Service not available 
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 825 Table is not complete 

 826 Not proc.no route exists 

 827 Not proc.node is unknown 

 828 Undefined error 

 829 Internal error 

 830 Release incompatibility 

 Undef. Undefined SAP status 

 
(*) If the message has been sent registered, the action is SENT AT NEXT NODE. If not, the message is 
considered being delivered. 
 
R/3 raises RFC communication exception (on some RFC communication problems) 
 
These situations should not normally occur.   
 

Action SAP 
Status 
Code 

TCfW Outbox “Response” field(TS_LAST_MDA_NOTE)/ 
Explanation 

No retries – 
“inactive-
problems” 

None ERR_NODE_UNKNOWN 
The node of the communications component to which the message should be 
forwarded could not be found by the R/3 System from which the message was sent. 

 None ERR_INVALID_VERSION 
The RFC version number entered has an invalid format (see registry 
TCLINKSC\SAP\RFCVersion) 

 None ERR_REC_NOT_SPECIFIED 
Improper coded recipients 

 None ERR_INCOMPATIBLE_VERSION 
The RFC version numbers (first two characters) are different from the RFC version 
number in R/3. 

 None ERR_PAC_NOT_SPECIFIED 
Improper coded attachments  

 None SYSTEM_FAILURE 
R/3 CPI-C user used for TC/LINK-SC, is wrong, does not exist or his password is 
wrong 

 
TC/LINK-SC recognizes some RFC communication problems during message transmission 
 
Typically such situations occur if network connection breaks during transmission. 
 

Action SAP Status Code TCfW Outbox “Response” field(TS_LAST_MDA_NOTE) 

KCS retries (BREAK=2) None RFCOpen Failure 

 None RFCCall Failure 

 none RFCReceive Failure 

 none RFCListen Failure 

 none RFC timeout 
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3. INSTALLATION PREREQUISITES 
TC/LINK-SC supports R/3 release 3.1g or higher until SAP NetWeaver 7.0; on any platform. 
 
The SAPconnect RFC interface is no longer supported for emails as of SAP NetWeaver 7.0 (see SAP 
note 1236270). As an alternative, it is recommended to use TC/LINK-SC7. Fax and SMS messages are 
still supported, but starting with NetWeaver 7.3, you need to use transaction SCON to maintain the RFC 
nodes. 
 
Some additional info: TC/LINK-SC uses SAPconnect and SAPconnect is part of the SAP Web Application 
Server (formerly known as SAP Basis). This means, that the TC/LINK-SC supports every SAP application, 
which runs on the SAP WAS and which uses SAPconnect for sending and receiving messages. An 
example: The latest mySAP ERP 2005 contains the SAP ECC (Enterprise Central Component) 6.0, which 
runs on the WAS 7.00. Therefore you can say that the TC/LINK-SC supports mySAP ERP 2005 or SAP 
ECC 6.0. So if a customer asks “Do we support SAP xxx?”, then you should check (or contact Support) if 
this SAP application runs on SAP WAS. 
 
Summary of known SAP application, which run on SAP WAS (6.x0 or higher) or SAP Basis (4.x): 
 R/3 3.1g – i 
 R/3 4.0x 
 R/3 4.5x 
 R/3 4.6x 
 SAP Enterprise = 4.7 
 mySAP ERP 2004 contains SAP ECC 5.0 
 mySAP ERP 2005 contains SAP ECC 6.0 
 mySAP CRM xxx 
 SAP S/4HANA 
 
TC/LINK-SC uses RFC as connection method. This is achieved by using SAP’s “librfc32.dll”. This library 
contains the necessary function calls to communicate with SAPconnect. Two instances of this DLL are 
between SAP and KCS: One on SAP side and one on KCS side, which is installed with the LINK-SC 
setup. It is recommended to always use the newest versions of the librfc32.dll. The DLL is downward 
compatible, so it should be no problem to use a 6.x version of librfc32.dll with a 4.6x version. 
Nevertheless, it is recommended to stay on the librfc32.dll version which has the same version number as 
the connected SAP system. 
 
Please refer to TC/LINK manual for general KCS server and general link server prerequisites (like license 
keys, required KCS (TCOSS) version, Windows version on the link server etc.) 
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4. INSTALLATION 

4.1 Installation Preparation 

4.1.1 Basic Terms 

TC/LINK-SC product connects the KCS server to the SAP R/3 application server via the SAPconnect 
interface.  
The whole communication between TC/LINK-SC and R/3 application server runs via SAP gateway and 
(optionally) via SAProuter. The communication is based on SAP’s RFC (Remote Function Call) technology 
(please see 2.1). 
 
During its startup, TC/LINK-SC “registers”  (connects to) at the SAP gateway with (free configurable) 
identifier called Program ID. Further, it logs on to the R/3 application server as a CPI-C user.   
 
All RFC connection parameters (network location of SAP gateway, SAProuter and R/3 application server) 
for TC/LINK-SC are stored in SAPRFC.INI file in the TCLINK directory (please see 4.1.4). 
 
On the R/3 side, the SAPconnect node must be created for the TC/LINK-SC. SAPconnect node 
configuration comprises routing, sending options, supported image formats etc.  
 
As to be able to contact specific TC/LINK-SC in the network, RFCDestination will be created and assigned 
to the SAPconnect node.  RFC Destination can be understood as some kind of TC/LINK-SC’s “RFC 
address”.  
But the network path to TC/LINK-SC is configured only indirectly with RFCDestination, via the SAP 
gateway.    
RFCDestination knows only the network location of the SAP gateway where TC/LINK-SC registered and 
TC/LINK-SC’s Program ID that was used for its registration. 

4.1.2 TCP/IP Hosts and Services 

Communication between TC/LINK-SC and R/3 environment (SAProuter, SAP gateway and R/3 application 
server) is based on the TCP/IP transport protocol.  
 
TC/LINK-SC connects to its partner-application by knowing the IP network address of partner-application’s 
host computer, and the TCP port number where the partner-application listens to. On the other hand, 
instead of binary IP network address/TCP port number couple the symbolic host name/service can be 
used: symbolic hosts names are maintained in Windows system file Hosts and symbolic services names 
in file Services.  Hosts file associates symbolic hosts names with their binary IP addresses. Services file 
maintains association of binary TCP ports to symbolic service names. Hosts and Services system files are 
both located in Windows SYSTEM32\DRIVERS\ETC directory. 
 
SAP applications use several TCP ports and following default symbolic service names for them: 
 
sapdp00   3200/tcp 

sapdp01   3201/tcp 

… 

sapdp98   3298/tcp 

sapdp99   3299/tcp 

 

sapgw00   3300/tcp 

sapgw01   3301/tcp 

… 

sapgw98   3398/tcp 

sapgw99   3399/tcp 

 

sapsp00   3400/tcp 

sapsp01   3401/tcp 
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… 

sapsp98   3498/tcp 

sapsp99   3499/tcp 

 
Note: SAP standard services are listed for information only, Kofax technician actually does not need to 
know them. 

4.1.3 SAProuter and Route String 

Typically, TC/LINK-SC will communicate with the SAP gateway and R/3 application server via one or more 
SAProuters (please see 2.1 and 9.7.4). For this purpose, SAP defines a route string.  A route string can 
have one or more sub-strings. Each sub-string contains parameters how to reach the next SAProuter host 
and SAProuter program on it. The route string is case sensitive. 
 
Such a substring looks like: 
 
 /H/host/S/service/P/password 

host symbolic host name or IP address of the target host computer 

service symbolic service name or port number of the program running on the target host computer 

password password for this connection, if needed (normally not used) 

 
If the connection runs via one or more (n) SAProuters, the appropriate route string looks like: 
 
/H/saprouter1/S/service1/P/password1/…./H/saproutern/S/servicen/P/separate/H/targethost 

 
On the other hand, if TC/LINK-SC communicates directly with target host computer (SAP gateway or R/3 
application server), the route string will be only: 
 
targethost 

 
(Without any /H/, /S/ or /P/ switches). 
 
The route strings are being used within SAPRFC.INI configuration file (see 4.1.4) and for this purpose they 
will be input during TC/LINK-SC’s setup (see 4.1.7).  
Please note that the very last sub-string of the route string pointing to the target host, does not contain any  
“target” service. The appropriate target service will be configured at another place, if necessary.  
 
For TC/LINK-SC, it is recommended: 
 
 Use binary IP address and TCP port number for first sub-string of the route string as to avoid entries in 

the hosts and services file on the local link server. If SAP System Administrator gives you symbolic 
service name instead of TCP port for the first sub-string, always insist on getting appropriate binary 
TCP port instead. 
 

 Use symbolic names got from SAP System Administrator for hosts and services in all subsequent 
route-sub-strings without having them entered to local hosts and services files.  These symbolic names 
are being evaluated on SAProuters along the route path – each SAProuter evaluates only those of its 
next route sub-string.  
 

 If only binary IP addresses/TCP ports are available for all sub-strings in the route-string, you may also 
use them for the whole route-string. 

 
Example 
 
Assume RFC communication running via:  
 SAProuter running on the host named “sapgate1”, with IP address 147.204.2.232, listening to the port 

3297 
 With target host named “hs8100” (its IP address unknown for TC/LINK-SC, the association of hs8100 

to its physical IP address is provided on sapgate1 computer) 
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The appropriate route-string would be (without any entries in local hosts and/or services files). 
 
/H/147.204.2.232/S/3297/H/hs8100 

4.1.4 RFC Connection Parameters (SAPRFC.INI File) 

The file SAPRFC.INI contains all connection specific parameters for the RFC library (LIBRFC32.DLL, 
used by TC/LINK-SC) which are needed to: 
 
 connect to an SAP R/3 application server (for RFC client)  
 to register an RFC server program at an SAP gateway and wait for RFC calls from any SAP System. 
 
The SAPRFC.INI file must be in the link directory, or it can be completely defined with full path and file 
names by the environment variable RFC_INI.  
(e.g., set RFC_INI = c:\rfctest\saprfc.ini).  
 
Note: SAPRFC.INI file is created automatically by TC/LINK-SC’s setup in the link directory. Environment 
variable RFC_INI is not used. Please see 4.2.5. 
 
One SAPRFC.INI file may contain separate sections for different types of connections for both RFC’s 
client and server, as well. Each section starts with the line: 
DEST=destination 

 
The connection type for a specific section is given by the line 
TYPE=connection_type 

 
SAP defines five connection types (‘R’, ‘B’, ‘A’, ‘2’ and ‘E’) but TC/LINK-SC uses only two types: ‘R’ for 
RFC server and ‘A’ for RFC client. 

4.1.4.1 Possible Parameters in SAPRFC.INI 

4.1.4.1.1 Connection Type ‘R’, for RFC Server  

Register an RFC server program at a SAP gateway and wait for RFC calls issued by an R/3 System.  
The following parameters can be used: 
 DEST = Destination name 
 TYPE = R 
 PROGID = ProgramID 
 GWHOST = Route string to SAP gateway 
 GWSERV = Service name of the SAP gateway 
 RFC_TRACE = 0/1: OFF/ON, optional; default:0(OFF) 
 
Explanation: 
 

Destination name symbolic name of specific section in SAPRFC.INI, any name possible 

ProgramID with this string RFC server “registers” at the SAP gateway 

Route string to SAP gateway  route string to the host where SAP gateway application runs 

Service name of the SAP 
gateway 

symbolic service or TCP port where SAP gateway application listens to 

4.1.4.1.2 Connection Type ‘A’, for RFC Client  

Connect RFC client to specific R/3 application server. The following parameters can be used: 
 DEST = Destination name 
 TYPE = A 
 GWHOST = Route string to SAP gateway 
 GWSERV = Service name of the SAP gateway 
 ASHOST = Route string to R/3 application server 
 SYSNR = R/3 system number 
 RFC_TRACE = 0/1: OFF/ON, optional; default:0(OFF) 
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Explanation: 
 

Destination name symbolic name of specific section in SAPRFC.INI, any name possible 

Route string to SAP gateway route string to the host where SAP gateway application runs 

Service name of the SAP 
gateway 

symbolic service or TCP port where SAP gateway application listens to  

Route string to R/3 appl. 
Server 

route string to the host where R/3 application server runs 

R/3 system number R/3 system number 

 
Note: TC/LINK-SC’s setup depicts each DEST= section in the SAPRFC.INI files by Windows –like section 
names (e.g., [SRVTCLINKSC] and [CLTCLINKSC]). These entries are completely ignored by RFC library, 
have no influence on the RFC communication and are used only for setup program internal purposes. 
 
Example 1  (direct connection to R/3 application server with IP address 204.108.81.5) 
 
DEST=RFCServer 

TYPE=R 

PROGID= TCLINK.TCLINKSC 

GWHOST=204.108.81.5 

GWSERV=3300 

RFC_TRACE=0 

 

DEST=RFCClient 

TYPE=A 

GWHOST=204.108.81.5 

GWSERV=3300 

ASHOST=204.108.81.5 

SYSNR=00 

RFC_TRACE=0 

 
Example 2  (connection with R/3 application server hs8100 via 2 SAProuters) 
 
DEST=RFCServer 

TYPE=R 

PROGID=TCLINK.TCLINKSC 

GWHOST=/H/193.81.166.10/S/3299/H/147.204.2.232/S/3297/H/hs8100 

GWSERV=sapgw00 

RFC_TRACE=0 

 

DEST=RFCClient 

TYPE=A 

GWHOST=/H/193.81.166.10/S/3299/H/147.204.2.232/S/3297/H/hs8100 

GWSERV=sapgw00 

ASHOST=/H/193.81.166.10/S/3299/H/147.204.2.232/S/3297/H/hs8100 

RFC_TRACE=0 

SYSNR=00 

4.1.5 SAPconnect: Parameters Summary for TC-LINK-SC 

TC/LINK-SC needs following parameters to be entered during its setup: 
 
 SAP R/3 application server IP address (if connected directly not via SAProuters) or route string (if 

connected via one or more SAProuters, please see 4.1.3) and its (R/3) system number, where it should 
log on. 
SAP R/3 application server IP address or route string and R/3 system number will be configured during 
TC/LINK-SC setup and must be provided by SAP System Administrator. 
 

 SAP gateway host IP address (if connected directly not via SAProuters) or route string (if connected 
via one or more SAProuters, please see 4.1.3) and TCP port (or service name), where SAP gateway 
application listens to.  



TC/LINK-SC Version 2.04.01 LINKSC_MAN.doc 

 

Kofax  25/178 
 

 
If TC/LINK-SC connects to the SAP gateway directly (not via SAProuters), the explicit TCP port of SAP 
gateway must be used. If not (SAP gateway accessed via SAProuters), symbolic service name may be 
used instead. 
 
Basically, SAP gateway may run anywhere in the TCP/IP network. But the only supported method is to 
use the SAP gateway running on the R/3 application server. This is not a restriction in the field, since 
on every R/3 application server supporting SAPconnect interface the default SAP gateway is running. 
  
SAP gateway IP address or route string and TCP port or service name must be provided by SAP 
System Administrator. 
 

 R/3 application server user login parameters, the user must be so called CPI-C user. 
 
These parameters are needed by TC/LINK-SC for login into R/3 application server:  
- Client (Mandant) 
- User 
- Password 
- Language (D for German or E for English). 
These parameters must be provided by SAP System Administrator. 
 

TC/LINK-SC Program ID, with this string TC/LINK-SC “registers” on the configured SAP gateway. 
Free configurable string, but the preferred convention is local_host_name.program_name, e.g., 
“PCLINK.TCLINKSC”, is case sensitive. 
May be freely configured during TC/LINK-SC setup, and the same string must be entered during 
RFCDestination setup (R/3 side). 

4.1.6 SAPconnect: Parameters Summary for R/3 Server 

Following configuration points are necessary: 
 
 RFC destination for TC/LINK-SC 

RFC Destination must be created on the SAP R/3 side for TC/LINK-SC, it is based upon three 
parameters:  
– SAP gateway’s host name or IP address (or even a route-string, but this is normally not the case) 
– Service name or TCP port of the SAP gateway  
–TC/LINK-SC’s Program Id (the same as that entered during TC/LINK-SC setup). 
(All of them must be the same as configured during TC/LINK-SC setup). 
 

 SAPconnect node for TC/LINK-SC 
SAPconnect node for KCS must be created on the SAP R/3 side. 
SAPconnect node must be assigned with TC/LINK-SC’s RFCDestination (see above). Further, several 
other node attributes, like format groups, send attribute classes, routing etc. must be configured for 
TC/LINK-SC’s  SAPconnect node, see 4.4.5 and 4.5.6 

4.1.7 SAPconnect: Load Balancing KCS -> R/3 Server 

Load Balancing is realized on KCS using the ability of links to poll the same queue. This means, if you 
want to use Load Balancing, following requirements must be met: 
 install two or more LINK-SC 
 the program ID can be different for the direction KCS -> R/3 
 the links must poll the same queue, i.e., the name of the queue must be the same 
 the service names can also be different, but it makes no sense, if they use the same queues 
 
If these settings are made, the so-called “parallel links” will perform load balancing on KCS side, i.e., if a 
message is waiting in the queue, the first free link will take it and send it out to SAP (see diagram below). 
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4.1.8 SAPconnect: Load Balancing R/3 Server -> KCS 

Normally, one R/3 Gateway Process is responsible for communication with external application like 
TC/LINK-SC.  
 
SAPconnect “knows” by the RFC Configuration where to start the Send Process. To implement R/3 load-
balancing for out-going messages follow these instructions: 
 
During the configuration of the RFCDestination (see also 4.4.3 for 3.1G respectively 4.5.3 for 4.0) leave 
the Gateway Parameters empty. SAPconnect now connects over the local Gateway Process of the 
Application Server, which initiates a Send Process.  
 
Of course, each Application Server, which starts a send process, must be connected to a TC/LINK-SC 
instance. Otherwise the messages would never be retrieved. It is also possible to register more than one 
LINK-SC to one application server to get load balancing even if there is only one application server 
available (see diagram on next page). 
 

 
 
Now Load Balancing on R/3 is established, if multiple send processes are scheduled. 
 
There are two possibilities: Either use a fixed Application Server (only possible with transaction SM36) or 
use any Batch Server (that means an Application Server which has configured a Batch-work process). 
 
The first possibility is less flexible regarding Load-Balancing and failsafe. 
 
SAP recommends to plan a couple of SAPconnect Send Processes with shifted time intervals fix on 
different Batch Server (not necessarily on every Batch-Server). Each Batch Server must be connected to 
one TC/LINK-SC.  
 
There exists a known error, that parallel send processes on one application server, can cause duplicate 
messages, because of an error in the locking mechanism. This error was solved with release 4.6. For 
releases 4.0x – 4.5x there exist a workaround. See OSS note 148471. 

4.2 TC/LINK-SC Setup 

4.2.1 Two Installation Modes 

KCS links can be installed in two different ways: 

Applicaton 
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Server 2 
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 Easy installation 
 Advanced installation 
See TC/LINK Manual for the general differences between these installation modes. 

4.2.2 Installation Steps on the KCS Server 

4.2.2.1 Licenses  

Get the required license keys and enter them to the KCS server. Please refer to the TC/LINK manual for 
detailed information.  

4.2.2.2 KCS 

Please check if the TCOSS version you are using is supported. Please refer to the TC/LINK manual for 
information about the minimum required TCOSS version and about restrictions for specific TCOSS 
version. 
 
You also have to know the KCS (TCOSS) server name, the transport type (RPC or Native) and the link 
type (e.g., TCP/IP) to connect to the KCS server. 
 

4.2.2.3 Create the KCS Link User  

The default name for the link user name is “TCLINK”. From TCOSS 7.22 on this user is automatically 
created during initial KCS installation with password “TCLINK”. Please refer to TC/LINK manual for 
detailed information.  

4.2.2.4 Create KCS Dependencies 

The KCS dependencies can be created automatically when the link starts. Please refer to TC/LINK 
manual for detailed information. If you disable this feature, you have to create KCS objects according to 
section 4.2.7 manually. You may not need to create link queue users for all available formats. Choose 
only those which are required.  

4.2.3 Installation Steps on the Link Computer 

4.2.3.1 Windows Link User Account  

There is no need to create a specific Windows user account for TC/LINK-SC. The link will be started with 
the system account.  

4.2.3.2 Windows TCDCEXE User 

If the document converter is necessary for TC/LINK-SC operation you need to know the user name, the 
password and the domain information of this user. Start setup when you are logged in with this user. 
Setup assumes the user name and domain of the currently logged in user are from the document 
converter user. It just asks for the password. 
 
This information only is required if you are operating TCDC in foreground mode. 

4.2.4 Run Setup Program 

 Log in to the Link PC. 
 Run SETUP32.EXE from the installation disk.  
 Select the TC/LINK-SC Link 
 To start setup, press the “Install” button.  
 Please refer to the TC/LINK manual for information about the general part of the installation. 

4.2.5 Easy Installation 

Use this mode for typical new installation (faxing only, no SMTP and/or X.400 addressing) and for update. 
If used for update, settings of the older installation are preserved. 
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As only fax operation is assumed, no own SMTP and X.400 are entered via input screens. 
Setup program sets the own SMTP domain to default value “topcall”, in order to make sending from KCS 
user to SAP R/3 possible.  Thus, the message originator (KCS user) will be set to   
TCUserId@topcall. Please see 2.3.3). 
 
Even in the easy installation mode, several SAPconnect specific parameters must be entered within 
following two setup screens: 
 
SAPconnect parameters setup screen 

 
 
All parameters being input in this window specify the R/3 application server and the SAP gateway where 
TC/LINK-SC is connected to. 
According to these parameters, the setup program generates the SAPRFC.INI file located in the TC/LINK-
SC directory. This file is being used by the SAP’s LIBRFC32.DLL (RFC library). For detailed description of 
SAPRFC.INI file, please see 4.1.4. 
 
Program ID (entry only in SAPRFC.INI file): With this string TC/LINK-SC registers on the configured SAP 
gateway. 
Free configurable string, but the preferred convention (and default value) is 
local_host_name.program_name, e.g., “PCLINK.TCLINKSC”, is case sensitive.  
Note:  The same Program Id string must be entered during RFCDestination setup (R/3 side). 
 
SAP gateway server (Route string) (entry only in SAPRFC.INI file): The IP address or host name (if 
connected directly, not via SAProuter) or route string (if connected via SAProuter) to the SAP gateway 
server. It must be provided by SAP System Administrator. 
Important: If TC/LINK-SC and SAP Server are located in different IP subnets and there is a firewall/router 
inbetween doing network address translation (NAT), then host name instead of IP address must be used 
and made sure, that this hostname is resolved to the correct IP address (using DNS or hosts file entry) on 
each side of the firewall. Reason: In case of NAT  eparated subnets the IP address is only meaningful for 
one side of the network, the host name, on the othe hand, can be translated to the “correct” IP address on 
each side of the firewall. This remark applies not only for the SAP gateway server definition but also for 
the SAP application server definition below. 
 
SAP gateway service name (entry only in SAPRFC.INI file): SAP gateway service name or TCP port 
number where the SAP gateway application listens to.  If connected directly this must be the binary TCP 
port. If connected via SAProuters, this may be the symbolic SAP gateway service name (since SAP 
symbolic services are evaluated on SAProuter computers. 
It must be provided by SAP System Administrator. 
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R/3 application server (Route String) (entry only in SAPRFC.INI file): The IP address or host name (if 
connected directly not via SAProuters) or route string (if connected via SAProuters) to the SAP R/3 
application server.  It must be provided by SAP System Administrator.  
Host name instead of IP address must be used here if the TC/LINK-SC machine and the SAP application 
server are NAT separated. See also the according remark above at the SAP gateway server definition. 
 
R/3 System number: the key for R/3 application server’s system number (entry in SAPRFC.INI file): 
System number of the R/3 application server, must be given by SAP System Administrator.  
 
Corresponding SAPRFC.INI file (created by setup) 
 
[SRVTCLINKSC] 

DEST=SRVTCLINKSC 

TYPE=R 

PROGID=SAPGW.TCLINKSC 

GWHOST=/H/192.1.52.1/S/3297/H/hs8100 

GWSERV=sapgw00 

RFC_TRACE=0 

 

[CLTCLINKSC] 

DEST=CLTCLINKSC 

TYPE=A 

GWHOST=/H/192.1.52.1/S/3297/H/hs8100 

GWSERV=sapgw00 

ASHOST=/H/192.1.52.1/S/3297/H/hs8100 

RFC_TRACE=0 

SYSNR=00 

 
R/3 login parameters setup screen 
 

 
 
Key for R/3 application server’s client  (registry TCLINKSC\SAP\RFCClient): Client (Mandant) for R/3 
application server, where the TC/LINK-SC logs in.  Must be provided by SAP System Administrator.  
 
Key for R/3 application server’s user  (registry TCLINKSC\SAP\RFCUser):  CPI-C user name on R/3 
application server, within the client area specified above.  Must be provided by SAP System Administrator.  
 
Key for R/3 application server’s password  (registry TCLINKSC\SAP\RFCPassword): R/3 application 
server user’s password. It must be provided by SAP System Administrator. See chapter 4.2.11 for more 
information on password restrictions. 

4.2.6 Advanced Installation 

In advanced installation mode, all setup options can be configured. Use this mode for installations, where 
also SMTP and/or X.400 addressing should be used. 
SAPconnect specific parameters must be configured with four setup screens. Two of them are the same 
as with Easy Install (see above), and two additional setup screens: 
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X.400 and SMTP domains (used only for SMTP and X.400 addressing) 

 
 
Own SMTP domain:  (Registry: 
SAP\SCLinkSMTPDomain) 

TC/LINK-SC’s own (virtual) SMTP domain 
 
Own X.400 domain:  (Registry: 
SAP\SCLinkX400Country 

SAP\SCLinkX400ADMD 

SAP\SCLinkX400PRMD 

SAP\SCLinkX400Org 

SAP\SCLinkX400OU1) 

TC/LINK-SC’s own (virtual) X.400 domain 
 
Note: For more details for TC/LINK-SC’s virtual domains, please see 2.3.2. 
 
SAPconnect advanced settings: 

 
 
KCS service to send via TC/LINK-SC using SAPconnect fax address type  (registry 
TCLINKSC\setup\ServiceSCFAX): KCS service with FREE address type, prefix default_link_queue:FAX: 
Default: SCFAX. 
 
KCS service to send via TC/LINK-SC using SAPconnect SMTP address type  (registry 
TCLINKSC\setup\ServiceSCSMTP): KCS service with FREE address type, prefix 
default_link_queue:SMTP: 
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Default: SCSMTP. 
 
KCS service to send via TC/LINK-SC using SAPconnect X.400 address type  (registry 
TCLINKSC\setup\ServiceSCX400): KCS service with FREE address type, prefix default_link_queue:X400: 
Default: SCX400. 
 
Requested notifications from SAP:  (Registry: TCLINKSC\SAP\ReadNotif)  
If set to 0, it disables the ‘registered mail’ handling. That is, the send option ‘registered’ will be ignored for 
all mails, no read notification will be requested from SAP for mails sent with the ‘registered’ flag and the 
KCS send order will be terminated already on delivery. Default is 0. 
Setting to 1 enables the ‘registered’ mail handling. 
Trace Level   (registry TCLINKSC\SAP\TraceLevel): Bitwise oriented trace level for SAPconnect specific 
part of TC/LINK-SC.  
 

Value Bit Description 

0 - no trace 

1 Bit 0 (LSB)  Trace all errors into the trace file. 

3 Bit 1 trace of RFC access functions (trace entry at function call and return). 

7 Bit 2  Trace of function call hierarchy and open objects.  

 
Default is 1. 
 
RFC time-out:  (Registry: TCLINKSC\SAP\RFCTimeout): The time in seconds TC/LINK-SC would wait for 
immediate (synchronous) notifications from R/3 application server, after having transmitted a message. 
Default 100 seconds. 

4.2.7 Automatic Creation of KCS Dependencies 

TC/LINK-SC needs several objects on KCS in order to work properly. These KCS objects are called “KCS 
dependencies”. 
The only KCS object that must exist (e.g., created via TCfW) before TC/LINK-SC starts, is the TCLINK 
user used by TC/LINK-SC to log in to the KCS server. All other KCS objects may be created 
automatically. 
 
For new installation of version TC/LP 1.09 or higher, this feature is activated by default.  
 
For version updates from TC/LP 1.08 or less the feature is disabled by default. All dependencies already 
exist for these updates. 
 
The following dependencies are created automatically during link startup if they do not exist. If they exist 
with different properties, the link will write an event log and terminate. Please check the event log in case 
of problems. 
 

Description Default name Registry subkey More information 

Link queue users TCLSCQ+image 
formats 
“I01234PBDGMN” 

  

Guest User GUEST Setup\GuestUser TC/LINK-MANUAL 

Default FAX service FAX Setup\ServiceFAX TC/LINK-MANUAL 

Default FREE service FREE Setup\ServiceFREE TC/LINK-MANUAL 

Default TOPCALL service TOPCALL Setup\ServiceTC TC/LINK-MANUAL 

Service SCFAX for sending 
to SAP FAX recipients via 
TC/LINK-SC 

SCFAX Setup\ServiceSCFAX Service has FREE address 
type, and prefix 
Default_link_queue:FAX: 

Service SCSMTP for 
sending to SAP SMTP 
recipients via TC/LINK-SC 

SCSMTP Setup\ServiceSCSMTP Service has FREE address 
type, and prefix 
Default_link_queue:SMTP: 

Service SCX400 for SCX400 Setup\ServiceSCX400 Service has FREE address 
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Description Default name Registry subkey More information 

sending to SAP X.400 
recipients via TC/LINK-SC 

type, and prefix 
Default_link_queue:X400: 

Default template DEFTEMP in link 
user’s message 
folder 

Setup\DefaultTemplate TC/LINK-MANUAL 
(Used for guest user, should 
also be default template for 
link user. Has to be checked 
with TCfW.) 

ONLYIMG template ONLYIMG in link 
user’s message 
folder 

Setup\OnlyImgTemplate TC/LINK-MANUAL 

Delivery Coversheet SCDEL CVR in link 
user’s message 
folder 

Setup\DelNotifCover Used by TC/LINK-SC as 
additional information (max. 50 
characters) sent with Delivery 
notification to SAP R/3  

NonDelivery Coversheet SCNONDEL CVR 
in link user’s 
message folder 

Setup\NonDelNotifCover Used by TC/LINK-SC as error 
information (max. 50 
characters) sent with Non-
delivery notification to SAP R/3   

 
Registry key “TCLINKSC\Setup\CreateDependenciesTopcall” is a flag that tells TCLINK whether it must 
check and create these KCS dependencies. It is set to 1 by SETUP. Whenever TCLINK starts and finds 
“Setup\CreateDependenciesTopcall” set to 1, it checks and creates the dependencies. TC/LINK does not 
reset this flag, so by default, dependency check is done at every link start.  
 
Creation of KCS dependencies may be disabled by setting 
“TCLINKSC\Setup\CreateDependenciesTopcall” to 0. 
 
Please refer to the TC/LINK manual for detailed information about this feature 

4.2.8 Multiple TC/LINK-SC Instances on One Link Server 

SAPconnect interface itself, in contrary to SAPcomm, is not able to perform message routing among 
several different SAP R/3 instances, and among several clients (in German, “Mandanten”) of one R/3 
instance. In order to fulfill this task, typically several instances of TC/LINK-SC will have to be installed on 
one link server.  
 
The customer will need one TC/LINK-SC instance per each client (“Mandant”) of each R/3 instance 
available. 
 
There are two ways of creating multiple instances. One is by re-running the Setup with a changed 
DEFAULTS.INI, the second way is to use the KCS Monitor Add-on available since version 1.12.03. 

4.2.8.1 Creating Multiple Instances via Setup 

Additional steps are necessary to prepare the installation of additional instances. All required changes can 
be made in the file DEFAULTS.INI. 
 
1. Install the first link using the default setup.  
2. For each additional instance do the following changes: 
 
Change the defaults.ini of the package you install. Normally the defaults.ini is located at Disk1of the 
installation pack. 
 
In DEFAULTS.INI, section [TCLINKSC_INSTANCE] 
 Change the registry subkey name, e.g., from TCLINKSC to TCLINKSC2. 
 Change the display name, e.g., from TC/LINK-SC to TC/LINK-SC 2 to get a second icon. 

 
in DEFAULTS.INI, section [TCLINKSC] 
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 Change the section name according to the new subkey name, e.g., from TCLINKSC to TCLINKSC2. 
 Change the KCS queue name (has to be different for each instance), e.g., from TCLSCQ to TCLSC2Q 
 Change the service names (has to be different for each instance), e.g., from SCFAX, SCX400 and 

SCSMTP to SCFAX2, SCSMTP2 and SCX4002 
 
Then start setup to install the additional instance of the link. 
Setup program creates one SAPRFC.INI file (see 4.1.4) for all TC/LINK-SC instances. Each instance will  
have two DEST= sections in this SAPRFC.INI file. 
 
Note: It is recommended to always perform these installation steps, and not manually by saving and 
restoring registry subkeys “TCLINKSC” for all next instances of the TC/LINK-SC! 
 
After finishing the installation of all your links you can change back your defaults.ini to get the defaults for 
a new installation. 

4.2.8.2 Creating Multiple Instances with KCS Monitor Add-on 

 
The preferred method creating a new instance is to use the KCS Monitor together with TC/LINK-SC Add-
on. 
 
 Start the KCS Monitor on the Link Server and select the local server. 
 Select the instance of the link you want to copy 
 Select copy (using the context menu or the menu entry in the edit menu) 
 Select paste and follow the change the mandatory parameters with the wizard (for a more detailed 

description pls. Refer to the Add-on directory) 
 
The new instance is now ready to run. Repeat the process for each instance you want to create. 
 
See chapter 5 for details. 

4.2.9 Multiple TC/LINK-SC Instances on Different Link Servers 

It is possible to install several TC/LINK-SC instances on different link servers and connect them to the 
same client within the same R/3 instance. This improves performance and provides better fault tolerance. 
 
On the KCS side, all TC/LINK-SC instances have to: 
 Use the same link user and the same link queue users on KCS. Otherwise, no failure operation would 

be possible, since each link would process its own messages from KCS only.  
 Use the same registry subkeys (default setup) for all instances. 
 
On the SAP R/3 side, all TC/LINK-SC instances have to: 
 Use the same CPI-C user to log in 
 Use the same connection parameters (route strings) for R/3 application server and SAP gateway 
 Use the same Program Id for each TC/LINK-SC 

(all TC/LINK-SC instances would register at the same SAPgateway with the same Program Id) 
 
For the typical fault tolerant installation, on each link server several TC/LINK-SC instances would be 
running in order to handle several clients and/or R/3 instances at the customer site. 
 
Example 
The customer has one R/3 instance (system number 00) and 4 clients 010, 020, 030 and 040. Each client 
should be served by two TC/LINK-SC instances running on different link servers. 
 
Following installation steps are recommended: 
 
 Install 4 TC/LINK-SC instances on the first link server, one instance per client, according to guidelines 

in 4.2.8 (each instance having different connection parameters to R/3 and different queue users on 
KCS server). 
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 Repeat the same steps on the second link server, for each TC/LINK-SC instance serving specific client 
take the same connection parameters to R/3 and queue users on KCS server as those of TC/LINK-SC 
instance on the first link server, serving the same client. 

4.2.10 Updating Multiple Instances of TC/Link-SC 

As the TCMON Add-On is not designed to make any updates, just to create quickly a new instance, you 
have to run the setup program at least once for one instance. This will ensure that you have the new 
.EXE, .DLL and MAP files. The other instances will use these new files automatically. 
 
But of course, updating only one time is only sufficient for the case that no additional registry entries were 
added to this newly released link (new features using new registry keys). In this case (when running the 
Setup only once) only the updated instance will have the new registry keys, all other instances will not 
have the new registry keys. 
 
Therefore, if also new registry keys have to be created by the setup program, you have the possibility, 
either to create this (in most cases only few) registry keys manually for each instance or really to adapt the 
Defaults.ini for each instance and run the setup program then once for each instance. It is recommended 
to use the second option and do not enter the registry keys manually, because of the possible 
inconsistencies, which can occur if it is not done properly. 

4.2.11 Password Restrictions of the LIBRFC32.DLL 

During installation of TC/LINK-SC two versions of LIBRFC32.DLL are copied to the link installation 
directory (default: “C:\TCOSS\TCLP”). The active one will be the newest release (7100.4.172.6307) of it. 
The second one will be an older one (6204.4.793.3955) and is inactive as long as it is not copied over the 
old one. It has a different filename (librfc32.6204.4.793.3955.dll). The reason for providing two versions is 
a changed behavior regarding passwords. See following table: 
 

LIBRFC Version MaxPasswordLength Case-Sensitivity Compatibility 

< 7.x 8 characters only upper-case 
characters are 
supported 

Can work with versions 7.x, as long as the 
max length of 8 chars is fulfilled and upper 
case passwords are used in TC/LINK-SC and 
SAP 

>= 7.x 40 characters Case sensitive, i.e. 
upper and lower 
case passwords 
supported 

Can work with versions below  7.x, as long as 
the max length of 8 chars is fulfilled and upper 
case passwords are used in TC/LINK-SC and 
SAP 

 
If you connect multiple TC/LINK-SC instances from one PC to different versions of SAP (both <7.x + 
>=7.x) then it is recommended to use the <7.x version of the LIBRFC32.DLL and fulfill the requirements it 
needs. 

4.2.12 Registry Keys Summary 

For TCLINK registry keys please refer to the TCLINK manual. 
The following table lists only SAPconnect-specific registry keys. 
 

Registry Description 

TCLINKSC\SAP\ReadNotif 
(DWORD) 

Enables registered mail handling for TC  SAP mails 
0 => the send option ‘registered’ will be ignored for all TC  SAP 
mails, no read notification will be requested from SAP for mails 
sent with the ‘registered’ flag and the KCS send order will be 
terminated already on delivery. 
1 = > enables sending registered mails in TC  SAP direction. 
Read notification will be requested from SAP for mails sent with 
the ‘registered’ flag and the KCS send order will be terminated 
only on the read event and not on delivery. 
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Registry Description 

TCLINKSC\SAP\RFCClient 
(STRING) 

R/3 application server’s client 
Client (Mandant) for R/3 application server, where the TC/LINK-
SC logs in.  Must be provided by SAP System Administrator. 

TCLINKSC\SAP\RFCCLTrace 
(DWORD) 

RFC client traces 
Reserved value, should not be changed. Default is 0. 

TCLINKSC\SAP\RFCDestination 
(STRING) 

RFC server destination name  
Denotes which section in the SAPRFC.INI file belongs to the RFC 
server, filled automatically by the setup program. Default is 
“RfcServer”. 

TCLINKSC\SAP\RFCLanguage 
(STRING) 

R/3 application server’s language 
Language, in which error messages and trace information are 
provided by the R/3 application server. Must be provided by SAP 
System Administrator. You should use the same short name (e.g., 
DE), as you use in the GUI. 

TCLINKSC\SAP\RFCPassword 
(STRING) 

R/3 application server user’s password.  Must be provided by SAP 
System Administrator. See chapter 4.2.11 for password 
restrictions. 

TCLINKSC\SAP\RFCPollCycle 
(DWORD) 

Poll cycle for RFC Server 
Poll cycle for the RFC server (receiver) in seconds. Automatically 
set to the  same value as has been set for general TCLINK 
registry key  General\PollCycle 

TCLINKSC\SAP\RFCR3Destination 
(STRING) 

RFC client destination name 
Denotes which section in the SAPRFC.INI file belongs to the RFC 
client, filled automatically by the setup program. Default is 
“RfcClient”. 

TCLINKSC\SAP\RFCTimeout 
(DWORD) 

RFC time-out 
The time in seconds TC/LINK-SC would wait for immediate 
(synchronous) notification from R/3 application server, after 
having transmitted a message. Default is 100 seconds. 

TCLINKSC\SAP\RFCUser 
(STRING) 

R/3 application server’s user 
CPI-C user name on R/3 application server, within the client area 
specified above.  Must be provided by SAP System Administrator. 

TCLINKSC\SAP\RFCVersion 
(STRING) 

RFC Version 
RFC Version in use, set to “0101” by setup program. Must not be 
changed. 

TCLINKSC\SAP\RFCNewCallingMethod 
(DWORD) 
 

Use the modified RFC calling method – according to Error-13571, 
Error 13066 
0 – old calling sequence (default) 
1 – new calling sequence 

TCLINKSC\SAP\SCLinkDIDLen 
(DWORD) 

DID Length 
The length of DID extension used for Enhanced originator 
mapping (see 2.3.5  Default is 3. 
If you do not want to use this feature set this value to 1000 
assuming that no fax number is that large. 

TCLINKSC\SAP\SCLinkSMTPDomain 
(STRING) 

Own virtual SMTP domain 
TC/LINK-SC’s own virtual domain. This virtual domain can be 
used for placing KCS addressing information in a dummy SMTP 
address when sending messages from SAP. General format for 
this kind of addressing with virtual domain looks like this: 
[service#]number[#answerback]@virtual_domain 
Read more in chapters “Addressing Using Virtual Domains” and 
“Virtual Domains for KCS Server”. 
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Registry Description 

TCLINKSC\SAP\SCLinkX400Country 
TCLINKSC\SAP\SCLinkX400ADMD 
TCLINKSC\SAP\SCLinkX400PRMD 
TCLINKSC\SAP\SCLinkX400Org 
TCLINKSC\SAP\SCLinkX400OU1 
(STRING) 

Own X.400 domain 
TC/LINK-SC’s own (virtual) X.400 domain. 

TCLINKSC\SAP\TCDelNotifAlways 
(DWORD) 

Controlling KCS Delivery Notifications 
If set to 1, TC/LINK-SC acknowledges all incoming messages 
from SAP R/3 with delivery/non-delivery notification even if they 
have not been requested by the SAP R/3 message’s originator. If 
set to 0, TC/LINK-SC sends delivery /non-delivery notifications to 
SAP R/3 originator only if he has requested them. Default is 1. 

TCLINKSC\SAP\TempPath 
(STRING) 

Directory for temporary files. If does not exist, automatically 
created by setup. This directory is used to stored temporarily all 
incoming messages and notifications from SAP R/3 in files named 
SCM*.TMP (messages) and SCN*.TMP (notifications). Default is 
C:\TCOSS\TCLINK\SCTEMP 

TCLINKSC\SAP\TestMode 
(DWORD) 

Test Mode  
Switch to make local loop tests via local SAP gateway possible.  If 
set to 1, local tests are possible. Default is 0. 

TCLINKSC\SAP\TraceLevel 
(DWORD) 

Trace Level 
Bitwise oriented trace level for SAPconnect specific part of 
TC/LINK-SC (see also 4.2.6). 

TCLINKSC\SAP\BinaryAttachments 
(DWORD) 

Controlling the behavior of TXT blocks 
Because of error #8640 the TC/LINK-SC saves every SAPconnect 
content block, after the first one, as a binary attachment. If the 
customer does not want this behavior, then you can change this, 
by creating the following new registry key and set it to 1 
0 … TXT blocks are saved as binary blocks 
1 … TXT blocks are saved as text blocks and BIN blocks as 
binary attachments. 

TCLINKSC\SAP\IgnoreFileName 
(DWORD) 

Controlling the behavior of SAP file names 
A new registry key disables the original file name and creates a 
pseudo file name 
0 … Original file name will be used. 
1 … Pseudo file name, like “Attachment.doc”, will be used. 

TCLINKSC\SAP\UseSAPCostCenter 
(DWORD) 

Using SAP Cost Center 
When the customer applies the SAPNote 680495, which is 
needed if you want to use the SAP User-ID as originator of a fax, 
also the SAP cost-center is filled into a SAPconnect field. If you 
want to use this information also as the KCS cost-center you have 
to set following registry value 
0 … (Default) no change 
1 … Use the SAP cost center as the KCS cost center 
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Registry Description 

TCLINKSC\SAP\ChangeOrig 
(DWORD) 

Using the SAP User ID as originator 
It is now possible to use the SAP User ID as the originator of 
faxes/SMSs instead of the original sender fax number or SMS 
sender number. This is used for cost accounting, as often the fax 
addresses/SMS sender number of the SAP users are not unique 
or correct. This feature can be used, by setting the registry key: 
0 … (Default) no change 
1 … change originator to User ID 
Additionally you have to customize SAP to send the required info 
in the message object, as it is not included in the standard 
SAPconnect interface. The customer has to apply the SAPNote 
680495. 
For the enhanced shadow user mapping for fax, it is necessary to 
change the TCLSC.MAP file (you have to add a REM in the 
TO_TC_ORIG section, marked in blue): 

ENTRY ------- FAX enhanced origmapping 

FAX 

SET_FREE_ADDRESS 

* 

SET_FREE_ADDRESS 

 

SEARCH_USER_ADDRESS 

SRC.TS_FREE_ADDR 

“” 

REM or REG.Setup\ServiceSCFAX\Name 

REM REG.SAP\SCLinkDIDLen 

Then you have to specify inactive addresses for every user with 
the service (e.g.) SCFAX (= SAP fax service) and as the number 
the SAP User-ID. 

TCLINKSC\SAP\EnableEncryption 
(DWORD) 

Enable Encryption 
0 … (Default) no change 
1 … TC/LINK-SC reads out the “TO_DO_OUT” field and puts it 
into the “TS_FILE_NAME” value of the message. 
This feature is only in combination with the TC/Encryption Link-
Exit useful.  
More Info: 
On the SAP side, you must set the “TO_DO_OUT” field in the 
SAPconnect interface to indicate whether a message should be 
encrypted/signed or not. 
You can find a list of the corresponding values below.  
This value will be available in the TS_ENV_NAME_POSTED field 
in the TC/Report database. 
A character (‘0’ to ‘7’) is used to indicate whether the message 
should be encoded/signed or not. 
‘0’… Not encoded, not signed, format PGP 
‘1’… Not encoded, not signed, format S/Mime 
‘2’… Encoded, not signed, format PGP 
‘3’… Encoded, not signed, format S/Mime 
‘4’… Not encoded, signed, format PGP 
‘5’… Not encoded, signed, format S/Mime 
‘6’… Encoded, signed, format PGP 
‘7’… Encoded, signed, format S/Mime 

 

4.3 Installation Steps on SAP R/3 Application Server 
The installation procedure depends on the SAP release version: 
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Installation on SAP R/3 Release 3.1 G – 3.1 I Please read 4.4 

Installation on SAP R/3 Release 4.0 B Please read 4.5 

Installation on SAP R/3 Release 4.6 x Please read 4.6 

Installation on SAP R/3 Release 6.20 (= SAP Enterprise 4.7) Please read 4.7 

Installation on SAP R/3 Release 7 Please read 4.8 

 

4.4 Installation on SAP R/3 Release 3.1 G – 3.1 I 
Note: To distinguish between the digit zero and the capital letter O it will be displayed like this: 
 

Digit zero Ø 

Capital letter O O 

 
Warning: Most entries are case sensitive! 

4.4.1 Logon to SAP R/3 Application Server with SAP GUI 

Log on into the R/3 system with the normal “Dialog” R/3 user (NOT CPI-C user!) 

 

4.4.2 Create CPI-C User for TC/LINK-SC 

Start transaction SUØ1. 

 
 
Type in the user name and click create. 

 
 
Enter the password. 
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User type CPIC. 
Assign the authorization profile S_A.SCON. 
Save the user. 
 

 

4.4.3 Set Up RFCDestination for TC/LINK-SC 

Return to the SAP R/3 Screen and start transaction SM59 

 
 
Click Create. 

 
 
Choose the name for the destination (e.g., BC-CON_TOPCALL) 
Enter TC/LINK-SC’s Program ID, case sensitive (e.g., SAPGW.TCLINKSC, where SAPGW is the 
TC/LINK-SC workstation name. Must be the same, as configured during TC/LINK-SC setup). 
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Set the connection type to ‘T’ (TCP/IP connection). 
Click the “Registration” button (set the Activation Type to Registration). 

 
 
Click the “Gateway” button and set the Gateway parameters (of the SAP gateway running on the 
TC/LINK-SC workstation). Gateway host and service must be the same as configured during TC/LINK-SC 
setup. 
 
Note: After starting the SM59 transaction, the “Gateway” button may not be visible on the screen. In this 
case choose the Menu Destination -> Gateway options as to activate it. 
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4.4.4 Test RFC Connection to TC/LINK-SC 

Verify if the RFC connection to TC/LINK-SC works. Click the “Test Connection” button. (TC/LINK-SC and 
SAP gateway must be running, of course). 

 

4.4.5 Set Up SAPconnect Node for TC/LINK-SC 

Return to the SAP R/3 Screen and start transaction SCOA. 

 
 
Click Configuration. 
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Now the following screen appears: 

 
 
Assign SAPconnect communication method to those address types (FAX, INT for SMTP or X40 for X400 
address types) which should be handled by SAPconnect interface. 
Note that one address type can be assigned ONLY to one particular communication method. 
All address types which should be handled by TC/LINK-SC, MUST be assigned to SAPCONNECT 
communication method. 

 
 
Create appropriate the Format Group for KCS. Choose proper name for KCS’s format group. There may 
be different format groups for each address type supported (e.g., TOPFAX for FAX and TOPMAIL for 
SMTP and X.400). 
Format Group must contain all format types supported by KCS, e.g., TIF, BMP, DOC etc. In any way, do 
not forget the format type Postscript (PS), since all internal SAPoffice format types may be converted to 
Postscript (depending on Conversion Rules below). 
 
Example (below) 
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Add a conversion rule (optional) 
SAP Internal formats not supported by the node (KCS) can be converted using SAP conversion modules, 
which convert respectively OTF formats into PDF, PS or RAW formats, ALI into RAW and SCR format into 
OTF. 
In the Ranking order column, determine the ranking order (1-9) in which the conversion rules are to be 
processed by the system. If the node supports several formats conversion takes place into the lowest-
ranking format.  
 
Example (below) 
The ranking order established means that OTF formats are converted as priority into PDF, PS or PCL 
formats. With the format group TOPFAX (see above), the conversion of OTF to PS would take place. 
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Nodes 
The following specifications can be made for the node: 
 Node (6-character, freely-definable name, e.g., TOPCON) 
 Comment 
 RFC destination (that created for KCS) 
 Country in which the node is situated (important for determining dialing codes for fax servers) 
 Path reference (marked, node can delete path references). 
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Node Attributes 
 The Address types, which can be processed by a node are established in the node attributes (FAX, 

X40 for X400 address type or INT for SMTP address type). 
 For each node/address pair, the Format Group is stated with the formats (see Format Groups above), 

which can be processed by the node when using the corresponding address type. 
 The device type to be used for the SAPscript-output from R/3 applications. The device type is defined 

in the SAPspool administration. 
Note that the device type depends on the format into which OTF documents are converted (see 
Conversion Rules above): PDF and PS require device type POSTSCPT that should be the default device 
type for KCS. 
 

 
 
Routing 
Routing specifies which messages should be transmitted via the respective node. 
 
Example (below) 
The node TOPCON gets all messages with FAX, SMTP and X.400 recipients for transmission to Austria 
(AT) and Slovakia (SK). 
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Send Attributes 
The send attribute classes cover parameters which are transferred to the node in the send operation and 
which control the dispatch time. 
If a SAPoffice user wants to send a fax, he can only choose between send immediately (= send attribute 
class “1”) and send at night (= send attribute class “9”).  But the concrete send options for the respective 
class must be configured for each SAPconnect node (for a specific send attribute class, they may vary 
from node to node). 
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The following parameters can currently be selected: 
 Priority of the send operation (Priority 1: send immediately – Priority 9: send at night) 
 Start time from which a send operation is to be executed 
 End time by which a send operation is to be completed 
 Send tomorrow if send operation is to be executed tomorrow. 
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4.4.6 Activate Address Types Needed in SAPoffice 

Go (back) to the SAP R/3 Screen and call transaction SO16.  Activate corresponding check-boxes for 
FAX, SMTP and/or X.400 components. 
 

 
 

4.4.7 Assign Fax Numbers, SMTP and/or X.400 Addresses to R/3 
Users 

Go (back) to the SAP R/3 Screen and start transaction SO12 and type in the R/3 User Id. 
 

 
 
Click Change. 
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Click Address. Then, click Communication types. 

 
 
Choose address type (e.g., FAX). Type your own fax number (with leading 0 + local area code, without 
international prefix!). 
 



TC/LINK-SC Version 2.04.01 LINKSC_MAN.doc 

 

Kofax  50/178 
 

 

4.4.8 Testing the Installation  

4.4.8.1 Create a Message  

Go (back) to the SAP R/3 Screen and start transaction SOØ2 (Office Outbox). 
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Select or create a new message and click Send . Select Fax Entry to select or to create a new fax 
recipient: 

 
 
The following screen allows you to enter a fax address: 

 
 

Click Copy to validate. click Send  again to confirm the sending. 
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4.4.8.2 Control the Status for Sending  

Go (back) to the SAP R/3 Screen and start transaction SCOA. 

 
 
Normally the send process is scheduled every half-hour, therefore waiting for the sending could take quite 
a long time. So to activate the send process, FAX in the address type field and click send. After a while 
(depends on the settings of TCLINKSC/SAP/RFCPollCycle) TC/LINK-SC picks up the message and 
transfers it to KCS. 

4.4.9 List of Useful SAP R/3 Transactions 

SM59 Managing the RFCDestination 
SCOA Managing the SAPconnect nodes, starting the send process, examining SAPconnect traces etc. 
SO12 Managing SAPoffice user’s profile (incl. own fax, Internet and X.400 addresses). 
SO16 Activating FAX, X.400 and SMTP components for SAPoffice users 
SO28 Inbound Distribution, SAP Postmaster and Routing 
SOØ1 Opening the SAPoffice inbox 
SOØ2 Opening the SAPoffice outbox 
SUØ1 Managing SAP R/3 users 
SU3 Managing logged in user (important if SU01 and SU02 not allowed, because no special rights 
needed) 

4.5 Installation on SAP R/3 Release 4.0 B 
Note: To distinguish between the digit zero and the capital letter O it will be displayed like this: 
 

Digit zero Ø 

Capital letter O O 

 
Warning: Most entries are case sensitive! 
 
4.5.1 Logon with SAP GUI 
4.5.2 Create an RFC User for TC/LINK-SC 
4.5.3 Create an RFC Destination to TC/LINK-SC 
4.5.4 Test the RFC Connection to TC/LINK-SC 
4.5.5 SAP Configuration 
4.5.6 Schedule a SAPconnect Background Send Process 
4.5.7 Activate the Fax Module in SAPoffice 
4.5.8 Assign a Fax Number to Each R/3 User: 
4.5.9 List of Useful SAP R/3 Transactions 
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4.5.1 Logon with SAP GUI 

Log on into the R/3 system with the normal “Dialog” R/3 user (NOT CPI-C user!) 
 

 

4.5.2 Create an RFC User for TC/LINK-SC 

Create a user for the fax server to logon to the R/3 system: 
Call: Tools > Administration, User maintenance > Users (transaction SUØ1) Start transaction SUØ1. 

 
 
Type in the user name and select the Menu User names > Create. 

 
 
Insert dummy address data of user into the first screen. 
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In the “Address” section type in any Last name you might want to use the same name as your CPI-C user. 
Go to next input screen: Logon data. 

 
 
Name and password must match with the values set in the configuration of the fax server. 
 The type of user must be “CPIC ”. 
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Go to next input screen: Profiles 

 
 
Assign the authorization profile “S_A.SCON ” to the user. 
 
To do this select a Profile-line and you will get a pull-down menu in the type field. 

 
 
Open the pull-down menu: 

 
 
Now select the “S_A.SCON” profile and you will come back to the screen before, but with your selected 
profile. 

 
 
Now save the user data, you can do this either by selecting User Names > Save from the menu or by 

clicking Save . 

4.5.3 Create an RFC Destination to TC/LINK-SC 

Create an RFC destination for outbound calls: 
Call: Tools > Administration, Administration > Network > RFC destinations (transaction SM59). 



TC/LINK-SC Version 2.04.01 LINKSC_MAN.doc 

 

Kofax  56/178 
 

 
 
Choose: Create 

 
 
Enter a name of the RFC destination (e.g., BC-CON_TOPCALL). 
Set connection type ‘T’ (=TCP/IP). 
Enter a description. Press Enter. 
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The next screen appears: 

 
 
Select activation type ‘Registration’. 
 
Enter TC/LINK-SC’s Program ID, case sensitive (e.g., SAPGW.TCLINKSC, where SAPGW is the 
TC/LINK-SC workstation name. It must be in the same way as configured during TC/LINK-SC setup). 
 
This program ID must match with the value defined with parameter PROGID in the saprfc.ini file on the fax 
server. 

4.5.3.1 Destination -> Gateway Options 

Choose the menu point Destination > Gateway options. 

 
 
Set the gateway options of the RFC destination. 
 
Enter the host name and the service of the SAP gateway. (Must be the same, as configured during 
TC/LINK-SC setup). 
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This host name and the service must match with the value defined with parameter GWHOST and 
GWSERV in the saprfc.ini file on the fax server. (see chapter 4.1.4 for detailed information of the RFC 
connection parameters) 
 
Click OK and save the RFC Destination. 
 
Now click “Test connection” to verify if everything is ok. (TC/LINK-SC and SAP gateway must be running, 
of course). 

4.5.4 Test the RFC Connection to TC/LINK-SC  

Verify if the RFC connection to TC/LINK-SC works. Click test connection button (see screen before)  
If your connection is ok you should get a screen like this. 
 

 

4.5.5 SAP Configuration 

Administration (system status) 

 
 
Do the SAPconnect configuration: 
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Call: Tools > Administration, Administration > Process technology, Communication > SAPconnect 
(transaction SCOT, View: System Status). 
Within this transaction you can go over the menu ‘View’ to the different views, which are displayed on this 
slide and on the following slides. 
 
System Status: 
From here you can view all defined output methods (e.g., FAX/INT/X40) and the already defined nodes 
(e.g., SXC1/COMFAX) and you will find information about the processing status. 
 

 
 
General SAPconnect Customizing 
In release 4.0x – 4.5x use transaction SCOT (Goto -> Customizing). With a double click on the marked 
customizing steps you will go to the following screens. Note: only the following screens are described 
here: 
0 Communication methods 
4.5.5.2 Conversion rules 
4.5.5.3 Recipient no.change (incoming) 
4.5.5.4 Send attempts 
 
In release 4.6x use Settings > xxx, where “xxx” represents the different settings you can change (see 
above). 

4.5.5.1 Communication Methods 

 
 
Set communication method SAPconnect for fax: 
 Click Communication methods. 
 Set the value for Fax to SAPCONNECT. 
 Save the communication methods. 
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4.5.5.2 Conversion Rules 

 
 
Add a conversion rule (optional) 
In case that the fax server does not support Postscript or PDF format, but another printer language format, 
e.g., HP PCL, you have to add a new conversion rule. If the fax server supports PS or PDF you can skip 
this step. 
 Click: Conversion rules, New entries. 
 Enter a new rule with: 

Format = OTF 
To format = extension of the supported printer format, e.g., PCL 
Ranking = a value between 3 and 8 
Function module = SX_OBJECT_CONVERT_OTF_PRT 
all other fields = empty 

 Save the conversion rules. 
 
Note: In this case you also have to set the device type of your node to an appropriate value, e.g., HPLJ4, 
see below: Administration (nodes) -2-. 

4.5.5.3 Recipient No Change (Incoming) 

 
 
Define exception rules for manipulating the recipient’s fax number in inbound messages. This is for the 
match of the recipients’ number as provided by the PBX or the fax server with the R/3 user’s fax number 
as stored in the R/3 address management. 
 
 New entries. 
 Enter a new rule with 

– the beginning sequence of a fax number that shall be replaced, 
– the substitute sequence that shall be inserted instead, or 
– a comment. 

 Save the rule. 
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4.5.5.4 Send Attempts 

 
 
Set the maximum number of repeat send attempts (0: only one attempt will be carried out). 

4.5.5.5 Define a Node and Its Attributes 

Call: Tools > Administration, Administration > Process technology, Communication > SAPconnect 
(transaction SCOT, View: Node). 
 

 
 
Create a new node by clicking “Create node”. Enter name of the node (6 characters) and a description. 
Enter the RFC destination created before. 
 

 
 
To use the node in productive mode, select “Node in use”. Later, save the node. 
 
Go to the fax specific configuration data. 
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4.5.5.6 Define Exception Rules for Fax Numbers 

Address area: Restriction of numbers for routing to this fax server. 
For each document format that is supported by the fax server enter a line with the 3-character extension of 
that format. 
 For plain ASCII text use format RAW 
 For Postscript documents use format PS 
Specify the country location of the fax server. 
Specify the device type of the fax server (e.g., POSTSCPT, HPLJ4, ASCIIPRT…) 
 
Transmission control –Restrict Time 
The send attribute classes cover parameters which are transferred to the node in the send operation and 
which control the dispatch time.  
You can choose your settings in the Transmission control area by clicking the “Restrict” button. 
(See 2.6 for detailed information). 
 

 
 
The R/3 4.0B reduces the free configurable priorities to 3.  
 0 – Urgent … –  Dringend  
 1 – Normal     – Normal 
 2 – Favorable – Günstig  
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The field “StartTime” allows to configure when the message will be sent (where as 00:00:00 means send 
immediately) 
 
The field “EndTime” allows to configure when the message must be sent latest or be deleted (This has no 
meaning on KCS so it is ignored)  
 
The checkbox “Tomrrw” allows to configure that the message will be send on the next day 
 
SAP – Office uses only Urgent-“Send immediately” or Favorable (Low Priority) – “Send at night”. Other 
SAP Application may use normal also.  
 
The SAP Applications communicate with SAPconnect by telling only which priority this message has 
(0,1,2). SAPconnect is responsible for filling the fields correctly 
 
The send time and date is supported by TC/LINK-SC. The end time and date (latest delivery) is not 
supported by TC/LINK-SC. 

4.5.5.7 Define Routing 

Call Tools > Administration, Administration > Process technology, Communication > SAPconnect 
(transaction SCOT, View: Routing). 
 

 
 
Enter a new rule by clicking “Create address area” or in release 4.6x double click on the desired address 
area. 
 

 
 
Transaction SCOT (View: Routing) 
Enter a new rule by clicking “Create address area”: 
AddrTyp = communication service 
An Address Area 
 FAX addresses consist of a country code followed by digits, they may have a wild card ‘*’ at the end 
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 INT addresses are in the normal SMTP format, they may have a wild card ‘*’ at the beginning 
 X40 addresses have the format C=xx;A=xx;P=xx; they may have a wild card ‘*’ at the end. 
Name of the node that is responsible for this address area 
Save the routing. 
 
Routing Test 
Test the routing of a fax message: 
Call: Tools > Administration, Administration > Process technology, Communication > SAPconnect 
(transaction SCOT, (Goto -> Routing test). 
 

 
 
Enter a communication service (‘FAX’) and an address, press Enter. 
In the box ‘Outbound node and address’ will be displayed, which node would be used when sending a fax 
to that number, and how the number would be adapted according to the international country codes and 
your exception rules. 

4.5.6 Schedule a SAPconnect Background Send Process 

Call Tools > Administration, Administration > Process technology, Communication > SAPconnect 
(transaction SCOT, (View-> Jobs). 
 

 
 
From here you can start the sending process in dialog or you can schedule a background job for the 
sending process. 
 

4.5.7 Activate the Fax Module in SAPoffice 
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Call Tools > Administration, Administration > Process technology, Office > General office settings 
(transaction SO16). 
 

 
 
Switch on Connected components: Fax component. Save SAPoffice settings. 

4.5.8 Assign a Fax Number to Each R/3 User: 

Each user who wants to send messages from R/3 via fax or other external communication services must 
have an originator address of the appropriate address type. 
 
Call Tools > Administration, User maintenance > Users (transaction SUØ1). 
Enter the user name and click Change. 
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Enter the user’s fax number. 
Save the user address. 
 

4.5.8.1 Send Fax Out of SAPoffice 

You have to create a SAPoffice document and to send it to a fax number. 
Call Office > Outbox (transaction SOØ2), Document > Create > New (or Ctrl+F1). 

 
 
Enter Type and Title of document. Continue with the content input for your document. Save your 
document. Select your document for sending. 
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Call Document > Send (or Shift+F8). 

 
 
Choose ‘Fax entry’ for the destination address (or Shift+F5). 

 
 
Insert Country code and receiving fax number in the ‘Fax Recipient Entry’. Continue (with copy). Send the 
fax at the end with the Send push button or Shift+F8. 
 
Activate sending process manually 
Normally, the send process is scheduled following a special pattern (look at 2.6 and 4.3.2.5.3). Therefore 
waiting for the sending could take quite a long time. So you can activate the sending process manually. 
 From SAPconnect Administration (Transaction SCOT (View: Jobs)) call ‘Goto -> Start send process’. 
 With release 4.6x you have to call ,Utilities -> Start send process’ 
 Enter Addr. Type: FAX 

 
 Select FAX and click OK. 
 
Then the message is processed: 
Process means message between SAP and KCS or message is on the fax line. 
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If everything is ok, then, after a while (depends on the settings of TCLINKSC/SAP/RFCPollCycle) 
TC/LINK-SC picks up the message and transfers it to KCS. 
 

4.5.8.2 Review Status of Outgoing Fax 

Call Office > Outbox (transaction SOØ2). Double click on the receiver column of the outgoing document 
(No.,VW, RR, RC, CC). 

 
 
Review the status. 

 
 
You can also review the transmission history of the sending request – click “Transm. History”. 
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4.5.9 List of Useful SAP R/3 Transactions 

 
SM59 Managing the RFCDestination 
SCOT Managing the SAPconnect nodes, starting the send process, examining SAPconnect traces etc. 
SO12 Managing SAPoffice user’s profile (incl. own fax, Internet and X.400 addresses). 
SO16 Activating FAX, X.400 and SMTP components for SAPoffice users 
SO28 Inbound Distribution, SAP Postmaster and Routing 
SOØ1 Opening the SAPoffice inbox 
SOØ2 Opening the SAPoffice outbox 
SUØ1 Managing SAP R/3 users 
SMGW Gateway Monitor, check registered systems 
SU3 Managing logged in user (important if SU01 and SU02 not allowed, because no special rights needed) 
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4.6 Installation on SAP R/3 Release 4.6 x 
Note: To distinguish between the digit zero and the capital letter O it will be displayed like this: 
 

Digit zero Ø 

Capital letter O O 

 
Warning: Most entries are case sensitive! 

4.6.1 Logon with SAP GUI 

Log on into the R/3 system with the normal “Dialog” R/3 user (NOT CPI-C user!) 
 

 

4.6.2 Create an RFC User for TC/LINK-SC 

Create a user for the fax server to logon to the R/3 system: 
 Call: Tools => Administration, User maintenance  => Users (transaction SUØ1) 
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 Start transaction SUØ1 

 
 
 Type in the user name and select the Menu User names ->create 

 
 



TC/LINK-SC Version 2.04.01 LINKSC_MAN.doc 

 

Kofax  72/178 
 

 Insert dummy address data of user into the first screen. 

 
 
 In the “Address” section type in any Last name you might want to use the same name then your CPI-C 

user. 
 Name and password must match with the values set in the configuration of the fax server. 
 
 Go to next input screen :  Logon data 

 
 
 The type of user must be “Communication” 



TC/LINK-SC Version 2.04.01 LINKSC_MAN.doc 

 

Kofax  73/178 
 

 
 Go to the next input screen 

 
 
 Assign the authorization profile “S_A.SCON ” to the user. 
 
 Now save the user data 

4.6.3 Create an RFC Destination to TC/LINK-SC 

Create an RFC destination for outbound calls: 
 Call: Tools=>Administration, Administration => Network =>    RFC destinations (transaction SM59)  
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 Choose: Create 

 
 
 Enter a name of the RFC destination (e.g., BC-CON_TOPCALL) 
 Set connection type ‘T’ (=TCP/IP) 
 Enter a description. 
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 Press Enter. The next screen will appear. 

 
 
 Select activation type ‘Registration’. 
 Enter TC/LINK-SC’s Program ID, case sensitive (e.g., SAPGW.TCLINKSC, where SAPGW is the 

TC/LINK-SC workstation name. Must be the same, as configured during TC/LINK-SC setup). 
This program ID must match with the value defined with parameter PROGID in the saprfc.ini file on the 
fax server. 

4.6.3.1 Destination -> Gateway Options (Optional) 

This is only necessary, if more than one application server should be connected to KCS, than only one 
server is the appropriate gateway, which must be entered here. 
 
 Choose the menu point ‘Destination -> Gateway options’ 

 
 
 Set the gateway options of the RFC destination. 
 Enter the host name and the service of the SAP gateway. 

(Must be the same, as configured during TC/LINK-SC setup). 
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This host name and the service must match with the value defined with parameter GWHOST and 
GWSERV in the saprfc.ini file on the fax server. (look at 4.1.4 for detailed information of the RFC 
connection parameters) 
 

 Click OK and save the RFC Destination. 
 

 Now click “Test connection” to verify if everything is ok. 
(TC/LINK-SC and SAP gateway must be running, of course). 

4.6.4 Test the RFC Connection to TC/LINK-SC  

Verify if the RFC connection to TC/LINK-SC works. Click test connection button (see screen before)  
If your connection is ok you should get a screen like this. 
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4.6.5 SAP Configuration 

Administration (system status) 

 
 
Do the SAPconnect configuration: 
  Call: Tools => Administration, Administration => Process technology, 

Communication => SAPconnect (transaction SCOT, View: System Status). 
 Within this transaction you can go over the menu ‘View’ to the different views, which are displayed on 

this slide and on the following slides. 
 System Status:  

From here you can view all defined output methods (e.g., FAX/INT/X40) and the already defined nodes 
(e.g., SXC1/COMFAX) and you will find information about the processing status. 
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4.6.5.1 Customizing – Communication Methods 

Menu “Settings -> Communication Methods” 

 
 
Set communication method SAPconnect for fax: 
  Click: Communication methods. 
  Set the value for Fax to SAPCONNECT. 
  Save the communication methods. 

4.6.5.2 Customizing – Conversion Rules 

Menu “Settings -> Conversion Rules” 
 

 
 
Add a conversion rule (optional): 
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 In case that the fax server does not support Postscript or PDF format, but another printer language 
format, e.g., HP PCL, you have to add a new conversion rule. 
If the fax server supports PS or PDF you can skip this step. 

 Click: Conversion rules, New entries. 
 Enter a new rule with: 

– Format = OTF 
– To format = extension of the supported printer format, e.g., PCL 
– Ranking = a value between 3 and 8 
– Function module = SX_OBJECT_CONVERT_OTF_PRT 
– all other fields = empty 

 Save the conversion rules. 
 
Important: 
 In this case you also have to set the device type of your node to an 

appropriate value, e.g., HPLJ4, see below: Administration (nodes) -2-. 

4.6.5.3 Customizing – Recipient No Change (Incoming) 

 
 
Define exception rules for manipulating the recipient’s fax number in inbound messages. This is for the 
match of the recipients number as provided by the PBX or the fax server with the R/3 user’s fax number 
as stored in the R/3 address management. 
 
 New entries. 
 Enter a new rule with 

– the beginning sequence of a fax number that shall be replaced 
– the substitute sequence that shall be inserted instead 
– a comment 

 Save the rule. 
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4.6.5.4 Define a Node and Its Attributes 

Call: Tools => Administration, Administration => Process technology, Communication => SAPconnect 
(transaction SCOT, View: Node). 
 

 
 
 Enter a new node with push button ‘Create node’ 
 Enter name of the node (6 characters) and a description 
 Enter the RFC destination created before 
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 Click Continue and enter the created RFC destination: 
 

 
 
 Click Continue and configure at least one supported address type: 
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 For example fax: 
 
 Specify the address area and the supported formats: 
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You must then specify the device type: 
 

 
 
Next you must specify the node specific country code: 
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You can then set further address types, which are configured similar: 
 

 
 
After you finished all address types you have to set some general node configurations: 
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The maximum waiting time for the repeat send attempt procedure. In the example above, they are left 
empty, but could be filled out, according to the customers desired behavior.The maximum waiting time for 
the repeat send attempt procedure. 
 

 
 
 If you check the “Node can resolve path references”, than the attachments are only send as a 

reference. Therefore it should not be checked. Otherwise probably attachments cannot be accessed.  
 If you check the “Node is to be monitored by the alert monitor, then the RFC destination is checked 

periodically by the Alert Monitor. This can lead to event log entries of the LINK-SC, because it does not 
recognize these checks. 



TC/LINK-SC Version 2.04.01 LINKSC_MAN.doc 

 

Kofax  86/178 
 

 

 
 
 Check “Node is ready for use” 
 If you check “Node supports: Connection test, status, trace”, then an additional software checks the 

connection. This is not supported by TC/LINK-SC. If you will do an connection test, you can use the 
RFC Connection test (SM59) 

 
Then the node is finished: 
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4.6.5.5 Define Routing 

You can define the routing later on by changing the “SAPconnect View“ to “Routing” and double-click on 
an address: 
 

 
 
Routing Test 
Test the routing of a fax message: 
 SAPconnect (transaction SCOT, (Utilities -> Routing test). 

 
 
 Enter a communication service (‘FAX’) and an address, press Enter. 
 In the box ‘Outbound node and modified recipient address’ will be displayed, which node would be 

used when sending a fax to that number, and how the number would be adapted according to the 
international country codes and your exception rules.  

4.6.6 Schedule a SAPconnect Background Send Process 

 Call: Tools => Administration, Administration => Process technology, Communication => SAPconnect 
(transaction SCOT, (View-> Jobs). 
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From here you can start the sending process in dialog or you can schedule a background job for the 
sending process. 

4.6.7 Activate the Fax Module in SAPoffice 

 
 Call: Tools => Administration, Administration => Process technology, 

Office => General office settings (transaction SO16). 
 

 
 
 Switch on Connected components: Fax component. 
 Save SAPoffice settings. 
 

4.6.8 Assign a Fax Number to Each R/3 User 

Each user who wants to send messages from R/3 via fax or other external communication services must 
have an originator address of the appropriate address type. 
 
 Call: Tools => Administration, User maintenance => Users (transaction SUØ1), 

enter the user name and click the Change push button. 
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 Enter the user’s fax number. 
 Save the user address. 
 

4.6.8.1 Send Fax Out of SAPoffice 

  You have to create a SAPoffice document and to send it to a fax number. 
 Call: Office => Outbox (transaction SOØ2),  
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 “New Message”(or Shift+F4). 
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 Click the “Send” Button(or Shift+F8) 
 
Activate Sending Process manually: 
Normally the send process is scheduled following a special pattern (look at 2.6 and 4.3.2.5.3), therefore 
waiting for the sending could take quite a long time. So you can activate the sending process manually. 
 
 From SAPconnect Administration (Transaction SCOT (View: Jobs)): Utilities -> Start send process’ 
 Enter Addr. Type : FAX 

 
 
 Select FAX and click OK. 
 
Then the message is processed: 
Process means message between SAP and KCS or message is on the fax line. 
If everything is ok, then, after a while (depends on the settings of TCLINKSC/SAP/RFCPollCycle) 
TC/LINK-SC picks up the message and transfers it to KCS. 
 

4.6.8.2 Review Status of Outgoing Fax 

 Call: Office => Outbox (transaction SOØ2),  
 Double-click on the message 
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 Review the status. 

 
 

4.6.9 Configuration of the PAG Service 

To use the SAP PAG service you have to define a Paging Provider in SAP. This can be done with 
Transaction “SA14” (e.g., “TOPC” as Pager service name): 
 

 
 
After you have specified a name, like “TOPC” and configured the SAPconnect node for PAG (Transaction 
“SCOT”), you can send a pager message out of SAPoffice with following addressing syntax: 
 
  e.g., TOPC:0186353295   (= <PagerServiceName>:<PagerNumber>) 
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The routing to the node works like other services (e.g., configure the address range, like TOPC:*): 
 

 
 

4.6.10 List of Useful SAP R/3 Transactions 

 
SM59 Managing the RFCDestination 
SCOT Managing the SAPconnect nodes, starting the send process, examining SAPconnect traces etc 
SO12 Managing SAPoffice user’s profile (incl. own fax, Internet and X.400 addresses). 
SO16 Activating FAX, X.400 and SMTP components for SAPoffice users 
SO28 Inbound Distribution, SAP Postmaster and Routing 
SOØ1 Opening the SAPoffice inbox 
SOØ2
  

Opening the SAPoffice outbox 

SUØ1 Managing SAP R/3 users 
SMGW Gateway Monitor, check registered systems 
SU3 Managing logged in user (important if SU01 and SU02 not allowed, because no special rights needed) 

 

4.7 Installation on SAP Web Application Server 6.20 
Note: To distinguish between the digit zero and the capital letter O it will be displayed like this: 
 

Digit zero Ø 

Capital letter O O 

 
Warning: Most entries are case sensitive! 
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4.7.1 Logon with SAP GUI 

Log on into the R/3 system with the normal “Dialog” R/3 user (NOT CPI-C user!) 
 

 

4.7.2 Create an RFC user for TC/LINK-SC 

Create a user for the fax server to logon to the R/3 system: 
 Call: Tools => Administration, User maintenance  => Users (transaction SUØ1) 
 Start transaction SUØ1 
 

 
 
 Type in the user name and select the Menu User names ->create 
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 Insert dummy address data of user into the first screen. 
 

 
 
 In the “Address” section type in any Last name you might want to use the same name then your CPI-C 

user. 
 Go to next input screen :  Logon data 
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 Name and Password must match with the values set in the configuration of the link server 
 The type of user must be “Communication” 
 
 Go to the next input screen 
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 Assign the authorization profile “S_A.SCON ” to the user. 
 
Now save the user data. 

4.7.3 Create an RFC Destination to TC/LINK-SC 

Create an RFC destination for outbound calls: 
 Call: Tools=>Administration, Administration => Network =>    RFC destinations (transaction SM59)  

 
 
 Choose: Create 
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 Enter a name of the RFC destination (e.g., BC-CON_TOPCALL) 
 Set connection type ‘T’ (=TCP/IP) 
 Enter a description 
 Press Enter.  
 
The next screen will appear 
 

 
 
 Select activation type ‘Registered Server Program’. 
 Enter TC/LINK-SC’s Program ID, case sensitive (e.g., PCMA.TCLINKSC5, where PCMA is the 

TC/LINK-SC workstation name. Must be the same, as configured during TC/LINK-SC setup). 
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This program ID must match with the value defined with parameter PROGID in the saprfc.ini file on the 
fax server. 

4.7.3.1 Gateway Options (Optional) 

 This is only necessary, if more than one application server should be connected to KCS, than only one 
server is the appropriate gateway, which must be entered here. 

 
 Set the gateway options of the RFC destination. 
 
 Enter the host name and the service of the SAP gateway. 

(Must be the same, as configured during TC/LINK-SC setup). 
This host name and the service must match with the value defined with parameter GWHOST and 
GWSERV in the saprfc.ini file on the fax server. (look at 4.1.4 for detailed information of the RFC 
connection parameters) 
 

 Hit the ‘OK’ button and save the RFC Destination.| 
 

 Now click “Test connection” to verify if everything is ok. 
(TC/LINK-SC and SAP gateway must be running, of course). 

4.7.4 Test the RFC Connection to TC/LINK-SC  

Verify if the RFC connection to TC/LINK-SC works. Click test connection button (see screen before)  
If your connection is ok you should get a screen like this. 
 

 

4.7.5 SAP Configuration 

Administration (system status) 
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Do the SAPconnect configuration: 
 Call: Tools => Administration, Administration => Process technology, 

Communication => SAPconnect (transaction SCOT, View: System Status). 
 Within this transaction you can go over the menu ‘View’ to the different views, which are displayed on 

this slide and on the following slides. 
 System Status:  

From here you can view all defined output methods (e.g., FAX/INT/X40) and the already defined nodes 
(e.g., SXC1/COMFAX) and you will find information about the processing status. 

4.7.5.1 Customizing – Communication Methods 

Menu “Settings -> Communication Methods” 

 
 
Set communication method SAPconnect for fax: 
  Click: Communication methods. 
  Set the value for Fax to SAPconnect. 
  Save the communication methods. 

4.7.5.2 Customizing – Conversion Rules 

In prior releases it was possible to specify general conversion rules, directly from the SAPconnect 
Administration. In 6.20 you can specify only conversion rules on node basis (see below). The general 
conversion rules are reachable over the transaction “SPRO”: 
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Click the “SAP Reference IMG” button and follow the tree down to “Conversion Rules”: 
 

 
 
There you can find the rules: 
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Add a conversion rule (optional): 
 In case that the fax server does not support Postscript or PDF format, but another printer language 

format, e.g., HP PCL, you have to add a new conversion rule. 
If the fax server supports PS or PDF you can skip this step. 

 Click: Conversion rules, New entries. 
 Enter a new rule with 

Format = OTF 
To format = extension of the supported printer format, e.g., PCL 
Ranking = a value between 3 and 8 
Function module = SX_OBJECT_CONVERT_OTF_PRT 
all other fields = empty 

 Save the conversion rules. 
 
Important: In this case you also have to set the device type of your node to an appropriate value, e.g., 
HPLJ4, see below: Administration (nodes) -2-. 
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4.7.5.3 Customizing – Recipient No Change (Incoming) 

 
 
Define exception rules for manipulating the recipient’s fax number in inbound messages. This is for the 
match of the recipients’ number as provided by the PBX or the fax server with the R/3 user’s fax number 
as stored in the R/3 address management. 
 
New entries 
Enter a new rule with 
 the beginning sequence of a fax number that shall be replaced 
 the substitute sequence that shall be inserted instead 
 a comment 
Save the rule. 
 

4.7.5.4 Define a Node and Its Attributes 

Call: Tools => Administration, Administration => Process technology, Communication => SAPconnect 
(transaction SCOT, View: Node). 
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 Enter a new node with push button ‘Create node’ 
Enter name of the node (6 characters) and a description 
Enter the RFC destination created before 

 
 
 Click Continue and enter the created RFC destination: 
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 Click Continue and configure at least one supported address type: 

 
 
 For example fax: 
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 Specify the address area and the address specific conversion rules: 

 
 
 You can then restrict the sending time: 
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 Next you must specify the node specific country code: 

 
 
 You can then set further address types, which are configured similar: 
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 After you finished all address types you have to set some general node configurations: 

 
 
 The maximum waiting time for the repeat send attempt procedure. In the example above, they are left 

empty, but could be filled out, according to the customers’ desired behavior. 

 
 
 If you check the “Node can resolve path references”, than the attachments are only send as a 

reference. Therefore it should not be checked. Otherwise probably attachments cannot be accessed.  
 If you check the “Node is to be monitored by the alert monitor, then the RFC destination is checked 

periodically by the Alert Monitor. This can lead to event log entries of the LINK-SC, because it 
does not recognize these checks. 
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 Check “Node is ready for use” 
 If you check “Node supports: Connection test, status, trace”, then an additional software checks the 

connection. This is not supported by TC/LINK-SC. If you will do an connection test, you can use the 
RFC Connection test (SM59) 

 
 Then the node is finished: 
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4.7.5.5 Define Routing 

You can define the routing later on by changing the “SAPconnect View“ to “Routing” and double-click on 
an address: 

 
 
Routing Test 
Test the routing of a fax message: 
 SAPconnect (transaction SCOT, (Utilities -> Routing test). 
 

 
 
 Enter a communication service (‘FAX’) and an address, press Enter. 
 In the box ‘Outbound node and modified recipient address’ will be displayed, which node would be 

used when sending a fax to that number, and how the number would be adapted according to the 
international country codes and your exception rules. 
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4.7.6 Schedule a SAPconnect Background Send Process 

Call: Tools => Administration, Administration => Process technology, Communication => SAPconnect 
(transaction SCOT, (View-> Jobs). 

 
 
From here you can start the sending process in dialog or you can schedule a background job for the 
sending process. 

4.7.7 Activate the Fax Module in SAPoffice 

 Call: Tools => Administration, Administration => Process technology, Office => General office settings 
(transaction SO16). 
 

 
 
Switch on Connected components: Fax component. Save SAPoffice settings. 

4.7.8 Assign a Fax Number to Each R/3 User: 

Each user who wants to send messages from R/3 via fax or other external communication services must 
have an originator address of the appropriate address type. 
 
Call: Tools => Administration, User maintenance => Users (transaction SUØ1), enter the user name and 
click Change. 
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Enter the user’s fax number. Save the user address. 

4.7.8.1 Send Fax Out of SAPoffice 

You have to create a SAPoffice document and to send it to a fax number. 
 Call: Office => Outbox (transaction SOØ2) 
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 “New Message” (or Shift+F4). 

 
 
 Click the “Send” Button(or Shift+F8) 
 
 Activate Sending Process manually: 

Normally the send process is scheduled following a special pattern (look at 2.6 and 4.3.2.5.3), 
therefore waiting for the sending could take quite a long time. So you can activate the sending process 
manually. 

 
 From SAPconnect Administration (Transaction SCOT (View: Jobs)): Utilities -> Start send process’ 

Enter Addr. Type : FAX 

 
 
 Select FAX and click OK. 
 
Then the message is processed: 
Process means message between SAP and KCS or message is on the fax line. If everything is OK, then, 
after a while (depends on the settings of TCLINKSC/SAP/RFCPollCycle) TC/LINK-SC picks up the 
message and transfers it to KCS. 

4.7.8.2 Review Status of Outgoing Fax 

Call: Office => Outbox (transaction SOØ2). Double-click on the message. Review the status. 
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4.7.9 Configuration of the PAG Service 

To use the SAP PAG service you have to define a Paging Provider in SAP. This can be done with 
Transaction “SA14” (e.g., “TOPC” as Pager service name): 

 
 
After you have specified a name, like “TOPC” and configured the SAPconnect node for PAG (Transaction 
“SCOT”), you can send a pager message out of SAPoffice with following addressing syntax: 
 
e.g., TOPC:0186353295   (= <PagerServiceName>:<PagerNumber>) 
 
The routing to the node works like other services (e.g., configure the address range, like TOPC:*): 
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4.7.10 List of Useful SAP R/3 Transactions 

 
SM59 Managing the RFCDestination 
SCOT Managing the SAPconnect nodes, starting the send process, examining SAPconnect traces etc. 
SO12 Managing SAPoffice user’s profile (incl. own fax, Internet and X.400 addresses 
SO16 Activating FAX, X.400 and SMTP components for SAPoffice users 
SO28 Inbound Distribution, SAP Postmaster and Routing 
SOØ1 Opening the SAPoffice inbox 
SOØ2 Opening the SAPoffice outbox 
SUØ1 Managing SAP R/3 users 
SMGW Gateway Monitor, check registered systems 
SU3 Managing logged in user (important if SU01 and SU02 not allowed, because no special rights needed) 

 

4.8 Installation on SAP with NetWeaver 7.x  
Remark: We will use in this description the character “Ø” instead of the digit zero to clearly distinguish it 
from the capital letter O. Warning: Most entries are case sensitive! 
 
Note: Starting with WAS 7.3, you need to use the transaction SCON instead of SCOT to maintain 
RFC nodes for Fax and SMS. For configuring the SMTP note, you can continue using the 
transaction SCOT. 

4.8.1 Configuration Steps Overview 

The following TC/LINK-SC specific configuration steps must be done on SAP in any case. These are the 
basic configuration steps for establishing the RFC connection between SAP and TC/LINK-SC. 
 
 Create an RFC communication user for TC/LINK-SC (Transaction SUØ1) 
 Create an “RFC destination” for TC/LINK-SC (Transaction SM59) 
 Create an SAPconnect RFC communication node (Transaction SCOT) 
 



TC/LINK-SC Version 2.04.01 LINKSC_MAN.doc 

 

Kofax  116/178 
 

B) The following general configuration steps are a prerequisite for the TC/LINK-SC operations. The 
configuration settings, however, are not TC/LINK-SC specific and they can already exist on SAP, if 
SAPconnect / SAP Business Workplace is already in use on the system. 
 
 Schedule a SAPconnect background send job for sending SAP-outbound messages (Transaction 

SCOT) 
 

 Set the “communication method” to “SAPconnect” for the address types you want to route with 
TC/LINK-SC (fax, pager, internet address, X.400). By default, the according communication methods in 
SAP 7.0 are already set to “SAPconnect”, so very likely there is nothing to do here. (Transaction 
SCOT) 
 

 Check the SAP Business Workplace (old name: “SAPoffice”) profile whether external sending for fax, 
pager, … is activated. By default, they are activated, so very likely nothing to do here. (Transaction 
SO16) 

 
C) Other configuration requirements, depending on / implicated by the actual usage / configuration: 
(Normally, these settings are not necessary for the simplest SAP<->TC/LINK-SC connection tests.) 
 
 Set the SAPconnect format conversion rules. This must be defined according to the output formats (PS 

/ PCL / PDF) configured on the SAPconnect node. Each internal format  output format conversion, 
configured implicitly on the SAPconnect node, must have assigned an according conversion function 
here. (Transaction “SPRO”) 
 

 Define the pager service (Transaction SA14) and pager address area on the SAPconnect node. 
(Transaction SCOT) This is interesting only if TC/LINK-SC will also be used for SMS transmission. 
 

 Configuration for sending also internet e-mails (messages with address type ‘Internet’) through 
TC/LINK-SC 
 

 Define telephone number substituting rules for SAP inbound faxes. This can be a solution, when the 
recipient telephone number of the inbound fax does not match with the fax address stored in the 
recipient SAP user record and so the inbound routing does not work. (Transaction SCOT) 

 
D) Finally: Prepare SAP users for sending / receiving messages: 
 
 Assign a fax (and/or SMS, Internet, X.400) address to all SAP users communicating through TC/LINK-

SC. 

4.8.2 Logon with SAP GUI 

Log on into the SAP 7.0 system with the SAP GUI application. (Do not use the RFC user for logon!) 
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4.8.3 Create an RFC User for TC/LINK-SC 

Create a special user for the SAP<->TC/LINK-SC RFC communication. This user with user type 
“Communications Data” will be used by TC/LINK-SC to log on into SAP. 
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 SAP menu: Tools => Administration => User Maintenance  => Users  (or call transaction SUØ1) 

 
 
 Enter the name of the RFC user to be created (e.g., “TOPCALLRFC”) and select the menu Users => 

Create (or, alternatively, click the toolbar button with the white empty page pictogram).  
 
This user name must be the same as configured on the link server in the registry setting 
..\TOPCALL\<link-name>\SAP\RFCUser. 
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 Enter an (arbitrary) “Last name” on the “Address” tab. 

 
 
 Define user type as “Communication Data” and enter a password on the “Logon data” tab.  

 
This password must be the same as configured on the link server in the registry setting  

  
..\TOPCALL\<link-name>\SAP\RFCPassword. 
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 Enter profile “S_A.SCON” on the “Profiles” tab. 

 
 
 Now, save the user data. (Menu Users => Save or click the toolbar button with the floppy disk 

pictogram) 
 

4.8.4 Create RFC Destination to TC/LINK-SC  

Create SAP<->TC/LINK-SC RFC connection (“destination”) definition. This RFC destination will then be 
used by our SAPconnect RFC node that will be created as next step in chapter 4.8.5. 
 
 SAP Menu: Tools => Administration => Administration => Network =>  RFC Destinations (or call 

transaction SM59) 
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 Choose menu Edit => Create (or the according toolbar button) 
 

 
 
 Enter a name of the RFC destination (arbitrary, e.g., BC-CON_TOPCALL) 
 Enter connection type “T” (=TCP/IP) 
 Enter some description 
 Press Enter on the keyboard to open the “Technical Settings” tab below 
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 Select activation type “Registered Server Program”. 
 Enter TC/LINK-SC’s Program ID, case sensitive. (E.g., PCPASZ.TCLINKSC5, where PCPASZ is the 

TC/LINK-SC workstation name. Note that this naming syntax with the computer name is not necessary 
at all.)  
This Program ID must be the same as configured during TC/LINK-SC setup. This configuration can be 
found on the TC/LINK-SC machine in the file c:\tcoss\tclp\saprfc.ini as PROGID parameter. 

 Set CPI-C timeout. E.g., select Default Gateway Value (60 seconds) 
 Set the gateway options (optional). This is necessary only if more than one application server should 

be connected to KCS. In this case, only one server is the appropriate gateway, which must be entered 
here. Enter the host name and the service of the SAP gateway on the “Gateway Options” tab. 
These values must be the same as configured during TC/LINK-SC setup: Gateway host name and the 
service must match with the value defined with parameter GWHOST and GWSERV in the saprfc.ini file 
on the link server. (Please consult chapter RFC Connection Parameters (SAPRFC.INI File) in this 
manual for detailed information of the RFC connection parameters) 

 
 Save the RFC Destination (e.g., click toolbar button with floppy disk pictogram) 
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 Click the Connection Test button (see screen before) 

It verifies if the RFC connection to TC/LINK-SC works. TC/LINK-SC and SAP gateway must be running 
for this test, of course. 
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 If your connection is ok, you will get a screen like this: 

 
 

4.8.5 Create SAPconnect RFC Node 

 Go to SAPconnect administration: SAP menu: Tools => Business Communication => Communication 
=> SAPconnect (or call transaction SCOT) 

 
 
 Change to node view, if you are not already in this view (Menu View => Node). (Hint: SAPconnect 

offers several views: System status, Routing, Node, Jobs. If you enter SAPconnect, always the view 
you have used last time will be displayed.) 
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 Click the new node button (or menu Nodes => Create ) 

 
 
 Enter node name (max. 6 characters) and description (e.g., “TCLINK” and “TOPCALL connection”, 

Remark: These are arbitrary texts, there is no according configuration value on TC/LINK-SC). Click 
Continue. 

 
 



TC/LINK-SC Version 2.04.01 LINKSC_MAN.doc 

 

Kofax  126/178 
 

 Set node type to “RFC Node”. Click Continue. 

 
 
 Enter the RFC destination you have created in the previous chapter. (With this setting you have 

actually connected this node to the TC/LINK-SC instance indirectly, through the given RFC 
destination). Click Continue. 
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 Configure address type fax. Click Continue. 

 
 
 Enter address area. It defines which SAP-outbound faxes will be routed to this RFC node. If you enter 

“*”, then SAPconnect will send all outbound faxes to this node. As a consequence, all SAP-outbound 
faxes will be delivered by TC/LINK-SC connected to this node. When entering “AT*”, only SAP-
outbound faxes with country code AT will be routed to this node. More restrictions, e.g., AT186353* are 
also possible. Click Continue. 

 
 
 Set output formats. Note that TC/LINK-SC must be configured to support the according format 

conversion. E.g., if PS (postscript) format is set here, then TC/LINK-SC must be installed with Lincoln 
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converter/postscript option. Click Continue. 

 
 
 Optional: Restrict send time. Click Continue. 
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 Enter country code for the node location. Click Continue. 

 
 
 If you want to let SAPconnect route messages also with other SAP address types to this RFC node, 

e.g., pager/SMS, then select ‘Y’, otherwise, select ‘N’. (Note that TC/LINK-SC supports the following 
SAP address types: fax, pager/SMS, X400, internet address. Therefore, only configuring one or more 
of these SAP address types makes sense.) 
Click Continue. 

 
 
 Optional: Define for how long periodic send attempts should be made. (The next send attempt starts 

always after 10 minutes, this cannot be configured.) E.g., defining 2 hours here means that 
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SAPconnect makes a send attempt in every 10 minutes, for 2 hours. Click Continue. 

 
 
 Do not set the following options! 

(If you check the “Node can resolve path references”, then the attachments are only sent as a 
reference. Therefore, it should not be checked. Otherwise, attachments will probably be inaccessible. 
If you check the “Node is to be monitored by the alert monitor” option, then the RFC destination is 
checked periodically by the Alert Monitor. This can lead to TC/LINK-SC event log entries, because it 
does not support these checks.) 
Click Continue. 

 
 
 Set “Node is ready for use” to activate the node. 

Note: If you check the “Node supports: Connection test, status, trace” option, then an additional 
software checks the connection. This is not supported by TC/LINK-SC. If you will do a connection test, 
you can use the RFC Connection test (SM59). 
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 Click Continue to finish the node creation. 

 
 
The node is created and displayed in the SAPconnect node view: 

 
 
Routing test: 
Once the is node created, it can be checked if the address areas defined on this node make the 
messages in fact route to this node as desired. 
With the routing test you can check which node is “responsible” for a certain address. That is, to which 
node will be routed a message with a certain recipient address. The SAPconnect internal routing is based 
on the address area definitions on the nodes; however, the possible overlapping address area definitions 
in the different nodes can make it difficult to find the responsible node for a certain address. E.g., NODE1 
has * and NODE2 has AT* as fax address area. SAPconnect routes the fax addressed to AT1111 to 
NODE2, even if AT1111 matches to both nodes address area, because the more specific address area 
has always priority. 
 
 Go to SAPconnect administration, if you are not already there. (SAP menu: Tools => Business 

Communication => Communication => SAPconnect or call transaction SCOT),  
 Menu: Utilities => Routing test 
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 Enter an address of your interest 
 Press Enter key on the keyboard 
 
In the fields Node and Recipient addr. Below (“Outbound node and modified recipient address”) you will 
get the responsible node for the given address and the modified recipient address. 
(Note: This test is a SAPconnect internal process, so you do not need a running TC/LINK-SC for this test.) 
 

  
 
 For more detailed information, why just this node was selected as outbound node, click the toolbar 

button with the magnifying glass icon (or menu Routes => Explain) 
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 It will also display how the number would be adapted according to the international country codes and 
your exception rules (Setting => Country code exceptions). 

 
 
 If you click the Back button on the toolbar (or press F3) you can get further explanatory information on 

the routing. 

 

4.8.6 Schedule a SAPconnect Background Send Job 

Go to SAPconnect administration if you are not already there: SAP menu: Tools => Business 
Communication => Communication => SAPconnect (or call transaction SCOT). 
 
Change to jobs view (View => Jobs), if you are not already in this view.  
 
Note: Existing jobs are displayed as calendar icons (see picture). 
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Faxes, emails, SMS that are sent from an SAP application are merely put into a queue. A periodically 
running background process, the SAPconnect send job, takes these messages from the queue and sends 
them via the configured SAPconnect nodes.  
If such a job is already scheduled (quite likely), then you can skip this configuration step. (E.g., in the 
picture above, there is already a job called SEND_MAIL.) Otherwise, a job can be scheduled here in the 
SAPconnect administration as follows: 
 
 Choose Job => Create (or the ‘new’ button on the toolbar), and specify a job name.  

 
 Select the line “SAP&CONNECTALL” (by clicking the list-side-button on the left) 
 Click Schedule button (green flag) above the list. 
 Choose “Schedule periodically”. 
 Specify a time interval (for example 2 minutes). 
 Choose “Create”. 
 
To check the properties of an existing job, set the cursor on the calendar icon (and not on the line with the 
job name!), and select Job => Display.  
 
To check the steps of a scheduled job, click Step. 
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“SAP&CONNECTALL” procedure picks up all message types from the queue and sends to the according 
SAPconnect node(s). If an already existing job performs other procedure than “SAP&CONNECTALL”, 
then it must be checked if it really deals with the message types we want to deliver with TC/LINK-SC. 
 

 

4.8.7 Checking the “Communication Methods” Belonging to the 
Different Address Types 

Go to SAPconnect administration if you are not already there: SAP menu: Tools => Business 
Communication => Communication => SAPconnect (or call transaction SCOT) 
 
Menu Settings => Communication methods 
 
The communication method for all message types to be handled by TC/LINK-SC must be set to 
SAPconnect. (Presumably, it is already set so, as default.) 
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4.8.8 Checking the SAP Business Workplace (“Office”) External 
Sending Settings 

SAP menu: Tools => Business Communication => Office => Shared office settings (or call transaction 
SO16). 
 
All TC/LINK-SC relevant components/connections (fax, pager …) have to be enabled. See according 
check boxes on this picture. Otherwise, no according message transfer is possible from/to SAP Business 
Workplace. 
 

 

4.8.9 Checking the SAPconnect Format Conversion Rules 

Go to transaction “SPRO” => SAP Reference IMG button  => list: SAP Customizing Implementation Guide 
=> SAP NetWeaver => Application Server => Basis Services => Communication interfaces => 

SAPconnect Client-Wide settings => General Settings => Conversion Rules (click the  button) 
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All output formats defined on the RFC node must have an according conversion method defined here. 
Otherwise, create an according new entry here. (It will be one of the entries marked on this picture.) E.g., 
if you defined on RFC node the fax address type with PDF as output format, and there is no entry for OTF-
>PDF conversion in this table, then create this entry as you see it in the list here. 
 

 
 

4.8.10 Configuring the Pager Service 

Pager service must be configured only if TC/LINK-SC will be used also for SMS transmission, otherwise, 
you can skip this step. 
 
 Go to transaction SA14 

Create a pager service entry as shown on the picture. E.g., service name is TOPC. 

 
 
 Go to SAPconnect administration: SAP menu: Tools => Business Communication => Communication 

=> SAPconnect (or call transaction SCOT) 
 Go to View => Node 
 Double-click the RFC node you configured for TC/LINK-SC. The node configuration dialog opens. 
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 Click the Set button next to the “Pager (SMS)” check box. 
 Define the address area on the Pager (SMS) address type configuration dialog, e.g., in our example 

TOPC:*. 

 
 

 Click  button. Note that the “Pager (SMS)” check box will not be set immediately on the parent 

dialog. Press here also the  button. Now, the changes will be stored on the node. 
 
Now you can send a pager message out of SAP with following addressing syntax: 
E.g., TOPC:0186353295, that is  <PagerServiceName>:<PagerNumber> 
 

4.8.11 Configuration for Sending Internet Emails via TC/LINK-SC 

 Go to SAPconnect administration: SAP menu: Tools => Business Communication => Communication 
=> SAPconnect (or call transaction SCOT) 

 Go to View => Node 
 Double-click the RFC node you configured for TC/LINK-SC. The node configuration dialog opens. 
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 Click the Set button next to the “Internet” check box. 

 
 
 Define the address area on the ‘Internet’ address type configuration dialog, e.g., in our example “*”. 

This means that all internet mails will be routed to our RFC node and so to TC/LINK-SC. But if you e.g. 
want that only internet emails with domain “dicomgroup.com” are routed to this RFC node (that is to 
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TC/LINK-SC), then define “*@dicomgroup.com”. 

 
 

 Press  button. Note that the “Internet” check box will not be set immediately on the parent dialog. 

Press here also the  button. Now, the changes will be stored on the node. 

4.8.12 Define Recipient Telephone Number Change Rules 

Optional configuration: You can define rules in SAPconnect to change the beginning of the recipient 
fax/telephone number in an SAP-inbound message. In some cases it is necessary for the proper inbound 
routing. Whether it is necessary, depends on the fax address definitions in the SAP user records. 
 
Go to SAPconnect administration: SAP menu: Tools => Business Communication => Communication => 
SAPconnect (or call transaction SCOT). Menu Settings => Recipient no. change (incoming). 
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Example: You chose 06227 as the beginning of a number to be replaced, and 0711 as the substitute 
number. If the system now receives the number 06227341122, it changes it to 0711341122. 
 

 

4.8.13 Assign Fax (SMS …) Address to Each SAP User 

Each user who wants to send/receive messages from/to SAP via fax or other external communication 
services must have an according address of the appropriate address type. 
 
SAP menu: Tools => Administration => User Maintenance  => Users  (or call transaction SUØ1) 
 

 
 
Use the Other communication… button to enter the SMS address for the user. 
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4.8.14 Testing the Configuration: Sending Fax out of SAP Business 
Workplace 

Go to SAP menu: Office => Workplace (Or alternatively: transaction SOØ2, this leads directly to the SAP 
Business Workplace / Outbox). 
 

 
 
Click New Message button, or choose menu Workplace => New message or Shift+F4 
 

 
 
Enter some message and addressing. Click the send button, or choose menu Document => Send. 
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Normally, it takes some minutes till the SAPconnect scheduled send job picks up this message from the 
queue, according to the time interval defined for the job. (See chapter 4.8.6, Schedule a SAPconnect 
Background Send Job.) However, it is possible to start the sending process manually: 
 
Go to SAPconnect administration: SAP menu: Tools => Business Communication => Communication => 
SAPconnect (or call transaction SCOT). Click the Start send process button on the toolbar or choose 
menu Utilities => Start send process. 
 

 
 
Define AddrType = “* All”, so all kind of messages will be picked up by this job run. Click Start. 
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Now, the test fax is sent. To review the status of the sent message, go to SAP Business Workplace / 
Outbox (Transaction SOØ2) 
 
If the message has only one recipient, then the send status is displayed in the list. (Green: sent; red: error; 
yellow: the send process has not picked up the message yet.) 
 
For more detailed information double click the list entry. 
 

 
 
In the Recipient list tab there is a more detailed delivery history per recipient. 
 



TC/LINK-SC Version 2.04.01 LINKSC_MAN.doc 

 

Kofax  145/178 
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4.9 R/3 – Customizing: Example Faxing an Order 
Confirmation 

The following example is taken from the Sales and Distribution module. Although the configuration of 
other R/3 modules like Material Management differ from the described solution, this is should give you an 
idea how it works. 

4.9.1 Assigning Fax Numbers to Business Partners (1) 

 
 

 
Go to: Logistics => Sales and Distribution => Master Data, Business partners => Sold-to party => Change 
=> Change (Transaction VDØ2). Specify the Business partner you want to change and select the Address 
data. 
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4.9.2 Assigning Fax Numbers to Business Partners (2) 
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4.9.3 Check the Output Control Customizing (1) 

 
 
 Go to R/3 Customizing: Tools  Business Engineer Customizing (Transaction: SPRO) 
 View the Enterprise IMG (Implementation Guide) 
 Go to: Maintain Output Types (Follow the path shown in the picture above) 
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4.9.4 Check the Output Control Customizing (2) 

 
 

 
 Select the Output Type you want to check the customizing for (In our example BA00 – Order 

Confirmation) and go to Processing routines 
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4.9.5 Check the Output Control Customizing (3) 

 
 
 Check if this Output Type is enabled for fax. If not, add an entry for fax. 
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4.9.6 Check Sales Master Data (1) 

 
 
 Go to: Logistics Sales and Distribution Master data; Output Sales document Change 
Select the respective Output Type (In this example BA00) and press Return 

4.9.7 Check Sales Master Data (2) 

 
 

 
 Select the respective Sales document type and press the execute button (F8)  
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4.9.8 Check Sales Master Data (3) 

 

possible send time 

 
 
 Enter 2 (Fax) in the Medium field. Also enter the partner function, the time you want to send the faxes 

and the language 
 Save your data 
 
Now we have checked all the necessary settings and are ready to create a sales order. 

4.9.9 Create a Sales Order (1) 

 
 
 Go to: Logistics  Sales and Distribution  Sales; Order Create (Transaction: VA01) 
 Enter the respective order type; sales organization; distribution channel and division; press Enter 
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4.9.10 Create a Sales Order (2) 

 
 
 Enter your order data 
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4.9.11 Create a Sales Order (3) 

 
 
 To check if the output type has been selected according to the customizing settings go to: Extras 
Output Header. 

 
 To output the order immediately go to: Further Data and set the Dispatch time to 4. 
 

4.9.12 Status Tracking – SAPoffice 

 
 
 The status of the document can be viewed in the outbox of the user. 
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4.9.13 Status Tracking – KCS 

 
 
 Finally, the fax can be viewed in the KCS Outbox. 
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5. KCS MONITOR ADD-ON 

5.1 Overview 
The TC/LINK-SC Configuration Add-on enables the KCS Monitor to locally configure and duplicate 
TC/LINK-SC instances: 

KCS Monitor

KCS Server

TC/LINK-SC 

Add-on

TCLINKSC1

TCLINKSC2

TCLINKSC<n>
configures

configures

configures

 
To turn on the Add-On you have to set following registry key: 
HKEY_LOCAL_MACHINE\SOFTWARE\TOPCALL\TCMON\EnableConfigurationMode = 1 (REG_DWORD)  

 
The TC/LINK-SC Configuration Add-on is responsible for interaction with the user and for making the 
changes on the local KCS Server.  
 
The most important registry and SAPRFC.INI file entries are serviced with this tool.  
 
The following commands are handled by the Add-on: Copy, Delete, Paste, and Properties. (see also 
release description of the KCS Monitor 7.12.00 (new name: KCS Monitor) for discussion about the 
principle concepts.) 
 
Note: The Add-on does not replace the setup. It needs at least one instance of the TC/LINK-SC in order 
to work. 
 
Note: To use this add-on, when connecting to your KCS server from KCS Monitor, you must identify the 
server with its computer name or IP address (but not with “localhost” or “.”). If you use “.” or “localhost”, the 
add-on does not function and its commands are unavailable. 
 

5.1.1 Copy Command 

The copy command copies the settings of the current selected TC/LINK-SC instance to the clipboard.  

5.1.2 Delete Command 

Deletes the current selection without copy to the clipboard. The instance is irretrievably deleted. 
 
Attention: The command actually deletes the settings for the current selected instance after copying to 
the clipboard. Therefore the user must acknowledge this before the action is performed: 
 

 
 
After accepting the dialog the following settings are deleted automatically: 
 
 The entry for the instance in ..\TOPCALL\Boot\Startup is removed. 
 The entries for the instance in the SAPRFC.INI are removed 
 Remove the whole registry sub-tree ..\TOPCALL\<INSTANCENAME> 
 The temporary directory for this instance is removed. 
 The entry in the start menu is removed. 
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Some changes cannot be made automatically; they must be made by the administrator. Therefore, a 
report window shows necessary information to accomplish this: 
 

 
 
Attention: After deleting the last instance, it is not possible to create again a new instance with the Add-
on. 
 
An Event Log entry logs the deletion of the instance.  

5.1.3 Paste Command 

The paste command appends the content of the clipboard (the previously copied link instance). A wizard 
guides the user through the necessary changes of settings that must be different: 
 
Situation before paste: 

TC/LINK-SC1

KCS Server

SAP Gateway 1 Instances

SAP System Client 1

SAP Gateway-2 Instances

SAP System Client 2

 
The first page asks about the necessary changes for the KCS settings. The values are proposed 
automatically generated out of the original name. 
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Name of  instance Used for the registry subkey name and the display name of the icon, must be 
unique.  

Name of queue KCS queue name, must be different for each instance. 

Name of service KCS Fax service name, must be different for each instance 

Name of SMTP service KCS SMTP service name, must be different for each instance 

Name of X.400 service KCS X4000 service name, must be different for each instance 

 
The program checks if the supplied names are valid and unique.  
 
The following pages ask the necessary information for connecting to the R/3 system. 
 
First the logon-parameter: 

 
 

Client Client (Mandant) for R/3 system. Must be provided by the R/3 System administrator 

CPI-C user CPI-C user name for R/3 system. Must be valid for the client specified above and must be 
provided by the R/3 System administrator 

Password CPI-C user password. Must be provided by the R/3 System administrator 

 
The following page asks about the necessary SAP R/3 settings for sending from KCS to the SAP R/3 
system: 
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Application server The hostname or IP-address of the application server. If the connection goes via 
a SAP Router a router string may be entered. The syntax is checked. Must be 
provided by the R/3 System administrator 

Gateway Host The hostname or IP-address of the Gateway server. If the connection goes via a 
SAP Router a router string may be entered. The syntax is checked. Must be 
provided by the R/3 System administrator 

Gateway service SAP gateway service name or TCP port number. Must be provided by the R/3 
System administrator 

R/3 system number System number of the R/3 application server. Must be provided by the R/3 
System administrator 

 
Finally the settings for sending from the SAP R/3 system to KCS: 

 
 

Program ID  With this string TC/LINK-SC registers on the configured SAP gateway. The 
proposed entry is local_hostname.instance_name. Attention: This string is case-
sensitive. 

Gateway Host The hostname or IP-address of the Gateway server. If the connection goes via a 
SAP Router a router string may be entered. The syntax is checked. Must be 
provided by the R/3 System administrator. 

Gateway service SAP gateway service name or TCP port number. Must be provided by the R/3 
System administrator. 

 
Only after the user finally acknowledged the settings by clicking Finish the new instance is created: 
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TC/LINK-SC1

TC/LINK-SC2

KCS Server

SAP Gateway 1 Instances

SAP System Client 1

SAP Gateway-2 Instances

SAP System Client 2

 
 
Except of the above mentioned changes all other settings are copied from the original instance.  
 
 An entry for the new instance in ..\TOPCALL\Boot\Startup is added. 
 The entries for the new instance in the SAPRFC.INI are added 
 The whole registry sub-tree is copied from the original instance to the new instance 
 The following parameters are changed after copying: 
 

Parameter (Registry key) Value 

CommandLine <Path from original instance> <instancename> 

General\VirReportFile <Path from original instance>\<instancename>.txt 

TOPCALL\Queue Taken from the wizard 

Setup\CreateTCObjects ServiceSCFax 
ServiceSCSMTP 
ServiceSCX400 

Setup\CreateDependenciesTopcall 1 

Setup\ServiceSCFAX\Name Taken from the wizard 

Setup\ServiceSCFAX\Prefix <Queue name from wizard><Format character from original 
instance>:FAX: 

Setup\ServiceSCSMTP\Name Taken from the wizard 

Setup\ServiceSCSMTP\Prefix <Queue name from wizard><Format character from original 
instance>:SMTP: 

Setup\ServiceSCX400\Name Taken from the wizard 

Setup\ServiceSCX400\Prefix <Queue name from wizard><Format character from original 
instance>:X400: 

SAP\RFCClient Taken from wizard 

SAP\RFCDestination <INSTANCENAME>SRV 

SAP\RFCPassword Taken from wizard, is encrypted 

SAP\RFCR3Destination <INSTANCENAME>CLT 

SAP\RFCUser Taken from wizard 

SAP\TempPath C:\TCOSS\TCLINK\TMP\<INSTANCENAME> 

 
 The temporary directory for this instance is created. 
 The entry in the start menu is created.  
 
All necessary changes in the R/3 system must be made manually. 
 
An Event Log entry logs the creation of the instance.  

5.2 Properties 
The TC/LINK-SC Configuration Add-on allows configuring the most important parameters with following 
property sheet.  
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Note: The parameter offered are literally the same as during the paste wizard except of the instance, 
which cannot be changed. 
 

 

5.3 Event Log Entries 
The following entries ensure that all that were made with the Add-on changes are logged. 
 

Code Severity Description Parameter Description 

15029 Information The user %1 has deleted the 
instance %2 

%1 – Windows user name 
%2 – Name of deleted instance 

15030 Information The user %1 has changed the 
RFC Client parameter of instance 
%2: %3 

%1 Name of user  
%2 Name of SC-Instance 
%3 Changed parameter 
Note: All parameters which are changed are 
listed the following way: 
<Old value> -> <New value> 

    15031 Information The user %1 has changed the 
RFC Server parameter of 
instance %2: %3 

%1 Name of user  
%2 Name of SC-Instance 
%3 Changed parameter 
Note: All parameters which are changed are 
listed the following way 
<Old value> -> <New value> 

    15032 Information The user %1 has changed the 
RFC Logon parameter of instance 
%2: %3 

%1 Name of user  
%2 Name of SC-Instance 
%3 Changed parameter 
Note: All parameters which are changed are 
listed the following way 
<Old value> -> <New value> 
The only exception is the password for the 
CPI-C user. In that case it is only logged that it 
was changed and not the value itself 

15033 Information The user %1 has changed the 
TOPCALL parameter of instance 
%2: %3 

%1 Name of user  
%2 Name of SC-Instance 
%3 Changed parameter 
Note: All parameters which are changed are 
listed the following way 
<Old value> -> <New value> 
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6. COMPATIBILITY 
Backward compatible with TC/LINK-AC. Update from TC/LINK-AC to TC/LINK-SC is possible without loss 
of functionality. Address formats may be different (for example Telex must be embedded with X.400 or 
SMTP). 
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7. PERFORMANCE 
This section documents the performance measured with the following equipment: 
 
KCS Server: NT 4.0, Pentium III 600 MHz, 512 MB RAM, TCOSS 7.37.00, Model 218 
Link Server: NT 4.0, Pentium III 600 MHz, 128 MB RAM 
 
TC/LINK-SC: 1.19.01, the only link active, no trace 
 

Test description Messages / hour Pages / hour 

Test 1: text msg (1 page)  
Mail system -> KCS 

approx. 10000 (*)  

Test 2: msg with (1 page) Word attachment 
Mail system -> KCS 

approx. 500  

Test 3: msg with 70 page Word attachment 
Mail system -> KCS 

approx. 250 approx. 17500 

Test 4: text msg (1 page) 
KCS -> Mail system 

approx. 2200  

Test 5: fax (1 page) 
KCS -> Mail system 

approx. 1400  

 
(*) ….The messages were sent out from SAPoffice using the Internet and Fax format. No postscript 
documents were generated by R/3. Other Tests have shown, that sending postscript messages to KCS, 
lead to a less good performance (approx. 800-1000 messages/hour). The reason for this is the conversion 
from postscript to a KCS readable format. 
 
Tests 2 and 3 were made with document conversion. If it is disabled, the performance is much better. 
Another important point for increasing performance is the connection to the R/3 system. If it is not in the 
LAN, the performance will be decreased. 
 
Parallel Links: 
 
If it is needed, more than one TC/LINK-SC can be installed on one PC. It is recommended to do not use 
more than 10 links in parallel on one computer. As it is obvious more links need more CPU time, and so it 
slows down the overall performance, especially if the poll cycle is too low. If it is still needed to install more 
than 10 links, e.g., for many SAP clients, where the traffic is low, it is possible to do so. 
 
Tests have shown that the limit is approximately 60 TC/LINK-SC on one PC. To achieve this, first you 
have to increase the page file size to 300-500 MB. Second you have to set in the registry key 
“HKLM\System\CurrentControlSet\Control\Session Manager\Subsystems\Windows” the value 
“SharedSection=1024,3072,512” and third you have to use TCSRV 7.10.0.6, because previous versions 
were only able to start 20 processes. 
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8. RESTRICTIONS 
 Exact error code mapping for delivery/non-delivery notifications not supported.  

 
 Only cover variables for message subject ($ERef$), recipient full name ($Name) and originator full 

name ($UName$) are being used. The reason is that only these cover variables have their 
counterparts in SAPconnect interface. 
 

 Load Balancing from R/3 to KCS only works on release 4.6x without trouble. For releases lower than 
4.6 see OSS note 148471 for a workaround. 
 

 The RFCPassword does not consist only of an even count of numbers (e.g., “2468”, “123456”). 
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9. HINTS 

9.1 SAP Notes (Hints) 
SAP maintains an error and hints database called OSS, which provides also very useful hints for 
SAPconnect interface.  
Some of them even describe patches for specific R/3 releases, necessary to implement to bring specific 
functionality to run. Every SAP R/3 customer has an access to this SAP’s online database. 
 
It is strongly recommended, that prior to the TC/LINK-SC installation the customer: 
 
 Checks via OSS database, which hints may be applicable for the specific R/3 installation. 
 Implement all necessary changes and patches to the R/3. 
 
The table below provides the summary of SAPconnect related OSS hints available to the release date of 
this TC/LINK-SC manual, including note number, short description and the R/3 release range for which the 
specific note is applicable. 
 

OSS Note 
Number 

Short description From release Up to release 

0008977 SAPoffice: External communication 30A 31I 

0017194 Information about fax in R/3 040 41A 

0039083 SAPoffice: X.400 send authorization value 30A 30E 

0075430 SAPconnect: send in Internet is not possibly 31G 31I 

0081597 Outbound SAP Forms, mail messages without effect 31G 31G 

0085164 Error in fax from SAPscript via SAPconnect 3.1G/H 31G 31H 

0085998 SAPoffice: Faxing WinWord documents 31G 31H 

0086106 SAPconnect: Faxing from application, error XS826 31G 31H 

0087784 SAPconnect: Conversion, error message 31G 31H 

0089238 Incorrect trnsm. Priority fax SAPscript/SAPconnect 31G 40A 

0089372 SAPconnect: Blanks in email addresses 31G 40A 

0089380 SAPconnect: SAPcomm tables are checked 31G 31G 

0089589 SAPoffice: external automatic forwarding 40A 40A 

0089966 SAPconnect: Status mail to sender (in German) 31G 31H 

0090335 Fax: No authorization for output device & 31G 31H 

0090758 SAPconnect: Transmission priority is not set 31G 31G 

0091485 SAPconnect: No delivery – sender is incorrect 31G 40A 

0092287 SAPconnect: resending incorrect mails/faxes 310 41A 

0092950 SAPoffice/SAPconnect: Fax, Internet mail, X.400 40A 40D 

0096220 SAPoffice: Internet-entry – wrong recipient 31G 31H 

0096252 SAPconnect, Fax: Formatting SCR/RAW documents 31G 
40A 

31I 
40B 

 

9.2 RFC Trace Files 
During the operation of the TC/LINK-SC, the trace file “DEV_RFC” is created in the link directory and 
some trace outputs from SAP RFC library are being copied here. Further, some CPIC trace files may 
occur in the same directory.  
These trace outputs cannot be switched off completely with R/3 3.1G and 3.1H.  It is a problem of SAP’s 
RFC library used by TC/LINK-SC. In all cases, the checkbox “Trace” with the RFCDestination 
configuration screen in the R/3 server (transaction SM59) must be deactivated (this reduces amount of 
traces being written but does not switch them completely off!). 
 
This problem should be solved with R/3 3.1I. 
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9.3 Faxing from R/3 Applications via TC/LINK-SC 

9.3.1 SAP Hint 85164 

With R/3 3.1H it is not possible to send faxes via SAPconnect interface and TC/LINK-SC due to the bug in 
the R/3 3.1H. But there is the SAP hint NR. 85164 available, that solves this problem.  
 
This problem should be solved with R/3 3.1I. 

9.4 Problems with Blanks Within SMTP and X.400 
Addresses 

With R/3 3.1H blanks within X.400 and SMTP addresses are suppressed. Thus it is not possible for 
example to embed MS Exchange or Lotus Notes addresses containing blanks into X.400 or SMTP 
address if sending via TC/LINK-SC. 
Please refer to the SAP hint NR. 89372. 

9.5 TC/LINK-SC Restart Behavior 
If the connection to SAP System is broken (RFC Server loses its connection), e.g., SAP Router is 
stopped, TC/LINK-SC retries first immediately. 
 
Then after 10 seconds, after 1 minute, after 3 minutes and finally 6 times each 10 minutes. Afterwards the 
link is stopped assuming that there are severe connection troubles. 
 
It is only possible to send a message from SAP R/3 after successful re-logon (In SAP terms after 
TC/LINK-SC has registered itself).  
 
So if the connection to SAP is re-established, the RFC Client can send successfully to SAP but the RFC 
Server has to wait for its re-registration. 

9.6 SAP Job RSCONN01 Hangs 
To avoid the problem described in error-13066 and error-13571 (“SAP job RSCONN01 hangs when 
sending a large number of outbound FAX messages via TC/LINK-SC in a KCS tandem environment”) set 
the following registry key to 1. 
 
…\TCLINKSC\SAP\RFCNewCallingMethod (DWORD) =  
  0 – original RFC calling method (default) 
  1 – modified RFC calling method  

9.7 R/3 Concepts 
The following sections explain some the main concepts of the SAP R/3 system. 
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9.7.1 R/3 Instance (Central System) 

D
Dialog

Message

Server
SAP

Gateway

Dispatcher

... V
Update

E
Locking

B
Batch

... S
Spool

Instance

 
 
An instance is an administrative unit combining components of the R/3 system that offers one or more 
services. The services offered by an instance are started or stopped together. All components of an 
instance share a common instance profile. 
 
A central R/3 system consists of one single instance offering all necessary SAP services 
 
A complete R/3 system offers the following application services: 
 
-Dialog processing (D) 
-Update (V) 
-Lock management (Enqueue/Dequeue) (E) 
-Background processing (Batch) (B) 
-Message (M) 
-CPI-C Gateway (G) 
-Spool (S) 
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9.7.2 Possible Distribution of the Application Level 
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A central system can easily be expanded to a distributed system by adding more instances that supply 
certain services. 
 
The example shows the installation of an additional dialog server (A), a background processing server (B) 
and a gateway server (C). These instances, which offer specific services normally run on their own 
computers, can also run on the same computer, as the example of the gateway server shows. 
 
The message server provides a central message service to the other R/3 application services for internal 
communication. 
 
Presentation machines (where the SAP GUI runs) are logged on to an application server by the message 
server. The performance database can be used for automatic load distribution. 
 
Each application server logs on at the message server with a unique name. Each application server 
knows the names of the servers on which update, enqueue, background processing, and spool services 
run, and activates these by supplying the address to the message server. Application servers can 
exchange short internal messages via the message server (such as initiating an update, requesting or 
releasing a lock, executing requests) 
 
The gateway service is used for communication with external systems. The TC/LINK-SC is such an 
external system and is thus connected via the gateway service to the SAP R/3 system. 

9.7.3 The SAP Client Concept (“mandant”) 

The client concept allows to operate a SAP system for multiple, independent enterprises.  This allows for 
example to have three different SAP clients on one actual SAP Server. 
 
One would be used for development, one for testing and one for the production. Each of them works 
independently, so that changes which are made in the development department do not interfere with the 
production system. In fact this is the situation in most companies. 
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9.7.4 Route Strings 

A route string describes a connection required between two hosts using one or more SAProuters. Each of 
these SAProuters then checks its Route Permission Table to see whether the connection between its 
predecessor and successor is allowed, and if it is, sets it up. 
 
A route string contains a substring for each SAProuter and for the target server.  
 
Each substring contains the information required by SAProuter to set up a connection in the route: the 
host name, the port name, and the password, if one was given. 

9.7.5 Syntax for Release <4.0A  

A route string has the syntax: 
(/H/host/S/service/P/pass)* 

 
It consists of any number of substrings in the form 
/H/host/S/service/P/pass 

 
Attention: H, S, and P must be uppercase! 
 
 /H/ indicates the host name or IP address 
 /S/ is used for specifying the service (port); it is an optional entry, the default value is 3299  
 /P/ indicates the password for the connection between the predecessor and the successor; it is an 

optional entry, the default value is “” 
 

9.7.6 Syntax for Release 4.0A or Higher 

A route string has the syntax: 
(/H/host/S/service/W/pass)* 

 
It consists of any number of substrings in the form 
/H/host/S/service/W/pass. 

 
Attention: H, S, and W must be uppercase! 
 
 /H/ indicates the host name or IP address 
 /S/ is used for specifying the service (port); it is an optional entry, the default value is 3299  
 /W/ indicates the password for the connection between the predecessor and successor on the route 

and is also optional (default is "", no password). In earlier Releases (<4.0A), the password entry was 
made one substring later and with the letter /P/. 

 
Due to downward compatibility, the older syntax is still possible. 

9.8 SAP Interfaces 
The following definitions of interesting SAP Interfaces are partly taken from the “SAP Interface Adviser”-
CD, which is available from SAP free of charge. 
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9.8.1 SAPComm – The “Old” Solution for Messaging 

Application
s

SAPoffice

Spool
Work Process

Spool

Communication
to  SAPcomm

RRFFCC CCPPII

CC
LLPPDD

IInntteerrnneett

GGaatteewwaayy
SSAAPPccoommmm

TTCC//LLIINNKK--AACC
SSAAPPLLPPDD

SSAAPPFFAAXX..DDLLLL

SMTP FAXSAP

X.400

FAX

X.400 via
SAPComm
was never
impl. by SAP
X.400

 
 
As explained in the diagram above, SAPComm is connected to the SAP Spool system and therefore all 
status information can be seen there. 
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9.8.2 SAPconnect – The “New” Solution for Messaging 

 
 
The SAPoffice Communication Interface allows R/3 applications to create and send messages. It also 
makes it possible for SAP Applications to lookup the current transmission status of these messages at any 
time. 
Furthermore the SAP Application can be enabled to receive messages and handle them in an appropriate 
way. 
 
SAP R/3 applications can generate and submit messages to the SAPoffice Communication Interface in 
several ways: 
 
 Applications can call SAPscript, specifying a recipient’s communication address instead of the usual 

act of specifying a printer’s name. In that case SAPscript will feed the SAPoffice Communication 
Interface instead of printing the document to the spool. 
This method is supported for compatibility reasons, there are restrictions in the support of new features 
of this interface (compound documents, multiple recipients, etc.) 

 
 Applications can use SAPscript for document formatting purposes only, and afterwards call the 

SAPoffice Communication Interface by itself. In that case the application has full control to all new 
features of this interface. 
This is the recommended method if the document content is automatically created by the application. 
 

 Applications may directly pass documents to the SAPoffice Communication Interface. 
This is the appropriate method if the document content has been formatted by the application itself, or 
has a non-R/3 specific format (e.g., MS Word, etc.). 

 
The SAPconnect RFC Interface is designed to plug-in external systems to the SAP R/3 Business 
Communication module.  
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9.8.3 SAPscript Raw Data Interface (RDI) 

Using the SAPscript Raw Data Interface (RDI), you can connect external text management systems to 
control individual requests, for example, optimizing postage expense. The interface contains all form data 
from the R/3 System, but no layout information such as font or page size. The external system alone is 
responsible for the layout and administration of the document data. The RDI is of special importance for 
mail processing. The external system sorts the document data from the interface and forwards the 
documents accordingly. 
 
The Raw Data Interface is a certifiable interface and allows easy connection to external systems. 
However, you pay the price for this extra function, as you lose tight integration with the R/3 System. For 
example, you cannot find out from within an R/3 application whether the external system successfully 
printed and sent the documents. In addition, extra expense is incurred each time you adapt a standard 
form, since the system has to adapt both an internal and external form. The external tool is not an integral 
part of the ABAP Development Workbench, so that field information (field type, output length and so on) 
from the ABAP Dictionary is not available.  
 
Note: This interface is not used by KCS 

9.8.4 Output Management System – (BC-XOM) 

 
The OMS interface is an open, generic interface to the R/3 spool system for external output management 
systems (OMSs). The OMS interface allows an efficient and well-integrated coupling of the R/3 spool 
system with an external output management system (OMS).  
 
This interface provides a reliable feedback channel. The OMS can return detailed job status information 
back to the R/3 system that can 
be viewed by the R/3 end user using transaction SP01. The kind and amount of status information is not 
specified by the interface. What information is available at the R/3 level depends of the features of the 
output management system using this interface. At least (specified 
by the interface description) job completion information has to be returned telling the R/3 system whether 
the job has been successfully printed or not.  
 
There are two flavors for the feedback channel:  
 
 The polling interface can be used as an easy way to return status information to the R/3 system. This 

flavor acts like access method ‘L’ and the ‘lpstat’ command, but the output format of the polling 
command is specified by SAP and allows to return detailed job and device specific status information. 
As with access method ‘L’ the polling is still done by the spool work process.  

 
 The callback interface can be used as an sophisticated way to return status information in time when it 

happens without requiring polling done by the spool work process. The information is actively sent to 
the R/3 system using an RFC interface. 

 
Note: This interface is not used by KCS 

9.8.5 Archive / Imaging Software (SAP ArchiveLink) 

 
SAP ArchiveLink is a component of the R/3 System to link optical archives and document management 
systems with SAP’s R/3 System. 
 
It is a general, cross-application interface providing R/3 business applications with archive functionality. 
The interface is based technically on SAP’s RFC (Remote Function Call) and supports the following 
functions:  
 
 Archiving and displaying of scanned documents  
 Forward-looking Workflow Management  
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 Archiving, display and retrieval of SAP print lists, outgoing documents and archiving data 
 
Additional components can be connected at the front-end via OLE, AppleScript and command line calls, 
depending on the document class concerned. As a reference to the respective archive object, the 
partner’s archive system transfers a unique document ID to the SAP R/3 System. It is maintained with all 
the other attributes in R/3. SAP ArchiveLink manages the entire communication with the archive system; 
there is no need for costly custom programming.  
 
Note: This interface is not used by KCS. 
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10. TROUBLESHOOTING 
If any problems encounter during TC/LINK-SC operation, TC/LINK-SC writes corresponding events into 
Windows event log, including information about possible reasons and actions to cure the problem without 
the need to activate system traces to locate the problem.  
 
There are three categories of event log entries: information, warning and error (for details please refer to 
the TC/LINK manual).  
 
For TC/LINK-SC troubleshooting it is recommended: 
 Always check Windows event log if any problem occurred, if corresponding entry found try to solve the 

problem according to proposed actions. 
 Activate the RFC traces on the R/3 side (transaction SCOA) for additional information. 
 
In the following the summary of typical problems is listed, that may occur during TC/LINK-SC operation. 
 
 
1. TC/LINK-SC starts and terminates immediately 
 
TC/LINK-SC cannot connect to KCS server, or cannot register at SAP gateway. The reason for this 
problem can be found in the event log entry. In the case of R/3 (RFC) problem, check the RFC error string 
in the event log, especially its LOCATION and ERROR parts. It should provide enough information for 
SAP System Administrator to find out the problem. Check again the connection parameters in the file 
SAPRFC.INI in the link directory (for detailed description of SAPRFC.INI, see 4.1.4). 
 
RFC error string example   
KEY=RFC_IO5 STATUS=CODE=CM_PRODUCT_SPECIFIC_ERROR STATUS=??? DATA=??? ID=??? 

MESSAGE=LOCATION    SapRouter on sapgate1 ERROR       connection to partner broken TIME        

Mon Feb 2 14:33:09 1998 RELEASE     40A COMPONENT   NI (network interface) VERSION     

23 RC          -95 MODULE niuxi.c LINE        857 DETAIL      NiPRead SYST INTSTAT=IO 

HANDLE=2 DRV=EXT LINE=316 CODE=5  

 
2. RFC Communication Test from R/3 (transaction SM59) fails 
 
TC/LINK-SC does not run, runs but has registered at the wrong/another SAP gateway or has registered 
with wrong/another Program Id (case sensitive!).  Verify the RFC connection parameters in the file 
SAPRFC.INI (especially lines GWHOST=, GWSERV=, and PROGID=) and within R/3 (transaction SM59). 
 
3. Sending a message from SAPoffice breaks with “Transmission failed” 
 
No connection with TC/LINK-SC – perform the RFC Communication test, R/3 transaction SM59 (see step 
2) 
 
4. Message sent from SAPoffice remains at “Sent” status. 
 
The message has not been sent to TC/LINK-SC yet. Check if the send process for corresponding address 
type (FAX, INT or X400) is running (R/3 transaction SCOA). If not, start it manually or schedule for 
background operation.  
 
5. Message sent from SAPoffice remains at “Transferred to node” status 
 
Message has already been transferred to TC/LINK-SC, but the notification from KCS has not arrived yet. 
Check the message on KCS server with TCfW Communication Server Client. 
If the send order is still on the “waiting” status, it was probably sent with “send at night” send class from 
R/3 (check its send time and date). If so re-send the message with send class “send immediately”.  
If KCS has already done some send retries and there are still some open retries, probably the recipient is 
wrong and KCS will send the delivery/non-delivery notification later. 
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If the send order is already completed (ok or inactive, problems), check the status of notification send 
order to TC/LINK-SC, especially its “Response” field. 
If there is “SYSTEM_FAILURE”, the R/3 CPIC user used for TC/LINK-SC is wrong. Check this user with 
R/3 transaction SU01, and also corresponding TC/LINK-SC registry settings: SAP\RFCClient, 
TCLINKSC\SAP\RFCUser and TCLINKSC\SAP\RFCPassword. 
If there was no notification send order at all, KCS has not sent any notification to R/3 originator. Check if 
registry key TCLINKSC\SAP\TCDelNotifAlways is set to 1 (for details see 2.5). 
If the notification was sent to (any) KCS user instead of to TC/LINK-SC, you either defined KCS shadow 
user without proper delivery/non-delivery in-actions, or TC/LINK-SC accidentally recognized this KCS user 
as shadow user by its address mapping facility. Check KCS UserId and proxy addresses of this user and 
refer to 2.3.4. 
 
6. Sending a message from KCS to R/3 breaks with an error code 
 
Check the “Response” field of the send order. Refer to section 2.7 for all possible error conditions that 
may occur on sending a message from KCS to R/3. 
 
The most typical one will be “Recipient not found” – R/3 recipient’s FAX, SMTP or X.400 address was 
wrong/not exist within R/3. Assign proper addresses to R/3 users with R/3 transaction SO12. If the 
response was “SYSTEM_FAILURE”, the R/3 CPIC user used for TC/LINK-SC is wrong. Check this user 
with R/3 transaction SU01, and also corresponding TC/LINK-SC registry settings: 
TCLINKSC\SAP\RFCClient, TCLINKSC\SAP\RFCUser and TCLINKSC\SAP\RFCPassword. 
 
7. With multi-instance TC/LINK-SC operation, one message sent from SAP R/3 is being sent (e.g., 
faxed) by KCS for several times 
 
Several TC/LINK-SC instances running on the same link server and serving different R/3 clients and/or 
R/3 instances, share the same temporary directory.  Please check registry key TCLINKSC\SAP\TempPath 
for all TC/LINK-SC instances – they must be different!  
 
8. SAP RFC timeout causes double (multiple) sending from TC -> SAP 
 
The registry setting <link>\SAP\RFCTimeout must be set properly. If this value is too small, then timeout 
can occur before SAP returns the (synchronous) response to a TC -> SAP message transfer. This causes 
TC/LINK-SC to resend the message to SAP, because the result of the previous message transfer is not 
known on the TC/LINK-SC side. If the result of the previous message transfer was actually OK, then this 
resending will result in multiple transfer of the same message. 
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11. SETUP CHECKLIST 
 

KCS Server CPU number 1)  

Link Server CPU number  

KCS version  

Link Server license or TC/LINK-XX license  
1) 

Key: 
Expire Date: 
Registrations: 

Postscript license 1) (optional) Key: 
Expire Date: 
Registrations: 

PCL5 license key (optional) Key: 
Expire Date: 
Registrations: 

GIF license key (optional) Key: 
Expire Date: 
Registrations: 

KCS Server Name  

Link Type to TOPCAL Server, transport type PRC or 
Native 

 

Secondary KCS Server Name (for tandem servers only)  

Link Type to secondary KCS Server (for tandem servers 
only) 

 

KCS Link User Name  

KCS Link User Password  

Win TCDCEXE User Name (foreground TCDC only)  

Win TCDCEXE User Password (foreground TCDC only)  

Win TCDCEXE User Domain (foreground TCDC only)  

Program Id  for registration at SAP gateway  

Route String to SAP gateway   

SAP gateway’s TCP port or service  

Route String to R/3 application server  

R/3 system number  

R/3 CPI-C user : Client (in German “Mandant”)  

R/3 CPI-C user : User  

R/3 CPI-C user:  Password  

 
1) For TCOSS < 7.08 in combination with TCOSS tandem servers these licenses have to be entered for 
both CPU numbers of the primary and the secondary TCOSS server. 
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Setup Checklist Example 
 

KCS Server CPU number 1)  

Link Server CPU number  

KCS version  

Link Server license or TC/LINK-XX license 1) Key: 
Expire Date: 
Registrations: 

Postscript license 1) (optional) Key: 
Expire Date: 
Registrations: 

PCL5 license key (optional) Key: 
Expire Date: 
Registrations: 

GIF license key (optional) Key: 
Expire Date: 
Registrations: 

KCS Server Name  

Link Type to KCS Server, transport type PRC or 
Native 

 

Secondary KCS Server Name (for tandem servers 
only) 

 

Link Type to secondary KCS Server (for tandem 
servers only) 

 

KCS Link User Name From TCOSS 7.22 on this user is automatically 
created during initial KCS installation with 
password “TCLINK”. Please refer to TC/LINK 
manual for detailed information 

KCS Link User Password 

Win TCDCEXE User Name (foreground TCDC only)  

Win TCDCEXE User Password (foreground TCDC 
only) 

 

Win TCDCEXE User Domain (foreground TCDC 
only) 

 

Program Id  for registration at SAP gateway E.g., SAPGW.TCLINKSC 
Example see 4.2.5 

Route String to SAP gateway  Must be provided by SAP System Administrator. 
Example see 4.1.3 ,4.1.4, 4.1.5 

SAP gateway’s TCP port or service Must be provided by SAP System Administrator. 
E.g., sapgwØØ 
Example see 4.2.5 

Route String to R/3 application server Must be provided by SAP System Administrator. 
Example see 4.1.3 ,4.1.4, 4.1.5 

R/3 system number Must be provided by SAP System Administrator. 
E.g., ØØ 
Example see 4.2.5 

R/3 CPI-C user : Client (in German “Mandant”) Must be provided by SAP System Administrator. 
E.g., 85Ø 
Example see 4.2.5 

R/3 CPI-C user : User Must be provided by SAP System Administrator. 
Example see 4.2.5 

R/3 CPI-C user:  Password Must be provided by SAP System Administrator. 
Example see 4.2.5 

 
1) For TCOSS < 7.08 in combination with TCOSS tandem servers these licenses have to be entered for 
both CPU numbers of the primary and the secondary TCOSS server.  
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