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Preface

This administrator's guide contains a description of common administrative tasks and configuration of the
Repository for Kofax Customer Communications (CCM), a communication development and document
management system.

Related documentation

In addition to this guide, the Kofax Customer Communications Manager documentation set includes the
following:

▪ Kofax Customer Communications Manager Release Notes
Contains late-breaking details and other information that is not available in your other Kofax Customer
Communications Manager documentation.

▪ Kofax Customer Communications Manager Installation Guide
Describes the installation procedure.

▪ Kofax Customer Communications Manager Getting Started Guide
Describes how to use Contract Manager to manage instances of Kofax Customer Communications
Manager.

▪ Kofax Customer Communications Manager Designer for Web User's Guide
Contains general information and instructions on using Kofax Customer Communications Manager
Designer for Web, which is an authoring tool and content management system for Kofax Customer
Communications Manager.

▪ Kofax Customer Communications Manager Repository User's Guide
Includes user instructions for Kofax Customer Communications Manager Repository and Kofax
Customer Communications Manager Designer for Windows.

▪ Kofax Customer Communications Manager Repository Developer's Guide
Describes various features and APIs to integrate with Kofax Customer Communications Manager
Repository and Kofax Customer Communications Manager Designer for Windows.

▪ Kofax Customer Communications Manager Template Scripting Language Developer's Guide
Describes CCM Template Script used in Master Templates.

▪ Kofax Customer Communications Manager Core Developer's Guide
Provides a general overview and integration information for Kofax Customer Communications Manager
Core.

▪ Kofax Customer Communications Manager Core Scripting Language Developer's Guide
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Describes CCM Core Script.

▪ Kofax Customer Communications Manager API Guide
Describes Contract Manager, which is the main entry point to Kofax Customer Communications
Manager.

▪ Kofax Customer Communications Manager ComposerUI for HTML5 JavaScript API Web
Developer's Guide
Describes integration of ComposerUI for HTML5 into an application, using its JavaScript API.

Getting help for Kofax products

Kofax regularly updates the Kofax Support site with the latest information about Kofax products.

To access some resources, you must have a valid Support Agreement with an authorized Kofax Reseller/
Partner or with Kofax directly.

Use the tools that Kofax provides for researching and identifying issues. For example, use the Kofax
support site to search for answers and messages, keywords, and product issues. To access the Kofax
Support page, go to www.kofax.com.

The Kofax support page provides:
▪ Product information and release news.

Click a product family, select a product, and select a version number

▪ Downloadable product documentation.
Click a product family, select a product, and click Documentation.

▪ Access to product knowledge bases.
Click Knowledge Base.

▪ Access to the Kofax Customer Portal (for eligible customers).
Click Account Management and log in.

▪ Access to support tools.
Click Tools and select the tool to use.

▪ Information about the support commitment for Kofax products.
Click Support Details and select Kofax Support Commitment.

Use these tools to find answers to questions that you have, to learn about new functionality, and to
research possible solutions to current issues.

Note  To optimize your use of the support portal, go to the Kofax Customer Portal login page and click
the link to open the Guide to the Kofax Support Portal. This guide describes how to access the support
site, what to do before contacting the support team, how to open a new case or view an open case, and
what information to collect before opening a case.

www.kofax.com
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Chapter 1

Administer CCM Repository

This chapter explains how to use the CCM Designer for Windows administrative interface, which is used
to manage the CCM Repository installation.

Administrative account

CCM Repository has a built-in user account called ITP Admin, which is used for administrative purposes.
The ITP Admin account has a number of advanced features that are not available to the other user
accounts. The advanced features include the following:
▪ Enter and review CCM Repository licenses
▪ Manage active user sessions
▪ Manage user accounts and global user authorization
▪ Break locks on objects
▪ Set installation properties
▪ Remove deleted items from the database

ITP Admin account cannot perform common communication development tasks.

The ITP Admin account and its user sessions do not count against the number of users specified in the
license. If a license violation occurs, you can use the ITP Admin account to resolve it.

Other users can be granted the "Allow login as Admin" right (for more information, see Create user
accounts). The users with this right have the same rights as ITP Admin, without their standard advanced
features. Such user sessions do not count against the license.

Note  Versions prior to 4.2.1 do not support ITP Admin rights for other user accounts.

Default password

The itpadmin user account has a default built-in password, which is www.aia-itp.com. For security
reasons, CCM Repository forces you to change this password when you first log in as ITP Admin.

If the password to the ITP Admin account is lost, you can use another user account with administrative
rights to reset the ITP Admin password.
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If no user account is configured with administrative rights, you can use CCM Repository to regenerate the
default password. To do so, you need access to the CCM Repository database and a tool to execute SQL
commands against that database, as shown below.
1. Execute the following SQL statement. Place the statement on a new line.

 DELETE FROM T1200 WHERE C1201=1

The statement removes the ITP Admin account.
2. Locate cvc.exe, which resides in the Programs folder of CCM Repository Server.
3. Restart CCM Repository Server and run cvc.exe within 10 seconds after starting the server.
4. Pass /cfg=<path to the correct itprep.ini file for the instance such as C:\CCM\Work

\5.1\Instance_01\designer\Config\itprep.ini> to cvc.exe to regenerate the ITP Admin account.
5. Once cvc.exe is finished, start CCM Designer for Windows, and then log in as ITP Admin with the

default password.
You are prompted to change the password.

After installation

The following section describes steps to perform after CCM Repository is installed, according to the
instructions in the Kofax CCM Installation Guide.

Note  The database attached to CCM Repository contains important production data. Make sure that
you perform a database backup on a regular basis.

Enter licenses

1. Start CCM Designer for Windows.

2. Log in as ITP Admin (see Administrative account).

3. On the menu, click View > License.
The "License information" window appears.

4. For the "ITP/MDK Repository base license," "ITP/MDK Repository model development license," and
"ITP/MDK Repository textblock editing license," click Edit. The "DID development (SDK/MP) license"
is only needed to develop DIDs in CCM Repository.
The Model Development License and the Text Block Editing License come with a number of users.
This is the number of user accounts and simultaneous user sessions that are allowed to develop
Master Templates and edit Text Blocks, respectively.

Note  By default, the maximum storage size is 25 MB for Text Blocks, Master Templates, and other
objects stored in the CCM Repository. To learn how to adjust this limit, see the section "Configure
Tomcat settings" in the Kofax Customer Communications Manager API Guide.
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Create user accounts

The ITP Admin account is intended for administrative purposes only. To participate in the development of
Master Templates or perform other common CCM Repository tasks, you need to create one or more user
accounts.

1. In the tree view, click Users.

2. On the menu, click File > New User.
The New User window appears.

3. Enter a name, a full name, and a password, and then click Add User.
A password must correspond to the password policy requirements. For more information on the
requirements, see Configure the password policy.

4. At least one user account must have the right to create projects and assign roles to users. For more
information, see Allow login as Admin right.

Allow login as Admin right

1. To allow the user to log in with the same rights as ITP Admin, in the tree view, click Users.

2. Right-click a user name in the right pane and then click Configuration.

3. To allow the user to log in with the same rights as ITP Admin, select the Authorization tab and
select Allow login as Admin. When selected, the user can assign roles and create projects.

4. Click OK.

Administrative tasks

The following sections describe the tasks specific to ITP Admin or to users with administrative rights.

When the ITP Admin user logs on to CCM Repository, the folders Users, Roles, and Audit Log Entries are
shown. These folders contain information and objects specific to the Administrator.

User management

Only the ITP Admin user or a user with administrative rights can create, delete or change user accounts.
The user accounts reside in the Users folder. To learn how to create a user account, see Create user
accounts.

Unified logon

CCM Designer for Windows prompts the user to enter a name and password when starting. Optionally,
the user may enter a Microsoft Windows account user name to log on to CCM Repository. This unified
logon is performed automatically when CCM Designer for Windows is started. A verification is performed
to ensure that the user name on the client is mapped to the same account on the server.
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To use unified logon, create user accounts in CCM Repository with the names matching those for the
Microsoft Windows user accounts. Also, CCM Repository Server must be configured to allow unified
logon. To do so, add the following line to the itprep.ini file on the servers. The location of the itprep.ini files
depends on the installation and the instance. Typically, the file can be found in <installation root>
\CCM\Work\<version number>\Instance_<instance number>\designer\Config.

Example C:\CCM\Work\5.1\Instance_01\designer\Config.

[Configuration]
AllowUnifiedLogon=Y

When CCM Repository Server is configured to use unified logon, you can force CCM Designer for
Windows to prompt the user to log in. To do so, start CCM Designer for Windows with the /asklogin flag
or add the following line to the itprep.ini file of the clients.

[Configuration]
Asklogin=Y

If you are already logged on to CCM Designer for Windows, click File > Switch user to switch to another
user.

Note  If you switch to another user, your rights also change.

Rename a user account

1. In the tree view, click Users, and in the right pane, right-click the user name, and then click
Configuration.
The Configuration window appears.

2. In the General tab, change the login name and/or the full name of the user account.
The user name has a maximum length of 254 characters. The full name has a maximum length of 79
characters.

3. Click Apply and click OK.

Authorize a user account

CCM Repository provides a role-based authorization functionality. A user can be assigned a role for all
CCM Repository projects or for a specific project, folder or document. A role defines the actions a user is
allowed to perform.

1. In the tree view, click Users, and in the right pane, select the user account.

2. Right-click the user account and click Configuration.
The Configuration window appears.

3. In the Authorization tab, in the Global roles pane, select or deselect roles assigned to the user.
To create new projects, at least one user must be assigned the Project Creator role.

4. Click Apply and click OK.
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Note  The roles assigned to a user account in the "Global roles" pane apply to all projects in CCM
Repository. To assign roles for a specific project, folder or document, use the Configuration window
for this project/folder/document.

Note  When a new role is assigned to a user, the user must log out and then log in.

Reset a password

The Administrator can reset the user's password if it is lost.

1. In the tree view, click Users, and in the right pane, select the user account.

2. Right-click the user account and click Change user password.
The "Change the user password" window appears.

3. Enter and repeat the new password and click OK.

Delete a user account

1. In the tree view, click Users, and in the right pane, select the user account.

2. Right-click the user account, click Delete, and then click Yes to confirm the action.
This user account can no longer be used to log on to CCM Repository. Also, the user account no
longer counts against the maximum number of users in the license. To see objects created with this
user account, click View on the menu, and then click Show deleted items.

Manage user sessions

To view and manage user sessions that are currently active:

1. On the menu, click View > The Sessions.
The "Active sessions" window appears.

2. Click a user session and click Refresh or Disconnect to refresh or close the session, respectively.

Configure the password policy

ITP Admin, or other user who manages CCM installation, can shape the password policy. This can be
done through configuration options in the itprep.ini file of the CCM Repository server of the instance.

Requirements for password

A password must meet the following requirements in a standard configuration. These requirements are
enforced when changing a password.
▪ Be at least 8 characters long
▪ If less than 20 characters long, it should contain at least three of the following character types:

lowercase letters, uppercase letters, digits, and other (symbols, punctuation, and so on)
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▪ For languages without lowercase/uppercase distinction, all three following character types should be
present: letters, digits, and other (symbols, punctuation, and so on)

▪ Not be used earlier by this user in the previous 12 months
▪ Additionally, if the organization has a list with forbidden passwords, the password should not be on this

list. For information on how to configure a list of forbidden passwords, see Configure a list of forbidden
passwords.

You can configure the two password lengths (8 and 20 by default) and the retention period for old
passwords. For more information, see Adjust the password policy settings.

Note  When an incorrect password is provided the user account will be locked out for five consecutive
times at login. To unlock it, the administrator has to reset the password of this user account. For more
information on how to reset a user's password, see Reset a password.

Adjust the password policy settings

Open the itprep.ini file and adjust the following settings, if necessary.

The location of the itprep.ini files depends on the installation and the instance. Typically, the .ini file
resides in: <installation root>\CCM\Work\<version number>\Instance_<instance number>
\designer\Config. For example, C:\CCM\Work\5.1\Instance_01\designer\Config

All values given in the following examples represent the default values.
1. Password length settings

You can change the minimum acceptable length of a password with the MinPasswordLength setting.
[Security] 
MinPasswordLength=8

With the MinSafePasswordLength setting you can define the minimum password length for which
the requirement of three different characters types is omitted.
[Security] 
MinSafePasswordLength=20

If MinSafePasswordLength is set to 0, all passwords require three different character types
regardless of their length. If this setting is set to a value less than or equal to MinPasswordLength,
passwords that satisfy the minimal length requirement do not need three different character types.
Example 1
[Security]
MinPasswordLength=8
MinSafePasswordLength=20

This example allows "a really long password" (22 characters) and "Passw0rd" (8 characters, 3
character types) but does not allow "password" (8 characters, 1 character type).
Example 2
[Security] 
MinPasswordLength=8 
MinSafePasswordLength=0

This example allows "Passw0rd" (8 characters, 3 character types) but does not allow "password" (8
characters, 1 character type) and "a really long password" (24 characters, 1 character type).
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Example 3
[Security]
MinPasswordLength=8
MinSafePasswordLength=8

This example allows "a really long password" (24 characters), "Passw0rd" (8 characters, 3 character
types), and "password" (8 characters, 1 character type).

2. Password reuse setting
With the PasswordReuseAge setting, you can configure the number of months that an old password
is retained and forbidden to be reused.
[Security]
PasswordReuseAge=12

If PasswordReuseAge is set to 0, it disables password reuse memory.
3. Lockout count setting

With the MaxFailedLogins setting you can configure the number of times a user can provide wrong
password before the user's account is locked out. If MaxFailedLogins is set to 0, the user account
is never locked out due to providing the wrong password.
[Security] 
MaxFailedLogins=5

4. Failed logon delay setting
When a logon attempt fails, there is a waiting period measured in seconds before it can be
attempted again. You can configure this waiting period with the FailedLoginDelay.The value of
FailedLoginDelay should be at least 0 and at most 15.
[Security] 
FailedLoginDelay=3

Note  Restart the CCM Repository server and Content Management API after changing these settings
in the itprep.ini file.

Configure a list of forbidden passwords

To prevent use of common passwords, the administrator can configure a list of passwords that will be
rejected as a new password for a user.
1. Create a .txt file with forbidden passwords, placing each password on its own line, or download such

a list from the Internet.
2. Name the file pwdblacklist.txt. The file must be in UTF-8 format with a Byte Order Mark.
3. Place the file in the CCM Repository configuration directory: <installation root>\CCM\Work

\<version number>\Instance_<instance number>\designer\Config

Example C:\CCM\Work\5.1\Instance_01\designer\Config
The file pwdblacklist.txt may already exist. In that case, append your own list of passwords to the
file.

Note  The case of the blacklisted passwords is not relevant: "password" in the blacklist will also
block "Password", "PASSWORD", and "PassWord."
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Note  Restart the CCM Repository server after changing this file. A very large list of forbidden
passwords may cause the first login and changing passwords to slow down after restart.

Project management

This section describes project management functions that may be useful to administrators.

Break locks on objects

The Administrator can break locks on objects locked by users. The Administrator can both break a lock on
a specific object or break all locks made by a user.

1. To break a lock on a specific object, in the tree view, locate and right-click the object, and then click
Break lock.
▪ If the Administrator is breaking a lock on a folder or a project, the "Break lock" window appears.

Select the user who locked the folder/project and click OK. All objects belonging to the folder are
now unlocked.

2. To break all locks made by a user, in the tree view, click Users.

3. In the right pane, right-click the user account, and then click Break lock.
All objects in CCM Repository that are locked by this user are now unlocked.

Purge deleted items

To permanently remove objects that are marked as deleted, the Administrator can use the Purge function.

The function may not remove all objects marked for deletion. For example, when a user deletes a source
document and does not delete the Master Template that was created based on it, the source document is
not purged until the Master Template is deleted as well. You cannot restore items once they are removed
using the Purge function.

Also, the Administrator has a subfolder called "purging blocked by" that lists objects that prevent the
revision from being removed. It may be used by these objects or configured in them (in case of folders
and projects). The Administrator can see this subfolder under the revisions and base objects marked for
deletion. The Show Deleted Items option must be enabled. To enable it, on the menu, click View and click
Show Deleted Items.

A document revision takes up the same amount of disk space as the original document. If you delete and
purge a revision, it is removed from the database and frees up disk space.

To purge an item, click it, and then click File > Purge.

View an audit log

The Administrator can view the Audit Log Entries to track important activities.

To view the Audit Log Entries, in the tree view, click Audit Log Entries and see the right pane.
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Obtain a report

The Administrator can obtain reports on the contents of CCM Repository. The reports are implemented as
Master Templates. Several predefined reports are available in the Reports project. You can create your
own reports so they appear in the Reports when you open a new CCM Designer for Windows browser
window.
1. To get a report when logged in as ITP Admin, in the tree view, click Users.
2. In the right pane, click the user account.
3. On the menu, click Report, and then click User authorization.

Clear a project

To free up disk space, the Administrator can perform a cleanup. The cleanup deletes labels and
redundant versions of the documents used in a project. Versions are considered redundant if they have
no status or are not in use. When the cleanup is complete, the document versions are marked for deletion
and can be restored, but labels are removed permanently. To remove the document versions completely,
use the Purge function (for more information, see Purge deleted items).

You should back up your data before performing a cleanup.

To perform a cleanup, click the project and, on the menu, click Cleanup a Project.

Administrator tools

This section gives a description of the tools that are available to the Administrator.

Dumping and loading the Repository database

You can dump the entire contents of the CCM Repository database to a file with the repdump tool. Later,
this file can be read into a database with the repload tool. Also, a dump can serve as a backup.

These tools can be used together to migrate the CCM Repository database to another DBMS.

The repload tool can load dump files from a CCM Repository installation of the same major and minor
version, regardless of the service pack or fix pack number.

Repdump /cfg=<path-to-config> "path\database dumpfile name"

Repload /cfg=<path-to-config> "path\dumped file name" [/cleardatabase]

In cfg=, pass the tool the correct itprep.ini file for the instance such as C:\CCM\Work
\5.1\Instance_01\designer\Config\itprep.ini.

You must run repdump.exe and repload.exe on the server that runs CCM Repository. Both tools are
installed in the root of the CCM Repository Server installation, and you must not move them. The
repdump tool creates Repdump.log, which resides in the same folder as the tool.
1. To use repload.exe, create a new database or select an existing database that can be emptied and

refilled.
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2. To load a file, stop CCM Repository. To do so, click Start on the menu, and then click Stop server.

If you use an existing database, use the /cleardatabase flag to empty the database. You cannot add the
content of a database dump file to the content of an existing CCM Repository database.

Note  The /cleardatabase flag destroys all content in the database of the loading CCM Repository.
Use it with caution.

If you started a client before using the repload tool, you may encounter errors as the database is no
longer empty. Use the /cleardatabase flag with the repload tool to empty the database before loading.

New database

You can create a new database for CCM Repository and a connection string to connect to it.

Note  The database attached to CCM Repository contains important production data. Make sure to
make a backup of the database on a regular basis.

Configure the new database

The new database must be configured on CCM Repository Server.

1. To configure the new database, navigate to the itprep.ini file and open it in a text editor such as
Notepad.

2. Locate the following entry.
[ODBC]
ConnString=<connection string>
user=<db user>
password=<db user password>

3. Change the values after the equals sign. Provide a connection string for the new database after
ConnString=. Also, change the database user name and password if necessary.
Restart the server after changing the configuration file.

Initialize the new database and upload reports

Use cvc.exe to prepare the database and upload the Reports.

1. Start a command line prompt.

2. Change the folder to the folder where you installed the CCM Repository Server.

3. Execute the following command.
 cvc reportsdump /cfg=<path to itprep.inifile>

Note  You can only see reports if one of your roles is allowed access to it. If you cannot see any
reports, or you can see only some reports, check your authorization.

Now you can open the client and start working with the new database.
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Other roles privileges

The following sections describe roles privileges that were not covered in the previous sections.

Configuration privilege

Use this privilege to edit the objects configuration. It gives access to the Configuration window for an
object. With this privilege, a user can make changes to the name and the description of an object. The
next privileges determine which of the other tabs of the Configuration window are shown. The General tab
is hidden to users who have no privilege to edit the tab.

The Configuration privilege is needed to configure authorization, auto-includes, characteristics, DID/CC,
Field Set, and project privileges.

Privilege to configure the Authorization tab

Use this privilege to assign and revoke roles. With this privilege, a user sees the Authorization tab in the
Configuration window. The Authorization tab is hidden to users who have no privilege to edit the tab.

Privilege to configure the Field Set tab

Use this privilege to add and remove Field Sets from a Forms or Text Block folder. When a Forms folder is
concerned, this privilege is also used to add and remove Text Block Lists from a Forms folder.

Privilege to configure the Characteristics tab

Use this privilege to set characteristics for a project. With this privilege, a user sees the Characteristics
tab in the Configuration window. The Characteristics tab is hidden to users who have no privilege to edit
the tab.

Privilege to configure the DID/CC and Style Documents tabs

Use this privilege to set the DID and Connection Configuration for a project or a folder as well as a Style
Document. With this privilege, a user sees the tabs DID/CC and Style Document in the Configuration
window of a project or a folder.

The DID/CC and Style Document tabs are hidden to users who have no privilege to edit these tabs.

Privilege to configure the Project tab

This setting is a privilege to configure a project. With this privilege, a user sees the Project tab in the
Configuration window. The Project tab is hidden to users who have no privilege to edit the tab.
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Chapter 2

Configuration

This chapter describes configuration issues.

General

Both CCM Designer for Windows and CCM Repository Server use itprep.ini configuration files. The files
use the same syntax but have different content and settings. You can edit the .ini files in a text editor such
as Notepad.

One itprep.ini file exists per server, and another exists for each client.

Note  The configuration files are read only at startup. You need to restart CCM Designer for Windows
on the client once you edit the client configuration file. Restart CCM Repository Server once you edit the
server configuration file.

Syntax

Initialization file sections

Options and settings are arranged in sections in the configuration file. A section starts with the section
name in square brackets on a separate line.

[Configuration]

Settings are added in "Name=value" format.

Note  If a setting is not listed in the .ini file, it is set to the default value.

You can use a semicolon to comment out a line in the configuration file. It must be the first character on a
line.

Shared configuration

The following configuration options are valid for both the client and the server.
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[Configuration]

This example shows the "Set logging" options.

logfile = itprep.log
logsize = 10485760
logrotate = 10

Relevant information is recorded to a file specified by the log file settings.

You can use the logrotate setting to determine how many obsolete log files should be kept (renamed to
itprep.log.1, itprep.log.2, and so on). A new log file is created every time CCM Repository starts, or when
the size of the log file exceeds the value in bytes set with the logsize setting.

The following is the folder where temporary files are placed.

temppath = %TMP%

Defaults to the temp folder are specified by Microsoft Windows. You can specify another path. Sufficient
disk space must be allocated for the temp folder.

Server configuration

All required settings are configured during installation. To edit the configuration file, navigate to the
Programs folder on the Windows Start menu, find the CCM Repository Server folder, and then locate the
Edit Configuration entry. This entry gives you access to the server configuration file.

Restart CCM Repository Server after editing the .ini file.

[Server]

In this section, the port number used by the server for requests is set. 2586 is the default value. Any port
number below 65536 is valid.

[Server]
port=2586
host=<server name or IP address>

The host value is added to the configuration file by the installer from other CCM programs that use the
same configuration file.

Unified logon

The following setting allows the user to log on to CCM Designer for Web using the user's Microsoft
Windows user account name.

[Configuration]
AllowUnifiedLogon=Y
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Licenses

There are three following license sections: [Base license], [Model development license], and [Text Block
development license]. Normally, these licenses are to be filled using CCM Designer for Windows. For
more information, see Enter licenses.

The following keys occur for each of the three license sections. The values are provided on the license
certificate. You must copy them.

company=
certificate=
environment=
date=
users=
key=

The date= value is the expiration date for the license given on the license certificate. Format: yyyymmdd.

The users= setting defines the maximum number of users that can be created and connected to the
server. This number is on the license certificate. The Administrator is not considered as a user in terms of
the license. For the base license, this value is 1.

[ODBC]

In the [ODBC] section, the connection with the database is configured. The Connection String entry is set
during installation.

connString = <connection string>

The connection string specifies the ODBC driver to use, the database to connect to, and various database
options.

Also, you can provide a data source name to store CCM Repository data.

DSN = <data source name>

In the following example, the user and password are provided as separate settings. They do not need to
be included in the connection string. This allows the encryption of the password in the configuration file.

user = <user to connect to the ODBC DSN>
password = <password to connect to the ODBC DSN>

If the password is present in the configuration file in plain text, it is encrypted once a connection with the
database is created. You can recognize the encrypted password by its encrypted: prefix. To change
the database password in the configuration file, replace the encrypted: string with a new plain text
password.

Note  The user account used to access the DBMS must be configured so that its password does not
expire, especially because it affects client access.



Kofax Customer Communications Manager Repository Administrator's Guide

20

[Network]

Use the [Network] setting to reduce the size of the packages sent over the network. You can use this
setting when network load errors occur.

msgsize= <packet size in kilobytes>

If network load errors occur, you should start with a package size of 64 KB. if the problems still occur, use
packages of 32 or 16 KB in size, and so on. The default packet size limit is 512 KB.

Note  Add the [Network] setting to any client connecting to a CCM Repository Server with an edited .ini
file.

Restart the CCM Repository Server after editing the .ini file.

Timeouts

The time that it takes CCM Repository to analyze documents and compile Master Templates is limited
to 60 seconds and 900 seconds, respectively. Large and complex documents may encounter a timeout.
These limits can be configured in the itprep.ini file of CCM Repository Server.

[ITP]
ConversionTimeout=60
CompilationTimeout=900

The values shown above are default values.

If you encounter the message crtmdl timed out, increment the CompilationTimeout value.

If you encounter the messages idoc2unc timed out, Generation timed out or Analysis timed out,
you should increment the ConversionTimeout value.

Restart CCM Repository Server to activate the changes.

Client configuration

All required settings are configured during installation. Restart CCM Designer for Windows after editing
the .ini file.

[server]

The [server] section contains the settings used to connect to the CCM Repository Server host and port.

[Configuration]
port=2586
host=<server name or IP address>

The default value for host is localhost. It indicates the computer that CCM Repository Server runs on.
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Port is the TCP/IP port number used to send requests to the Server. This port number should match the
port value set in the [server] setting of the CCM Repository Server .ini file.
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