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Preface

This guide, which contains general information and instructions on using Kofax Customer
Communications Manager Designer for Web, is intended for all users, regardless of their role. We
recommend that you read this guide before using the software.

Related documentation

In addition to this guide, the Kofax Customer Communications Manager documentation set includes the
following:

▪ Kofax Customer Communications Manager Release Notes
Contains late-breaking details and other information that is not available in your other Kofax Customer
Communications Manager documentation.

▪ Kofax Customer Communications Manager Installation Guide
Describes the installation procedure.

▪ Kofax Customer Communications Manager Getting Started Guide
Describes how to use Contract Manager to manage instances of Kofax Customer Communications
Manager.

▪ Kofax Customer Communications Manager Repository Administrator's Guide
Describes administrative and management tasks in Kofax Customer Communications Manager
Repository and Kofax Customer Communications Manager Designer for Windows.

▪ Kofax Customer Communications Manager Repository User's Guide
Includes user instructions for Kofax Customer Communications Manager Repository and Kofax
Customer Communications Manager Designer for Windows.

▪ Kofax Customer Communications Manager Repository Developer's Guide
Describes various features and APIs to integrate with Kofax Customer Communications Manager
Repository and Kofax Customer Communications Manager Designer for Windows.

▪ Kofax Customer Communications Manager Template Scripting Language Developer's Guide
Describes CCM Template Script used in Master Templates.

▪ Kofax Customer Communications Manager Core Developer's Guide
Provides a general overview and integration information for Kofax Customer Communications Manager
Core.

▪ Kofax Customer Communications Manager Core Scripting Language Developer's Guide
Describes CCM Core Script.

▪ Kofax Customer Communications Manager API Guide
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Describes Contract Manager, which is the main entry point to Kofax Customer Communications
Manager.

▪ Kofax Customer Communications Manager ComposerUI for HTML5 JavaScript API Web
Developer's Guide
Describes integration of ComposerUI for HTML5 into an application, using its JavaScript API.

System requirements

Information about system requirements is available from the Cross Product Compatibility Matrix, which is
available from the Kofax website at www.kofax.com. The matrix is updated regularly, and we recommend
that you review it carefully before installing your product.

Training

To ensure your best experience in working with Kofax Customer Communications Manager Designer for
Web, complete our complimentary and interactive e-learning modules located at www.kofax.com.

www.kofax.com
www.kofax.com
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Chapter 1

Introduction

This chapter introduces Kofax Customer Communications Manager and Kofax Customer
Communications Manager Designer for Web.

Kofax Customer Communications Manager

Kofax Customer Communications Manager (also known as CCM) is a single integrated solution to
automatically produce large numbers of standard documents and compose professional individual
correspondence.

CCM empowers the organization to engage and communicate with customers by generating relevant and
personal communication delivered through different channels.

Kofax Customer Communications Manager Designer for Web

Kofax Customer Communications Manager Designer for Web (also known as CCM Designer for Web) is
an authoring tool and content management system for Kofax Customer Communications Manager.

CCM Designer for Web offers the following key features:
▪ Lifecycle management and a version control system
▪ Role-based functionality
▪ Reusable elements
▪ Central management of templates and content

View on documents

The organization can have hundreds of different documents such as letters, policies, offers, invoices, and
many others. A document consists of various elements, such as the address, salutation, body of a letter,
and closing. A document can also have a corporate identity that includes a logo, footer, standard font,
custom margins, and so on.

Typically, the organization has a number of similar documents. For example, all letters in the organization
may have the same layout, headers and footers, address block, and salutation.

To manage all these elements correctly and easily, they are managed individually in CCM Designer for
Web. Document production in CCM Designer for Web is template-based. Various document elements,
such as blocks of text (so called Text Blocks), or a corporate footer, can be created and adjusted
individually. Changes have to be applied only once.
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CCM Designer for Web is role-based. Changes in certain document elements, such as those related to
the corporate identity, can only be applied by a user whose role is to manage the corporate identity.

Working with separate document elements makes it possible to easily apply multi-branding. Content
elements, such as Text Blocks, can be reused by sub-brands, if their corporate identities differ.

The following figure reproduces the structure of a letter with various elements.

 

 

The logo, name, address, reference, ending, signature, and footer might be identical with each letter. In
CCM Designer for Web, these elements are defined in Master Templates.

The body might differ in each letter. It is defined in Content Wizards and Text Blocks. Content Wizards
and Text Blocks are linked to Master Templates using Document Templates.

A corporate design of a document (headers, footers, font, margins, and so on) is defined in the Page
Style and Style Sheet.

Publication workflow

CCM Designer for Web features a version control system for tracking the history of any object.

CCM Designer for Web also monitors the entire process of publication. This is done with the help of
the lifecycle management system. Every object in the software is part of lifecycle. Within the protected
environment of CCM Designer for Web, you can execute the entire process of testing, accepting, and
publishing.
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CCM Designer for Windows

CCM Designer for Web is a successor to CCM Designer for Windows. Some functions of CCM Designer
for Windows are not yet available in CCM Designer for Web.
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Chapter 2

Getting started

This chapter provides information to help you start working with CCM Designer for Web.

Find your task

CCM Designer for Web offers role-based functionality. This section helps you to get the most important
information based on the tasks you carry out in your organization.

Task 1: add and edit content of a document

You have a lot of domain knowledge. Your task is creating and editing documents and text. In CCM
Designer for Web, you work with Text Blocks, Text Block Lists, Content Wizards, Forms, Document
Templates, as well as Letter Books, Quick Templates, Static Documents, Metadata, and Changesets.

You should review the following topics:

Create a new Text Block

Change the text of a document

Include a Text Block in the document

Create a list of Text Blocks

Include a Text Block List in a Content Wizard

Categorize Text Blocks using Metadata

Format the text in a document

Apply multi-branding features

Use Forms

Work with Quick Templates

Upload Static Documents

Work with Document Templates

Test an object

Unlock, accept, and publish objects

Work with Changesets
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Task 2: manage the corporate identity

You change logos, adjust the margins of a letter and edit the contents of a footer. In CCM Designer for
Web, you work with Text Blocks and Document Templates, as well as Resources, Corporate Design, and
Changesets.

You should review the following topics:

Create a new Text Block

Change the text of a document

Format the text in a document

Include a Text Block in the document

Create a list of Text Blocks

Include a Text Block List in a Content Wizard

Work with Document Templates

Use Resources

Work with Corporate Design

Test an object

Unlock, accept, and publish objects

Work with Changesets

Task 3: create templates

You create templates of documents. You have knowledge of data and applications. In CCM Designer
for Web, you work with Master Templates, Document Templates, Data Backbone, Fields and Field Sets,
Includes, Libraries, and Changesets.

You should review the following topics:

Work with Master Templates

Work with Document Templates

Work with Data

Add Includes

Add Libraries

Test an object

Unlock, accept, and publish objects
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Work with Changesets

Task 4: manage CCM Designer for Web

You create authorizations, new users, and projects. You are the administrator.

We advise that you review all of the sections in this guide. To learn more about your primary tasks, see
the following topics:

Access CCM Designer for Web

Create a new project

Unlock, accept, and publish objects

Reject changes

View the version history of an object

Work with Changesets

Synchronize data between projects

Get information on the published objects in a file

Export and download a project

Make a copy of a project for troubleshooting

Access CCM Designer for Web

Functionality in CCM Designer for Web is organized according to roles. Each user is assigned a role
depending on a task in the project (see Find your task). Every role comes with a set of permissions. For
instance, a Project Administrator is able to grant a template designer access to the project to edit Text
Blocks, and so on.

Note  Typically, CCM Designer for Web is integrated into a business application of the organization. A
user may not need to log on. In case CCM Designer for Web remains unintegrated, the user receives
credentials to log on from a system administrator.

Note  If the installation is successful, a predefined project called "InstallationTest" appears after a user
logs on. Several usage examples in this guide are based on the predefined project, which is intended
for testing and training purposes. You can delete the project using CCM Designer for Windows.
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Roles and permissions

CCM Designer for Web comes with the following roles and corresponding permissions:
▪ Author: Delete, Edit, New, Rename, Set description, Test, Unlock, View.

▪ Content Reviewer: Accept, Reject, Test, View.

▪ Publisher: Publish, Reject, Test, View.

▪ Publishing Author: A Publishing Author is granted permissions of both an Author and a Publisher.

▪ Publishing Reviewer: A Publishing Reviewer is granted permissions of both a Content Reviewer and
a Publisher.

▪ Viewer: A Viewer can View only.

▪ Project Administrator: A Project Administrator is granted all permissions mentioned above. A Project
Administrator's duty is to grant access to other users.

In CCM Designer for Web, you cannot create new roles.

In general, the following rules apply to all permissions:
▪ Roles and correspondent permissions can only be granted to users through the assignment of roles
▪ No permission is granted by default

Assign a role to the user

Use this procedure to assign roles to CCM Designer for Web users.

1. Click a project or a folder a group of users works on and click Authorization in the Other Actions
pane on the right.
The Authorization window appears.

2. From the drop-down list, select a user.

3. Select one or several roles and click Apply.
The Confirmation window appears.

4. Click Yes.
You will receive a notification that the authorizations have been saved.
Repeat the preceding steps for every user.

Note  To create a new user, use CCM Designer for Windows. For more information, see the
section "Create user accounts" in the Kofax Customer Communications Manager Repository
Administrator's Guide.

Change your password

You can change the password that the Administrator assigned to you.
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A password must meet the following requirements:
▪ Minimum password length is 8 characters
▪ If length is fewer than 20 characters, password should contain at least three of the following character

types: lowercase letters, uppercase letters, digits, and other (symbols, punctuation, and so on)
▪ Password cannot be repeated during a 12-month period
▪ If applicable, password should not appear on your organization's list of forbidden passwords

Note  If you provided an incorrect password five consecutive times, your account will be locked out at
login. To unlock it, contact your administrator.

For information on the password policy, see the section "Configure the password policy" in the Kofax
Customer Communications Manager Repository Administrator's Guide.

1. To change your password, in the upper right corner, click the user icon, and then click Change my
password.
The Change my password window appears.

2. Provide the old password and the new password.
If you have no old password, you are not prompted to provide it.

3. Click Change.
You will receive a notification that the password has been changed. Click OK.
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Chapter 3

Work with CCM Designer for Web

Based on the project role assigned to you, select the applicable tutorials in this chapter and read them
carefully.

Create a new project
With CCM Designer for Web, you can upload and import an existing project. To create a new project for
use in CCM Designer for Web, see Create a new project from within CCM Designer for Windows.

Upload and import a project to CCM Designer for Web
1. On the toolbar, click the navigation arrow icon and then click Dashboard.

The dashboard appears.

2. Click Import.

3. Browse to the project to import and click Open.

Note  The maximum supported size of the import file is currently limited by available memory
but typically is around 100 MB. For larger imports, use CCM Designer for Windows. For more
information, see the section "Import and Export" in the Kofax Customer Communications Manager
Repository User's Guide.

4. Click Upload.

5. Enter a name for the project and click Import.
A notification appears when the project is imported to CCM Designer for Web. It will appear in CCM
Designer for Web.

Tip  You may need to refresh CCM Designer for Web to see changes you have applied. To do so,
on the toolbar, click the round arrow icon.

Create a new project from within CCM Designer for Windows

To create new projects, you need to have the corresponding privilege. To learn how to get the privilege,
see the section "Allow login as Admin right" in the Kofax Customer Communications Manager Repository
Administrator's Guide

1. Start CCM Designer for Windows.

2. Click File > New > New Project.
You are prompted to select a document type and a model (Master Template) language.

3. Adjust the settings and click Create.
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The New Project - Configuration window appears.

4. On the General tab, enter a name for the project.

5. Click Apply and then click OK.
The new project appears in CCM Designer for Web. You may need to wait some time for the new
project to appear. If the project does not appear, on the toolbar, click the round arrow icon to refresh
the screen.

Create a new Text Block

A Text Block is a meaningful piece of text that can be reused for different purposes. A Text Block is
usually one or two paragraphs long.

1. Click the project and navigate to Content > Text Blocks.

2. Click the folder that has the type of the document to contain a new Text Block.
For example, to add a new Text Block to a Welcome Letter, it is likely that the folder you need is
named Letters.

3. Click the folder with the document to contain a new Text Block and then click New Text Block in the
New pane on the right.
The New Text Block window appears.

4. Enter a name for the Text Block and click OK.

Note  The name of the Text Block should be meaningful. For example, to add a new Text Block to
a Welcome Letter that will contain information on the loyal customer club, assign the same name
to the Text Block.

The Text Block appears in the folder.

5. To add text to the Text Block, click the Text Block and then click Edit in the View and Edit pane on
the right.
The Text Block Editor appears.

6. Create the text. You can add Fields. To learn more about the editor's functionality, see Format the
text in a document.

7. Save your changes.
To see how the Text Block is going to look in the result document, see Test an object.

Create a new Rich Text Block

CCM Designer for Web gives you the ability to create Rich Text Blocks and edit them in Microsoft Word if
you want to apply formatting that is not available for regular Text Blocks from the Text Block Editor.

1. Click the project and navigate to Content > Text Blocks.

2. Click the folder with the document to contain a new Rich Text Block and then click New Rich Text
Block in the New pane on the right.
The New Rich Text Block window appears.

3. Enter a name for the Rich Text Block and click OK.
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The Rich Text Block appears in the folder.

4. To add text to the Rich Text Block, click it and then click Edit in the View and Edit pane on the right.
Also, you can download the Rich Text Block to your computer to edit it in the editor of your choice
and then upload it back to CCM Designer for Web. To do so, click the object and then click
Download for editing locally in the View and Edit pane on the right. Click Just download or click
Lock and download to lock the object for other users. When you finish editing the object in your
editor, save it and then click Upload locally edited file in CCM Designer for Web to upload the file
from your computer.

Note  The maximum supported size of the uploaded file is 40 MB.

5. Microsoft Word opens. Create or paste the text.

6. Close Microsoft Word and save the changes when prompted to do so.
To see how the Rich Text Block is going to look in the result document, see Test an object.

Include a Text Block in the document
1. Navigate to Content > Content Wizards and click the folder with the document you want to contain

a certain Text Block.

2. Click the file to add a Text Block to and then click Edit in the View and Edit pane on the right.
The Content Wizard Editor appears.

3. On the menu, click Edit and click Add Text Block.
The Text Block window appears.

4. Double-click the folder to contain a Text Block.

5. Click the Text Block to add.

Note  To preview the Text Block, select Text Block Preview in the bottom left corner.

6. Click Add and Close.
The Text Block appears in the structure of the document you are composing. To change the position
of the Text Block in the document structure, click the Text Block and then use the arrows located on
the toolbar on the left.

7. Click File > Save.

8. Click File > Close.

Note  By clicking the red X icon to close the editor, you may lose some changes you have applied.

To view the document or the changes you have applied, see Test an object.
To learn how to adjust properties of a Text Block, see Adjust properties of a Text Block in a Content
Wizard.

Adjust properties of a Text Block in a Content Wizard

You can make a Text Block optional or mandatory and editable or non-editable.
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Make a Text Block editable
Editable means that the user can edit the text of the document being created. This can be useful to add
some personal touch to the document. For example, an employee of your organization can specify in the
letter whether he or she has been in contact with the customer by phone or by email so that the letter
becomes more personal.

1. Navigate to Content > Content Wizards and find the folder with the Content Wizard to edit.

2. Click the Content Wizard and then click Edit in the View and Edit pane on the right.
The Content Wizard Editor appears.

3. Find and right-click the Text Block and then click Edit.
The Text Block window appears.

4. Select Editable.
The Text Block is non-editable by default.

5. Click Ok.

6. Save the changes and close the Content Wizard Editor.

Make a Text Block optional
An optional Text Block consists of predefined text that you can include in your document if needed.
This can be useful to add some extra information in your letter to the customer. For example, to add
information on the annual holiday closing of your organization, you can create a Text Block, make it
optional and use only when you need it. To learn how to create Text Blocks, see Create a new Text Block.

1. Navigate to Content > Content Wizards and find the folder with the Content Wizard to edit.

2. Click the Content Wizard and then click Edit in the View and Edit pane on the right.
The Content Wizard Editor appears.

3. Find and right-click the Text Block and then click Edit.
The Text Block window appears.

4. Select Optional.

5. Click Ok.

6. Save the changes and close the Content Wizard Editor.

Add a condition to a Text Block

By default, a Text Block or another element such as a group of Text Blocks is always included in a
Content Wizard. You can specify whether a Text Block in question is to be used under certain conditions.

1. Navigate to Content > Content Wizards and find the object you need.

2. Click the object and click Edit in the View and Edit pane on the right.
The Content Wizard Editor appears.

3. On the menu, click Edit and then click Add Text Block.
The Text Block window appears.
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4. Find and click the Text Block to which you want to add a condition.

5. Click Add and Close.
The Text Block appears in the structure of the document. To change the position of the Text Block in
the document structure, click the Text Block and then use the arrows located on the toolbar on the
left.

6. Right-click the Text Block and click Edit.
The Text Block window appears.

7. Click the Show/Hide tab.

8. Check Textblock is not always included.

9. Click New on the right to add a new condition.
The Condition window appears.

10. From the drop-down list, select a Field that relates to the Text Block in question. The Text Block will
be included when this Field is equal to the value Y (for yes).
You can apply as many conditions as necessary.

11. Enter Y and click Ok.
The condition has been applied. This Text Block will now only be included in the Content Wizard
when the Field specified is equal to Y.

12. Click Ok.

13. Click File > Save.

14. Click File > Close.

Test a conditional Text Block

If you applied a condition to a certain Text Block, test the Content Wizard it belongs to.

1. Navigate to Content > Text Blocks.

2. Click the Text Block to test and then click Test in the Other Actions pane on the right.
The Test window appears.

3. Click Edit Test Data. For example, you can change a name, gender, or address for the test. This
allows you to check whether data is correctly included in the document.
The Test window appears.

4. Click the Field you specified while including a condition.

5. Enter Y into the required fields to specify that something is different for this test.

6. Click Test.
The document opens in Microsoft Word. Navigate to the conditional Text Block to check if it is
correct.

Retest a conditional Text Block without it appearing in the document
1. Navigate to Content > Text Blocks.

2. Click the Text Block to which you applied a condition and then click Test in the Other Actions pane
on the right.
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The Test window appears.

3. Click Edit Test Data.
The Test window appears.

4. Click the Field you specified while including a condition.

5. Enter N (for no) instead of Y in the required fields.

6. Click Test.
The document appears without the conditional Text Block.

7. Close Microsoft Word.

Add a condition to a group of Text Blocks

You can make a group of Text Blocks conditional so they only appear when you need them in your
document. A group of Text Blocks is also known as a Section.

1. Navigate to Content  > Content Wizards and find the object you need.

2. Click the object and then click Edit in the View and Edit pane on the right.
The Content Wizard Editor appears.

3. In the document structure, right-click the group and then click Edit.
▪ To create a new Section, on the menu, click Edit > Add Section.

The Section window appears.

4. Click the Show/Hide tab.

5. Select Section is not always included.

6. Click New on the right to add a condition to the section.
The Condition window appears.

7. From the drop-down list, select a Field that relates to the section. The section will be included when
this Field is equal to the value Y (for yes).

8. Click Ok.
The condition is applied to the section.

9. Click Ok.
Inclusion of the group of Text Blocks is now conditional. This group will only appear in a document
when you need it.

10. Click File > Save.

11. Click File > Close.

Test a conditional group of Text Blocks

If you applied a condition to a group of Text Blocks, test the Content Wizard to which they belong.

1. Navigate to Content > Content Wizards.

2. Click the object to which you added a group of conditional Text Blocks and click Test in the Other
Actions pane on the right.



Kofax Customer Communications Manager Designer for Web User's Guide

22

The Test window appears.

3. Click Edit Test Data.
The Test window appears.

4. Click the Field you selected while adding a condition to the group.

5. Enter Y in the required fields.

6. Click Test.
The document opens in Microsoft Word. Find and check the group of Text Blocks.

7. Close Microsoft Word.

Retest a conditional group of Text Blocks without them appearing in the
document
1. Navigate to Content > Content Wizards.

2. Click the object to which you added a group of conditional Text Blocks and click Test in the Other
Actions pane on the right.
The Test window appears.

3. Click Edit Test Data.
The Test window appears.

4. Click the Field you selected while adding a condition to the group.

5. Enter N instead of Y in the required fields.
The document opens in Microsoft Word without the conditional group of Text Blocks.

6. Close Microsoft Word.

Change the text of a document
This section explains how to update documents that require corrections.

First, determine which object you need to change:
▪ If a piece of text needs to be adapted, it is a Text Block that you need to edit.

You can use a filter to quickly locate it: the filter works on the name and text of the Text Blocks and Rich
Text Blocks. In the upper right corner, find the text box, type the search word, and then click the filter
icon. The filtered Text Blocks appear under the Text Blocks folder in the tree view. To deactivate the
filter, delete the search word and click the filter icon.

▪ If the structure of the document needs to be adapted, it is a Content Wizard that you need to edit.

The following procedure shows how to find the Content Wizard used in your document. Each document is
created by a Document Template.

1. Navigate to Communications > Document Templates.

2. Click the Document Template to make changes to and then click View in the View and Edit pane on
the right.
The Document Template Editor window appears.
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3. Find the Parameters section and in the Content section learn which Content Wizard is used in this
document. Remember the name of the Content Wizard.

4. Close the Document Template Editor window.

5. Navigate to Content > Content Wizards and find the object to change.

6. Click the object and then click Edit in the View and Edit pane on the right.
The Content Wizard Editor for the Content Wizard you need to edit appears.

7. In the tree view, you can see the Text Blocks used in this document.
To preview a Text Block, click it and, on the menu, click View > Show Text Block Preview. The
preview appears in the bottom right corner.

8. Close the Content Wizard Editor window.
To edit any of those Text Blocks, you can use the filter or navigate to Content > Text Blocks to
locate the Text Block.
To view any changes you have applied to a certain object in CCM Designer for Web, see Test an
object.

Create a list of Text Blocks

In CCM Designer for Web, you can create a list of Text Blocks that are available to you while a document
is being composed. There are two ways to define the contents of a Text Block List:
1. Create a Text Block List as an alias of a Text Block folder to make all Text Blocks in that folder

available for document composition. To learn more, see Create a Text Block List as an alias for a
Text Block folder.

2. Create a fixed set of Text Blocks by manually adding only the needed Text Blocks to a list. To learn
more, see Create a Text Block List as a fixed set of Text Blocks.

Create a Text Block List as an alias for a Text Block folder

1. Navigate to Content > Text Block Lists.

2. Click Text Block Lists and then click New Text Block List in the New pane on the right.
The New Text Block List window appears.

3. Enter a name for the Text Block List and click OK.
The new Text Block List appears in Text Block Lists.

4. Click the new Text Block List and then click Edit in the View and Edit pane on the right.
The Text Block List Editor window appears.

5. Select is an alias for a Text Block Folder.

6. Click Select to choose a Text Block folder to become an alias for the Text Block List to create.

7. Choose a folder and click Select.

8. Click Save & Close.
To include your Text Block List in a Content Wizard that appears when you are composing a
document, see Include a Text Block List in a Content Wizard.
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Create a Text Block List as a fixed set of Text Blocks

1. Navigate to Content > Text Block Lists.

2. Click Text Block Lists and then click New Text Block List in the New pane on the right.
The New Text Block List window appears.

3. Enter a name for the Text Block List and click OK.
The new Text Block List appears in Text Block Lists.

4. Click the new Text Block List and then click Edit in the View and Edit pane on the right.
The Text Block List Editor window appears.

5. Select is a fixed set of Text Blocks.

6. Click Edit list to add Text Blocks.

7. Click the Text Blocks to select them and then click OK.

8. Click Save & Close.

Include a Text Block List in a Content Wizard

By including a Text Block List in a Content Wizard, you facilitate the process of composing a document.

1. Navigate to Content > Content Wizards and find the object to edit.

2. Click the object and then click Edit in the View and Edit pane on the right.
The Content Wizard Editor window appears.

3. On the menu, click Edit and then click Add Selection > Section Group.
You can also add a Text Block List to an existing Text Block Selection Group.
The Section Selection Group window appears.

4. Enter a name for the group and make a selection where needed. You can also make the Selection
Group conditional. For more on how to add a condition, see Add a condition to a group of Text
Blocks.

5. Click Ok.
The new Text Block Selection Group appears in the structure of a Content Wizard. You can adjust
the position of the group by clicking the arrows located on the toolbar on the left.

6. Right-click the new Text Block Selection Group and click Add Text Block List.
The Text Block List window appears.

7. Select a Text Block List and click Ok.
The Text Block List appears in the structure of a Content Wizard.
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Categorize Text Blocks using Metadata

Another way to categorize Text Blocks is the use of Metadata. Metadata is a means to organize and
categorize Text Blocks by applying labels to them. Metadata makes it possible to create labels and to
apply them to Text Blocks so that you can easily filter Text Blocks and use the ones you need.

Create and edit Metadata

1. Navigate to Content > Metadata.

2. Click Metadata and then click New Metadata in the New pane on the right.
The New Metadata window appears.

3. Enter a name for the new Metadata object and assign an ID.
The ID consists of digits.

4. Click OK.
The new Metadata object appears in Metadata.

5. Click the new Metadata object and then click Edit in the View and Edit pane on the right.
The Metadata Editor window appears.

6. Select One value can be selected or Multiple values can be selected. This determines whether
multiple values of the Metadata can be associated with a Text Block or whether a Text Block can
have only one of these values.

7. Enter a name for a value and click Add. Do so for every value to create.

8. Click Save & Close.

9. To use Metadata, you have to promote it to the Published status. For information on how to promote
objects in CCM Designer for Web, see Unlock, accept, and publish objects.

Attach Metadata to a group of Text Blocks

1. Navigate to Content > Text Blocks.

2. Click the folder of Text Blocks to which you want to attach Metadata and then click Configure in the
Other Actions pane on the right.
The Configuration window for the Text Block folder appears.

3. Click the Folder Metadata tab.

4. Click Add Metadata to Folder and select the Metadata object to add. Select at least one default
value if you are prompted to do so and click OK.

5. Click Apply and then click OK.
Metadata is added to every Text Block in the folder. To edit Metadata for a particular Text Block, see
Edit Metadata for a single Text Block in a group.
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Edit Metadata for a single Text Block in a group

Use the Text Block Editor if you need to update the Metadata labels for a Text Block.

1. Navigate to Content > Text Blocks.

Tip  You can also create a new Text Block inside the group and attach to it a different Metadata
label.

2. Click the Text Block with the label to update and then click Edit in the View and Edit pane on the
right.
The Text Block Editor window appears.

3. On the toolbar, click the Metadata icon to edit Metadata.

4. Click Edit and select a different value for the Text Block.

5. Click OK.

6. Click OK again.
A different Metadata label is attributed to the Text Block.

7. Click Save & Close.

Edit Metadata for a single Rich Text Block in a group

1. Navigate to Content > Text Blocks.

Note  You can also create a new Rich Text Block inside the group and attach to it a different
Metadata label.

2. Click the Rich Text Block with the label to update and then click Edit in the View and Edit pane on
the right. Select Edit Metadata.

3. Click the pencil icon and select a different Metadata value for the Rich Text Block.

4. Click OK.

5. Click OK again.
A different Metadata label is attributed to the Rich Text Block.

Format the text in a document

The sections describing formatting options are written with the assumption that you have a basic
understanding of Microsoft Word.

Several text-formatting options are available in the Text Block Editor of CCM Designer for Web.
▪ Styling of the text
▪ Bold formatting
▪ Italics formatting
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▪ Underline formatting
▪ Numbered list
▪ Bulleted list
▪ Increase indent
▪ Insert and edit table
▪ Insert a Field

The styling of the text in the Text Block Editor differs from the styling in the result document. Styling of
the result document is implemented in CCM Designer for Web and complies with the corporate identity of
your organization. To look at the result document, see Test an object.

Note  In CCM Designer for Web, the styles in the style document are not applied to Includes, Master
Templates, and Rich Text Blocks when you edit them. The styles are applied in the result document.

To apply extra formatting, see Define the text styles of a document.

Insert a table

You can insert a table in a document in the Text Block Editor.

1. Navigate to Content > Text Blocks.

2. Click the Text Block to contain a table and then click Edit in the View and Edit pane on the right.
The Text Block Editor window appears.
The process of defining the Text Block is described in the topic Change the text of a document.

3. Place the cursor where you want to insert a table and click the table icon. You can also click this icon
to edit a table.
The Insert/Edit Table window appears.

4. Set the properties for the table.
▪ Select Autosize to adapt the width of the columns to the size of the text.
▪ Select First column, Last column, Header row, or Footer row to apply styling that differs from

other table elements. The styling applied complies with the style of the template.

5. Click Insert.
The table appears where you placed the cursor.

6. Enter some text in the table and click Save & Close.

Include a Field

In CCM, you can use data variables, which are known as Fields. For example, this may be useful to add
the name and the last name of the customer to a letter.

1. Navigate to Content > Text Blocks.
The process of defining the right Text Block is described in the topic Change the text of a document.

2. Click the Text Block where you want to have a Field and then click Edit in the View and Edit pane
on the right.
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The Text Block Editor appears.

3. Place the cursor where you want to include a Field and select the Field in the Fields list on the right
side of the window. You can use a search function here.

4. Double-click the Field to add it to the document.
The Field appears where you placed the cursor.

5. Save your changes.

Format a Field

You can apply basic formatting to a Field. For example, you can specify that the name of a Field should
always be in capital letters.

1. Navigate to Content > Text Blocks.

2. Click the Text Block to which a certain Field belongs and then click Edit in the View and Edit pane
on the right.
The Text Block Editor appears.

3. Click the Field to format and click the F button on the toolbar.

4. Select a formatting and click OK.
You can check if the formatting is applied. If successful, the name of the formatting appears after the
name of the Field. For example, [CustomerAddress.City:upper] indicates that uppercase formatting
has been applied.

5. Click Save & Close.

Add a condition to a Field

You can apply conditional formatting to a Field. For example, this may be useful to make sure that the
name of the client is always preceded by Mr., Mrs., or Ms. The following procedure explaining how to add
Mr. or Mrs., depending on the addressee's gender.

1. Navigate to Content > Text Blocks.

2. Click the Text Block to edit and then click Edit in the View and Edit pane on the right.
The Text Block Editor appears.

3. Place the cursor where you want the name of the customer to appear. From the Fields list on the
right, find and double-click the Fields [Customer.Initials] and [Customer.Surname] if they are not
there.
The Fields appear in the text.

4. Place the cursor before the [Customer.Initials] Field and add the [Customer.Gender] Field.
The Field appears in the text.

5. Click the [Customer.Gender] Field in the text and then click the F button on the toolbar.

6. From the drop-down list, select Condition.
For the Compare with parameter, enter M (for male).
For the Use if matches parameter, enter Mr.
For the Use otherwise parameter, enter Mrs.
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7. Click OK.
If the value for gender is M, the Text Block uses Mr. If the value is not M, Mrs. is used.

8. Click Save & Close.

Test a conditional Field

If you applied a condition to a Field, test a Text Block it belongs to.

1. Navigate to Content > Text Blocks.

2. Click any Text Block to which a conditional Field belongs and click Test in the Other Actions pane
on the right.
The Test window appears.

3. Select the status In development and the needed Document Template.

4. Click Edit Test Data.
The Test window appears.

5. In the Customer field, enter M or F for Mr. or Mrs., as applicable.

6. Click Test.
The document opens in Microsoft Word. Check if the conditional Field appeared correctly.

7. Close Microsoft Word.

Apply multi-branding features

If your organization has branches or offices with different addresses and phone numbers, you can easily
apply multi-branding to the text and corporate identity used in your documents.

Generating documents with different logos in the header or footer requires knowledge of scripting in a
Master Template. For more information, see the Kofax Customer Communications Manager Template
Scripting Language Developer's Guide.

Apply multi-branding features to the text in a document

If your organization has offices located at different addresses, you can specify them in CCM Designer for
Web and then select the right address when sending documents to your customers.

Note  If you already have Text Blocks containing different addresses for different places, skip Step 1
and Step 2.

1. Create several Text Blocks for different addresses. To create Text Blocks, see Create a new Text
Block.

2. Add the Text Blocks to a document that will have different addresses in its text. See Include a Text
Block in the document.
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Note  In the Content Wizard Editor, place the Text Blocks with the addresses one after the other
within the document structure.

3. Navigate to Content > Content Wizards.

4. Click the document that will contain different addresses and click Edit in the View and Edit pane on
the right.
The Content Wizard Editor window appears.

5. In the document structure on the left, right-click one of the Text Blocks containing an address, and
then click Edit.
The Text Block window appears.

6. Click the Show/Hide tab.

7. Select Textblock is not always included. Other properties must remain as set by default.

8. Click New on the right to add a condition to the Text Block.

Note  If a condition has been already created, you may edit it. Click Edit.

The Condition window appears.

9. On the Fields list, select a Field that relates to the address you need. In the empty space to the right
from the value drop-down list, enter text associated with the selected Field.

10. Click Ok.
The condition is applied to the Text Block.

11. Click Ok.

12. Repeat Steps 4 - 11 for every Text Block that contains a different address.

13. Close the Content Wizard Editor.

Use Forms

CCM Designer for Web can easily collect information that is not yet available in a system database.
Forms are a means to get such information to store in Fields in the Data Backbone, and to use to produce
documents. Forms are shown and processed by the Master Template responsible for the document
creation. Forms provide you with a list of questions and store your answers in Fields. You can create and
edit Forms.

There are three types of items you can include in a Form: question, text, or group.

Use a question item to ask for information from the user. Several question types are available, such as
a date question ("What was the date of your phone call with the customer?"). In the question text it is
possible to make use of a Field. All question types contain a Question text, an Answer field, and Help text.
The following types of questions are allowed:
▪ Text Question
▪ Choice Question
▪ Checkbox Question
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▪ Number Question
▪ Date Question
▪ Time Question (different for each question type)

Use a text item to offer the user extra information when a document is being composed. This text will not
appear in the document. For example, the text can show a warning that the user is supposed to read. It
may also show an explanation for a series of questions.

Use a group item to group elements. A group can hold questions, text elements, and other groups.
Groups can be hidden or shown based on a condition.

Create a new Form

This section describes how you can create various types of Forms. In order to attach a Form to a Master
Template, you need knowledge of CCM Template Script. To learn more on the scripting language, see the
Kofax Customer Communications Manager Template Scripting Language Developer's Guide.

Create a Form

A Form may contain almost any type of information.

1. Navigate to Content > Forms.

2. Click Forms and then click New Form in the New pane on the right.
The New Form window appears.

3. Enter a name for the Form and click OK.
The new Form appears.

4. Click the new Form and then click Edit in the View and Edit pane on the right.
The Form Editor opens.

5. Click the Form.

6. On the toolbar on the left, click the plus icon, click Question, and then select the type of the question
you need.
A new window appears.

7. Enter text in the required fields and make selections where needed.
You can also insert a Field from the Fields list if this option is available in the item of your choice.
Click Fields and select a Field.

8. Select Answer field to specify where the answers to the questions will be stored in the Data
Backbone.

9. In the Default answer section, select Default answer if this option is available in the question type
of your choice. You can select to have no default answer, or select it from the Fields list so that the
default answer is taken from the Data Backbone and modify it when necessary.
Go to the Validation tab to adjust the validation settings. For example, you can specify that the
answer to the question may not be left empty.

10. Click OK.
The new Form appears in the window on the right.
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If you have more than one Form, you can create a group of Forms.

Create an Editable Text Block Question

1. Navigate to Content > Forms.

2. Click the Form you need and click Edit in the View and Edit pane on the right.
To create a new Form, see Create a new Form.
The Form Editor opens.

3. Click the Form.

4. On the toolbar on the left, click the plus icon and click Question > Editable Text Block Question.
The Editable Text Block Question window appears.

5. Enter text in the required fields.
You can also insert a Field from the Fields list where this option is available. Click Fields and select
a Field.

6. In the Default answer section, select Text Block, and then select one of the editable Text Blocks.
You can also select From Field if the default answer is already in the system.

7. Click OK.
The new Editable Text Block Question Form appears in the window.

Create a Text Block Question

Text Block Question is a choice question where you can select Text Blocks.

1. Navigate to Content > Forms.
To create a new Form, see Create a new Form.

2. Click the Form to which you want to add a group and click Edit in the View and Edit pane on the
right.
The Form Editor opens.

3. Click the Form.

4. On the toolbar on the left, click the plus icon and click Question > Text Block Question.
The Text Block Question window appears.

5. Enter some text in the required fields.
You can also insert a Field from the Fields list where this option is available. Click Fields and select
a Field.

6. Select Store text blocks in field to specify where the answers to the questions will be stored in the
Data Backbone.

7. Select Auto insert text blocks to automatically insert all of the Text Blocks that you selected for the
document.

8. Click OK.
The Form appears in the window. You can change the position of the Form using arrows located on
the toolbar on the left.
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Create a group of questions

You can create a group of questions and add all of the questions that belong together to this group. You
can also make this group appear conditionally.

1. Navigate to Content > Forms.
To create a new Form, see Create a new Form.

2. Click the Form to which you want to add a group and click Edit in the View and Edit pane on the
right.
The Form Editor opens.

3. Click the Form.

4. On the toolbar on the left, click the plus icon and click Group.
The Group window appears.

5. Enter a title for the group. You can also insert a Field from the Fields list if it is already in the Data
Backbone. To do so, click Fields and select a certain Field.
▪ In the Include group section, select Group is not always included if you want the group to be

included on certain conditions.

▪ You can also select to make the group expandable or shown based on conditions related to the
questions asked previously in the Form. Select either Group is expandable or Group is shown
conditionally.

6. Click OK.
The group of Forms appears in the window.

Create text in a Form

You can create static text in a Form. This can be useful to add text before all the questions.

1. Navigate to Content > Forms.

2. Click the Form to which you want to add a static text and then click Edit in the View and Edit pane
on the right.
The Form Editor appears.

3. Click the Form.

4. On the toolbar on the left, click the plus icon and click Text.
The Text window appears.

5. Enter the text. You can also insert Fields from the Fields list if it is already in the Data Backbone. To
do so, click Fields and select a certain Field.

6. Click OK.

7. Close the editor.
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Use QForms

A QForm is a type of Form used in combination with Content Wizards. QForms are used if the document
has Text Blocks that do not have values. In this case, a QForm provides you with a list of relevant
questions related to the Fields used in these Text Blocks. A QForm helps to save time when composing a
document with multiple Fields. You can create and edit QForms.

Create a new QForm

The process of creating and editing QForms is similar to that of Forms. The difference is that QForms
do not support a Text Block Question and an Editable Text Block Question, and that you cannot make a
group conditional.

1. Navigate to Content > Forms.

2. Click Forms and click New QForm in the New pane on the right.
The New QForm window appears.

3. Enter a name for the QForm and click OK.
The new QForm appears in Forms.

4. Click the new QForm and then click Edit in the View and Edit pane on the right.
The editor appears.

5. Click the QForm.

6. On the toolbar on the left, click the plus icon and select an item and its type.

7. Adjust the settings and click OK.
Make other changes to the QForm, if needed, and proceed with Attach a QForm to a Content
Wizard.

Attach a QForm to a Content Wizard

1. Navigate to Content > Content Wizards and click the folder with the document to which you want to
attach a QForm.

2. Click the document and then click Edit in the View and Edit pane on the right.
The Content Wizard Editor window appears.

3. Click the name of the object in the document structure on the left, right-click the object, and then
click Edit.
The Content Wizard window appears.

4. Click Select to select a QForm.
The Make Selection window appears with all available QForms.

5. Select a QForm for the document you are composing and click Select.

6. Close the Content Wizard window.
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Work with Quick Templates

A Quick Template allows such dynamic elements as Fields. Quick Templates usually include forms and
checklists. For example, your organization employee may need to send a customer a form to be filled with
answers. Quick Templates are a means to generate such forms and to get information quickly.

You can create a Quick Template with Microsoft Word and with the built-in HTML Quick Template Editor.
You cannot change the format once a Quick Template is created.

Create and edit a Quick Template as a Microsoft Word document

To create and edit a Quick Template with Microsoft Word, proceed with the following steps.

1. Navigate to Content > Quick Templates.

2. Click Quick Templates and then click New Quick Template in the New pane on the right.
The New Quick Template window appears.

3. Enter a name for the Quick Template you are creating. From the drop-down list, select Microsoft
Word Document and then click OK.
The Quick Template appears in Quick Templates.

4. Click the Quick Template you just created and click Edit in the View and Edit pane on the right.
Also, you can download the Quick Template to your computer to edit it in the editor of your choice
and then upload it back to CCM Designer for Web. To do so, click the object and then click
Download for editing locally in the View and Edit pane on the right. Click Just download or click
Lock and download to lock the object for other users. When you finish editing the object in your
editor, save it and then click Upload locally edited file in CCM Designer for Web to upload the file
from your computer.

Note  The maximum supported size of the uploaded file is 40 MB.

The Quick Template opens in Microsoft Word.

5. Add some text and Fields. When in Microsoft Word, you cannot add Fields directly as in the Text
Block Editor. The Fields in Microsoft Word should replicate the Fields from the Fields list (see
Include a Field).
For example, to add a Field containing the last name of the customer, place the cursor where you
want to have this Field and type «[Customer.LastName]». You can also add some basic Microsoft
Word formatting to the Field.

Note  Make sure that the Field you want to use does exist in the Fields list.

6. Close Microsoft Word and save the changes when prompted to do so.

7. Click the Quick Template and click Create Document Template in the Other Actions pane on the
right.
You will receive a notification that the Document Template has been created. The Document
Template appears.
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8. To view the Quick Template, navigate to Communications > Document Templates. Click the
Document Template and then click Test in the Other Actions pane on the right.
The document is opened in Microsoft Word.

Create and edit a Quick Template as an HTML document

The following steps describe how to create a Quick Template as an HTML document. In the HTML Quick
Template Editor, you can edit only UTF-8 encoded HTML files.

1. Navigate to Content > Quick Templates.

2. Click Quick Templates and click New Quick Template in the New pane on the right.
The New Quick Template window appears.

3. Enter a name for the Quick Template you are creating. From the drop-down list, select HTML
Document and then click OK.
The Quick Template appears in Quick Templates.

4. Click the Quick Template you just created and click Edit in the View and Edit pane on the right.
Also, you can download the Quick Template to your computer to edit it in the editor of your choice
and then upload it back to CCM Designer for Web. To do so, click the object and then click
Download for editing locally in the View and Edit pane on the right. Click Just download or click
Lock and download to lock the object for other users. When you finish editing the object in your
editor, save it and then click Upload locally edited file in CCM Designer for Web to upload the file
from your computer.

Note  The maximum supported size of the uploaded file is 40 MB.

The Quick Template is opened in the HTML Quick Template Editor.

5. Add some HTML elements. You can add Fields from the Fields list on the right. Place the cursor
where you want to insert this Field and then double-click the Field to insert it. Also, you can click the
Field on the Fields list and then drag it to the edit field on the left.

6. Click Save & Close.
You will receive a notification that the Document Template has been created.

7. Click the Quick Template and then click Create Document Template in the Other Actions pane on
the right.
The Document Template appears.

8. To view the Quick Template, navigate to Communications > Document Templates. Click the
Document Template and click Test in the Other Actions pane on the right.
The Test window appears.

Upload Static Documents

A Static Document is a document that you can upload to CCM Designer for Web and use unchanged.
Static Documents can include maps, diagrams, attachments, and so on.
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Static Documents do not contain dynamic elements such as Text Blocks, Content Wizards, Fields, or
others.

1. Navigate to Content > Static Documents.
The New Static Document window appears.

2. Click Static Documents and then click New Static Document in the New pane on the right.

3. Enter a name for the Static Document you are creating and click OK.
The Static Document appears.

4. Click the Static Document you just created and click Edit in the View and Edit pane on the right.
The Static Document window appears.

5. Click the pencil icon to upload a new file.

6. Navigate to the file to upload and click Open.
Supported file formats are .doc, .docx, .xls, .xlsx, .ppt, .pptx, and .pdf.

Note  The maximum supported size of the uploaded file is 40 MB.

The file appears as a current file.

7. Click Save & Close.

8. Click the Static Document and then click Create Document Template in the Other Actions pane.
You receive a notification that the Document Template has been created. The Document Template
appears in Document Templates.

9. To view the Static Document you uploaded, navigate to Communications > Document Templates.
Click the Document Template for the Static Document you uploaded and click Test in the Other
Actions pane on the right.
The document is opened in a PDF editor.

Use Resources

The Resources folder holds various resources used to generate documents, such as CSS Style Sheets,
XSLT Style Sheets, Overlays, and images of different formats. The resources can be accessed with CCM
Core Script and CCM Template Script, depending on the resource type.

For information on how to access CCM Designer for Web resources with the languages instructions,
see the Kofax Customer Communications Manager Core Scripting Language Developer's Guide and the
Kofax Customer Communications Manager Template Scripting Language Developer's Guide.

Create and edit a Resource

You can create and edit resources in CCM Designer for Web.

1. Navigate to Resources.
▪ To create a new Resource, click Resources and then click New Resource in the New pane on

the right.
The New Resource window appears.
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▪ Enter a name for the new resource, select a type from the drop-down list, and then click OK.
The new object appears in Resources.

2. Click the Resources object to edit. Depending on the object type, you can either edit it by clicking
Edit in the View and Edit pane or download it to your computer to change it in the editor of your
choice. To do so, click the object and then click Download for editing locally in the View and Edit
pane on the right. Click Just download or click Lock and download to lock the object for other
users. When you finish editing the object in your editor, save it and then click Upload locally edited
file in CCM Designer for Web to upload the file from your computer.

3. The Resource Editor window appears. Enter or paste the necessary code.

4. Click Save & Close.

About XSLT Style Sheets and CSS Style Sheets in CCM Designer for Web

In CCM Designer for Web, you can convert XML documents to HTML or different XML-based formats.
This is managed in XSLT Style Sheets. The XSLT processor can also call CSS Style Sheets. When a
CSS Style Sheet is attached to HTML documents, you can define different styling properties that need to
be applied to an HTML document.

About Overlays

In the Overlays folder in Resources, you can store static Microsoft Word documents that can be retrieved
with scripting instructions in CCM Core. Overlays are mostly used in combination with PDF files.

Upload an image to Logos

In the Logos folder in Resources, you can store images. This can be useful to print a document with a
corporate logo in the header or footer. Using images requires scripting in a Master Template responsible
for the document you are generating.

1. Navigate to Resources > Logos.

2. Click Logos and then click New Resource in the New pane on the right.
The New Resource window appears.

3. Enter a name for the new resource, select Logos from the drop-down list, and then click OK.
The new object appears in Logos.

4. Click the new object and click Upload locally edited file in the View and Edit pane on the right.
The "Upload a new version" window appears.

5. Click Select File.
Supported file formats are .gif, .jpg, .jpeg, .png, and .bmp.

6. Choose the file to upload and click Open.

7. When the file has been uploaded, click Upload.
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Work with Corporate Design

In CCM, you can maintain the layout definitions for the document separately from the content. Such a
layout definition is called a Brand. A Brand contains Page Style and Style Sheet documents.

A Style Sheet defines the text style properties in the documents. A Page Style defines the margins and
the section properties in the documents.

1. To create a new Brand, navigate to Corporate Design and click New Brand in the New pane on the
right.

2. Enter a name for the new Brand and click OK.
The Brand appears in Corporate Design.

3. To learn how to define the Style Sheet and Page Style documents, see the next sections.

Define the text styles of a document

1. Navigate to Corporate Design and click the Brand you are working on.
▪ To create a new Style Sheet, click Style Sheet and then click New Style Sheet in the New pane

on the right.
▪ Enter a name for the new Style Sheet and click OK.

The new object appears in the Style Sheet folder.

2. Click the Style Sheet to edit and click Edit in the View and Edit pane on the right.
Also, you can download the Style Sheet object to your computer to edit it in the editor of your
choice and then upload it back to CCM Designer for Web. To do so, click the object and then click
Download for editing locally in the View and Edit pane on the right. Click Just download or click
Lock and download to lock the object for other users. When you finish editing the object in your
editor, save it and then click Upload locally edited file in CCM Designer for Web to upload the file
from your computer.

Note  The maximum supported size of the uploaded file is 40 MB.

3. Microsoft Word opens. You can now edit the formatting styles that are added to the Style Sheet.
For example, to format the basic text font, the item might be named ITP_normal.

4. Make necessary changes and click OK.
Changes are applied to every item with this style in result documents where this Style Sheet is
applied. To apply the Style Sheet to a document, you need to use a command of CCM Template
Script. For more information, see the section "stylesheet" in the Kofax Customer Communications
Manager Template Scripting Language Developer's Guide.

5. Close the Microsoft Word document and save the changes when prompted to do so.

Format a table
You can use Style Sheets to create a custom table style, or format the ITP_table style if it is available in
the preview of formatting styles. The steps below describe how to create a new table style to use in the
documents.
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Note  ITP_table styles are only applied to tables in standard Text Blocks. Any other table style added to
Style Sheets can only be used in a Rich Text Block.

1. Navigate to Corporate Design and find the brand you are working on.

2. Click Style Sheet and select the file to format.

3. Click the file and then click Edit in the View and Edit pane on the right.
Microsoft Word opens. You can preview the formatting styles.

4. Place the cursor in the blank space at the end of the document, click the Insert tab in Microsoft
Word, and then click Insert Table.

5. Define the number of columns and rows and click OK.
The table appears where you placed the cursor.

6. Navigate to Table Tools > Design >Table Styles.

Tip  If this tab is not available, click the table you inserted and the Table Tools tab will appear.

7. Click the small arrow located in the lower right corner to see more options.

8. Click New Table Style.
The Create New Style from Formatting window appears.

9. Enter a name for the style in accordance with the names of the styles previewed in the document.
Example ITP_table.

10. Make necessary changes and click OK.
The new style appears in the Table Styles section.

11. Click the new style to apply to your table.

12. Close the Microsoft Word document and save the changes when prompted to do so.

Define the page style of a document

You can format the style of the page in Page Style.

1. Navigate to Corporate Design and click the Brand you are working on.
▪ To create a new Page Style, click Page Style and then click New Page Style in the New pane on

the right.
▪ Enter a name for the new Page Style and click OK.

The new object appears in the Page Style folder.

2. Click the Page Style to format and then click Edit in the View and Edit pane on the right.
Also, you can download the Page Style object to your computer to edit it in the editor of your
choice and then upload it back to CCM Designer for Web. To do so, click the object and then click
Download for editing locally in the View and Edit pane on the right. Click Just download or click
Lock and download to lock the object for other users. When you finish editing the object in your
editor, save it and then click Upload locally edited file in CCM Designer for Web to upload the file
from your computer.

3. The Microsoft Word document opens. Select the Page Layout tab and find the Page Setup section.
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4. Click the small arrow in the lower right corner in the Page Setup section.
The Page Setup window appears.

5. Make necessary changes and click OK.

6. Close Microsoft Word and save the changes when prompted to do so.
To view the changes you have applied, see Test an object.

Work with Data

Manage Field Sets

A Field Set is a group of Fields containing data that can be associated with Text Blocks and Forms.

For example, you can create a Field Set, such as CompanyData, and add its Fields to a Text Block (see
Include a Field). When creating question Forms, you can save the answers in the Fields of a certain Field
Set (see Use Forms).

Also, you can use a special Field Set type, Status Field Set, in combination with Content Wizards. In a
Content Wizard, you can optionally add Sections and Text Blocks as well as create editable Text Blocks.
During composition of a document or a Document Pack, the user can interactively choose to include the
Section or the Text Block and/or to change the content of the editable Text Block.  Status Field Sets can
be used to store information on the user's choice and to store the content of the changed editable Text
Block.

Create and edit a Field Set

1. Navigate to Data > Field Sets.
▪ To create a new Field Set, click New Field Set in the New pane on the right.
▪ Enter a name for the new Field Set and click OK. The name can only contain alphanumeric

characters and must start with a capital letter.
The new object appears in Field Sets.

2. Click the needed Field Set and then click Edit in the View and Edit pane on the right.
The Field Set Editor appears.

3. To add a Field to the Field Set, click the plus icon.

4. Enter a name, a default value, a format, and a description for the Field.
The default value is only used if the Field is used in a Text Block and no other value is assigned to it.
The format determines how the content of the Field is formatted when that Field is used in a Text
Block. You can select the following formats. The result of the format is language dependent, which
applies to the thousand separators and date representation.

Format Description
none No formatting is applied to the content of the Field.

The content is presented as is.
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date Presents the content of the Field as a date. The day
and the year are presented as numbers; the month
is presented as the month's name. The Field must
contain a numerical date value.
The result depends on the output language.
Example 20160621
Results
English US: June 21 2016
English UK: 21 June 2016
Dutch: 21 juni 2016

amount Rounds the numerical content of the Field to two
decimals and adds thousand separators, if applicable.
Use this format if the numerical content of the Field
should be represented as money amounts. No
currency signs or other additions are added. The Field
must contain a numerical value.
Example 1234.56
Result 1,234.56

numerals without format Rounds the numerical content of the Field to zero
decimal positions. No thousand separators are added.
The Field must contain a numerical value.
Example 1234.56
Result 1235

uppercase Represents the text content of the Field in uppercase
characters.
Result NEW YORK

lowercase Represents the text content of the Field in lowercase
characters.
Result new york

5. When you finish adding the Field, click the save icon to the right of the Description field. When you
finish creating the Field Set, click Save & Close.

6. Now you need to add the Field Set to the Data Backbone. For more information, see the section
"Add a Field Set to the Data Backbone" in the Kofax Customer Communications Manager
Repository User's Guide.

Create a Status Field Set and add it to a Content Wizard

1. Navigate to Data > Field Sets.
▪ To create a new Status Field Set, click New Status Field Set in the New pane on the right.
▪ Enter a name for the new Status Field Set and click OK. The name can only contain alphanumeric

characters.
The new object appears in Field Sets.

2. Click the needed Status Field Set and then click Edit in the View and Edit pane on the right.
The Field Set Editor appears.

3. To add a Field to the Status Field Set, click the plus icon.
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Unlike regular Fields, Fields of a Status Field Set have no default value and format.

4. Enter a name and a description for the Field. When you finish adding the Field, click the save icon to
the right of the Description field. When you finish creating the Status Field Set, click Save & Close.

5. Now you need to add the Status Field Set to the Data Backbone. For more information, see the
section "Add a Field Set to the Data Backbone" in the Kofax Customer Communications Manager
Repository User's Guide.

6. To add the Status Field Set to a Content Wizard, navigate to Content > Content Wizards.

7. Click the needed document and then click Edit in the View and Edit pane on the right.
The Content Wizard Editor opens.

8. Double-click the Section or the Text Block to edit.

9. In the appeared window, select the Advanced tab.

10. From the drop-down list, select the Status Field. Select unique Status Fields for each object.

11. Click Ok. Close the Content Wizard Editor and save the changes when prompted to do so.
Now the information on the interactive choice will automatically be stored in a resulting Data
Backbone XML when composing the document or Document Pack.

Manage Test Data

CCM Designer for Web uses data to generate documents. All the data received from the repository and
collected from interaction with the clients is defined by the Data Backbone. CCM Designer for Web also
allows you to manage data that is used to test the documents.

There are two ways to manage the Test Data content:
▪ To create a new XML file containing the data you need and upload it to CCM Designer for Web.
▪ To edit the existing data file. See Edit Test Data.

Edit Test Data

You can download an existing XML Test Data file, make changes to it, and then upload it back to CCM
Designer for Web.

1. Navigate to Data.

2. Click Data Backbone and then click Manage Test Data in the Other Actions pane on the right.
The Test Data Manager window appears.

3. Choose the XML file to edit and click the pencil icon.
The Edit Test Data window appears.

4. Click Download.

5. Open the file in a text editor. Make necessary changes to the data.

Note  Make changes only to the values, leaving the XML structure and tags intact.

6. Save the file to your computer.

7. Close the Edit Test Data window.
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8. In the Test Data Manager window, click Add to upload the file you changed.
The New Test Data window appears.

9. Enter a name for the file and click the pencil icon.

10. Navigate to the XML Test Data file you just edited, click it, and then click Open.

11. In the New Test Data window, click OK.
The XML file appears in the list and is ready to be used in the test.

Work with Master Templates

A Master Template is a program responsible for the document creation. It links all components of the
document together, such as Text Blocks, Content Wizards, and Data Backbone. Every type of document
has its own Master Template.
You can write a Master Template in CCM Template Script, which is the scripting language used to
program documents. The following sections are written with the assumption that you are familiar with the
concepts of CCM Template Script. To learn on the available keywords, functions, and procedures, see the
Kofax Customer Communications Manager Template Scripting Language Developer's Guide.

Create a new Master Template

1. Navigate to Master Templates, right-click it, and then click New Master Template in the New pane
on the right.

2. Enter a name for the Master Template and click OK.

3. Click the new Master Template and then click Edit in the View and Edit pane on the right.
Also, you can download the Master Template to your computer to edit it in the editor of your
choice and then upload it back to CCM Designer for Web. To do so, click the object and then click
Download for editing locally in the View and Edit pane on the right. Click Just download or Lock
and download to lock the object for other users. When you finish editing the object in your editor,
save it and then click Upload locally edited file in CCM Designer for Web to upload the file from
your computer.

4. Add necessary CCM Template Script instructions as described in the Kofax Customer
Communications Manager Template Scripting Language Developer's Guide.
To facilitate the process of working with Master Templates, you can take advantage of Includes (see
Add Includes) and Libraries (see Add Libraries).

Add Includes

CCM Designer for Web is all about reusable content. Different Master Templates can make use of single
functions and procedures. Includes contain functions and procedures and can be reused in more than
one Master Template. This helps you reuse correct functions, such as date and addressing. To avoid
mistakes when creating a new Master Template, you can refer to such functions instead of writing them
manually.
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Note  In CCM Designer for Web, when a change is applied to an Include, it affects the Master Template
that makes use of this Include. To prevent errors, we recommend that you recreate a template after an
Include is updated.

Create and edit an Include
1. Navigate to Master Templates > Includes.

2. Click Includes and then click New Include in the New pane on the right.
The New Include window appears.

3. Enter a name for the new Include and click OK.

4. Click the new Include and then click Edit in the View and Edit pane on the right.
Also, you can download the Include to your computer to edit it in the editor of your choice and
then upload it back to CCM Designer for Web. To do so, click the object and then click Download
for editing locally in the View and Edit pane on the right. Click Just download or Lock and
download to lock the object for other users. When you finish editing the object in your editor, save
it and then click Upload locally edited file in CCM Designer for Web to upload the file from your
computer.

5. Add or paste necessary code and close Microsoft Word.
To attach an Include to a document, see the next section.
If an error occurs, click View error document.

Attach an Include

Note  To prevent errors, do not rename an Include once it is included.

1. Navigate to Master Templates.

2. Find and click the document to attach an Include and then click Edit in the View and Edit pane on
the right.
Microsoft Word is opened.

3. Create a new paragraph where you need to insert an Include, place the cursor in the new paragraph,
and type __INC(the name of the Include).

4. Add all the needed __INC instructions and close Microsoft Word.

5. Save the changes when prompted to do so.

Add Libraries

Libraries are a means to create reusable instructions for CCM Designer for Web when Master Templates
are executed. While Includes are compiled in Master Templates, Libraries are completely self-contained.
Each Library is compiled individually.

Libraries can contain the following reusable functions and procedures:
▪ Formatting functions used to format Fields in Text Blocks.

You can extend the list of available functions by defining your own format functions in a Library.



Kofax Customer Communications Manager Designer for Web User's Guide

46

▪ Filter functions used to filter Text Blocks in Text Block Lists.
▪ Export functions and procedures used in Master Templates. These functions and procedures cannot

produce word processor instructions.

Create and edit a Library
1. Navigate to Master Templates > Libraries.

2. Click Libraries and then click New Library in the New pane on the right.
The New Library window appears.

3. Enter a name for the new Library and a level and click OK.

Note  All Libraries have to be assigned unique level numbers. Level numbers determine the order
in which the contents are loaded. Libraries with higher levels have priority over libraries with lower
levels. The default level is 100.

The new Library appears in Libraries.

4. Click the new Library and then click Edit in the View and Edit pane on the right.
The Library opens in the Library Editor.

5. Add or paste the necessary code to the Library. For more information on the reusable functions and
procedures that a Library can contain, see the sections "FORMAT functions," "FILTER functions,"
and "EXPORT functions and procedures" in the Kofax Customer Communications Manager
Template Scripting Language Developer's Guide.

6. Click Save & Close.
If an error occurs, click Show Error Document.

Compile a Master Template

You need to compile the Master Template you created or edited for the changes to take effect.

1. Navigate to Master Templates.

2. Find and click the document to compile and then click Compile in the Other Actions pane on the
right.
If an error occurs, click View error document.

Add a Documentation document

The Master Templates folder also contains that Documentation folder where you can store documents
for the projects. You can create and edit a document in CCM Designer for Web or download it to your
computer for editing in the editor of your choice.

1. Navigate to Master Templates > Documentation.

2. Click the folder and then click New Documentation Document in the New pane on the right.

3. Type a name for the document and click OK.
The new document appears in Documentation.

4. Click the new document and then click Edit in the View and Edit pane on the right.
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Also, you can download the document to your computer to edit it in the editor of your choice
and then upload it back to CCM Designer for Web. To do so, click the document and then click
Download for editing locally in the View and Edit pane on the right. Click Just download or
Lock and download to lock the object for other users. When you finish editing the document in your
editor, save it and then click Upload locally edited file in CCM Designer for Web to upload the file
from your computer.

Note  The maximum supported size of the uploaded file is 40 MB.

5. Enter or paste the necessary text and close Microsoft Word.
Save the changes when prompted to do so.

Work with Document Templates

Document Templates are used to generate documents. Every document has its own Document Template,
which is based on a Master Template, a Quick Template, or a Static Document.

To create and define a new Document Template, you might first want to learn about Master Templates
(see Work with Master Templates), Quick Templates (see Work with Quick Templates), and Static
Documents (see Upload Static Documents).

Create a new Document Template

The following procedure explains how to create a Document Template based on a Master Template.

1. Navigate to Communications > Document Templates.

2. Click Document Templates and then click New Document Template in the New pane on the right.
The New Document Template window appears.

3. Enter a name for the new Document Template and click Next.
The Document Template Editor appears.

4. In the Based on Master Template section, click the pencil icon to define a Master Template and
other properties.

5. In the new window, select the Master Template tab and click a Master Template on which the new
Document Template will be based.
The name of the Master Template appears in the section.

6. In the Description section, click the pencil icon to add a description.

7. If the Parameters section contains parameters, to provide or edit them, see the following
information.
If the Master Template on which the Document Template is based contains parameters, such as
TEXT, DATE, WIZARD, or FORM, the Document Template Editor prompts you to provide values for these
parameters. You must provide values for all mandatory parameters (marked with an asterisk). For
optional parameters, you may leave them unchanged. To get a description of a parameter, move the
pointer to the parameter name.
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If the parameter contains a field to fill out, type the necessary value in the field. Otherwise, click the
pencil icon, and type a value or make a selection, as applicable.
For more information on the parameters and how to define them in a Master Template, see the
section "PARAMETER" in the Kofax Customer Communications Manager Template Scripting
Language Developer's Guide.

8. Click Save & Close.
The new Document Template appears in Document Templates.

Create and edit a new Document Pack Template

A Document Pack contains sets of documents. For example, this is useful if you want to send your
customer multiple documents in one pack, without combining them manually. A Document Pack is
created from a Document Pack Template.

1. Navigate to Communications > Document Pack Templates.

2. Click Document Pack Templates and then click New Document Pack Template in the New pane
on the right.
The New Document Pack Template window appears.

3. Enter a name for the new Document Pack Template and click OK.
The new Document Pack Template appears in the Document Pack Templates folder.

4. Click the new Document Pack Template and then click Edit in the View and Edit pane on the right.
▪ As you edit the new Document Pack Template for the first time, the "Cover letter" window opens.

In the Name field, enter a meaningful name for the Cover letter.

▪ Under Content, select one of the following options.
To create a document based on a particular Document Template, select Document Template and
then select a Document Template from the drop-down list.

Note  Whenever you select a Document Template from a drop-down list, you can start typing
the name of the Document Template to filter the list.

To add a document stored outside of CCM to the Document Pack, select Import Document.

5. Click OK to proceed.
The Document Pack Template Editor appears.

6. The "Cover letter" slot appears under Properties.

7. You can make changes to the slot, if needed.
▪ In the Description field, you can optionally enter text about the content of this slot.

▪ If you selected Document Template and you see the drop-down list "Every channel uses the
Template", refer to Create and edit a Document Pack Template with channels for details and
information on what to do next.

▪ If you create a "Cover letter" slot and selected Import Document, the setting "The business
application is required to provide an import document for this slot." is disabled. If you create a
non-cover letter slot, select this check box to require a document that will be imported.
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8. In the Slot Identifier field, you can optionally specify a reference for the business application so it
could reference the slot by its slot identifier. A reference must be valid.

Note  If you are creating a Document Pack Template to be used with Kofax TotalAgility, you must
provide a reference for every slot of the Document Pack Template.

9. Click Save to save the current changes.

10. To add a new slot to your Document Pack Template, click Add.
The Add a new Slot window appears.

11. Provide the requested information and click Add Slot.
The new slot appears.

12. To make the new slot conditional and/or optional, proceed to the Steps 13 and 14. You cannot make
the "Cover letter" slot conditional or optional.

Note  To change the order of slots, click to the right of a slot so the arrows sign appears and drag
the slot to the correct position. You cannot change the leading position of the "Cover letter" slot.

13. To make the new slot conditional so the resulting document appears in the result Document Pack on
a condition, select This slot will be included conditionally. Click each of the following elements to
set the expression.
▪ Click «select a field» and select a Field from the Fields List.
▪ Click (as text) and select one of the options to specify how the selected Field value should be

interpreted.
▪ Click is equal to/ is on/ is at and select one of the options to specify how the selected Field value

should be compared with the second part of the expression.
▪ Click the value and choose whether the selected Field value should be compared to a particular

value or to the value of another Field.
If you selected the value, click «enter a value» and enter a value, such as a text, number, date,
or time. If you selected the value of field, click «select a field» and select a Field from the list.

To add another expression, click Add. When you state multiple expressions, click and/or to indicate
whether all or at least one condition is true. If the entire condition is true, the slot is included in the
result Document Pack.
To remove an expression, move the pointer to the right of the line, wait until the bin icon appears,
and then click it.

14. To make the new slot optional so the user can choose whether to include the resulting document in
the Document Pack, check The user can choose to include this slot.

15. To select a Document Template to prepare data to add to the Data Backbone, click Properties and
select a Document Template from the Data Preparation Template list.

16. Click Save to save the changes and continue working on the Document Pack Template or Save &
Close to save the changes and close the Document Pack Template Editor.
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Create and edit a Document Pack Template with channels

This section is written with the assumption that your organization is using the functionality that lets you
specify Document Templates for "channels" in CCM Designer for Web.

To produce documents with different formats and purposes, various channels can be configured. For
example, the channels can include print, archive, email, or web portal. The Document Pack Template
Editor provides an optional functionality that offers you to define the content that should be produced
for one or multiple channels. Each channel uses a default Document Template, but exceptions can be
specified.

To learn how to edit a Document Pack Template with respect to defining the content for each of the
configured channels, follow these steps:

1. Navigate to Communications > Document Pack Templates.

2. Click the needed Document Pack Template and then click Edit in the View and Edit pane on the
right.
The Document Pack Template Editor is opened.

3. Select a slot that is using a Document Template for its content (under Content, Document
Template must be selected).

4. From the Every channel uses the Template list, select a Document Template that as the default
Document Template for those channels that have no Document Template assigned to them.

5. Now you can add exceptions for one or multiple channels, that is, add a different Document
Template for a particular channel. To do so, click Add exception and select a channel.
To delete an exception for a channel, move the pointer to the right end of the corresponding section,
wait until the bin icon appears, and then click it.

6. Select a Document Template for each of the added channels from the corresponding lists. If you
need a particular channel to be empty, select No document is produced for this channel in the list
for this channel.

Note  If you receive a notification saying that the Document Pack Template no longer contains
configuration for particular channels, this means that the configuration has been cleared for some
reason. To automatically remove all channels that no longer exist in the Document Pack Template,
click Yes. To manually make necessary changes to the slots containing those channels, click No
and locate the slots.

7. Make other changes to the Document Pack Template, if needed. For more information, see Create
and edit a new Document Pack Template.

8. Click Save & Close to save the changes and close the Document Pack Template Editor.

Test a Document Pack Template

To verify that the Document Pack Template you created is correct, you can review it.

1. Click the Document Pack Template and then click Test in the Other Actions pane on the right.

2. Select a status and a Test Data file and then click Test.
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The Test window appears.

3. Review the documents included in the pack.
▪ If the Document Pack Template contains interactive Document Templates, fill in the fields and click

Next to proceed. Then click Review to review the non-interactive documents starting from the first
slot. To review a particular slot, click the magnifying glass in the structure on the left.

▪ If channels have been configured for the Document Pack Template, proceed with Step 4.

▪ If no channel has been configured, you can simply review the documents included in the pack.

4. You can review the document for each channel:
▪ To review the document for the first slot in the Document Pack Template, click Review and then

select a channel to view its content.
▪ To review the document for a particular slot, click the magnifying glass and then select a channel

to view its content.
▪ If the document is an HTML document, click Download to save or open it in a separate browser

window.

Note  To get information on the available channels, click the question mark.

If no document is included for a particular channel in this slot, a notification is shown.

5. When you finish testing the Document Pack Template, click Next to confirm and close the window.
To review the documents included in the Document Pack Template in more detail, you should test
their corresponding Document Templates. For information on testing objects in CCM Designer for
Web, see Test an object.

Work with Letter Books

Use Letter Books to configure and organize a collection of Document Templates. Letter Books are
available outside CCM Designer for Web and you can import them.

Create and edit a Letter Book

1. Navigate to Communications > Letter Books.
▪ To create a new Letter Book, click Letter Books, and then click New Letter Book in the New

pane on the right.
The New Letter Book window appears.

▪ Enter a name for the new Letter Book and click OK.
The new Letter Book appears in Letter Books.

2. Click the Letter Book and then click Edit in the View and Edit pane on the right.
The Letter Book Editor window appears.

3. In the window on the right, click and drag Document Templates to the window on the left.

4. You can also refer to other Letter Books from the current Letter Book. To do so, click the Letter
Books tab, and then click and drag the Letter Books you need to the window on the left.
▪ Click Update Nested Letter Books to apply changes to existing Letter Books, if applicable.
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▪ Click Copy descriptions to copy the description to each Document Template in this Letter Book
that has no description.

5. When you finish creating the Letter Book, click Save & Close.

Import a Letter Book

1. Navigate to Communications > Letter Books.

2. Click Letter Books and then click Import Letter Book in the Other Actions pane on the right.

3. Click Select and Import File.

4. Click the file to upload and click Open.

Note  Letter Books are XML files.

When the file is imported, close the window.

Test an object

You can test the changes you applied or the document you created before unlocking or accepting them.

1. Navigate to the object to test.
For example, if you inserted a table in a Welcome Letter and want to see the whole document,
navigate to Content > Text Blocks > Letters.

2. Click the object and then click Test in the Other Actions pane on the right.
The Test window appears.
The status line indicates the status of an object (for more information on the status, see View the
version history of an object).
The upper frame shows which Document Templates use this Text Block.
The lower frame shows the data file to use in the test.

3. Select a status, a Document Template, and a Test Data file.
To edit data to use in the test (such as name, gender, customer address, or other), select a Test
Data file and then click Edit Test Data. Click Expand All to see all data available to be edited.

4. To adjust additional test settings, click Show advanced options.
▪ Select one of the following test modes:

Detect to determine and automatically run the test in the applicable mode.
Non interactive if all needed information is available for the tested document.
Interactive if you need to manually provide additional information that is not available from the
Data Backbone, or select Text Blocks that should be used in the test document.

▪ Select the result format.

▪ Optionally, you can provide Keys and Extras. For more information, see the section "Keys and
extra parameters" in the Kofax Customer Communications Manager Core Developer's Guide.

5. Click Test.
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6. If you are prompted to enter additional information, enter it in the forms that appear and click Next to
proceed.

7. Review the changes you have applied and close Microsoft Word.

Rename an object

Note  You can only rename an object if it is not referred to by name by the parts of the application. You
cannot rename or delete folders in CCM Designer for Web.

1. Navigate to the object to rename, click it, and then click Rename in the Other Actions pane on the
right.
The Rename window appears.

2. Enter a new name for the object and click OK.
The object appears with a new name.

Copy an object

You can create a copy of an object. An object can only be copied where it is allowed to create a new
object of that type. This includes authorization. Only the Draft version of an object is copied.
1. To copy or cut an object, click it and then click Copy or Cut in the Other Actions pane on the right.
2. Select the location for the object and click Paste.

To make a copy of an object in the same folder, click the object and then click Make copy here.

Unlock, accept, and publish objects

CCM Designer for Web features a lifecycle management system. When an object is edited, it can be
processed through various phases before it is used in the production. The lifecycle includes the following
phases:
▪ In development: the object is being edited; the changes are only visible to the editing user.
▪ Draft: the changes have just been made; the changes are visible to other users for review, test, and

acceptance.
▪ Accepted: the edited object is correct and ready to be published.
▪ Published: the object is used in the production.

The lifecycle consists of unlocking, accepting, and then publishing the object.

To unlock:
1. When you finished editing the object, click it and then click Unlock in the Publication Workflow

pane on the right.
2. Enter a description of the changes and click OK.
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The object is now in the Draft phase.

To accept:
1. When you finished testing and reviewing the object, click it and then click Accept in the Publication

Workflow pane on the right.
2. Click Yes to promote the object to the Accepted phase.

To publish:
1. When the object is to be used in the production, click it and then click Publish in the Publication

Workflow pane on the right.
2. Click Yes to promote the object to the Published phase.

Note  You can change the status of an object manually only from CCM Designer for Windows. See Use
a previous version of a Text Block.

Unlock, accept, or publish all objects at once
In CCM Designer for Web, you can unlock, accept, or publish all objects belonging to a project at once.

1. Click the project you are working on and then click Unlock, Accept, or Publish in the Publication
Workflow pane on the right.

2. Click OK or Yes when prompted to proceed.

Reject changes
CCM Designer for Web does not feature a changes notification system. If an object or some changes
have been unlocked or accepted, the user who has a permission to reject changes has to be informed of
the name and location of the promoted object.

1. Navigate to the object that have been unlocked or accepted, click the object, and then click Reject in
the Publication Workflow pane on the right.

2. Enter a description of the rejection and click OK.

Note  The author of the rejected changes has to correct them and promote the object again.

View the version history of an object

CCM Designer for Web features a version control system. You can check the history of an object.

1. Navigate to the object you want to check the history of, click it, and then click View History in the
Other Actions pane on the right.
The "Revision history" window appears.
The status In development means that the object is being edited.
The status Draft means that the object has been just created or edited.
The status Accepted means that the object is correct and ready to be published.
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The status Published means that the object is being used in the production.

2. View the object by clicking the eye symbol to the right of the object.
If you want to delete unnecessary versions of objects, see Remove redundant versions of objects.

Remove redundant versions of objects

You can remove all redundant versions of the objects used in the project. Versions are considered
redundant if they are not used anymore in document production.

1. Click the project and then click Cleanup project in the Other Actions pane on the right.

2. Be sure to read the warning message and click Yes to proceed.
You will receive a notification that the cleanup has been started.

3. Click Yes.
When the cleanup is completed, you receive a notification.

Use a previous version of a Text Block

If it appears that a previously published version of a Text Block is needed or better than the currently
published version, you can easily revert to it using CCM Designer for Windows.

1. Start CCM Designer for Windows.

2. Click Projects and then click the folder that contains the project you are working on.

3. Click Text Blocks and look for the folder that contains the Text Block you need.
For example, to change the status of a Text Block that belongs to a Welcome Letter, it is likely that
the Text Block belongs to a Letters folder.

4. Click the folder and then click the document that includes the Text Block you need.

5. Click the Text Block and then click Text Block Revisions.
You can see a list of available versions of the Text Block.

6. Right-click the version number you want to make the current published version. Click Status > Mark
as Accepted.
The version is now an accepted version.

7. Right-click the version number once more. Click Status > Mark as Published.
This version of the Text Block is now published and will be used in the production of documents that
use this Text Block.

Work with Changesets

Changesets are a means to group objects to modify them in a single change process. Changesets may
be useful to implement changes to documents or the corporate identity of your organization. You can
define a Changeset in a project so that it only contains the objects that belong to this change process.
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You need to manually add needed objects to a Changeset (see Create a new Changeset, Manage a
Changeset).

Changesets can be active or inactive. A Changeset becomes active once it is created. The goal of a
Changeset is to pass a number of related changes to objects through the object lifecycle, ending with
publication of these changes. Once a Changeset is published, it receives the Published status and
becomes inactive automatically. Also, you can manually deactivate a Changeset. When you deactivate a
Changeset, objects that belong to it can be used again outside of the Changeset. For more information on
the statuses and the lifecycle system, see Promote a Changeset.

The following restrictions apply to a Changeset:
▪ An object may be member of only one active Changeset.
▪ You can remove an object from a Changeset only if it has not been changed since it was added.
▪ To perform actions on a Changeset that you are working on, select it from the Changeset list. If you do

not select a Changeset, you can perform actions on objects that are not in any active Changeset.

Create a new Changeset

1. On the toolbar, click the navigation arrow icon and then click Manage Changesets.
The Changesets main window appears.

2. On the Project drop-down list, select a working project.

3. Click New Changeset in the New pane on the right.
The New Changeset window appears.

4. Enter a name and a description for the Changeset and click OK.
The Changeset appears with the New status.

5. Click the Changeset and then click Open Changeset in the Other Actions pane on the right.
The main window of CCM Designer for Web appears.

6. To view objects that you can add to the Changeset, deselect Hide objects that are not in the
Changeset.

7. To add an object to the Changeset, select an object that is not yet part of any active Changeset and
then click Add to Changeset in the Other Actions pane on the right.

Note  To add an object that is in another active Changeset, this Changeset must be deactivated.
Contact a user who is responsible for that Changeset. To learn how to deactivate a Changeset,
see Deactivate a Changeset.

8. To go to the Changeset main window, click the navigation arrow icon on the toolbar and then click
Manage Changesets.

Manage a Changeset

This section contains information on how to manage Changesets.

1. To start working with a Changeset, click Changesets on the dashboard. From the CCM Designer for
Web main window, click the navigation arrow icon and then click Manage Changesets.
The Changesets main window appears.
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2. On the Project list, select a project. To see all Changesets, select All Projects.

3. Click a Changeset you need and then click Open Changeset in the Other Actions pane on the
right.
The CCM Designer for Web main window appears.

Also, you can start working with a particular Changeset from the CCM Designer for Web main
window. To work with a certain project, on the Project list on the toolbar, select a project. To see
objects for a certain Changeset, on the Changeset list, select a Changeset. To only view objects that
belong to the Changeset, select Hide objects that are not in the Changeset.

Note  When you are not working in a Changeset, you cannot make changes to the objects that
belong to an active Changeset.

Promote a Changeset

An integral part of Changesets is the usage of the lifecycle system. To use the functionality of a
Changeset, you need to unlock, accept, and publish it.

A Changeset has a status determined by the lowest of the statuses that its objects have. For example,
if a Changeset contains a number of objects, each having a different status, such as Draft, Accepted,
and Published, it receives the Draft status, the lowest status in this case. If one of these objects is edited
and receives the In development status, the Changeset receives the In development status as well. Also,
when you promote a Changeset that contains objects that other users work on, the Changeset keeps the
In development status.

If the Changeset has the In development status, you can make it a draft. To do so, click the Changeset
and then click Unlock in the Publication Workflow pane on the right. Enter a description of the changes
and click OK. The Changeset receives the Draft status.

If the Changeset has the Draft status, you can accept it. Click the Changeset, click Accept in the
Publication Workflow pane on the right, and then click Yes. The Changeset receives the Accepted
status.

If the Changeset has the Accepted status, you can publish it. Click the Changeset, click Publish in the
Publication Workflow pane on the right, and then click Yes. The Changeset receives the Published
status.

When a Changeset receives the Published status, it automatically becomes deactivated.

You cannot accept or publish objects individually.

You may delete an inactive Changeset. To do so, verify that "Show inactive Changesets" is selected, click
the Changeset, and then click Delete in the Other Actions pane on the right.

Deactivate a Changeset

You might need to deactivate a Changeset so objects that belong to it can be used in another Changeset.
An inactive Changeset is retained, but you cannot reactivate it.
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To deactivate a Changeset, click it in the main Changeset window, click Deactivate in the Other Actions
pane on the right, and then click Yes. From the main window of CCM Designer for Web, click the
navigation arrow icon on the toolbar, click Manage Changesets, and then repeat the action.

Synchronize data between projects

In CCM Designer for Web, you can synchronize data between a source project and a target project.
Synchronization takes the changes made to published objects in the source project and applies them
to the corresponding objects in the target project. In the target project, additional objects can be added.
These additions are not lost.

You cannot synchronize projects when you are working in a Changeset.

The following objects are always included in synchronization. The target project should not contain any of
these objects with In development status.
▪ Data Backbone
▪ Field Sets

Synchronization does not update already existing Fields. It only adds new Fields. Synchronization only
adds Field Sets used in the Data Backbone.

▪ DIDs
Synchronization only includes compiled DIDs. DID documents are not included. For more information
on DIDs, see the section "Use DIDs" in the Kofax Customer Communications Manager Repository
User's Guide.

▪ Libraries
In the target project, the only status that a Libraries object should have is Published.

The following objects are optionally included in synchronization:
▪ Text Blocks
▪ Content Wizards, including Text Block Lists and Forms
▪ Document Templates

Document Templates are only updated and/or added when the underlying Master Template exists in
the target project. Otherwise, Document Templates are omitted in synchronization.

To synchronize two projects, follow these steps:

1. Click the target project and navigate to Data.

2. Locate the Data Backbone object, click it, and then click Synchronize from in the Other Actions
pane on the right.
The "Synchronize from" window appears.

3. Select the source project to synchronize the data from.

4. Select the type of objects to copy from the source project to the target project.
If you do not need to synchronize existing Document Templates, select Only synchronize new
Document Templates. If you do not select this option, changed Document Templates are also
synchronized.

5. From the target status list, select the status that the objects will receive in the target project.
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Synchronization overwrites changes in the target project. Make sure you have a backup of the target
project, so that locally changed content is not overwritten.

6. Click Synchronize.
Synchronization only happens if the two Data Backbones are compatible: all nodes of the Data
Backbone of the target project must be present in the Data Backbone of the source project.
However, you can extend the Data Backbone of the source project to ensure that all Data Structures
that you were working with are still present after synchronization. New Data Structures might have
been added during synchronization.
Synchronization does not update objects in the target project that reside in an active Changeset. If it
encounters such an object, synchronization is aborted.
Also, if synchronization encounters other problems when updating an object, the process is aborted,
and no changes are made to the target project.

Get information on the published objects in a file

You can retrieve information on the published objects of a certain project in an XML file. This information
includes details on the objects, such as the name, the date when the object was last changed, and a
description of the changes made in the published version. This may be helpful if you are synchronizing
data between a source and a target project and want to see what objects have been changed in the
source project.

1. Click Project Listing on the dashboard. From the CCM Designer for Web main window, click the
navigation arrow icon, click Dashboard, and then repeat the action.

2. Select the project from the drop-down list and click Create project listing.

3. Open or save the file.

Export and download a project

To transfer a project you have been working on to a different environment, you need to export and
download it.

Note  The maximum supported size of the export file depends on available memory but typically is
around 100 MB. For larger exports, use CCM Designer for Windows. For more information, see the
section "Import and Export" in the Kofax Customer Communications Manager Repository User's Guide.

1. Click Export on the dashboard. From the CCM Designer for Web main window, click the navigation
arrow icon and then click Dashboard.

2. Select the project to export and click Export.
You are notified that the project is being exported.

3. Click OK.
As soon as the project is exported, you can download it.

4. Click Download to download the project.
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You are prompted to open or save the project.

5. Click Save.
By default, the project is saved to the folder with downloaded files on your computer.

Make a copy of a project for troubleshooting

You can create a copy of a certain project as an MDK file. This may be useful if you are experiencing
issues with your project and want to send that to Technical Support for troubleshooting.

1. Click Create Diagnostic Info on the dashboard. From the CCM Designer for Web main window,
click the navigation arrow icon, click Dashboard, and then repeat the action.

2. Select the project from the drop-down list and click Create Diagnostic Information.

3. When the information is created, click Download.
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