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Preface
This user's guide contains general information and instructions on using Kofax Customer
Communications Manager Designer for Web. Read this guide completely before using the software.
The guide is useful for all users of Kofax Customer Communications Manager Designer for Web,
regardless of their role.

System Requirements
Information about system requirements is available from the Cross Product Compatibility Matrix, which is
available from the Kofax website at www.kofax.com. The matrix is updated regularly, and we recommend
that you review it carefully before installing your product.

Training
To learn more about Kofax Customer Communications Manager and Kofax Customer Communications
Manager Designer for Web, visit our Knowledge Center located at ccmkc.kofax.com.
To ensure your best experience in working with Kofax Customer Communications Manager Designer for
Web, complete our complimentary and interactive e-learning modules located at www.kofax.com.
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Kofax Customer Communications Manager
Kofax Customer Communications Manager (also known as CCM) is a single integrated solution to
automatically produce large numbers of standard documents and compose professional individual
correspondence.
Kofax Customer Communications Manager is a solution that empowers the organization to engage and
communicate with customers by generating relevant and personal communication delivered through
different channels.
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Kofax Customer Communications Manager
Designer for Web
Kofax Customer Communications Manager Designer for Web (also known as CCM Designer for Web) is
an authoring tool and a content management system for Kofax Customer Communications Manager.
CCM Designer for Web offers the following key features:
▪ Lifecycle management and a version control system
▪ Role-based functionality
▪ Reusable elements
▪ Central management of templates and content

View on Documents
The organization can have hundreds of different documents such as letters, policies, offers, and invoices.
A document consists of various elements, such as the address, salutation, body of a letter, and closing. A
document can also have a corporate identity which includes logo, footer, standard font, specified width of
margins, and so on.
Typically, the organization has a number of similar documents. For example, all letters in the organization
have the same layout, headers and footers, address block, and salutation.
To manage all these elements correctly and easily, they are managed individually in CCM Designer for
Web. Document production in CCM Designer for Web is template-based. Various elements of documents,
such as blocks of text (so called Text Blocks), or a corporate footer, can be created and adjusted
individually. Changes have to be applied only once.
CCM Designer for Web is role-based. Changes in certain elements of documents, such as in those
related to the corporate identity, can only be applied by a user whose role is to manage the corporate
identity.
Working with separate elements of documents makes it possible to easily apply multi-branding. Content
elements, like Text Blocks, can be reused by sub-brands, while their corporate identities differ.
The following figure reproduces the structure of a letter with various elements.
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The logo, name, address, reference, ending, signature, and footer might be identical with each letter. In
CCM Designer for Web, these elements are defined in Master Templates.
The body might differ in each letter. It is defined in Content Wizards and Text Blocks. Content Wizards
and Text Blocks are linked to Master Templates using Document Templates.
A corporate design of a document (headers, footers, font, margins, and so on) is defined in Page Style
and Style Sheet.

Publication Workflow
CCM Designer for Web features a version control system for tracking the history of any object.
CCM Designer for Web also monitors the entire process of publication. This is done with the help of
the lifecycle management system. Every object in the software is part of lifecycle. Within the protected
environment of CCM Designer for Web, you can execute the entire process of testing, accepting and
publishing.

CCM Designer for Windows
CCM Designer for Web is a successor to CCM Designer for Windows. Some functions of CCM Designer
for Windows are not yet available in CCM Designer for Web 5.0.
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Chapter 1

Work with CCM Designer for Web
Based on the project role assigned to you, select the applicable tutorials in this chapter and read them
carefully.

Getting Started
CCM Designer for Web offers role-based functionality. This topic helps you to get the most important
information based on the tasks you carry out in your organization.

Task 1: Add and Edit Content of a Document
You have a lot of domain knowledge. Your task is creating and editing documents and texts. In CCM
Designer for Web, you work with Text Blocks, Content Wizards, Document Templates, Forms, as well as
with Letter Books, Text Block Lists, Static Documents, Quick Templates, and Metadata.
You should review the following topics:
Create a New Text Block
Edit the Text of a Document
Format the Text in a Document
Include a Text Block in the Document
Adjust Properties of a Text Block in a Content Wizard
Create a List of Text Blocks
Include a Text Block List in a Content Wizard
Create a New Document Template
Create a New Letter Book
Categorize Text Blocks Using Metadata
Apply Features of Multi-branding
Create a New Static Document
Create a New Quick Template
Test an Object
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Submit for Acceptance or Publication

Task 2: Manage the Corporate Identity
You change logos, adjust the margins of a letter and edit the contents of a footer. In CCM Designer for
Web, you work with Text Blocks and Document Templates, as well as with Resources and Corporate
Design.
You should review the following topics:
Create a New Text Block
Edit the Text of a Document
Format the Text in a Document
Include a Text Block in the Document
Adjust Properties of a Text Block in a Content Wizard
Create a List of Text Blocks
Include a Text Block List in a Content Wizard
Create a New Document Template
Work with Letter Books
Use Resources
Define Styles for the Text of a Document
Format the Page Style of a Document
Test an Object
Submit for Acceptance or Publication

Task 3: Create Templates
You create templates of documents. You have knowledge of data and applications. In CCM Designer
for Web, you work with Master Templates, Document Templates, Data Backbone, Fields and Field Sets,
Metadata, Includes, and Libraries.
You should review the following topics:
Work with Master Templates
Create a New Document Template
Test an Object
Manage Test Data
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Categorize Text Blocks Using Metadata
Work with Includes
Work with Libraries
Submit for Acceptance or Publication

Task 4: Manage CCM Designer for Web
You create authorizations, new users, and projects. You are the administrator.
Read all of the topics of this chapter.

Access CCM Designer for Web
Functionality in CCM Designer for Web is organized according to roles. Each user is assigned a
role depending on a user's task in the project (see Getting Started). Every role comes with a set of
permissions. For instance, a Project Administrator is able to grant Template Designers access to the
project to edit Text Blocks, and so on.
Note Typically, CCM Designer for Web is integrated into a business application of the organization. A
user may not need to log on. In case CCM Designer for Web remains unintegrated, the user receives
credentials to log on from a system administrator.
Note If the installation is successful, InstallationTest4-4 built-in project appears after a user logs on.
The project can be deleted from CCM Designer for Windows.

Predefined Roles
CCM Designer for Web comes with a set of predefined roles and corresponding permissions:
▪ Author: Delete, Edit, New, Rename, Set description, Test, Submit for acceptance, View.
▪ Content Reviewer: Submit for publication, Reject, Test, View.
▪ Publisher: Publish, Reject, Test, View.
▪ Publishing Author: A Publishing Author is granted permissions of both an Author and a Publisher.
▪ Publishing Reviewer: A Publishing Reviewer is granted permissions of both a Content Reviewer and
a Publisher.
▪ Viewer: A Viewer can View only.
▪ Project Administrator: A Project Administrator is granted all permissions mentioned above. A Project
Administrator's duty is to grant access to other users.
Note In CCM Designer for Web 5.0, you cannot create new roles.
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In general, the following rules apply to all permissions:
▪ Roles and correspondent permissions can only be granted to users through the assignment of roles
▪ No permission is granted by default
▪ Permissions cannot be suppressed

Assign a Role to the User
Use this procedure to assign roles to CCM Designer for Web users.
1.

Right-click the project a group of users works on and click Authorization.
The Authorization window appears.

2.

In the drop-down list, select a user.

3.

Select one or several roles and click Apply.
The Confirmation window appears.

4.

Click Yes.
You will receive a notification that the authorizations have been saved.
Repeat the preceding steps for every user.
Note To create a new user, use an external program. Contact a sales representative for CCM or
an IT person responsible for maintaining CCM.

Create a New Project
Note You cannot create a new project with CCM Designer for Web 5.0; you can only upload and import
an existing project. To create a project for use in CCM Designer for Web, see Create a New Project in
CCM Designer for Windows.

Upload and Import a Project to CCM Designer for Web
1.

On the menu, click File > Dashboard.
The dashboard appears.

2.

Click Import.

3.

Browse to the project to import and click Open.

4.

Click Upload.

5.

Enter a name for the project and click Import.
A notification appears when the project is imported to CCM Designer for Web. It will appear in CCM
Designer for Web.
Tip You may need to refresh CCM Designer for Web to see changes you have applied. Click
Refresh.
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Create a New Project in CCM Designer for Windows
1.

Start CCM Designer for Windows.
You may be prompted to enter you credentials.

2.

Click File > New > New Project.
You are prompted to select a document type and a Master Template language.

3.

Adjust the settings and click Create.
The New Project - Configuration window appears.

4.

In the General tab, enter a name for the project.
If you need to adjust settings in the other tabs, visit our Knowledge Center located at
ccmkc.kofax.com.

5.

Click Apply and then click OK.
The new project appears in CCM Designer for Web.
Note You may need to wait some time for the new project to appear. If the project does not
appear, click Refresh to refresh the software.

Create a New Folder
You can create a Folder wherever this option is available.
1.

Navigate to the Folder to which you want to add another Folder. Right-click the Folder and click New
> New Folder.
The New Folder window appears.

2.

Enter a name for the new Folder and click OK.
Note The name should be meaningful.
The new Folder appears in the Folder.
Note You may need to refresh the software to see the changes you have applied. Click Refresh in
the toolbar.

Work with Document Templates
Document Templates are used to generate documents. Every document has its own Document Template.
A Document Template is based on a Master Template, a Quick Template or a Static Document.
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Create a New Document Template
In order to create and define a new Document Template, you should first have a knowledge of Master
Templates, Static Documents, and Quick Templates. See Work with Master Templates, Create a New
Static Document, and Create a New Quick Template.
1.

Navigate to Communciations > Document Templates, right-click Document Templates and click
New > New Document Template.
The New Document Template window appears.

2.

Enter a name for the new Document Template and click Next.
The Document Template Editor appears.

3.

In the Based on Master Template section, click the pencil icon to define a Master Template and
other properties.

4.

In the new window, click the Master Template tab and click a Master Template on which the new
Document Template will be based.
The name of the Master Template appears in the section.

5.

In the Description section, click the pencil icon to add a description.

6.

Click Save & Close.
The new Document Template appears in Document Templates.

Create a Document Pack Template
A Document Pack contains sets of documents. A Document Pack is created from a Document Pack
Template. Document Pack Templates are created and maintained in CCM Designer for Web.
1.

Navigate to Communications > Document Pack Templates, right-click Document Pack
Templates and click New > New Document Pack Template.
The New Document Pack Template window appears.

2.

Enter a name for the new Document Pack Template and click OK.
The new Document Pack Template appears in the Document Pack Templates Folder.

3.

Right-click the new Document Pack Template and click Edit.
The Document Pack Template Editor appears.

4.

In the Select cover letter window, select a cover letter and click Select.
▪ To change the selected cover letter, click the dots sign on the right of the cover letter slot, click
Select Cover Letter and repeat Step 4.

5.

To select a Document Template to prepare the data, click the dots sign on the right of the Data
Preparation Template slot and click Select Data Preparation Template.
The Select Data Preparation Template window appears.

6.

Select a Data Preparation Template and click Select.

7.

To add one or multiple Document Templates, click the plus icon.
The Add Document Templates window appears.
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8.

Select one or more Document Templates and click Add.
The Document Template appears in the Document Pack Template Editor. To remove a redundant
Document Template, click the dots sign on the right of the Document Template slot and click
Remove.

9.

To manage properties of any slot, click the dots sign on the right of the slot and click Properties.
The Properties window appears.

10. Check Optional to allow the user creating the Document Pack to include or exclude this Document
Template.
11. Provide a reference for the slot if there is an integrating application that needs to access this slot.
12. Click Save.
13. Click Save & Close.

Work with Letter Books
Use Letter Books to configure and organize a collection of Document Templates. Letter Books are
available outside CCM Designer for Web and you can import them. You can create, edit, and import Letter
Books.

Create a New Letter Book
1.

Navigate to Communications > Letter Books, right-click Letter Books and click New > New
Letter Book.
The New Letter Book window appears.

2.

Enter a name for the new Letter Book and click OK.
The new Letter Book appears in Letter Books.

3.

Right-click the new Letter Book and click Edit.
The Letter Book Editor window appears.

4.

In the window on the right, click and drag Documents Templates to the window on the left.
Note You can also refer to other Letter Books from the current Letter Book. To do so, click the
Letter Books tab, click and drag the Letter Books you need to the window on the left.

5.

When you finished creating the Letter Book, click Save & Close.

Import a Letter Book
1.

Navigate to Communications > Letter Books, right-click Letter Books and click Import Letter
Book.

2.

Click +Browse.

3.

Click the file to upload and click Open.
Note Letter Books are XML files.
When the file is imported, close the window.
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Create a New Text Block
A Text Block is a meaningful piece of text that can be reused for different purposes. A Text Block is
usually one or two paragraphs long.
1.

Navigate to Content > Text Blocks, click the Folder that contains the type of the document to
contain a new Text Block.
For example, to add a new Text Block to a Welcome Letter, it is likely that the Folder you need is
named Letters.

2.

Right-click the Folder with the document to contain a new Text Block. Click New > New Text Block.
The New Text Block window appears.

3.

Enter a name for the Text Block and click OK.
Note The name of the Text Block should be meaningful. For example, to add a new Text Block to
a Welcome Letter that will contain information on the loyal customer club, assign the same name
to the Text Block.
The Text Block appears in the Folder.

4.

To add text to the Text Block, right-click it and then click Edit.
The Text Block Editor appears.

5.

Create the text. You can add Fields. To learn more about the editor's functionality, see Format the
Text in a Document.

6.

Save your changes.
To see how the Text Block is going to look in the result document, see Test an Object.

Edit the Text of a Document
This section explains how to update documents that require corrections.
Each document is created by a Document Template. To make changes to some piece of text (Text Block),
you need to know which document in Documents Templates contains this Text Block.
1.

Navigate to Communications > Document Templates, right-click the Document Template to make
changes to and then click View.
The Document Template Editor window appears.

2.

Find the Parameters section to learn which Content Wizard is used in this document. Remember
the name of the Content Wizard. You need this name to find the Content Wizard that contains the
document to update.

3.

Close the Document Template Editor window.

4.

Navigate to Content > Content Wizards, click the Folder that contains the file to change.
For example, to make changes to a Welcome letter, it is likely that the file will be in a Letters Folder.

5.

Right-click the file and click Edit.
The Content Wizard Editor appears.
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6.

In the menu on the left, select the Text Block to update.
Note To preview the Text Block, click View in the dashboard and then select Show Text Block
Preview. The preview appears in the bottom right corner.

7.

Right-click the Text Block and click Edit.
The Text Block window appears.

8.

To make the Text Block editable, select Editable in the Behaviour frame. To learn more on editable
Text Blocks, see Make a Text Block Editable.

9.

Remember the location of the Text Block in the menu on the left and then click OK.

10. Close the Content Wizard Editor window.
11. Navigate to Content > Text Block, click the Folder that contains the Text Block to change.
12. Right-click the Text Block and click Edit.
The Text Block Editor window appears.
13. Make necessary changes to the Text Block.
14. Click Save & Close.
15. Close the Text Block Editor window.
Note To view any changes you have applied to a certain object in CCM Designer for Web, see
Test an Object.

Include a Text Block in the Document
1.

Navigate to Content > Content Wizards, and click the Folder with the document you want to
contain a certain Text Block.

2.

Right-click the file to add a Text Block to and click Edit.
The Content Wizard Editor appears.

3.

On the menu, click Edit and click Add Text Block.
The Text Block window appears.

4.

Double-click the Folder that contains a Text Block to add.

5.

Click the Text Block to add.
Note To preview the Text Block, select Text Block Preview in the bottom left corner.

6.

Click Add and Close.
The Text Block appears in the structure of the document you are composing. To change the position
of the Text Block in the document structure, click the Text Block and then use the arrows located in
the toolbar on the left.

7.

Click File > Save.

8.

Click File > Close.
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Note By clicking the red X icon to close the editor, you may lose some changes you have applied.
To view the document or the changes you have applied, see Test an Object.
To learn how to adjust properties of a Text Block, see Adjust Properties of a Text Block in a Content
Wizard.

Adjust Properties of a Text Block in a Content Wizard
You can make a Text Block optional or mandatory, editable or non-editable.

Make a Text Block Editable
Editable means that the user can edit the text of the document that is being created. This can be useful to
add some personal touch to the document. For example, an employee of your organization can specify in
the letter whether he or she has been in contact with the customer by phone or by email so that the letter
is more personal.
1.

Navigate to Content > Content Wizards, find the Folder with the Content Wizard you want to make
changes to.

2.

Right-click the Content Wizard and click Edit.
The Content Wizard Editor appears.

3.

Find and right-click the Text Block and then click Edit.
The Text Block window appears.

4.

Select Editable.
Note The Text Block is non-editable by default.

5.

Click OK.

6.

Close the Content Wizard Editor.

Make a Text Block Optional
An optional Text Block consists of predefined text that you can include in your document if needed. This
can be useful to add some extra information in your letter to the customer. For example, if you want to
add some information on the annual holiday closing of your organization, you can create a Text Block
containing this information, make it optional and use only when you need it. To learn how to create Text
Blocks, see Create a New Text Block.
1.

Navigate to Content > Content Wizards, and find the Folder with the Content Wizard to make
changes to.

2.

Right-click the Content Wizard and click Edit.
The Content Wizard Editor appears.

3.

Find and right-click the Text Block and then click Edit.
The Text Block window appears.

4.

Select Optional.

18

Kofax Customer Communications Manager Designer for Web User's Guide

5.

Click OK.

Add a Condition to a Text Block
By default, a Text Block or another element such as a group of Text Blocks, is always included in a
Content Wizard. You can specify whether a Text Block in question is to be used under certain conditions.
1.

Navigate to Content > Content Wizards, and click the Folder with the object you need.
For example, to add a conditional Text Block to a Welcome Letter, it is likely that the Folder you need
is named Letters.

2.

Right-click the object you need and click Edit.
The Content Wizard Editor appears.

3.

On the menu, click Edit and then click Add Text Block.
The Text Block window appears.

4.

Find and click the Text Block to which you want to add a condition.

5.

Click Add and Close.
The Text Block appears in the structure of the document. To change the position of the Text Block
in the document structure, click the Text Block and then use the arrows located in the toolbar on the
left.

6.

Right-click the Text Block and click Edit.
The Text Block window appears.

7.

Click the Show/Hide tab.

8.

Select Text Block is not always included.

9.

Click New on the right to add a new condition.
The Condition window appears.

10. In the drop-down list, select a Field that relates to the Text Block in question. The Text Block will be
included when this Field is equal to the value Y (for yes).
Note You can apply as many conditions as necessary.
11. Enter the value Y and click OK.
The condition has been applied. This Text Block will now only be included in the Content Wizard
when the Field you specified is equal to the value Y.
12. Click OK.
13. Click File > Save.
14. Click File > Close.

Test a Conditional Text Block
If you applied a condition to a certain Text Block, test the Content Wizard it belongs to.
1.

Navigate to Content > Content Wizards > Text Blocks, and right-click the Text Block to test and
then click Test.
The Test window appears.

19

Kofax Customer Communications Manager Designer for Web User's Guide

2.

Click Edit Test Data. You can, for example, change a name, gender or address for the test. This
allows you to check whether data is correctly included in the document.
The Test window appears.

3.

Click the Field you specified while including a condition.

4.

Enter Y into the required fields to specify that something is different for this test.

5.

Click Test.
The document opens in Microsoft Word. Navigate to the Text Block you included on a condition to
check if it is correct.

Retest a Conditional Text Block Without it Appearing in the Document
1.

Navigate to Content > Content Wizards > Text Blocks, right-click the Text Block to which you
applied a condition, and then click Test.
The Test window appears.

2.

Click Edit Test Data.
The Test window appears.

3.

Click the Field you specified while including a condition.

4.

Enter N (for no) instead of Y in the required fields.

5.

Click Test.
The document appears without the conditional Text Block.

6.

Close Microsoft Word.

Add a Condition to a Group of Text Blocks
You can make a group of Text Blocks conditional so they only appear when you need them in your
document.
1.

Navigate to Content > Content Wizards, and click the Folder with the document you need.

2.

Right-click the document and click Edit.
The Content Wizard Editor appears.

3.

In the document structure, right-click the group and then click Edit.
The Section window appears.

4.

Click the Show/Hide tab.

5.

Select Section is not always included.

6.

Click New on the right to add a condition to the section.
The Condition window appears.

7.

In the drop-down list, select a Field that relates to the section. The section will be included when this
Field is equal to the value Y (for yes).

8.

Click OK.
The condition is applied to the section.

9.

Click OK.
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Inclusion of the group of Text Blocks is now conditional. This group will only appear in a document
when you need it.
10. Click File > Save.
11. Click File > Close.

Test a Conditional Group of Text Blocks
If you applied a condition to a group of Text Blocks, test the Content Wizard to which they belong.
1.

Navigate to Content > Content Wizards, right-click the object to which you added a group of
conditional Text Blocks, and then click Test.
The Test window appears.

2.

Click Edit Test Data.
The Test window appears.

3.

Click the Field you selected while adding a condition to the group.

4.

Enter Y in the required fields.

5.

Click Test.
The document opens in Microsoft Word. Find and check the group of Text Blocks.

6.

Close Microsoft Word.

Retest a Conditional Group of Text Blocks Without Them Appearing in the
Document
1.

Navigate to Content > Content Wizards, right-click the object to which you added a group of
conditional Text Blocks, and then click Test.
The Test window appears.

2.

Click Edit Test Data.
The Test window appears.

3.

Click the Field you selected while adding a condition to the group.

4.

Enter N instead of Y in the required fields.
The document opens in Microsoft Word without the conditional group of Text Blocks.

5.

Close Microsoft Word.

Create a List of Text Blocks
In CCM Designer for Web, you can create a list of Text Blocks that are available to you while a document
is being composed.
There are two ways to define the contents of a Text Block List:
▪ The first is to create an alias for a Text Block Folder by creating a list of all the Text Blocks
belonging to a certain Folder. To learn more, see Create a List of Text Blocks as an Alias for a Text
Block Folder.
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▪ The second is to create a fixed set of Text Blocks by manually adding only the needed Text Blocks
to a list. To learn more, see Create a List of Text Blocks as a Fixed Set of Text Blocks.

Create a List of Text Blocks as an Alias for a Text Block Folder
You can create a list of Text Blocks that are available to you while a document is being composed.
1.

Navigate to Content > Text Block Lists, right-click Text Block Lists, and then click New > New Text
Block List.
The New Text Block List window appears.

2.

Enter a name for the Text Block List and click OK.
The new Text Block List appears in Text Block Lists.

3.

Right-click the new Text Block List and then click Edit.
The Text Block List Editor window appears.

4.

Select is an alias for a Text Block Folder.

5.

Click Select to choose a Text Block Folder to become an alias for the Text Block List you want to
create.
The Text Block Folders window appears.

6.

Select a Folder. Double-click a Folder to open lower level Folders. Click the blue up arrow icon to
return to higher level Text Block Folders.

7.

Click OK.

8.

Click Save & Close.
To include your Text Block List in a Content Wizard that appears when you are composing a
document, see Include a Text Block List in a Content Wizard.

Create a List of Text Blocks as a Fixed Set of Text Blocks
1.

Navigate to Content > Text Block Lists, right-click Text Block Lists, and then click New > New Text
Block List.
The New Text Block List window appears.

2.

Enter a name for the Text Block List and click OK.
The new Text Block List appears in Text Block Lists.

3.

Right-click the new Text Block List and then click Edit.
The Text Block Lists Editor window appears.

4.

Select is a fixed set of Text Blocks.

5.

Click the blue plus icon to add Text Blocks.

6.

After adding all the Text Blocks you need, click Save & Close.
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Include a Text Block List in a Content Wizard
By including a Text Block List in a Content Wizard, you facilitate the process of composing a document.
1.

Navigate to Content > Content Wizards, and click the Folder that contains the type of the
document you want to edit.

2.

Right-click the document and then click Edit.
The Content Wizard Editor window appears.

3.

On the menu, click Edit and then click Add Selection > Section Group.
You can also add a Text Block List to an existing Text Block selection group.
The Text Block Selection Group window appears.

4.

Enter a name for the group and make a selection where needed. You can also make the selection
group conditional. For more on how to add a condition, see Add a Condition to a Group of Text
Blocks.

5.

Click OK.
The new Text Block selection group appears in the structure of a Content Wizard. You can adjust the
position of the group by clicking the arrows located in the toolbar on the left.

6.

Right-click the new Text Block selection group and click Add Text Block List.
The Text Block List window appears.

7.

Select a Text Block List and click OK.
The Text Block List appears in the structure of a Content Wizard.

Categorize Text Blocks Using Metadata
Another way to categorize Text Blocks is the use of Metadata. Metadata is a means to organize and
categorize Text Blocks by applying labels to them. Metadata makes it possible to create labels and to
apply them to Text Blocks so that you can easily filter Text Blocks and use the ones you need.

Create and Edit Metadata
1.

Navigate to Content > Metadata, right-click Metadata, and click New > New Metadata.
The New Metadata window appears.

2.

Enter a name for the new Metadata object and assign an Id.
Note Contact a IT person responsible for maintaining CCM for information about which ID to
assign. Also, the ID format supports only numeric characters.

3.

Click OK.
The new Metadata object appears in Metadata.

4.

Right-click the new Metadata object you and click Edit.
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The Metadata Editor window appears.
5.

Select One value can be selected or Multiple values can be selected depending on how many
values you want to associate with the Metadata object.
For example, to create values for different languages, such as English, French, and German, select
Multiple values can be selected.

6.

Enter a name for a value and click Add. Do so for every value to create.

7.

Click Save & Close.

Attach Metadata to a Group of Text Blocks
1.

Navigate to Content > Text Blocks, right-click a Folder of Text Blocks to which you want to attach
Metadata, and click Configure.
The new window appears.

2.

Click the Folder Metadata tab.

3.

Click Add Metadata to Folder and select the Metadata object you want to add.
▪ Select at least one default value if you are prompted to do so and click OK.

4.

Click Apply and then click OK.
Metadata is attributed to every Text Block in the Folder. To edit Metadata for a particular Text Block,
see Edit Metadata for a Single Text Block in a Group.

Edit Metadata for a Single Text Block in a Group
If you attributed Metadata labels to a group of Text Blocks but certain Text Blocks of the group should be
labeled otherwise, you can specify this in the Text Block Editor.
1.

Navigate to Content > Text Blocks, right-click the Text Block you want to be labeled otherwise, and
click Edit.
Tip You can also create a new Text Block inside the group and attach to it a different Metadata
label.
The Text Block Editor window appears.

2.

In the toolbar, click the Metadata sign to edit Metadata.

3.

Click Edit and select a different value for the Text Block.

4.

Click OK.

5.

Click OK.
A different Metadata label is attributed to the Text Block.

6.

Click Save & Close.

24

Kofax Customer Communications Manager Designer for Web User's Guide

Format the Text in a Document
The sections describing formatting are written with the assumption that you have a basic understanding of
Microsoft Word.
Several text-formatting functions are available in the Text Block Editor of CCM Designer for Web.
▪ Styling of the text
▪ Bold formatting
▪
▪
▪
▪
▪
▪
▪

Italics formatting
Underline formatting
Numbered List
Bulleted List
Increase Indent
Insert and Edit Table
Insert a Field
Note The styling of the text in the Text Block Editor differs from the styling in the result document.
Styling of the result document is implemented in CCM Designer for Web and complies with the
corporate identity of your organization. To look at the result document, see Test an Object.
Note To apply extra formatting, see Define Styles for the Text of a Document.

Insert a Table
You can insert a table in the document within the Text Block Editor.
1.

Navigate to Content > Text Blocks, right-click the Text Block you want to contain a table, and click
Edit.
Note The process of defining the Text Block is described in the topic Edit the Text of a Document.
The Text Block Editor window appears.

2.

Place the cursor where you want to insert a table, and click the table icon to insert a table. You can
also click this icon to edit a table.
The Insert/Edit Table window appears.

3.

Set the properties for the table.
▪ Select Autosize to adapt the width of the columns to the size of the text.
▪ Select First column, Last column, Header row, or Footer row to add alternative styling so that
these parts of the table differ from the rest of the table. The styling applied complies with the style
of the template.

4.

Click Insert.
The table appears where you place the cursor.
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5.

Save you changes.

Include a Field
Use the Text Block Editor to include a Field in a Text Block.
1.

Navigate to Content > Text Blocks.
Note The process of defining the right Text Block is described in the topic Edit the Text of a
Document.
The Text Block Editor appears.

2.

Place the cursor where you want to include a Field, and select the Field in the Fields list on the right
side of the window. You can use a search function here.

3.

Double-click the Field to add it to the document.
The Field appears where you placed the cursor.

4.

Save your changes.

Format a Field
You can apply basic formatting to a Field. For example, you can specify that the name of a Field should
always be in capital letters.
1.

Navigate to Content > Text Blocks, right-click the Text Block where a certain Field belongs and
click Edit.
The Text Block Editor appears.

2.

Click the Field to format and click the F button in the toolbar.

3.

Select a format and click OK.
You can check if the formatting is applied. If it was successful, the name of the formatting appears
after the name of the Field. For example, [CustomerAddress.City:upper] meaning that uppercase
formatting has been applied to it.

4.

Click Save & Close.

Add a Condition to a Field
You can apply conditional formatting to a Field. This can be useful, for example, to make sure that the
name of the client is always preceded by Mr. or Mrs. The following procedure explaining how to add Mr. or
Mrs. depending on the addressee's gender.
1.

Navigate to Content > Text Blocks, right-click the Text Block to edit, and click Edit.
The Text Block Editor appears.

2.

Place the cursor where you want the name of the customer to appear. From the Fields list on the
right, find and double-click the Fields [Customer.Initials] and [Customer.Surname] if they are not
there.
The Fields appear in the text.

3.

Place the cursor before the [Customer.Initials] Field and add the [Customer.Gender] Field.
The Field appears in the text.
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4.

Click the [Customer.Gender] Field in the text and then click the F button in the toolbar.

5.

From the drop-down list, select Condition. For the Compare with parameter, enter M (for male). For
the Use if matches parameter, enter Mr. For the Use otherwise parameter, enter Mrs.

6.

Click OK.
If the value for gender is M, the Text Block uses Mr. If the value is not M, Mrs. is used.

7.

Click Save & Close.

Test a Conditional Field
If you applied a condition to a Field, test a Text Block it belongs to.
1.

Navigate to Content > Text Blocks, right-click any Text Block where a conditional Field belongs and
click Test.
The Test window appears.

2.

Select the status in development and the needed Document Template.

3.

Click Edit Test Data.
The Test window appears.

4.

In the Customer field, enter M or F for Mr. or Mrs., as applicable.

5.

Click Test.
The document opens in Microsoft Word. Check if the conditional Field appeared correctly.

6.

Close Microsoft Word.

Define Styles for the Text of a Document
Use Style Sheets to define the text style properties in a document.
1.

Navigate to Corporate Design and click the Folder with the project you work on.

2.

Click Style Sheet and select the file to format.

3.

Right-click the file and click Edit.
Microsoft Word opens. You can preview the formatting styles that are built-in to CCM Designer for
Web.

4.

Click the Home tab.

5.

Find the Styles section and click the small arrow in the lower right corner.
The Styles window appears on the right.

6.

Right-click the style to format to open the context menu.
For example, the basic text font. In this case, the item might be named ITP_normal: Basic style.

7.

Click Modify.
The Modify Styles window appears.

8.

Make necessary changes and click OK.
Changes are applied to every item that uses the properties of the style you have edited.

9.

Close the Microsoft Word document and save the changes when prompted to do so.
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Format a Table
You can use Style Sheets to create a custom table style, or format the ITP_table style if it is available in
the preview of formatting styles. The steps below describe how to create a new table style to use in the
documents.
Note ITP_table styles are only applied to tables in standard Text Blocks. Any other table styles added
to Style Sheets can only be used in Rich Text Block.
1.

Navigate to Corporate Design and click the Folder with the project you work on.

2.

Click Style Sheet and select the file to format.

3.

Right-click the file and click Edit.
Microsoft Word opens. You can preview the formatting styles that are built-in to CCM Designer for
Web.

4.

Place the cursor in the blank space at the end of the document, click the Insert tab in Microsoft
Word, and then click Insert Table.

5.

Define the number of columns and rows and click OK.
The table appears where you placed the cursor.

6.

Navigate to Table Tools > Design > Table Styles.
Tip If this tab is not available, click the table you inserted and the Table Tools tab will appear.

7.

Click the small arrow located in the lower right corner to see more options.

8.

Click New Table Style.
The Create New Style from Formatting window appears.

9.

Enter a name for the style in accordance with the names of the styles previewed in the document.
Example, ITP_table_custom.

10. Make necessary changes and click OK.
The new style appears in the Table Styles section.
11. Click the new style to apply it to your table.
12. Close the Microsoft Word document and save the changes when prompted to do so.

Apply Features of Multi-branding
If your organization has branches or offices with different addresses and phone numbers, you can easily
applying multi-branding to the text and corporate identity used in your documents.
Generating documents with different logos in the header or footer requires knowledge of scripting in a
Master Template or CCM Core Process Script. For more information, see the documentation for CCM or
the CCM Core Process Script.
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Apply Features of Multi-branding to the Text of a Document
If your organization has offices or branches located at different addresses, you can specify them in CCM
Designer for Web and easily choose the right address when sending documents to your customers.
Note If you already have Text Blocks containing different addresses for different places, skip Step 1
and Step 2.
1.

Create several Text Blocks for different addresses. To create Text Blocks, see Create a New Text
Block.

2.

Add the Text Blocks to a document that will have different addresses in its text. See Include a Text
Block in the Document.
Note In the Content Wizard Editor, place the Text Blocks with the addresses one after the other
within the document structure.

3.

Navigate to Content > Content Wizards, click the Folder that contains the type of the document
that will contain different addresses.

4.

Right-click the document and click Edit.
The Content Wizard Editor window appears.

5.

In the document structure on the left, right-click one of the Text Blocks containing an address and
click Edit.
The Text Block window appears.

6.

Click the Show/Hide tab.

7.

Select Text Block is not always included. Other properties must remain as set by default.

8.

Click New on the right to add a condition to the Text Block.
Note If a condition has been already created, you may edit it. Click Edit.
The Condition window appears.

9.

On the Fields list, select a Field that relates to the address you need. In the empty space to the right
from the value drop-down list, enter a text that is associated with the chosen Field.

10. Click OK.
The condition is applied to the Text Block.
11. Click OK.
12. Repeat Steps 5 - 12 for every Text Block that contains a different address.
13. Close the Content Wizard Editor.
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Format the Page Style of a Document
You can format the style of the page in Page Style.
1.

Navigate to Corporate Design, and click the Folder with the project you work on.

2.

Click Page Style and find the object to format.
For example, if you are formatting the page of a Welcome Letter, it is likely that the file you need is
named Letters.

3.

Right-click the object and then click Edit.
The Microsoft Word document opens.

4.

Click the Page Layout tab and then find the Page Setup section.

5.

Click the small arrow in the lower right corner in the Page Setup section.
The Page Setup window appears.

6.

Make necessary changes and click OK.

7.

Close Microsoft Word and save the changes when prompted to do so.
To view the changes you have applied, see Test an Object.

Test an Object
You can test the changes you applied or the document you created before submitting them for
acceptance or publication.
1.

Navigate to the object you want to test.
For example, if you inserted a table in a Welcome letter and want to see the whole document,
navigate to Content > Text Block > Letters.

2.

Right-click the object and click Test.
The Test window appears.
The status line indicates the status of an object (for more information on the status, see Submit for
Acceptance or Publication, Use a Previous Version of a Text Block, View the Version History of an
Object.)
The upper frame shows which Document Templates use this Text Block.
The lower frame shows the data file to be used in the test.

3.

Select a status, a Document Template, a Test Data file and click Test. To edit data to be used in the
test (such as name, gender, customer address, or other), continue to the next step.

4.

To edit Test Data, select a Test Data file and then click Edit Test Data.
The Test window appears.

5.

Click Expand All to see all data available to be edited.

6.

Make necessary changes and click Test.

7.

If you are prompted to enter additional information, enter information in the forms that appear and
click OK.
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8.

Review the changes you have applied and click OK.

9.

Close Microsoft Word.

Manage Test Data
CCM Designer for Web uses data to generate documents. All the data received from the repository and
collected from interaction with the clients is defined by the Data Backbone. CCM Designer for Web also
allows you to manage data that is used to test the documents.
There are two ways to manage the Test Data content:
▪ The first is to create a new XML file containing the data you need and upload it to CCM Designer for
Web.
▪ The second is to edit the existing data file. See Edit Test Data.

Edit Test Data
You can download an existing XML Test Data file, make changes to it, and then upload it back to CCM
Designer for Web.
1.

Navigate to Data > Field Sets, right-click Data Backbone and then click Manage Test Data.
The Test Data Manager window appears.

2.

Choose the XML file to edit and click the pencil icon.
The Edit Test Data window appears.

3.

Click Download.

4.

Open the file in a text editor. Make necessary changes to the code.
Note Make changes only to the text value. For example, the code for the country's name must
read as follows: <Country>USA</Country>. Spaces can be part of the code.

5.

Save the file to your computer.

6.

Close the Edit Test Data window.

7.

In the Test Data Manager window, click the blue plus icon to upload the file you changed.
The New Test Data window appears.

8.

Enter a name for the file and click the pencil icon.

9.

Navigate to the XML Test Data file you have just edited, click it and then click Open.

10. In the New Test Data window, click OK.
The XML file appears in the list and is ready to be used in the test.
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Submit for Acceptance or Publication
CCM Designer for Web features a lifecycle management. You need to submit for acceptance the changes
applied or the items created, and then submit them for publication. In order to submit an object to
publication, you first need to submit it for acceptance.
1.

Navigate to the object to submit, right-click it and click Submit for Acceptance.
The "Submitting for acceptance" window appears.

2.

Enter a description of the changes and click OK.
The changes are submitted for acceptance.
The status Draft means that the object has been just created or edited.
The status Accepted means that the object is ready to be published.
The status Published means that the object is being used in the production.
Note You can change the status of an object manually only from CCM Designer for Windows. See
Use a Previous Version of a Text Block.

3.

As soon as an object is submitted for acceptance, it can be submitted for publication. Right-click the
item submitted for acceptance and then click Submit for Publication.
Note You need to inform your Publisher if you submitted something for publication. To publish an
object, right-click the object and click Publish.

Submit or Publish all Objects at Once
In CCM Designer for Web 5.0, you can submit/publish all objects belonging to a project at once.
1.

On the menu, click the project you are working on and click SUBMIT FOR ACCEPTANCE, SUBMIT
FOR PUBLICATION, or PUBLISH accordingly.

2.

Click OK when prompted to proceed.
Note When submitting for acceptance, enter a description of the changes and click OK.

Use a Previous Version of a Text Block
When editing a document, you may want to use a Text Block that was used before to make a previously
published version a current published version.
1.

Start CCM Designer for Windows.

2.

Click Projects and then click the Folder that contains the project you work on.

3.

Click Text Blocks and look for the Folder that contains the Text Block you need.
For example, to change the status of a Text Block that belongs to a Welcome Letter, it is likely that
this Text Block belongs to a Letters Folder.
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4.

Click the Folder and then click the document that includes the Text Block you need.

5.

Click the Text Block and then click Text Block Revisions.
You can see a list of available versions of the Text Block.

6.

Right-click the version number you want to make a current published version. Click Status > Mark
as Accepted.
The version is now an accepted version.

7.

Right-click the version number once more. Click Status > Mark as Published.
This version of the Text Block is now a published one and will be used in the production of
documents that use this Text Block.

View the Version History of an Object
CCM Designer for Web features a version control system. You can check the history of an object.
Navigate to the object you want to check the history of, right-click the object, and click History.
The "Revision history" window appears.
The status Draft means that the object has been just created or edited.
The status Accepted means that the object is ready to be published.
The status Published means that the object is being used in the production.
If an object has no status, you may want to delete it. See Remove Redundant Versions of Objects.

Remove Redundant Versions of Objects
You can remove all redundant versions of the objects used in the project. Those versions are considered
redundant if they have no status or are not in use.
1.

On the menu, click the Folder with the project you work on.

2.

Right-click the project and click Cleanup Project.

3.

Be sure to read the warning message and click Yes to proceed.
You will receive a notification that the cleanup has been started.

4.

Click Yes.
When the cleanup is completed, you receive a notification.

Reject Changes
The Administrator can reject changes that other users submitted for publication.
Note CCM Designer for Web 5.0 does not feature a changes notification system. If an object or some
changes have been submitted for publication, the Administrator has to be informed of the name and
location of the submitted object.
1.

Navigate to the object that has been submitted for publication, right-click the object, and then click
Reject.
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The new window appears.
2.

Enter a description of the rejection and click OK.
Note The author of the changes that have been rejected will have to correct them and submit for
publication again.

Use Forms
CCM Designer for Web can easily collect information that is not yet available in a system database.
Forms are a means to get such information, to store it in Fields in Data Backbone, and to use it to
produce documents. Forms are managed by the program called Master Template responsible for the
document creation. Forms provide you with a list of questions and store your answers in Fields. You can
create and edit Forms.
There are three types of items you can include in a Form: a question, a text, and a group.
The use of a question allows you to ask a question to the user. There are several types of questions. For
example, a date question ("What was the date of your phone call with the customer?"). In the question
text it is possible to make use of a Field. All question types contain a Question text, an Answer field, and a
Help text. The following types of answers are allowed:
▪ Text Question
▪ Choice Question
▪ Checkbox Question
▪ Number Question
▪ Date Question
▪ Time Question (different for each question type)
A text is a way to offer the user extra information when a document is being composed. This text will not
appear in the document. The text can, for example, show a warning that the user is supposed to read. It
may also show an explanation for a series of questions.
A group can be used to group elements. A group can hold questions, text elements, and other groups.
Groups can be hidden or shown based on a condition.

Create a New Form
Create a Question Form
A question Form may contain almost any type of information.
1.

Navigate to Content > Forms, right-click Forms and click New > New Form.
The New Form window appears.

2.

Enter a name for the Form and click OK.
The new Form appears.
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3.

Right-click the new Form and click Edit.
The Form Editor opens.

4.

In the toolbar on the left, click the plus icon, click Question and then select the type of the question
you need.
A new window appears.

5.

Enter some text in the required fields and make selection where needed.
You can also insert a Field from the Fields list if this option is available in the form item of your
choice. Click Fields and select a Field.

6.

Select Answer field to specify where the answers to the questions will be stored in the Data
Backbone.

7.

In the Default answer section, select Default answer if this option is available in the question type
of your choice. You can choose to have no default answer, or select it from the Fields list so that the
default answer will be taken from the Data Backbone and modify it when necessary.
▪ Go to the Validation tab to adjust the validation settings. For example, you can specify that the
answer to the question may not be left empty.

8.

Click OK.
The new question Form appears in the window on the right.
Note If you have more than one Form, you can create a group of Forms.

Create an Editable Text Block Question
1.

Navigate to Content > Forms, right-click the Form you need and click Edit.
To create a new Form, see Create a New Form.
The Form Editor opens.

2.

In the toolbar on the left, click the plus icon, click Question > Editable Text Block Question.
The Editable Text Block Question window appears.

3.

Enter some text in the required fields.
You can also insert a Field from the Fields list where this option is available. Click Fields and select
a Field.

4.

In the Default answer section, select Text Block and then select one of the editable Text Blocks.
You can also select From Field if the default answer is already in the system.

5.

Click OK.
The new Editable Text Block Question Form appears in the window.

Create a Text Block Question
Text Block question is a choice question where you can select Text Blocks.
1.

Navigate to Content > Forms, right-click the Form to which you want to add a group and click Edit.
To create a new Form, see Create a New Form.
The Form Editor opens.

2.

In the toolbar on the left, click the plus icon, click Question > Text Block Question.
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The Text Block Question window appears.
3.

Enter some text in the required fields.
You can also insert a Field from the Fields list where this option is available. Click Fields and select
a Field.

4.

Select Store Text Blocks in Field to specify where the answers to the questions will be stored in the
Data Backbone.

5.

Select Auto insert Text Blocks to automatically insert all of the Text Blocks that you selected for the
document.

6.

Click OK.
The Form appears in the window. You can change the position of the Form using arrows located in
the toolbar on the left.

Create a Group of Questions
You can create a group of questions and add all the Forms that topically belong to this group. You can
also include a group of QForms on certain conditions.
1.

Navigate to Content > Forms, right-click the Form to which you want to add a group and click Edit.
To create a new Form, see Create a New Form.
The Form Editor opens.

2.

In the toolbar on the left, click the plus icon and click Group.
The Group window appears.

3.

Enter a title for the group. You can also insert a Field from the Fields list if it is already in the Data
Backbone. To do so, click Fields and select a certain Field.
▪ In the Include group section, select Group is not always included if you want the group to be
included on certain conditions.
▪ You can also choose to make the group expandable or to be shown based on conditions related
to the questions that were asked previously in the Form. Select either Group is expandable or
Group is shown conditionally.

4.

Click OK.
The group of Forms appears in the window.

Create Text in a Form
You can create static text in a Form. This can be useful to add text before all the Forms.
1.

Navigate to Content > Forms, right-click the Form to which you want to add a static text and click
Edit.
To create a new Form, see Create a New Form.
The Form Editor opens.

2.

In the toolbar on the left, click the plus icon and click Text.
The Text window appears.
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3.

Enter a text. You can also insert Fields from the Fields list if it is already in the Data Backbone. To do
so, click Fields and select a certain Field.

4.

Click OK.

5.

Close the editor.

Use QForms
QForm is a type of Form used in combination with Content Wizards. QForms are used if the document
has Text Blocks that do not have values. In this case, QForm provides you with a list of relevant questions
related to the Fields used in these Text Blocks. QForm helps to save time when composing a document
with multiple Fields. You can create and edit QForms. Use the following procedure to attach a QForm to a
document.
1.

Navigate to Content > Content Wizards, and click the Folder with the object that lacks certain
information.

2.

Right-click the object and click Edit.
The Content Wizard Editor window appears.

3.

Click the name of the object in the document structure on the left, right-click the object and then click
Edit.
The Content Wizard appears.

4.

Click Select to select a QForm.
The Make Selection window appears with all available QForms.

5.

Select a QForm and click Select.

6.

Close the Content Wizard window.

Create a New QForm
The process of creating and editing QForms is similar to the one of Forms. The difference is that you
cannot create QForms as a Text Block and as an editable Text Block, and you cannot select to include a
group of QForms on certain conditions.
1.

Navigate to Content > Forms, right-click Forms and click New > New QForm.
The New QForm window appears.

2.

Enter a name for the QForm and click OK.
The new QForm appears in Forms.

3.

Right-click the new QForm and click Edit.
The editor appears.

4.

In the toolbar on the left, click the plus icon and select an item and its type.

5.

Adjust the settings and click OK.
The QForm appears.
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Attach a QForm to a Content Wizard
1.

Navigate to Content > Content Wizards, and click the Folder with the document to which you want
to attach a QForm.

2.

Right-click the document and click Edit.
The Content Wizard Editor window appears.

3.

Click the name of the object in the document structure on the left, right-click the object and then click
Edit.
The Content Wizard window appears.

4.

Click Select to select a QForm.
The Make Selection window appears with all available QForms.

5.

Select a QForm for the document you are composing and click Select.

6.

Close the Content Wizard window.

Create a New Static Document
A Static Document is a document that you can upload to CCM Designer for Web and use unchanged.
Static Documents do not contain dynamic elements such as Text Blocks, Content Wizards, Fields, and so
on. Static Documents can include maps, diagrams, attachments, and so on. Static Documents are part of
the lifecycle system, which means that they need to be submitted for acceptance, publication, or rejected.
1.

Navigate to Content > Static Documents, right-click Static Documents and click New > New
Static Document.
The New Static Document window appears.

2.

Enter a name for the Static Document you are creating and click OK.
The Static Document appears.

3.

Right-click the Static Document you just created and click Edit.
The Static Document window appears.

4.

Click the pencil icon to upload a new file.

5.

Navigate to the file to upload and click Open.
Note Allowed formats to be uploaded are .doc, .docx, .xls, .xlsx, .ppt, .pptx, and .pdf.
The file appears as a current file.

6.

Click Save & Close.

7.

Right-click the Static Document and click Create Document Template.
You will receive a notification that the Document Template has been created. The Document
Template appears in Document Templates.

8.

To view the Static Document you have uploaded, navigate to Communications > Document
Templates, right-click the Document Template for the Static Document you uploaded and click Test
> Test.
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The document opens in a PDF editor.

Create a New Quick Template
A Quick Template allows such dynamic elements as Fields. Quick Templates usually include forms and
checklists. For example, your organization employee may need to send a customer a form to be filled
with answers. Quick Templates are a means to generate such forms and to get information quickly. Quick
Templates are part of the lifecycle system, which means that they need to be submitted for acceptance,
publication, or be rejected.
1.

Navigate to Content > Quick Templates, right-click Quick Templates and click New > New Quick
Template.
The New Quick Template window appears.

2.

Enter a name for the Quick Template you are creating and click OK.
The Quick Template appears in Quick Documents.

3.

Right-click the Quick Template you just created and click Edit.
The Quick Template opens in Microsoft Word.

4.

Add some text and Fields. When in Microsoft Word, you cannot add Fields directly as in the Text
Block Editor. The Fields in Microsoft Word should replicate the Fields from the Fields list (see
Include a Field).
For example, to add a Field containing the last name of the customer, place the cursor where you
want to have this Field and type [Customer.LastName]. You can also add some basic Microsoft Word
formatting to the Field.
Note Make sure that the Field you want to use does exist in the Fields list.

5.

Right-click the Quick Template and click Create Document Template.
You will receive a notification that the Document Template has been created. The Document
Template appears.

6.

To view the Quick Template, navigate to Communications > Document Templates, right-click the
Document Template for the Static Document you uploaded and click Test > Test.
The document opens in Microsoft Word.

Use Resources
Resources of CCM Designer for Web hold resources used in CCM Core Process Script.

Use XSLT Style Sheets and CSS Style Sheets in CCM Designer for Web
In CCM Designer for Web, you can convert XML documents to HTML or different XML-based formats.
This is managed in XSLT Style Sheets. The XSLT processor can also call CSS Style Sheets. When a
CSS Style Sheet is attached to HTML documents, you can define different styling properties that need to
be applied to an HTML document.
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Create a New Resource
You can create and edit resources in CCM Designer for Web.
1.

Navigate to Resources, right-click Resources and click New Resource.
The New Resource window appears.

2.

Enter a name for the new resource, select a type in the menu and click OK.
The new object appears in Resources.

3.

Right-click the new object and click Edit.
The Resource Editor window appears.

4.

Enter or paste necessary code.

5.

Click Save & Close.

Use Overlays
In the Overlays Folder in Resources, you can store static Microsoft Word documents that can be retrieved
with scripting instructions in CCM Core. Overlays are mostly used in combination with PDF files.
Note Request your CCM sales representative to provide you with training materials on CCM Core
Process Script.

Store Images in Logos
In the Logos Folder in Resources, you can store images. This can be useful to print a document with a
corporate logo in the header or footer. Using images requires scripting in a Master Template responsible
for the document you are generating. Request your CCM sales representative to provide you with the
training materials. To upload an image to Logos, see Upload an Image to Logos.

Upload an Image to Logos
1.

Navigate to Resources > Logos , right-click Logos and click New Resource.
The New Resource window appears.

2.

Enter a name for the new resource, select Logos in the drop-down list and click OK.
The new object appears in Logos.

3.

Right-click the new object and click Edit.
The Resource Editor window appears.

4.

Click the pencil icon to upload a new file.

5.

Choose the file to upload and click Open.

6.

When the file has been uploaded, click Save & Close.
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Work with Master Templates
A Master Template is a program responsible for the document creation.

Work with Includes
Note This section is written with the assumption that you are familiar with the concepts of scripting. To
learn more on programming CCM Designer for Web, request your sales representative to provide you
with training materials.
CCM Designer for Web is all about reusable content. Different Master Templates can make use of single
functions and procedures. To facilitate the process of working with Master Templates, you can take
advantage of Includes. Includes contain functions and procedures and can be reused in more than one
Master Template. This helps you to reuse correct functions, such as date and addressing. To avoid
mistakes when creating a new Master Template, you can refer to such functions instead of writing them
manually.
Note In CCM Designer for Web 5.0, when a change is applied to an Include, it is applied to the Master
Template that makes use of this Include. To prevent errors, we recommend that you recreate a template
after an Include is updated.

Create and Edit an Include
1.

Navigate to Master Templates > Includes, right-click Includes and click New > New Include.
The New Include window appears.

2.

Enter a name for the new Include and click OK.
The new Include appears.

3.

Right-click the new Include and click Edit.
The Include opens in Microsoft Word.

4.

Make necessary changes and close Microsoft Word.
For more information, see Attach an Include.
Note If an error occurs, click VIEW ERROR DOCUMENT on the toolbar.

Attach an Include
An Include contains different reusable _INC instructions, which are word processor documents that
include programming instructions. Before a Master Template is used, all of the needed Includes have to
be collected and compiled in a Master Template.
Important To prevent errors do not rename Include once it is included.
1.

Navigate to Master Templates > Documentation, right-click the document to which you want to
attach an Include, and click Edit.
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Microsoft Word opens.
2.

Create a new paragraph where you need to insert an Include, place the cursor in the new paragraph
and type _INC (the name of the Include).

3.

Add all the needed _INC instructions and close Microsoft Word.

4.

Save the changes when prompted to do so.

Work with Libraries
Note This section is written with the assumption that you are familiar with the concepts of scripting. To
learn more on programming CCM Designer for Web, request your sales representative to provide you
with training materials.
Libraries are a means to create reusable instructions for CCM Designer for Web when Master Templates
are executed. While Includes are compiled in Master Templates, Libraries are completely self-contained.
Each Library is compiled individually.
Libraries can contain reusable functions and procedures:
▪ Filter functions used to filter Text Blocks in Content Wizards
▪ Formatting functions used to format Fields in Text Blocks
Note You can extend the list of available functions by defining format functions in a Library.
▪ All functions and procedures used in Master Templates
Note These functions and procedures cannot produce word processor instructions.

Create and Edit a Library
1.

Navigate to Master Templates > Libraries, right-click Libraries and click New > New Library.
The New Library window appears.

2.

Enter a name for the new Library and a level and click OK.
Note All Libraries have to be assigned unique level numbers. Level numbers determine the order
in which the contents are loaded. Contact an IT person responsible for maintaining CCM to enter a
correct level.
The new Library appears in Libraries.

3.

Right-click the new Library and click Edit.
The Library opens in the Library Editor.

4.

Make necessary changes.

5.

Click Save & Close.
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Compile a Master Template
Navigate to Master Templates > Documentation, right-click the document you want to compile and
click Compile.
If an error occurs, click VIEW ERROR DOCUMENT on the toolbar.
The Documentation Folder stores all documents belonging to a project that have nothing to do with
the execution of templates and documents.

Rename an Object
Note You can only rename an object if it is not referred to by name by the parts of the application.
1.

Navigate to the object to rename, right-click the object and then click Rename.
The Rename window appears.

2.

Enter a new name for the object and click OK.
The object appears with a new name.

Export and Download a Project
To transfer a project you have been working on to a different environment, you need to export and
download it.
1.

On the menu, click File and then click Dashboard.

2.

Click Export.

3.

Select the project to export and click Export.
You will receive a notification that the project is being exported.

4.

Click OK.
As soon as the project has been exported, you will be able to download it.

5.

Click Download to download the project.
You will be prompted to open or save the project .

6.

Click Save.
The project is saved to the Folder with downloaded files on your computer by default.
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